Jump to content

QE on HP TouchSmart IQ506 - A Cry for Help !


bisk
 Share

1 post in this topic

Recommended Posts

Hello Everyone.

 

I am trying to get QE and Resman working on an HP TouchSmart IQ506.

 

This is an all-in-one unit very similar to an iMac with an Intel C2D and NVidia 9300M GS onboard video w/256MB VRAM. The video device goes by 10de:06e9.

 

So far, I have tried …

 

Natit

NVEnabler

NVinject

GraphicsEnabler=Yes in c.a.B.plist using the following iterations of Chameleon …

Chameleon RC4-AsereBLN-1.1.9

Chameleon_2.0_RC5_r593

Chameleon_2.0_RC5_r656

Chameleon_2.0_RC5_r699

 

The last 2 releases in the above list are supposed to be 9300M GS aware so I also tried to add an NVCAP line like:

 

<key>NVCAP_06e9</key>

<string>[the nvcap string]</string>

 

Of course, NVCAP Maker 1.4 chokes on the latest BIOS ROM for the IQ506 thusly …

 

ROM file: /Volumes/Kihei-Archives/Archives/Hackintosh/Systems/16.HP_IQ506_10.6.4/HP_IQ506/IQ506_BIOS/NVCap/JAN5.10.ROM

Copyright 2008 Arti Itra version 1.4

If you find this program useful you

may consider a PayPal donation to:

arti.macelite@gmail.com

 

0400000000000000000000000000000700000000

 

This is probably a laptop that will not support the built-in display.

The external connectors may neither work as expected.

 

-----

 

So I tried an NVCAP from a guy who has it working on his laptop but, of course, that fails.

 

Finally, I tried my hand at playing around with DSDT mods, using a piece of DSDT code from another guy that claims to have this video chip working and well amy but probably not on the IQ506. I'm not an expert with DSDT mods and though getting it compiled in was easy enough, the results were exactly the same as all other attempts.

 

A Totally Black Screen.

 

I am able to log in via VNC and look around to see that Resman is working in almost all cases but still not QE. I use an attempt at launching Toast or DVD Player as my simple initial test for working QE.

 

Here are links to the only relevant posts that I have found concerning all of this …

 

http://www.projectosx.com/forum/index.php?...ic=748&st=0

http://www.projectosx.com/forum/index.php?showtopic=1187

http://www.insanelymac.com/forum/index.php?showtopic=195578

 

I would post on these except that I am not able either due to the fact that I am too new or that the post that I wish to reply to is too old.

 

So, I resurrect this topic again in hopes of stimulating some interest.

 

If there are any gurus out there who can just nudge me in the right direction, I'll go running at it hard and happily post a full tutorial if I should be so lucky as to crack this.

 

From all the time that I've spent on this it seems that this silly system simply can't navigate to the built-in video device once we try to use anything other than standard VESA video output.

 

Could this just be an NVCAP thing or does the DSDT need major mods as well ?

 

If it's something really silly and simple that I'm missing here, all the better :thumbsup_anim:

 

Thanks in advance !

 

bisk

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...