Jump to content
bigblk150

Dell Latitude E6510 DSDT

56 posts in this topic

Recommended Posts

Well,

 

 

 

A update;

 

The shutdown fix works.

The VGA fix (no Graphicsenabler) DSDT fix for the NVS 3100 works too in Lion.

 

 

But! Before i was using a DSDT either by amirstep, or stonecrz (i thought they we're the same before)

But they differ!

 

The way stonecrazy applied the VGA fix didn't work for me at all. The way the shutdown fix was applied did.

The way amirstep applied the VGA DSDT fix works 100% for me.

 

Now the funny part.

Neither of the DSDT's worked for me, for Lion. I've tried the latest version both gentleman posted.

But they're fixes worked when i copied tehm to my own DSDT.

 

MIND THIS; when you 'switch' and try a different DSDT for graphics that is. Try twice (at least). I've noticed that it migh fail after the "first switch", but will work perfect after that....

 

Hope this helpes!

 

I have to test VGA out when i'm in the office. Haven't got any VGA screen anymore at home.

Also have to test hibernation. What i really want is sleep, but that might be a bit much to ask for...

 

SD card would also be nice!

 

 

By the way! Does anyone know how to get output back after [PCI configuration] during boot?

 

 

I have an E6510 that I am trying to get Lion on... In order to keep from duplicating efforts, do you have the DSDT file that did work for you?

 

Thanks!

Share this post


Link to post
Share on other sites
Advertisement
Hi Guys,

 

 

I've got an Dell E6510.

i had Snow leopard running before. Found the shutdown/vga fix here, unfortunately no sleep.

 

I do appreciate the effort by the entire community.

 

Anyway,

]

 

I got Lion running, and i think this is the place to drop the tips.

 

First of all; You perfect Snow Leopard DSDT will NOT work.

I suspect that the main reason for not working is either the shutdown, or the VGA fix.

I think that it's the VGA fix.

 

Besides that; be sure to have a DSDT with the "slow sata/ ICH" edits already in them. With them, it will/might work, but it'll be unstable at boot...

 

I replaced the wifi card with a broadcom, so no hassle there.

And yes, i have a Nvidia 3100 running perfect QI/CE on ONLY GraphicsEnabler.

I totally don't get the "kext needed for this Nvidia card" part.

Even got a "pretty fair" Voodookext. (Volume buttons work; mute doesn't)

I find soundflower a bit of a CPU hog, so i don't use it all the time. At least not with Logic and/or Ableton live

 

i must say, that back when i installed SL, i did had some issues. Unfortunately i can't exactly recall what fixed it.

But... I'm pretty sure it was the bootloader.

 

 

I wil try the shutdown/vga fix soon. Maybe this weekend.

I tried it this week, and broke the startup ----> as i was saying. One of those fixes doesn't play nice with Lion.

 

Besides my Dell i've got a pretty nice i7 920 @4.2 Ghz, on a raid 0 partition. I recently updated this machine to Lion too, and i must say, it's the best/most stable OSX/hackintosh yet!. I run 2 video cards GT8800 and a ATI 6770, both with gpu bios from /extra. They power 3x 30" monitors.

 

Took me some blood, sweat, and almost tears.... (especially the raid 0 part)

 

Ow, and i'm only into vanilla installs.

 

If anyone has questions. I'll help/answer if i can. I've been dooin

 

Hi.

Please can you provide working DSDT for Lion?

Second, how did you get your accelerated graphics to work in Lion? I tried maybe all possible combinations of GraphicsEnabler=Yes/No, many driver versions, but with no luck. The only success for me is using newest drivers from nVidia and deleting /System/Library/Extensions/GeForce*. But there is no acceleration then! :-( If I leave the GL drivers in place, I boot into white screen and nothing else happens.

Thanx in advance for your help.

 

OPP

Share this post


Link to post
Share on other sites

Forgive me if I sound like a newbie, but I have been trying very hard to get Lion installed on my system. I have installed Snow Leopard 10.6.8 and cannot upgrade the system. When I look at my system specs, the processor is reported as "Unknown Processor". I have tried to use the DSDT files within this posting, but everytime I try to use the files the system halts after reboot and the Apple Screen with a message to power of the system. I am new to the world of Mac, but have been trying very hard to learn to configure the system properly. I also have a Dell Latitude E6510 with the following specs:

 

Dell Latitude E6510

Quad Core i7 1.60 GHz

8GB RAM @ 1333MHz

nVidia NVS 3100M with 512MB DDR3 (working, but listed as unidentified, and no QE enabled in OS)

Intel Gigabit Ethernet

Intel 3600 WiFi a/b/g/n

Intel HDA

 

I have also created a bootable USB for Lion, but I never reach the installer. I ran the -v command and before the installer starts, the system halts at "PCI Configuration Begin." I have also tried all types of startup options, but nothing works. Does anyone know how to help or what I am missing?

Share this post


Link to post
Share on other sites

I just started building my hackintosh on my e6510 and this is what I had to use to boot my usb setup disk for lion:

 

-v npci=0x2000 PCIRootUID=0 GraphicsEnabler=YES

 

I also had to use that when I selected to boot the lion drive after install.. That is as far as I have gotten.

Share this post


Link to post
Share on other sites

I know this is a very old thread, but this thread gave me some of the clues I needed to get sleep working on the Latitude E6410 running Mojave 10.14.6.  See my solution here: https://www.insanelymac.com/forum/topic/339102-mojave-on-dell-latitude-e6410-with-working-sleep/

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×