Jump to content

Dell Inspiron 9400 - No video


9 posts in this topic

Recommended Posts

Hello all,


I have a Dell Inspiron 9400.


Specs are:


Moble Intell Core Solo (its core duo but have it set as solo in bio)

i945GM Chipset

945GM Video Card (Intel 450GMA)

Sigmatel Audio

Broadcom 440x 10/100 intergrated

Dell Wireless 1390 (i believe is also broadcom related)


I am using iDeneb 10.5.6 as my distro


The issue im having is i get no video after boot up. Laptop boots fine after it loads i get a blue screen and then it goes black. Any one have any insite on this???? anyone have a fix for it????


Thanks for the help

Link to comment
Share on other sites

  • 1 year later...

Hello All,


Valir I have almost the smae system as you.


Dell Inspiron E1705 / 9400

Core 2 Duo - T7400 , 2.16Ghz (You said you set it to solo in Bios) im not sure how you did that Im using the A10 Bios Rev: And I dont see the option to do anything like that.


Mobil Intel® 945GM/GU/PM/GMS/940GML and Intel® 945GT Express Processor to DRAM Controller - 27A0

Ricoh Chipset (Im sure this is for the card reader)

Mobil Intel ®945 Express Chipset Family (Video)

Sigmatel Audio - (Dell Drivers website states that it is a - (SIGMATEL STAC 92XX C-Major HD Audio)


I also have 3 Network Cards Listed


Dell Wireless 355 Bluetooth Module - Bluetooth


Broadcom 440x 10/100 intergrated


Dell Wireless 1490 Dual-Band WLAN MiniCard


I did get Mac Os X installed once with Snow Leopard 10.6 Ideneb i also got the blue screen and then the black screen. The problem that i found on mine was that the Apple kext was loaded automatically from the cd. So i had to boot up under -s for single user mode and then delete all the kext files for the video card. Once i did that i was up and running or so i thought.


The wireless kext ( or also known in windows as driver) was working but I had a kernal error and everytime i downloaded something i would download the file and then it went verifing and crashed my computer. Also at the time i didnt have a ethernet kext installed and i was told that i need to reinstall it from scratch and loqd those kexts in as i go if i want those devices to work.


I have been unsucessful with that as of yet.


So i am looking for help as to what i should load for kexts to get my laptop up and running and fully functional.


Any advice you give give in return would be greatful i would like to figure this thing out as i find it challenging


thanks in advance

Dave AKA Stinger696969


So I finally got it installed again and now i am typing to you from the dell with Mac OSX installed however it is not snow leopard like i thought. the c.d. i was using was labeled as 10.6 so thats why i thought it was snow leopard. in fact the CD was 10.5.6 so its just leopard.



Edited by stinger696969
Link to comment
Share on other sites

So i have been using the new operating system for a day now . So far everything is going great, unless i want to do something other than post here .


Examples: I plug a USB flash drive in Kernel Error

I download something it gets all the way to 100% then it goes to verify the information: Kernel Error

So this means i cant download Firefox or an updated safari - and without them i cant listen to pandora radio because you need updated browser for that. So thats pretty annoying. I have not found much else wrong with it so far but the problems i listed if anyone knows anything to help me fix this that would be awesome


On board network working

wireless network working

I think the video is working by a default function i do not believe there is any kext installed for it. only resolution option i have is 1024x768

front buttons working

sound working

apps working ( just cant get any new ones yet)



Link to comment
Share on other sites

So its been a couple days and ive been working on this Dell.


Here's what I Installed this time


Ideneb Essential System

Sigmtel 9200 Inspiron 9400 - ( Sound )

ICHX Fixed - Driver for Intel ICH7,8,9

Kernal 9.2.2 SSE3

Apple440X - ( Broadcom Local Area Connection )


Firewire Remove

IOUSB Family Fix ( This was a fix to attempt to fix a non working USB, Still didnt work for me )

Seatbel Fix

Intel GMA950 ( Video )


Kext Helper

OSx86 Helper

Temp Monitor


After the OS installed the computer booted up to a blue screen and then went to a blacak screen

so here is how i fixed it.


I booted the computer with -s for single user mode once here i had to type the following commands


mount -UV /

cd system

cd library

cd extensions


then i typed LS -L AppleIntel* to find all the video card drivers.

then it listed all the files so i then typed


rm -rf AppleIntel with the file names to remove them all and once i removed all the video drivers i was able to boot up the computer.


Now i am able to download programs and everything is seems functional except for the USB that i mentioned so what ill have to live with downloading whatever i want on another computer and copy it over the network or put it on a cd big deal. everything else is working




Oh i forgot to mention again it is Leopard 10.5.6

Link to comment
Share on other sites

So I tried to do an update and the computer crashed so i had to reinstall the OS again and this time i left out the IOUSB Family Fix which is the USB controller and my usb is working great.


So now I'm looking for a kext to fix my video.


Mobil Intel® 945GM/GU/PM/GMS/940GML and Intel® 945GT Express Processor to DRAM Controller - 27A0


Please help




Link to comment
Share on other sites


  • Create New...