Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
terranova2142

ATI Radeon HD 5450 Working On Snow Leopard

160 posts in this topic

Recommended Posts

Yesterday my computer wasn't booting at all. I think I figured an issue, I don't have an ATI Radeon HD 5450, but a Sapphire HD 5450. I read that that doesn't matter, but is that really true? The vendor code & device ID differs. Might I be a using the wrong Rom as a result?

 

If so, How could I find a working ROM for it?

Share this post


Link to post
Share on other sites

I returned the Graphic card, unfortunate. Where would I look for a good recommendation for a MacPro 3,1? I'm just looking for an upgrade for my ATI Radeon HD 2600 XT 256 MB. If possible below €180,-

 

I didn't have much luck on google so far. There are alternatives, but always so expensive.. :S

Share this post


Link to post
Share on other sites

5450 HDMI Audio: works fine on the same rig in Win7 64 via the latest ATI Catalyst driver. My Saphire's HD 5450 HDMI audio values are VID 1002 | DID AA01 | SubSys 00AA0100. Do you know of a patched AppleHDA or VoodooHDA for these IDs?

 

EDIT: whooo, here's the guide ..

Share this post


Link to post
Share on other sites

I have 10.6.6 installed and I followed all the steps step by step. I have a few problems. When I jumped to 10.6.6 from 10.6.4, the Graphics update wouldn't install at all. Then, after editing my Apple plist file with the graphics 1280x1024x32 it will boot properly, but after the Apple logo on boot it just turns off the display. But the OS is working underneath, I can press F12 and the disk drive opens, so WTH? Any ideas?

Share this post


Link to post
Share on other sites

Gavin, you're wasting unnecessary time putzing around w. these old OS versions (+ won't encounter motivation in the forum to help u w. these .. esp. not having supplied the slightest info about ur setup).. just install a fresh 10.7.x, or (at the least) 10.6.8, and you might not even have such problem .. (encouraging u 2 b professional here, dig .. ;) ?)

___________________________________

 

HDMI Audio: if s.b. has time to get it going for the HD 5450 (I don't at this point), here's toleda's manual incl. useful files.

Share this post


Link to post
Share on other sites

I Got my HD5450 (Gigabyte GV-R545D3-1GI) to work fairly easy

 

1) Got my card bios dump from windows and renamed to 1002_68f9.rom

 

2) Installed Retail 10.6.0 with OSX ModCD

 

3) Installed Combo Update 10.6.8 (didn't reboot)

 

4) Installed audio, network, legacy kernel, sleepenabler, put my 1002_68f9.rom to /Extra

 

5) Edited plist's of ATI5000Controller.kext and ATIRadeonX3000.kext (added 0x68f91002)

 

6) Installed latest chameleon bootloader via ChameleonWizard

7) Edited org.chameleon.boot.plist added

<key>GraphicsEnabler</key>

<string>Yes</string>

<key>UseAtiROM</key>

<string>Yes</string>

<key>AtiConfig</key>

<string>Hoolock</string>

<key>AtiPorts</key>

<string>3</string>

<key>Graphics Mode</key>

<string>1280x1024x32@75</string>

8) Rebooted with -x -v

Share this post


Link to post
Share on other sites

Hi i had this working before, The machine since has stopped working so ive had to reboot but now when ever i install these kexts my grahpics res options are not there and i cant get QE working. any ideas ?

Share this post


Link to post
Share on other sites

hi all,

i'm really stupid newbies, but i read all topic and my 5450 don't work on snow Leopard

can please help me step by step

Tk's by advance 

REDTOX

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • What did you add exactly, i did inject the unsupported 100 series kext and did see my macOS partition. I couldn't boot at all. I still get an error from VoodooPS2Mouse i think here is an image: https://drive.google.com/open?id=1dkcoWh2ZXj56ketONkrV8x9TNOVJdXkf
    • @Slice what's te correct russian translation for "copy to clip board"?   .. I need also a translation for "log copied to clip board!"
    • Hello MaLd0n,   Could you please make DSDT edits for my new Skylake desktop Lenovo M910t    RunMe files: https://www96.zippyshare.com/v/5bgqAiga/file.html
        Thank you very much in advance!
    • Have you tried adjusting the Khz in midi pref pane or editing the info plist to suit your needs. that sometimes corrects weird noise behavior.
    • Hello Mald0n:

      Nice to meet you, I have created a post about my problem on High Sierra before and I was redirected to this guide by Allan.

      As mentioned in the post, I was not able to get pass the login screen at initial boot and the system could not shutdown occasionally.

      However I solve the high temperature problem when I replace the clover folder you provide on first post, currently the cpu temperature is around 5x-6x'c after 10 mins up time.

      Attached is the clover folder, ioreg as well as the send me app, thanks for your help!

      p.s. I notice that your clover boot efi is a old traditional grey apple boot logo, Is there a version of modern dark and white logo one that I could replace with? Thank you!

      https://www.insanelymac.com/forum/topic/333867-cant-get-pass-2nd-stage-boot-logo-on-initial-boot-and-high-temperature/   My system:
      Gigabyte GA-X48-DQ6
      Core 2 Extreme QX9650 C0
      4 x Kingston DDR2 800ghz Ram
      Galaxy GTX460 1GB
      120GB SSD Leven JS500120C, high Sierra installed
      250GB seagate ST3250310AS
      250GB WDC WD2500JS-08NCB1
      File: https://drive.google.com/file/d/1_k3_jxvzGaLfDzin0zSAUT5ml16Hq15c/view?usp=sharing      


×