Jump to content

Native Networking Solutions?

2 posts in this topic

Recommended Posts



I've been trying to get networking working on a native OS X install and found the following osx drivers:



for LinkSys USB200M and Pegasus based USB ethernet adapters.



Belkin F507050 USB Wireless ethernet and others using the RT2571 chipset

(there is also a PCCard D-Link DWL-G630 driver though not for intel yet)



Zydas' driver for the ZD1211 USB wireless ethernet (e.g. 3com 3CRUSB10075)


and in fact my laptop has an RTL8139 which should also be supported but...


...they all give what seems to be the same kernel trap (page fault) on boot shown below.

I have an P4 SSE2 hp nx9110 laptop, have tried 10.4.5, 10.4.6 installs and also tried

copying the AppleRTL8139.kext from 10.4.3 and 10.4.1 as many suggest.


Does anybody know a solution to this conundrum?


Any help very greatly appreciated.




post-45023-1155504579_thumb.jpg post-45023-1155504612_thumb.jpg post-45023-1155504633_thumb.jpg

Link to comment
Share on other sites



I found what sees to be the only solution to this problem, that is, to use a very

old "MacOSx 10.4.3 8F1111A Patched Jas v4.2b.iso" ISO. It seems native

support for my nx9110's version of the RTL8139 has been broken since then.





Link to comment
Share on other sites


  • Create New...