Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
mastershredder

Lenovo Z560 installation

55 posts in this topic

Recommended Posts

Alright, I got the z560 with the i3 380M Processor, 310M Graphics, 500gb hard drive, 4gb RAM.

I have OSX installed perfectly, except for 2 things that I can notice immediately.

 

My ethernet and trackpad do not work.

 

So my question is how did you others get your trackpad to work? It seems like I've tried everything, but what'd you guys do to get yours working?

Share this post


Link to post
Share on other sites
My ethernet and trackpad do not work.

 

So my question is how did you others get your trackpad to work? It seems like I've tried everything, but what'd you guys do to get yours working?

 

I took the kext from first post - it works perfectly

Share this post


Link to post
Share on other sites
I took the kext from first post - it works perfectly

 

Alright thanks, I'll try that. What about audio? I tried the kext for z560 posted previously, however, still no luck.

Share this post


Link to post
Share on other sites
hi N but in your pakage isnt present the atheros kext: it means that atheros wifi works otb? and have you tested your package with SL or Lion or Both. Everyway thanks for uploading and sharing your dsdt and extra with us

 

no kext for wifi needed for me, works oob.

just in case, here is my smbios and boot plist, I forgot to include it with the kexts:

 

smbios.plist:

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">'>http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>SMbiosdate</key>

<string>07/26/10</string>

<key>SMbiosversion</key>

<string>MBP61.88Z.0057.B0C.1007261552</string>

<key>SMboardproduct</key>

<string>Mac-F22589C8</string>

<key>SMfamily</key>

<string>MacBook Pro</string>

<key>SMmanufacter</key>

<string>Apple Inc.</string>

<key>SMproductname</key>

<string>MacBookPro6,1</string>

<key>SMserial</key>

<string></string>

</dict>

</plist>

 

 

boot.plist:

 

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>Kernel</key>

<string>mach_kernel</string>

<key>Kernel Flags</key>

<string>-v arch=x86_64</string>

<key>GraphicsEnabler</key>

<string>Yes</string>

<key>GenerateCStates</key>

<string>Yes</string>

<key>GeneratePStates</key>

<string>Yes</string>

<key>Timeout</key>

<string>3</string>

<key>Legacy Logo</key>

<string>Yes</string>

<key>EthernetBuiltIn</key>

<string>Yes</string>

</dict>

</plist>

 

 

 

best

 

N

 

...only Snow, no use for Lion yet...

Share this post


Link to post
Share on other sites

Has ANYONE been brave enough to try Lion on this laptop yet? I'm really curious... Oh, and I finally got my laptop completely working (as far as I can tell), although I'm not sure how lol. Ethernet, built in wireless, QE/CI, audio, trackpad, keyboard, etc. it's all working

Share this post


Link to post
Share on other sites

I have been working on some laptop issues over the weekend and wanted to know if somebody came up with a solution:

 

1. HDMI Audio - Apparently it should be easy to get HDMI Audio working with Voodoo but I only have Headphones and Mic in Sound Preferences. An alternative would be to use a patched AppleHDA but I assume this doesnt work for our chipset. In Win7 HDMI Audio works so there must be a way!

 

2. Hibernation - Apparently this is working for N One but even with his DSDT, kexts, boot.plist and smbios it's not working for me. If you want to try out if its working

Go to terminal enter: sudo pmset -a hibernatemode 0

In Security tab in System Preferences disable "Use secure virtual memory"

Install http://deepsleep.free.fr/

 

For me it goes to sleep and its waking up but no USB devices are detected anymore after hibernation

Share this post


Link to post
Share on other sites

Hi!

Someone have AppleHDA.kext for Connexant Cx20585(Z560-62A-BK3)?

With VoodooHDA not work HDMI sound (GF310M) :)

Share this post


Link to post
Share on other sites

Would there be a change, if any, to use this guide with an Lenovo Z560 that uses a 480M processor instead of the 430M?

Share this post


Link to post
Share on other sites

I have everything working except for multi gestures via the trackpad. I had to actually remove the voodoops2trackpad from voodoops2controller in order to get my trackpad to work.

 

Anyone know how to get the trackpad to work properly?

 

ughhhhhhh, i'm also getting kernel panics when i use ethernet.

 

any ideas? anyone?

 

My specs are Lenovo IdeaPad Z560 0914-4GU - i5-480M 4GB/128GB SSD G310M

Share this post


Link to post
Share on other sites
new kexts for trackpad sinaptics .Seting panel tachpad system seting

TRACKPAD.SYNAPTIC_GESTURE.zip

 

hmmm, didn't work for me. i had to go into ApplePS2Controller.kext and remove ApplePS2Trackpad.kext to get my trackpad to work again...still without multi gestures. might try a reinstall...

Share this post


Link to post
Share on other sites

Динамик ноутбука speakers +

Разъм для наушников headphone +

Микрофон ноутбука mic -

Внешний микрофон Extmic +

Автодетект autodetect +

 

Device (HDEF)
		{
			Name (_ADR, 0x001B0000)
			Method (_PRW, 0, NotSerialized)
			{
				Return (Package (0x02)
				{
					0x0D,
					0x03
				})
			}
			Method (_DSM, 4, NotSerialized)
			{
				Store (Package (0x0E)
					{
						"AAPL,slot-name",
						Buffer (0x09)
						{
							"Built in"
						},
						"device-id",
						Buffer (0x04)
						{
							0x56, 0x3B, 0xEC, 0x10
						},
						"layout-id",
						Buffer (0x04)
						{
							0x0C, 0x00, 0x00, 0x00
						},
						"model",
						Buffer (0x1A)
						{
							"HD Audio Conexant Cx20585"
						},
						"name",
						Buffer (0x11)
						{
							"Conexant Cx20585"
						},
						"device_type",
						Buffer (0x11)
						{
							"Audio Controller"
						},
						"PinConfigurations",
						Buffer (One)
						{
							0x00
						}
					}, Local0)
				DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
				Return (Local0)
			}
		}

Purple_RC1.2.zip

Share this post


Link to post
Share on other sites

Yurick, can you please explain what this is meant for ?

 

- To adress the hdmi sound out problem only

- Is this to replace VoodooHDA ?

 

- will this work with AppleHDA when added to dsdt (without voodoohda?) ?

 

I cant read russian...

 

Thx

Share this post


Link to post
Share on other sites

Oh Wow! Thanks my Russian friend!

Now I have sound with the z560 in 10.6.8 WITHOUT VoodooHDA!!

Even the automatic switching for Headphones work!

 

I deleted AppleHDADisabler.kext

I installed the Purple AppleHDA from the post above to /System/Library/Extensions/ with KextHelper

and added his code to my DSDT

 

That was it ;)

 

Next will be HDMI Audio!

Share this post


Link to post
Share on other sites

Oh Wow! Thanks my Russian friend!

Now I have sound with the z560 in 10.6.8 WITHOUT VoodooHDA!!

Even the automatic switching for Headphones work!

 

I deleted AppleHDADisabler.kext

I installed the Purple AppleHDA from the post above to /System/Library/Extensions/ with KextHelper

and added his code to my DSDT

 

That was it ;)

 

Next will be HDMI Audio!

 

Featured include built-in microphone, and then he does not want to be switched

Share this post


Link to post
Share on other sites

hey yurick, i dont fully understand sorry! Right now the internal mic is not working, i have to connect an external device for microphone.... is there any way to enable internal mic?

Share this post


Link to post
Share on other sites

hey yurick, i dont fully understand sorry! Right now the internal mic is not working, i have to connect an external device for microphone.... is there any way to enable internal mic?

does not work and we do not know how to do it ... where is that it prevents

http://www.applelife.ru/topic/33384-lenovo-ideapad-z560-g560a-и-другие-mac-os-x-lion/page__hl__z560

Share this post


Link to post
Share on other sites

Hi all,

 

I have 10.7.3 running on this z560:

 

Lenovo IdeaPad Z560 M37AQGE - i5-430M 4GB/320GB G310M

 

Only problem so far, sleep doesnt work, well, actually it does, but the screen stays black!

 

Any ideas?

 

Help much appreciated!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×