Jump to content

<string>idlehalt=0<string> in Snow


5 posts in this topic

Recommended Posts

If I don't type cpus=1 every time I boot I get the stuttering effect, and when I use the idlehalt=0 so I don't have to remember to type the cpus=1 every time I boot my computer, I get a kernel panic.


Now the idlehalt=0 works very well under Leopard (10.5.x) but doesn't work in Snow Leopard (10.6.x).


Has any one found a solution for this problem. I hope so.


I ended up re-installing Snow about 5 times before I figured out that putting that idlehalt=0 between <string> was what was causing my kernel panics. Now even tho I've removed it I still get the kernel panic and can only boot in safe mode and still have to include the cpus=1 to not get the stuttering effect.


Now if you are asking how do I know that the idlehalt=0 is what was causing my kernel panics, if I sill get them even tho I've removed the idlehalt=0, the answer is that I've got another installation of Snow where I never put the idlehalt=0 and so far it has not kernel panic once. But I still have to type cpus=1 every time I boot to not get the stuttering effect.


All I can say is that there is something else causing the kernel panic. I have upgraded from 10.6.3 to 10.6.6. In the other installation I don't there upgrade because I don't want to end up with another kernel panic.



Acer Aspire 5601AWLMi

Intel Core Duo processor T2050

(1.6 GHz, 533 MHz FSB, 2 MB L2 cache)

15.4" WXGA CrystalBrite LCD (16ms)

Intel Graphics Media Accelerator 950

It came with 100GB HDD 5400rpm but I'm using an external 250GB USB drive

DVD-Super Multi double layer (support DVD+R Double Layer/DVD+-RW)

Came with 512MB DDR2 (support dual-channel) I added another 512 to make it 1GB

802.11a/b/g wireless LAN which I have never been able to get to work in Leopard

Link to comment
Share on other sites

You're right that was a typo on my part but in my com.apple.Boot.plist it's typed correct and my computer still panics.




Not <string>idlehalt=0<string>, it's <string>idlehalt=0</string>. Spot the difference.

Look for a C-state setting in your BIOS, and disable it? Maybe that'll help.

Link to comment
Share on other sites

  • 1 year later...
  • 1 month later...

I´m also new to the whole Hackintosh materia, but I was able to solve the sound problems.


I was investigating why my CPU (Intel T2300) won´t use Speedstep, because it always run at 996MHz and didn´t change the clockspeed (Geekbench 32Bit 1412 Points). At this time there weren´t any sound issues. Then I installed VoodooPowerMini.kext in S/L/E and removed NullCPUPowermangement.kext from E/E. Speedstep now worked (proofed with "SMC Monitor", Geekbench 32Bit 2221 Points), but the sound was horribly crackling and stuttering when the mouse was not moved. With tip of Gringo Vermelho (btw Thank you for this!) regarding the C-States I got it finally working.


First of all I changed the sampling-rate to 44100 and second I changed my org.chameleon.Boot.plist with the tool "Chameleon Wizard" by the following:

Generate P-States -> Yes

Generate C-States -> No (or not marked in "Chameleon Wizard")

Drop SSDT -> Yes


I also use a selfmade DSDT which got with the help of the program DSDTFixer, which fixed all the errors and warnings automatically. Don´t know if that is important to know.

My system is an Acer Aspire 5652WLMi running at 10.6.3. Hope this helping others.

Link to comment
Share on other sites


  • Create New...