Jump to content

Still waiting for root device


alexrose
 Share

13 posts in this topic

Recommended Posts

Hello,

I have a weird problem, and I say weird because, before being taken into service, everything was fine. I could install any version of mac on my notebook, without problems(and without video drivers - but that's not a very big problem).

Now, after my notebook is out from service(they changed the video cable and my dvd rw), I can't install mac on my pc. It keeps getting me that error: "still waiting for root device".

I tried dozen of versions: hazard, iatkos, kalway, ideneb, ipc etc but no luck.

 

 

Mentions:

- My notebook specs are in signature.

- Changing bios settings, it's not really an option for me(BIOS is fairly limited)

- i tried to boot with: -x -v; -f -v; cpus=1 -v; platform=ACPI -v (no luck)

- photo uploaded with error

post-666848-1295206245_thumb.jpg

Link to comment
Share on other sites

Sorry for the double post, didn't see you mentioned your HDD in your sig.

Your HDD is a PATA drive. You will most likely need some driver, because I think SL doesn't natively detect IDE drives, or SATA drives that are not in AHCI mode.

 

Edit: Nvm your desktop's HDD is SATA... (I need to get some coffee :P)

Double-check the RAID mode (can be called differently in your BIOS), and make sure it's set to AHCI. You usually have opions like IDE, RAID and AHCI, usually hidden in Advanced chipset configuration, Onboard configuration, or something similar.

 

Note that changing to AHCI makes any Windows (if you have any on your HDD) unbootable.

Link to comment
Share on other sites

Before the guys from service changed my video cable and dvd-rw i could install mac on my pc without problems. I don't think it has something to do with my hdd settings.

Also you mentioned something about hidden settings. Can you give me more details, please?

As I said, can't change anything from bios(frickin' limits).

post-666848-1295214259_thumb.jpg

post-666848-1295214266_thumb.jpg

post-666848-1295214273_thumb.jpg

Link to comment
Share on other sites

My guess would be that it has to do with your DVD drive. You said they replaced it. Is it the same model? Try installing OSX from a flash drive with your DVD drive disconnected.

 

Follow this guide to make the USB drive.

http://www.maciverse.com/install-os-x-snow...lash-drive.html

 

Edit: I just saw notebook. You can create a virtual Mac OS X in Windows using vmware and then create a working usb mac os x usb drive. If you are able to install it (the system recognizes your HD) then maybe with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] you can see the DVD. Cross your fingers for this though. You will have a Macintosh (I do not like the word Hack sorry) without a DVD, if you can settle for this ok.

 

Cheers,

Alexander.

Link to comment
Share on other sites

RAID on a Laptop, what are you smoking.

 

This is widely documented and easy to fix though.

Well, it AHCI necessarily have something to do with RAID, but some BIOSes call the setting Raid mode, whereas others call it IDE mode, IDE compatibility, SATA mode, MCP configuration (or something similar), etc.

 

I think, ONCE you have your OSX installed, you MIGHT be able to get rid of AHCI en enable IDE mode again, but the easiest way is to leave AHCI on, if you can, and follow this tutorial to make Windows bootable.

 

I'm currently investigating the possibilities of booting the install DVD without AHCI (because my laptop's BIOS is locked and does not allow you to change much).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...