Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Toshiba Satellite P500 Wireless/Wired connection problem.

1 post in this topic

Recommended Posts

Hi I had a post in the new users area and it was closed before the problem was resolved. Here I go again! I have a Toshiba Satellite P500-BT2G23 if you want more info click here http://www.toshibadirect.com/td/b2c/cdetland.to?poid=496203.

My eithernet does not work (I don't have the slightest clue on how to set up it maybe that's the problem) along with my wifi (Air port does not show anything). Also, after I restarted my laptop from the install my keyboard does not work anymore.


Here are my Ethernet and Wireless cards!


Atheros AR8132 PCI-E Fast Ethernet Controller

Realtek RTL8191SE Wireless Lan 802.11n PCI-E NIC


Thanks in advance,


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.