Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Andy Vandijck

Apple Shipping drive DVD fix (for PATA/SATA)

44 posts in this topic

Recommended Posts

Thank you very much dear Andy, worked beautiful for my PATA DVD (ATAPI), even burning, everything ok. The extension is loaded from /E/E. And shipping values (merged with mines) take it from MacBook3,1 (late 2007) IOReg jejeje.

6720s_MB31_PataLegacy_Andy.png

Also, following the advise and procedure applied by Smith@@™, additionally I have this:

Bus_ATA.png

Info.plist for edition purposes attached. All credits and gratefully to Andy of course. Cheers.

6720s_MB31_PATA_DVD_AndyMergeNub_info.plist_For_Edition.zip

Share this post


Link to post
Share on other sites

Hello Andy, this kext work in 64 bits? I have installed in my System x86_64 and it doesn't load the kext.

 

 

 

 

Thanks!!!!!!

Share this post


Link to post
Share on other sites

Even though this look like it works at least with one of my hacks (GA EP45-DS3 Q6600 cpu) the two DVDs I have in it actually seem to not work any better from before. I still get the probs one of them and sometimes both get "locked up", the OS sees them but I can´t access them. In theory it works but when you start to use the DVDs for real it does´nt seem there´s no difference from without this fix.

Share this post


Link to post
Share on other sites

Hi Andy,

 

Thanks for the guide to fix SATA and non SATA DVD drives. Unfortunately my system has no change with or with out the kext.

 

Attached are the files and the kext that I am using, will appreciate your help.

 

My SATA DVD Drive model is LG - GH22NS50

DeviceMergeNub.kext.zip

post-183336-1292646467_thumb.png

post-183336-1292646481_thumb.png

post-183336-1292646489_thumb.png

post-183336-1292646502_thumb.png

post-183336-1292646513_thumb.png

post-183336-1292646522_thumb.png

post-183336-1292646531_thumb.png

post-183336-1292646540_thumb.png

Share this post


Link to post
Share on other sites

a bit off-topic, but, does anybody know of an apple combo drive with bd support ?

Share this post


Link to post
Share on other sites

I tried this kext for my `TSSTcorp DVD+-RW TS-T633C` but still no luck.

 

Is this kext compatible for my drive? can anyone tell.

 

My drive spec is

vendor identification: TSSTcorp

Product identification: DVD+-RW TS-T633C

 

Edit:

 

Finally I got it working. I guess i was using wrong kext. But i am still having a little problem, I am unable to insert the CD/DVD into driver after system startup.

Share this post


Link to post
Share on other sites

Sorry for resurrecting the topic, but I've noticed this issue on both my desktop and my laptop with OS X 10.8.5. I was able to compile the source as a 64bit-only binary, using SDK 10.8, targeting OS X 10.6 and when I installed it, after the first reboot, my drive was recognized as Mat{censored}a DVD-R UJ-846 in System Information / DIsc burning, but the random spinning remains and usually it starts several minutes after my display has gone to sleep and stops, when I wake it up. Is there anything that can be done about it?

 

Edit 14.10.2013: It seems the 10.8.5 supplemental update solved the problem.

Share this post


Link to post
Share on other sites

Sorry for resurrecting the topic, but I've noticed this issue on both my desktop and my laptop with OS X 10.8.5. I was able to compile the source as a 64bit-only binary, using SDK 10.8, targeting OS X 10.6 and when I installed it, after the first reboot, my drive was recognized as Mat{censored}a DVD-R UJ-846 in System Information / DIsc burning, but the random spinning remains and usually it starts several minutes after my display has gone to sleep and stops, when I wake it up. Is there anything that can be done about it?

 

Edit 14.10.2013: It seems the 10.8.5 supplemental update solved the problem.

 

Thx so much for reporting back about 64bit issue, I thought it didn't work since no one confirmed...would you mind uploading your 64 kext mod please!, would it run with no problem on Mavericks, if so does it still solve the issue?

 

Thx

Share this post


Link to post
Share on other sites

Thx so much for reporting back about 64bit issue, I thought it didn't work since no one confirmed...would you mind uploading your 64 kext mod please!, would it run with no problem on Mavericks, if so does it still solve the issue?

 

Thx

You probably won't need it, if you have installed OS X 10.8.5 with the supplemental update or later. Turning off the Put the hard disk(s) to sleep when possible option in the Energy Saver prefpane will be quite enough.

Share this post


Link to post
Share on other sites

Thx so much...yea I know, turning it off fixes it, can`t help but think that it might be useful to have it, you never know, I`d have to insist if you don`t mind...sorry!

Share this post


Link to post
Share on other sites

Thx so much...yea I know, turning it off fixes it, can`t help but think that it might be useful to have it, you never know, I`d have to insist if you don`t mind...sorry!

There it is.

Debug and Release are 64bit-only, Release Leopard and Release Tiger are 32bit-only.

Share this post


Link to post
Share on other sites

Thx so much philip, 64bit ones work fine on Mavericks (it says SuperDrive now when you click on the eject button)...but it`s only cosmetic though since it didn`t fix anything unless you turn off that setting like you said..Thx again!!!

Share this post


Link to post
Share on other sites

Thx so much philip, 64bit ones work fine on Mavericks (it says SuperDrive now when you click on the eject button)...but it`s only cosmetic though since it didn`t fix anything unless you turn off that setting like you said..Thx again!!!

Could you compile one for me? I'm noob and know nothing about compiling kext   :(

OS X ML 10.8.5

My vendor: hp

My product id: BD E  DC6E2SH

(there're 2 spaces between 'E' and 'DC6E2SH')

Thanks in advance!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×