Jump to content
InsanelyMac Forum
Svenmike

Dual displays with XFX Radeon HD 4650!

Recommended Posts

Just wanted to share with anyone who wants to know, I finally managed to get dual displays with my HD 4650 card. This card has Dual-DVI so this may not work with other cards that have DVI, VGA, HDMI. I used Chameleon RC5 and I edited the framebuffer for HD 4650 to "Eulemor". This only gives mirrored displays, but the trick is to use ROM file.

 

I used GPUID in windows to extract the graphics card bios, and transfered it to my /Extra folder and renamed it 1002_9498.rom. Then used the AtiUseROM=Yes in com.apple.boot.plist.

 

I currently have one display on DVI and the other on DVI - VGA dongle since I only have 1 DVI monitor. I also am not sure if sleep works correctly yet. I will try a little later when I'm done with work and I'll report back.

 

Update: Just tried sleep and the monitors did not wake from sleep. Although this may be an issue with my DSDT rather than my graphics card. Does anyone know if sleep works with this card?

Share this post


Link to post
Share on other sites
Advertisement
Guest sincro77

i just installed iatkos 10.6.3 and updated ..installed ati radeon 4650..got dual mirrors right away.\

with qeci... so your whole bios thing with eulemur is not what giving dual mirrors.. i have mot mot

listed now... i had peregrine in 10.6.4 hazard but only single screen.. the boot files are what affect what ports are activated... so whoever makes those should know how to enable scereen 2 goddamit

Share this post


Link to post
Share on other sites
Just wanted to share with anyone who wants to know, I finally managed to get dual displays with my HD 4650 card. This card has Dual-DVI so this may not work with other cards that have DVI, VGA, HDMI. I used Chameleon RC5 and I edited the framebuffer for HD 4650 to "Eulemor". This only gives mirrored displays, but the trick is to use ROM file.

 

I used GPUID in windows to extract the graphics card bios, and transfered it to my /Extra folder and renamed it 1002_9498.rom. Then used the AtiUseROM=Yes in com.apple.boot.plist.

 

I currently have one display on DVI and the other on DVI - VGA dongle since I only have 1 DVI monitor. I also am not sure if sleep works correctly yet. I will try a little later when I'm done with work and I'll report back.

 

Update: Just tried sleep and the monitors did not wake from sleep. Although this may be an issue with my DSDT rather than my graphics card. Does anyone know if sleep works with this card?

 

Excellent!

 

Now running dual displays on my dual dvi xfx 4650 1gb on 10.6.5, full qe/ci. and it's fast!

Also monitor detection is fully working, I also cant test sleep, as my intel dq35j0 does not work with sleep presently.

I also had to change the device ids in the usual 4600 & x2000 kexts, but i worked a treat!

 

Thank you so much, for sharing your method!

Share this post


Link to post
Share on other sites
i just installed iatkos 10.6.3 and updated ..installed ati radeon 4650..got dual mirrors right away.\

with qeci... so your whole bios thing with eulemur is not what giving dual mirrors.. i have mot mot

listed now... i had peregrine in 10.6.4 hazard but only single screen.. the boot files are what affect what ports are activated... so whoever makes those should know how to enable scereen 2 goddamit

 

The only thing that the boot file does is tell inject OS X with what framebuffer to use for your graphics card. The framebuffer is what determines what connections work. You can manually change this with Chameleon source code and edit "ati.c". Read my reply to you on the other HD4650 thread.

 

 

 

Excellent!

 

Now running dual displays on my dual dvi xfx 4650 1gb on 10.6.5, full qe/ci. and it's fast!

Also monitor detection is fully working, I also cant test sleep, as my intel dq35j0 does not work with sleep presently.

I also had to change the device ids in the usual 4600 & x2000 kexts, but i worked a treat!

 

Thank you so much, for sharing your method!

 

Which framebuffer are you using and what connections are you using? i.e. dvi on both ports, or dvi on one port and vga adapter on the other

Share this post


Link to post
Share on other sites

Hi.

I have a saphire ati HD4650 512 gddr3 on EP45-ds3r motherboard. F10 bios and F10 dsdt.aml

Using iatkos s3 v2 (10.6.3).

Tried every method found on insanelymac but no luck.

 

Now i have my gpu bios. It is .bin not .rom

Can you explain what do i have to do in order to use it and make this card work ?

 

Thank you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×