Jump to content

ATI HD5670


FAQBoy
 Share

5 posts in this topic

Recommended Posts

Can anyone with a working ATI HD 5670 card explain how they were able to get it recognized correctly? I saw it in the new iMac and thought it should work without trouble on 10.6.4 and have seen others can do it. Nothing I try works.

 

Setting graphics enabler = yes gives me a black screen and makes the GPU fan turn on, even with ATY_Init and the Graphics Update files (ATI*.kext minus the ATIRadeonX3000* files) and my rom file as 1002_68d8.rom

 

Graphics Update 1.0 ATI files = Hang on boot, but can login single user

ATY_Init and the Graphics Update 1.0 files = Hang on boot, but can login single user

GraphicsEnabler = yes, UseAtiRom=yes, plus ATY_Init and the Graphics Update files = black screen and fan. I can't even boot single user and must use tonymac's ATI_5XXX_3 cd before I can fix my com.apple.boot.plist

 

I am using Chameleon 2.0 RC4 r684 with the Preboot.dmg from tonymac's ATI_5XXX_3 boot CD (I don't know what is in Preboot.dmg, but without it my system goes black and reboots itself when trying to boot the internal HD (Same for Install DVD).

 

I'm sorry if my English is not good. Please tell me to clarify if needed. Thank you.

 

Also I should add that the motherboard is a ga-p55-usb3 with i3 processor.

Link to comment
Share on other sites

Just in case anyone finds this via google. I now have the 5670 working with 10.5.4. I had two issues preventing it from working.

1. ATY_Init was the wrong version and did not include support for the 5600 series cards. Once I switched to the correct version I had half the battle won.

2. I was using a preboot.dmg ramdisk from Tonymac's boot disk that included the wrong version of ATY_Init. With 10.6.3 I needed the ram disk to get an image. However, 10.6.4 booted fine without it. I noticed there were two instances of ATY_Init starting in the logs and once I removed ATI_Init from /System/Library/Extensions, I was still getting one instance starting. That led me to the ram disk.

 

Once ATY_Init was installed I reran Graphics Update 1.0 installer to add back in the ATIRaedonX3000* drivers and then openGL worked with the ATI renderer.

 

After those two problems were solved, the correct ATI_Init worked with my 5670 card. Giving me better resolution and correctly identifying my card. I did a quick test and found the 5670 worked with the Uakari, Baboon, Vervet, Langur, Glago, Hoolock, and Motmot framebuffers for DVI out at 32bit. The Eulemur framebuffer did not work.

 

I hope this helps someone.

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...