Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
DaniFilth

Attansic L1 Built-in on Snow Leopard 10.6.4

16 posts in this topic

Recommended Posts

Hello,

 

anyone got the Attansic L1 (1969:1048) running on Snow Leo 10.6.4? Installed yesterday with 10.6.3 Retail and Chameleon on my Asus P5KPL and everything is working perfectly except that damn onboard LAN.

 

I installed this kext and actually everything appears to be fine, the controller is detected and listed everywhere it should be, but it can't get an ip over dhcp. I can manually assign an ip to me, but still don't reach any other host in my lan. Strange thing, after some time (about 10-15 mins) my server and MacBook are listed in the Finder sidebar, but anyway not reachable, when I click them. Already updated to 10.6.4, but no change...

 

Someone got a hint for me?

Share this post


Link to post
Share on other sites

Okay, I solved the problem and the solution was very simple. I found this page and wanted to compile the driver myself. First I removed my old AtherosL1.kext and rebooted the system, suddenly my network card received an ip from my dhcp server. I checked the kexts with System Profiler and saw, that there was an AttansicL1.kext now active and working. I just forgot to remove a non-working AtherosL1.kext, which blocked the working AttansicL1.kext.

 

For everyone interested, I attached the AttansicL1.kext, working for me on an Asus P5KPL, Snow Leopard 10.6.4 64-bit. System Profiler says it's 32 and 64 bit compatible.

AttansicL1Ethernet.kext.zip

Share this post


Link to post
Share on other sites
Okay, I solved the problem and the solution was very simple. I found this page and wanted to compile the driver myself. First I removed my old AtherosL1.kext and rebooted the system, suddenly my network card received an ip from my dhcp server. I checked the kexts with System Profiler and saw, that there was an AttansicL1.kext now active and working. I just forgot to remove a non-working AtherosL1.kext, which blocked the working AttansicL1.kext.

 

For everyone interested, I attached the AttansicL1.kext, working for me on an Asus P5KPL, Snow Leopard 10.6.4 64-bit. System Profiler says it's 32 and 64 bit compatible.

j

Hi,

Is it working after wake from sleep?

Share this post


Link to post
Share on other sites
Okay, I solved the problem and the solution was very simple. I found this page and wanted to compile the driver myself. First I removed my old AtherosL1.kext and rebooted the system, suddenly my network card received an ip from my dhcp server. I checked the kexts with System Profiler and saw, that there was an AttansicL1.kext now active and working. I just forgot to remove a non-working AtherosL1.kext, which blocked the working AttansicL1.kext.

 

For everyone interested, I attached the AttansicL1.kext, working for me on an Asus P5KPL, Snow Leopard 10.6.4 64-bit. System Profiler says it's 32 and 64 bit compatible.

Hi, Dani

I am interested in the new compiled driver. Have you tried the newly compiled AtherosL1.kext? Not the AttansicL1.kext.

And would you share the new one, please?

Share this post


Link to post
Share on other sites
j

Hi,

Is it working after wake from sleep?

 

Sorry, don't know since my hardware doesn't support sleep on OS X.

 

Hi, Dani

I am interested in the new compiled driver. Have you tried the newly compiled AtherosL1.kext? Not the AttansicL1.kext.

And would you share the new one, please?

No, I didn't, but I will do the next days...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×