Jump to content

Stop Ubuntu Drive from Automounting?


Zanneth
 Share

1 post in this topic

Recommended Posts

Hello there!

 

I just installed Ubuntu 10.10 on a drive that is completely independent from my Snow Leopard drive today. Everything is the same with both OS's, but now everytime I boot into OS X, I get this:

 

http://cl.ly/603a4e3a8cde57b417a9

 

I'm assuming it's because it's trying to mount my Ubuntu drive, but since Snow Leopard can't read or write ext4, it fails. It's getting kind of annoying and I want it to stop trying to mount my drive each time I boot.

 

I tried modifying my /etc/fstab file to add the following lines:

 

UUID=<UUID for Main Partition>  none  ufs  ro,noauto
UUID=<UUID for Swap Partition>  none  swap  sw,noauto

 

but this doesn't work. Each time I boot I still get the dialog box that says that it tried to mount it and failed. There doesn't seem to be any errors in any system logs on bootup. I got both of the UUIDs from Ubuntu, because apparently there's no way to get the UUID of a drive in Snow Leopard unless it's mounted and working.

 

Am I doing something wrong? Perhaps I don't have the right filesystem type in my /etc/fstab? In fstab's man page, it doesn't list ext4 as an option, so I'm using 'ufs' instead. Perhaps I'm using the wrong UUID? I got the UUIDs from Ubuntu by typing 'ls -l /dev/disk/by-uuid'.

 

Any help is greatly appreciated! Thanks!

Link to comment
Share on other sites

 Share

×
×
  • Create New...