Jump to content
buoo

[Guida] Snow Leopard su Asus P5Q Series

1,290 posts in this topic

Recommended Posts

Snow Leopard su Asus P5Q Series

 

 

schermata20101011a12231.png

 

 

Guida semplicissima per l'installazione di Snow Leopard Retail su schede madri Asus P5Q Series (Chipset P45/ICH10R - G45/ICH10). Questa non vuole essere una ripetizione di guide già presenti ma semplicemente un sistema più semplice per consentire a noob e utenti con minor disponibilità di tempo, di installare Snow Leopard sostanzialmente in tre passaggi. Prima di scendere nel dettaglio sarà necessario munirci di una copia di Snow Leopard Retail 10.6.X.

 

 

Informazioni utili

Questa guida è studiata per possessori di schede video Snow-Compatibili, così eseguita va a pennello per possessori di schede video Nvidia ed alcune Ati Radeon serie 4XXX. Qualora foste in possesso di altre schede video quali ad esempio Ati serie 5XXX potete tranquillamente contattarmi, al più più presto dove possibile fornirò tutto il necessario. La guida non si addice ai possessori di vecchi processori Intel con Socket 775, qui solo Dual & Quad Core. La base dei pacchetti autoinstallanti è Chameleon 2 RC5 Rev 570 sfruttato per la generazione automatica dei C-States e P-States per il funzionamento nativo dello Speedstep e DSDT customizzato.

 

 

Guide attualmente disponibili

P5Q - P5Q3 - P5QD Turbo - P5Q Pro Turbo - P5Q Deluxe - P5Q-VM - P5Q Pro - P5Q-E - P5QL Pro

 

 

 

 

--------------------------------------------------------------------------------------------------

 

Boot-132

 

 

Alternativo

 

 

--------------------------------------------------------------------------------------------------

 

 

Guida

 

Per prima cosa scaricate l'archivio specifico per il vostro modello e il combo update 10.6.6 reperibile dal sito ufficiale dell' apple __http://support.apple.com/kb/dl1349 , masterizzate il cd boot-132 ed impostate le seguenti modifiche al bios:

 

 

Storage Configuration

Configure SATA as [AHCI]

 

Power

Suspend Mode [s3 Only]

ACPI 2.0 Support [Enable]

ACPI APIC Support [Enable]

 

 

Possiamo iniziare! Inserite il Boot-132 nel lettore DVD e lasciate partire il pc da DVD. Una volta giunti alla schermata del Chameleon estraete il Boot-132 e sostituitelo con il DVD di Snow Leopard. Attendete che venga caricato, schiacciate F5, poi lo selezionate, ed infine premete invio.

 

Un esempio:

schermata20101007a13014.png

 

Partita l'installazione di Snow, una volta selezionata la lingua, aprite Utility Disco dal menù Utility e create tutte le partizioni che volete formatandole in Mac OS esteso (Journaled) e scegliendo come tabella delle partizioni GUID. A questo punto possiamo chiudere Utility Disco ed installare sulla partizione che vogliamo.

 

94708897.png- 98612854.png

 

Aspettate che la barra scorra fino al 100% fino ad ottenere un messaggio di questo tipo (non vi spaventate)

 

schermata20101007a13192.png

 

Riavviate con il Boot-132 all'interno del lettore, ma questa volta, giunti alla schermata del Chameleon, selezionate la partizione dove avete installato Snow e premete invio. Così facendo, vista la presentazione di Snow e selezionate un paio di preferenze, tra cui la scelta della password, giungerete alla scrivania. Adesso scompattate l'archivio ed installate il pacchetto autoinstallante, non riavviate ma installate il combo update 10.6.4, infine riavviate. A questo punto potete togliere il Boot-132 perchè non serve più. Rigiunti alla scrivania aprite kext Helper b7, programmino per installare kext fornito nell'archivio ed installiate i kext evidenziati di giallo trascinandoli all'interno del programmino inserendo la password e premendo su Easy Install.

 

p.s. spesso kext helper fa un po' di capricci dopo l'installazione dei kext ..è normale ;) (se non si chiude dopo l'installazione dei kext forzate la sua chiusura)

Lanciate il programmino Kext Utility per riparare i permessi.

 

 

40308917.png- 62356899.png

 

Adesso aprite il Terminale e scrivete: sudo pmset -a hibernatemode 0, schiacciate il tasto invio poi scrivete la password e di nuovo invio.

 

Riavviate e buon Mac :D

Share this post


Link to post
Share on other sites
Advertisement

Complimenti per lottimo lavoro Buoo, veramente semplicissima. Questa potrebbe essere veramente una guida NoobProof. Avanti così ;)

Share this post


Link to post
Share on other sites

No, non mi funzia, sono arrivato fino all'aggiornamento al 10.6.4 e al riavvio si pianta come con la guida di mrmojorisin in questo modo

img00007201010081800.th.jpg

sembrerebbe un problema sull'apic.... sicuramente viene dal dsdt

 

Io sono sicuro di aver fatto tutto a modo nel Bios, però se vuoi mi metto a fare un po' di foto e le posto.

 

ciao

Share this post


Link to post
Share on other sites

Si, una volta tolto il dsdt va dentro come un treno.... e poi si spegne anche bene!

 

quindi continuo nell'installazione dei kext gialli, riparazione permessi e il comando a terminale (Cos'è?)

 

tutto ok, la macchina gira a 64 bit, vedo la mancanza di alcuni kext che tu avevi risolto con il dsdt.(dischi arancioni)

 

Soprattutto ora si spegne finalmente, poi va in stop e si risveglia dallo stop... ma poi quando le dico spegniti: panic... ma solo dopo il risveglio dallo stop.

 

Riavvia ok.

 

Voodoohdaprefpane fa piantare il pannello preferenze

 

 

Io non capisco cosa ha questa macchina di diverso con quella di mrmojorisin (da cui immagino provenga anche il tuo DSDT)... ha 2 giga di ram in più e il processore leggermente diverso, ma sempre un quad core (poi nel dsdt non ci dovrebbe essere lo speed step se ho capito bene).

 

Tra l'altro se ti posso muovere un piccolo appunto i tempi di chameleon sono cortissimi.

Forse sarebbe meglio avere la possibilità di fermare il boot per dare dei flag proprio nei primi momenti dell'installazione e della sua messa a punto per poi ridurli come hai fatto tu... ma è una sciocchezza

Share this post


Link to post
Share on other sites

Bene allora una volta tolto il DSDT installa EvoDSDT ed estrai il tuo dsdt originale, lo compili e lo metti al posto di quello che ho customizzato io.

Vedi se va ....

Share this post


Link to post
Share on other sites
Bene allora una volta tolto il DSDT installa EvoDSDT ed estrai il tuo dsdt originale, lo compili e lo metti al posto di quello che ho customizzato io.

Vedi se va ....

 

calma calma... io sono gnucco parecchio con sta cosa del dsdt...

il dsdt l'ho estratto con ubuntu (una volta ho letto che non si poteva farlo da snow) poi devo correggere gli errori comuni poi lo compilo così com'è e lo metto in extra giusto?

Share this post


Link to post
Share on other sites
calma calma... io sono gnucco parecchio con sta cosa del dsdt...

il dsdt l'ho estratto con ubuntu (una volta ho letto che non si poteva farlo da snow) poi devo correggere gli errori comuni poi lo compilo così com'è e lo metto in extra giusto?

 

Lo devi estrarre con il programmino che ti ho detto Evodsdt, non fare alcuna correzione! Premi il tasto compile lo rinomini in DSDT.aml e lo piazzi in extra.

Riavvia e vedi se va, dopo quelle 2, 3 modifiche da fare te le faccio io una alla volta

Share this post


Link to post
Share on other sites
Lo devi estrarre con il programmino che ti ho detto Evodsdt, non fare alcuna correzione! Premi il tasto compile lo rinomini in DSDT.aml e lo piazzi in extra.

Riavvia e vedi se va, dopo quelle 2, 3 modifiche da fare te le faccio io una alla volta

 

Yep! funziona il zavaglio!

 

questo è il dsdt:

dsdt.rar

Share this post


Link to post
Share on other sites

faccio i miei sentiti complimeti a buoo per questa guida...molto curata soprattutto la parte dsdt ( a mio modesto parere ) spero che verrai riconosciuto per tutto il lavoro che stai facendo...e sperando di non sporcare... Alien il dsdt è lo stesso postato qui http://www.insanelymac.com/forum/index.php...t&p=1562657 con la sola modifica della sezione CPU ( Alias rimosse ) ....qualcosa ci sarà di diverso? oppure ho cannato?

Share this post


Link to post
Share on other sites

Ho provato l'installazione adesso, ma dopo aver installato, il pacchetto pel la mia mainboard e il combo, il sistema non parte più

Sono partito con -s, ma non riesco a cancella il dsdt.aml (causa sicura dei miei problemi)

Mi dice file di sola lettura

Che faccio?

Share this post


Link to post
Share on other sites
Prova adesso

 

 

 

 

 

tonihorse prova anche tu questo dsdt.

 

Al boot dai il comando DSDT=/Extra/abc.aml rispetta le lettere maiuscole

 

Faccio ripartire il sistema

velocemente faccio partire chameleon

tasto tab

vado sul boot

scrivo la tua dicitura

ma nada de nada

schermo nero ed il sistema non va

 

Perdonami ma quella stringa a cosa serve?

Share this post


Link to post
Share on other sites

sicuro che non è la porta video dietro???

prova l'altra porta della scheda video, a me la 9600 lo faceva con la porta dvi, invece co la vga tutto perfetto.

 

quello è!

Share this post


Link to post
Share on other sites
sicuro che non è la porta video dietro???

prova l'altra porta della scheda video, a me la 9600 lo faceva con la porta dvi, invece co la vga tutto perfetto.

 

quello è!

 

Grande, il problema era proprio la scheda video

Ora funge tutto senza problemi

Anche la risoluzione video va perfettamente

 

 

Grazie mille boo, sei un grande

Share this post


Link to post
Share on other sites
Prova adesso

 

Allora, sempre meglio...

i dischi non sono più arancioni

dopo lo stop si spegne correttamente

 

se c'è una chiavetta (Flash drive) attaccata (anche smontata) non va in stop, o meglio ci va e si sveglia subito dicendo che non è quello il modo di togliere una chiavetta

 

Quali modifiche hai fatto?

 

A breve aumenterò la ram, serviranno modifiche?

 

EvOreboot serve ancora?

 

Alien il dsdt è lo stesso postato qui http://www.insanelymac.com/forum/index.php...t&p=1562657 con la sola modifica della sezione CPU ( Alias rimosse ) ....qualcosa ci sarà di diverso? oppure ho cannato?

 

No dai, mi sono espresso male e ti ho fatto capire peggio, io avevo postato un dsdt ancora sporco, solo perchè speravo che qualcuno mi dicesse dove stava la differenza hardware con quello di mrmojorisin.

 

comunque grazie dell'interessamento e dello sbattimento....è bello sapere che c'è una comunity così.

Share this post


Link to post
Share on other sites

arrivo spè

 

 

adesso proviamo a migliorare ulteriormente il DSDT ...spè te lo posto.

 

non perdere questo qui che è già a buon punto :wacko:

 

 

EDIT: prova al terminale a dare questo comando sudo pmset -a hibernatemode 0 poi la pasword ecc eccc

Share this post


Link to post
Share on other sites

Scusa Buoo notavo adesso che il sistema non si spegne

Il riavvio funziona bene, ma quando spengo, quadro nero disco off ma il tutto resta acceso

Share this post


Link to post
Share on other sites
Scusa Buoo notavo adesso che il sistema non si spegne

Il riavvio funziona bene, ma quando spengo, quadro nero disco off ma il tutto resta acceso

 

 

Questo succede se spegni col tasto del case oppure dalla barra della scrivania?

Share this post


Link to post
Share on other sites
Con tutti e due i modi!!!

 

 

ma nella cartella Extra/extensions c'è il kext Evoreboot??

 

prova a dare il comando sudo pmset -a hibernatemode 0 al terminale, poi metti la password e prova a spegnere

Share this post


Link to post
Share on other sites
ma nella cartella Extra/extensions c'è il kext Evoreboot??

 

prova a dare il comando sudo pmset -a hibernatemode 0 al terminale, poi metti la password e prova a spegnere

 

il kext è presente

ho dato il comando da terminale, ma nada de nada

come prima quadro nero disco off e tutto il testo acceso

Share this post


Link to post
Share on other sites

Se premi il tasto del case lo mandi in stop, non lo spegni.

Cmq mi sembra strano sto fatto che non si spegne ...sicuro che non premi stop invece di spegni ???

Prova a premere stop allora invece di spegnere

Share this post


Link to post
Share on other sites
Se premi il tasto del case lo mandi in stop, non lo spegni.

Cmq mi sembra strano sto fatto che non si spegne ...sicuro che non premi stop invece di spegni ???

Prova a premere stop allora invece di spegnere

 

 

Stop e/o spegni fa sempre la stessa cosa

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×