Jump to content
InsanelyMac Forum
crackpot fish

OSX on HP Z600

Recommended Posts

UPDATE 2012-04-18: As there are still some poor souls out there who want to turn their Z600 into a MacPro, let me give you an update on how things are.

UPDATE 2012-07-13: Just checked this thread three months on and I almost had to laugh at how grumpy (to my own eyes at least) and pi..ed off I come accross in some sentences. Apparently it took more out of me than I realized. I'll just leave it that way, since that's how it was, but please don't take offence.


1. I am still using mine and it works fine on 10.6.8 SL

2. My hardware setup is


- HP Z600 with Bios 3.54 PCB rev B (the one that cannot take E56xx)

- Dual Xeon E5520 2.26GHz

- 12GB (2x3x2GB)

- Original HP Firewire PCIe card for Z600

- ASRock SATA3 PCIe card (x1, Marvel 9120 based)

- 2x Corsair F120 SSD

- 2x 1TB 7200rpm Seagate HDD

- AMD RADEON HD5770 1GB (Sapphire Flex)


3. All hardware works.

4. I was quite happy with it. Until ...


One person contacted me last week and asked how I had done it. I was curious if the setup still were possible they way I did it last time. What ensued was failure after failure for almost a day - then I succeeded. It was not a lot of fun. I won't be doing this again anytime soon.

Let me just say, I have installed originally in 2010Q4, with one proc and 6GB and no expansion cards and two disks. Putting stuff into a case is more enjoyable than taking it out again and putting it in again (several times over).


What I had to do is basically what Tony Mac says and really what I can recommend you do, item by item, without cutting corners. That is the gist of it. Do NOT cut corners. Do NOT skip steps. Hackintoshes don't roll that way.


0. Connect a PS2 Keyboard (and PS2 mouse, if you have it) to the Z600. USB will be dead until you manage to get a working USB kext onto it, which is past item 13 (and which is past my caring) in this list.


1. Remove ALL PCIe cards except for the controller you will be booting from and your graphics adapter. I mean physically remove them from the case. Don't try to get past that with disabling ROM, disconnecting drives etc.etc. Nobody cares, at least OS X won't.


2. Insert the controller card for booting; in my case this is a cheap 20€ JMB363 2-port SATA card. I put it into the second slot (first x16) from the top. I have the graphics in the 4th (second x16) slot. NOTE: Everytime I say "the controller" from now on, I mean the PCIe JMicron JMB363 one. We don't use the onboard Intel, we don't work with Sil3132, no Marvell, nothing. The only thing I got to work is the JMB363. Please ask somebody else if you want to use a card based on a different chip.


3. The controller MUST support AHCI/RAID and MUST be set to AHCI/RAID mode.


4. Connect the CD/DVD to one SATA port and the target HDD to the other SATA port. NOTE: You might have to switch those around in very rare cases (I had to). I have no clue why it would make a difference. But the CD should be on the first SATA port. If you have a combined IDE/SATA controller like my JMB363 from LogiLink, don't use a hard disk or CD on the IDE port. And don't use a USB CDROM


5. Do not connect anything to any of the onboard SATA ports. Nada. Not a single disk, a second DVD or whatever. You do not have to disable the Intel onboard SATA or put it into IDE mode or kick it in the balls. It does not matter. Just don't connect anything to it.


6. Remove everything except for 1 stick of 2GB each per processor, for a MAX of 4GB. Yes, you will have to fumble the other sticks out and re-insert them later; sometimes you will get quite far in the install with a lot of memory, then suddenly die from 'pmp_steal_memory....' or a similar disease. I know pulling RAM in the Z600 is tedious, but labatyd, get over it.


7. Yes, again check that you have removed ALL cards; no firewire, no PCI, no offboard sound, no video - nothing. Firewire cards WILL be found and that will skew your IO Controller structure and OS X will try to boot off of your connected video camera or your bicycle or god knows what. Also, another SATA controller WILL be found. I understand you won't rip out the ICH10R from the mainboard, lucky for us, it is not a requirement.


8. Boot with the eyeBoot-ATI-5xxx-3. YES, I KNOW! There is a cryboot-3.3.0 now. The sad thing is, it will not work with this rig, even if it makes a fairly good effort. It even gets past the "Still waiting for root device", but it hangs sometime later during Ethernet (or maybe if you give it a few days, it will continue). And yes, the Legacy 2.7.2 won't work either, because it lacks ATI support; you'll know when the fans rev up. If you manage to get them to work, greaty-ay, drop me a line. I couldn't.


9. Remove Abbot-ATI-5xxx-3 CD.


10. Insert full retail Mac OSX DVD (10.6.3 in my case)


11. Press F5.


12. Boot MAC OSX Install with -v only (don't pass anything else, no -x, no PCIRoot no PCIRootUID...). This will take a while, at least a few minutes, but less than 15.


13. When you get to the setup screen, you've won. Just read one of the other tutorials on installing your favorite kexts, setting up a DSDT, the works.



I hope you'll manage to.




I got the question 'can you post your BIOS settings, etc.' quite often. I never needed to change the BIOS settings and when I have altered them -out of despair- to the best of my knowledge it was without any positive or detrimental effect on the success of my installation attempts. I run the install with Multiprocessor, all cores active, ROM enabled on all slots etc.etc. The key is having only hardware physically present inside the machine that the boot disk does understand or at least manages to ignore without panicking.


----Original post follows------


First off, sorry for the long post. I just want to provide as much information as possible, not to steal too much of anybody's time.




Has anybody got 10.6.X SL working on a HP z600 workstation?


I have


HP Z600

1x E5520 CPU XEON Nehalem 2.26 4/8

1x XFX ATI HD5770


Intel ICH10R SATA on-board

1x DVDROM SATA internal

1x DVDROM USB external

2x SAMSUNG 1TB HDD sATA internal

SB Audigy PCI

Realtek 8119 PCIe Ethernetcard (should be supported)



Bios Rev 03.12 Rev.A

PCB Revision is B3 (not the newer C2, so no 5600 CPU support)


I use

-######-ATI-5xxx-3 and Retail Snow Leopard (I have both a 10.6 and a 10.6.3)


I have tried


-Booting from both USB or DVD-ROM

-combinations of -x -v cpus= (1 and without) busratio= (17 and 22 and without)

-rd= (one of disk0,disk1,disk2,disk0s1,disk1s1...)

-BIOS SATA: IDE mode/AHCI+RAID mode with BIOS download/AHCI+RAID without BIOS

Note: if BIOS download = Disabled => Harddisks become unbootable

-Switching the DVD/disks around on the SATA ports



The outcome now invariably is that I get the dreaded: Still waiting for root device.



BUT: Once I have actually gotten to the INSTALLER WINDOW (!) and I could select the language etc. The problem though was that none of the hard disks where visible for installing/partitioning (in Disk Utility).


The sad thing now is that I can't remember what my BIOS settings and or hardware config were (yes, I am THAT stupid; changing a lot of settings and not writing down the current one, really bright...).


I believe that basically installing on the Z600 should be feasible.



- At the moment all the hardware again is in the computer. Is taking things out really relevant for getting rid of the "still waiting for root device" error? (The first few tries I followed tony's advice and pulled 1 stick of 2gb, removed the pcie cards except for video...)

e.g. reduce mem to 4GB, take out Audigy, take out RealTek...

- How can I best test what exactly the problem is?

- Does anybody have experience with the Z600 and osx86? I have read the thread on the successful Z800 install, but the problem is the Z800 has SAS support/controller in addition to SATA, my Z600 only has 6 SATA ports, which seemed the key to success there.

- I have a (cheap-ass) SATA/IDE PCI extension card in another computer; would it make sense to extract that, put it into the Z600, then try to install from it? I do believe it has a Silicon Image chip.

- Is ###### even the best way? Alternatives? Am I doing it wrong? I do

1. ###### boots (from DVD)

2. Switch disk to retail

3. <F5>

4. Mac OSX Install DVD appears

5. specify options

6. <Enter>

7. Mild adrenaline rush as messages whizz past, eyes frantically hunting for any sign of different outcome

8. Messages end, waiting period of about 20 seconds

9. Still waiting for root device

10. Tears and sobs

- I have a real MBP 17" with 10.6.4 on it; does that help in any way for the install? (create images there or whatever).





Share this post

Link to post
Share on other sites

Update: I manage to reliably get to the installer now, using the external pcie SATA controller (and hooking the dvd up there) and [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]-ATI-5xxx-3 with Retail 10.6.3.


But no luck seeing the hard disks in disk utility. :)


Any experience which external PCIe SAS/SATA controller would work?






Share this post

Link to post
Share on other sites

Update: I have now a(n almost completely) working installation. Woot!


Details: Strangely enough one of the main points to success was to change the connectors on the SATA controller (LogiLink with JMicron 20363 chip) i.e. swap DVD and HDD (used a spare disk for this).


After that installing went smoothly.


BUT: normal disks could not be seen, no usb (rather a bummer), only mirror graphics, USB does not work, so you MUST use a PS2 keyboard.


Then: installed 10.6.4 update, no problems there.


Then: kext injection part 1) [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]

Note: For graphics you have to take the Ver...-think, not the U... (Uruk Hai? No.)

Still no go on the USB and disk frontier.

Also did an [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] here



Then: kext injection part 2) manually

Went to kexts.com.

Downloaded everything USB and SATA controller relevant.

Yes! Working USB, working USB bluetooth dongle, my linux SATA disks (on the ICH10R) popping up in disk utility. => The key for the SATA here was AHCIPortInjector.kext, I think.


kexts I installed (not all might be necessary)























Next steps / remaining problems:

- 6GB are recognized in System Info, but only 4GB are shown as available; i don't think it's a 32-bit issue, but could be

- HDA internal is working, SB Audigy is not => looking for driver

- I still can only boot from the DVD; if I boot from hard disk I get "still waiting for root.."; string since my kexts are found when I do from DVD. Need to look into this some more, maybe I need a preboot.dmg ; simple rd= does nothing.

- I have 3 screens connected to the XFX 5770 (DVI,DVI->VGA,DisplayPort->MiniDisplayport->DVI); this works in Linux as a multihead with radeon driver, even though the Displayport adapter is passive (you have to do a little trick, though). In OSX only 2 out of 3 are working in multi, but all 3 in mirror. Maybe I can fix this.


This thing is really fast!




Share this post

Link to post
Share on other sites

I have now a working bootable install! :P


(reminder: If I mention vendors/brands it is not to advertise them, but to make it easier for others to reproduce and follow)


I started completely over with a clean install, DVDROM and target disk connected to a JMicron (0x197b 0x2363 JMicron JMB362/JMB363 AHCI Controller), this time splitting the hard disk into 2 partitions. One partition I keep as backup for each step of progress I make on the working system.


Currently working hardware

OnBoard BCM Ethernet

Onboard Intel HDA Audio

Bluetooth dongle USB

USB Wireless Mouse

USB Apple Keyboard

ATI XFX 5770 1GB with 2 monitors

ICH10-R RAID (onboard)



Note: After I had done all the steps -to the last comma- as suggested by tonymac the last time (i.e. removing parts of the hardware), I simply did not want to go through that again also because pulling cards all the time poses the danger of damage to the hardware and is really time consuming.

The install went smoothly anyway with all of the following hardware present. I am not saying that tony's suggestions are invalid in any way, just that it wasn't necessary for my setup to pull the hardware.


LogiLink JMicron controller in PCIe Slot 1

XFX5770 in PCIe Slot 2

SB Audigy in PCI Slot 2 (not working though)

6GB installed

1x 1TB Seagate ST31000528AS HP34 Barracuda 7200.12 connected to SATA port 0

1x 1TB Seagate ST31000528AS CC38 Barracuda 7200.12 connected to SATA port 1

1x 80GB Seagate ST380013AS 3.05 connected to JMicron

1x HPDVDROM connected to JMicron



Important steps:


1. Getting USB to fully work is not that easy, I backed up the IOUSBFamily.kext from the System/Library/Extensions and moved it to /Extra/Extensions; there inside the .kext (Contents) I replaced EHCI,OHCI,UHCI with the versions from kexts.com. Take care though, when messing with /S/L/E.


2. I never got the hard disk boot to work from the JMicron; I don't know why, but I tried everything I can think of, no cigar. :unsure: However with the Intel RAID controller working I decided to try something different and simply plugged the Hard disk into an nboard SATA port of the ICH10R and - it works! So: INSTALL with DVDROM and Disk attached to JMicron (for me it worked only with DVDROM on the inner and disk on the outer port; might be different on yours), for BOOTING move the hard disk to the onboard-ICH10R Controller. :graduated: Yay!


3. for graphics support, you have to put GraphicsEnabler=No and install the ATI5xxx kexts into the System; use kext helper b7 (from [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]) to install; they are going into /System/Library/Extensions not /Extra/Extensions! If I run with GraphicsEnabler=Yes, I get blank screen and full fan spin, followed by a reboot.


4. Never forget to run Kext Utility or System Utilties from [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] before trying another boot :excl:


5. My current list of kexts









IOUSBFamily.kext => copied and modified (!)


































6. my /Extra/com.apple.Boot.plist

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">




<key>Kernel Flags</key>






<key>Legacy Logo</key>













Note: the com.apple.Boot.plist on your disk will not be read when booting with [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]-DVD (and selecting the disk); it boots but the [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]-DVD has its own com.apple.Boot.plist which it reads and has maxmem=4096 in place as a kernel flag, so you will only see 4GB of RAM. Now I get all 6GB with the native hard disk boot and the file above. All your settings in your hard disk Boot.plist are in vain if you boot from the DVD.


Things to try next:

- Boot in 64bit mode (trying that right after sending this post) :worried_anim:

- 3 Monitors simulatenously


<NOTE> :offtopic:

Note for ATI XFX 5770 - also of interest for linux users:


It appears that there is no way for an ATI 5770 to get three monitors working without an active adapter (DisplayPort->DVI,DisplayPort->VGA). BUT: The funny thing is I do have it working on Linux (Gentoo) with the opensource radeon driver. My setup is

DisplayPort: Adapter LogiLink:DisplayPort->MiniDisplayPort + Adapter:MiniDisplayPort->DVI->BenQ T905

DVI: ->Dell SP2309W

DVI: Adapter Apple: DVI->VGA->Samsung SyncMaster 192V

(DisplayPort->HDMI also works, but gives me a red line on the far left on the monitor, so I chose this)


The trick is that when you start X with the radeon driver, you will only get an image on DisplayPort and DVI-0, but if you simply execute (and put this into a Gnome Startup Item):


xrandr --output DVI-1 --rate 75 --auto


And the third screen will be there! You can also do it manually by selecting the third screen in gnome Display setup and selecting a different refresh rate, clicking apply and then simply revert this change right away. The screen/card just needs a little nudge, apparently.


Maybe there is a way for OSX, too, even though I have just ordered a Sapphire DP->Single DVI adapter for € 20, maybe that will do it without the tricks...



Share this post

Link to post
Share on other sites

- No cigar on 64-bit which is kind of obvious now, since ATY_Init is 32-bit :)


- Booting from my grub2 (on disk0) works via chainloading. Just create an entry like this


set root='(hd2)'

chainloader +1



(that's with having OSX on third SATA disk, of course, hd0 = linux1,hd1=linux2,hd2=OSX)

Share this post

Link to post
Share on other sites

OK, so I am still facing the same (minor) issues:


1) Sleep only works if I explicitly load SleepEnabler.kext (as root) after I have booted. Wakeup works nicely, resleeping and rewaking also works. But I have to kextload it the first time. Strange.


2) Shutdown is not working. Restart is OK, but with shutdown the machine seems to power down completely, then (about a second afterwards) it comes back alive again. I'll check if any connected peripheral causes this (e.g. when I turn OFF my DELL monitor with integrated webcam, that is the cue for the machine to wake from sleep, probably because the USB-hub/webcam send a signal on poweroff). Shutdown in Gentoo: no problemo.


3) The non-triple-monitor problem. I'll give it another go with a Sapphire 5770 FLEX, which is supposed to be capable of three simultaneous DVI outputs but if that doesn't pan out, I'll just have to live with 2 monitors.




Share this post

Link to post
Share on other sites

Two of the three issues I could resolve:


1) I got sleep to work always by removing all but one copy of SleepEnabler.kext in /S/L/E and rebuild cache etc.etc, you know the drill. I then had to remove it because of the 10.6.5 update, though - which by the way worked flawlessly :rolleyes:


2) I managed to get triple monitor setup working. :)


I have an XFX 5770 and a Sapphire 5770 FLEX (not simultaneously, Z600 can't take that powerwise and space inside would've become too cramped anyways; and who needs 6 displays? but i digres... )


XFX 5770:

- Linux: triple monitor works with radeon driver and passive/active adapter (DVI,DVI/HDMI,DP)

- Linux: triple monitor works with ATI/fglrx driver and active adapter (DVI,DVI/HDMI,DP)

- Windows: triple monitor works with active adapter (DVI,DVI/HDMI,DP)

- OSX (ATY_Init,Vervet): no triple, but any two


Sapphire 5770 FLEX:

- Linux: triple monitor with any adapter and any combination of three ports, both for radeon and fglrx driver (DVI,DVI,DP OR DVI,DVI,HDMI, or DP, HDMI, DVI...)

- Windows: triple monitor with any combination of ports; same as Linux

- OSX (ATY_Init): no chance, only dual possible. Tried even editing the Info.plist (@2, etc.) in ATY_Init.kext, no game.



The solution for OSX

- OSX: triple monitor ONLY with DVI,HDMI,DisplayPort + active adapter (!) and WITHOUT ATY_Init (!). Even though this is the flex version, any other combination e.g. DVI,DVI,DP or DVI,DVI,HDMI does NOT work.


So, pick the DVI-D, the HDMI (with the enclosed HDMI->DVI adapter) and DP with an ACTIVE DP->DVI adapter; the cheaper Sapphire SingleLink active adapter for around 19€ is sufficient even for 2048x1152 (DELL SP2309W). Even though the card should be capable of other combinations (that's why I got the FLEX in the first place)

This is the ONLY ONE COMBINATION that works for me.


Note: the FLEX runs also a bit faster, quieter and cooler than the XFX 5770. Might be specific to my sample, who knows.


Now for the WITHOUT ATY_Init.kext part:

- get Cham 2.0 RC5 (629+) and install

- get the boot file from Kabyl (find references to it on several forums), and put in /

(e.g. here http://www.insanelymac.com/forum/index.php?showtopic=231768)

- remove ATY_Init.kext (of course, you should back it up)

- run Kext Utility

- Change GraphicsEnabler to YES in boot plist (I had to have it to NO for ATY_Init to work, otherwise fan going full throttle and blank screens, followed by reboot,I'm sure you've been there)

- Hope for the best.


Next steps:


- Re-enable Sleep on 10.6.5

- 64-bit mode

- correct powerdown/shutdown (restart works)

- Possibly bite the bullet and start creating a DSDT for the Z600 and get rid of the kexts.

Share this post

Link to post
Share on other sites

- correct powerdown/shutdown (restart works)


This was resolved (to my utter shame :P ) by simply disabling "S5 wake on lan" in the BIOS, where S5 of course is shutdown state.

However, I am surprised that did not impede Linux and Win7 to get it right.

No matter, Z600 shutting down fine now, restart still working.


Still no go on the sleep front, I get blank screens but fans keep spinning, SleepEnabler cannot be loaded (I tried three versions from kexts.com)




Share this post

Link to post
Share on other sites

Another update after some weeks of satisfactory working: I have attained 64-bit mode.

Why did I want this: So I can run VMS with lots of memory.


After having switched from ATY_Init (which was a previous source of problems), the onlyremaining problematic kexts appeared to be


- LegacyAppleRTC

- My WD Studio II "Turbo" driver


How To:

1) remove problematic kexts (32-bit); find them in System Profiler, 64bit = no. However some are meant to be 32-bit (BSDKernel, System6)

1.1) Don't forget to run Kext Utility, as always.

2) Try a boot with parameters arch=x86_64. Some suggest the use of -force64 too, but I do not need that

3) If it works, put the arch in your com.apple.Boot.plist als Kernel Flags



Also, once I was in 64-bit I had to go for the 2.1.7 MacFuse so not to lose NTFS-3G support for my shared NTFS disks.

This remedied a hang of Disk Utility when the WD Studio was connected, as well.



Shutdown and restart are still working. I'll try sleep next thing (this seems to be a neverending story).

Share this post

Link to post
Share on other sites

For those interested, I have put up my /Extras folder + /boot on kexts.com, as a result of a rather long PM conversation where I was helping someone out to get his up and running.


Just search for z600 on kexts.com.


If you manage to get a Quadro 4000 running, glad if you post your solution here. ;)




Share this post

Link to post
Share on other sites



I'm trying to install SL on my Z600.


Can you give me your BIOS settings please ?


It could make me win a lot of time.





Share this post

Link to post
Share on other sites


I'm trying to install SL on my Z600.


Can you give me your BIOS settings please ?


It could make me win a lot of time.






Hey, I'm currently at work, but I'll make some screenshots and try to put them up or if you can tell me what you need specifically, I'll write them down.


Most important is to put SATA into RAID/AHCI mode and otherwise to be aware that YOU CANNOT INSTALL FROM THE ONBOARD SATA PORTS.


You MUST use a different SATA controller for the first time install, for BOTH the install dvd-rom and the hard disk. If there is some way with a newer version of [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] etc. I don't know about it. I invested around 20 hrs and tried a lot of things, but the only way it worked is to install from a JMicron-based supported controller, subsequently add the kexts for Intel controller and then continue from there.




Share this post

Link to post
Share on other sites


I'm trying to install SL on my Z600.


Can you give me your BIOS settings please ?


It could make me win a lot of time.






If you tell me the specific problem you have, I might be able to help you.


The only really important setting is to use SATA RAID/AHCI on the ports.

Share this post

Link to post
Share on other sites


I'm trying to install SL on my Z600.


Can you give me your BIOS settings please ?


It could make me win a lot of time.






I have a more recent Z600 (with E5607 CPUs)... for the install, I needed to remove memory to leave 4G, use a JMicron SATA controller and make the following changes to BIOS:

Storage->Options->SATA Emulation = RAID+AHCI

Storage->Boot Order->Embedded Ethernet Controller = Disable

Security->Network Service Boot = Disable

Advanced->Processors->Active Cores = 1 Core

Advanced->Device Options->S5 Wake on Lan = Disable

Advanced->Device Options->SATA RAID Option ROM download = Disable


After the install was complete, remove the JMicron and make the following changes to BIOS:

Advanced->Processors->Active Cores = All Cores.

Advanced->Device Options->SATA RAID Option ROM download = Enable


HTHs! ;)

Share this post

Link to post
Share on other sites



Thank you for the very informative guide. However, I just skipped the Installation part and installed via the USB Drive of my MB Pro, which somehow removed the part of buying a PCI SATA and PS2 KB/Mouse. Also, i deleted the AppleHPET.kext on the USB drive after the installation so that i can start using the USB KB/Mouse. Based on this procedure, you can then use the latest eye-Boot to boot your new installation. Once all the updating is completed, i used SuperDuper to copy my USB OSX to my HDD and run [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]. Saved me time on removing and reinserting components.


Just a question...had you made your switch to Lion?

Share this post

Link to post
Share on other sites

Hello Gents,


Thanks for all the info regarding SL install on a Z600.


Currently I'm struggling with the following , my Z600 has a maxed out memory config , 48 GB in total.

I was reading in this thread that you need to lower the amount of memory to 2 times 2 GB (2 GB for each CPU).

Since i only use 8GB stick i can't lower the amount of memory to 2 times 2 GB , do i fly need to lower the amount of memory (in other words not doing so won't allow me to install SL on my Z600. ?


Any ideas ?


My Z600 holds the following components.


2 times X5670.

48 GB memory ( 6 times 8GB)

Nivia Quadro FX 1800.


Thanks in advance.

Share this post

Link to post
Share on other sites

Hello there, sorry for taking such a long time to answer, I haven checked here in a while.


@Coelacanth: That sounds like a much smoother way to do it, glad that worked for you. I tried a similar approach but I absolutely failed i.e. got stuck without root device. Un- and reinstalling hardware components and messing around inside the machine was really what vexed me the most about this whole thing. Of course I now have a working install on an external disk which I can restore from any time, but going from my MBP17 2008 with 10.6.3 never worked.

As for Lion, I never managed that. I tried once, but it wrecked my install (hang on boot). As I have an MBA with Lion and I must say that even though nice, it is not all that different from SL, I have not invested much time. I might try for an upgrade when I have more time on my hands (and rebuilt my tolerance for frustration), though Mountain Lion probably will be out by then.


@HerrRML: I'm afraid I cannot really say if that will work or not, but I can understand why that would be advantageous. I'd just give it a go with memory installed, what can it hurt? (Somewhere in the middle of the thread) I managed to install once without having to remove memory past 4GB, but I could not repeat that success during later attempts (on 2cpus/12GB etc). It might work differently on various BIOS/firmware versions or even PCB revisions (mind you I have the older version of the Z600 PCB that won't even take 56xx CPUs). The way I described was the only way I personally could reliably and repeatedly reproduce a successful install. I was really getting tired after all the failed attempts and went with what always worked for my rig. But if I were you, I'd try rlf's suggestion first (maxmem option) or even without any special parameters at all or just -x.

In truth, if you work from a fresh disk (which I recommend, possibly buy a cheap one for the install), all you can lose is time (and your nerve). It can be something you absolutely would not think about that ruins the install (for me the firewire card was the most surprising thing at the time, though afterwards it did make quite some sense, of course).

Also I would check if one of the newer Cham/xxxxx/xxxxx disks works out of the box. So many options :unsure:


Hope you manage!



Share this post

Link to post
Share on other sites

@Crackpot...i managed to update to 10.7 by using a SAS Adapter LSI Logic 3041E...best thing above all, i can do a clean install without a glitch. I am now running 10.7.4 on my HP Z600 and never had a single KP since i installed it...Just don't use the Hardware RAID of the adapter as this will not show up in the Installation...If by chance you will update to ML, please give us a heads up as your guide helped a lot...

Share this post

Link to post
Share on other sites

My setup at the moment


- HP Z600 with latest and greatest Bios PCB rev AE (main board with Hexsupport) (i swapped the main board with no hex core support with this HW rev)

- Dual Xeon X5670 2.93GHz

- 48GB (8 * 8GB)

- 2x 1TB 7200rpm Seagate HDD

- NVidia Quadro FX1800


Ive been trying above mentioned options without any success , but what i did manage to figure out is why it always reboots.


Im running into a kernel panic


panic (CPU0 caller Kernel Trap at ............ type 13)



Any suggestions gents ?


Quick update i installed the following KEXT (NullCPUPowerManagement) with success now I'm able to boot till the language screen with only maxmem=4096.

Looks promising :)


Currently Lion is installing , I'm using the onboard Sata controller , add a few KEXT files , when I'm done with installing I'll write a detailed list of what I've added to install set.

Runs smooth , the only thing I'm missing at the moment is a USB mouse , but a keyboard works fine as well.



Share this post

Link to post
Share on other sites

Cant seem to get more then 1 core working , as soon as I select more then 1 core from within the bios , i won't boot anymore (crash).

Any input??



Share this post

Link to post
Share on other sites

I suggest you get an SAS card and it will solve your problem...i've had that problem before, but when i installed the SAS card, i was able to install Lion without a single glitch, much like installing from a real Mac Pro...had updated to 10.7.5 and still working perfect.

Share this post

Link to post
Share on other sites

- No cigar on 64-bit which is kind of obvious now, since ATY_Init is 32-bit :o


- Booting from my grub2 (on disk0) works via chainloading. Just create an entry like this


set root='(hd2)'

chainloader +1



(that's with having OSX on third SATA disk, of course, hd0 = linux1,hd1=linux2,hd2=OSX)


Have you solved the problem for the video card 32bit or 64bit

Can you make a geekbench


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Hi I m trying to install High Sierra 10.13.4 in my dell Inspiron N5110 using MBR patch .Please help me with post installation procedures for patching audio graphics etc    specs                                                                     Intel(R) Core(TM) i5-2430M CPU @ 2.40GHz ,                                                                               Display Adapters    NVIDIA GeForce GT 525M  Intel(R) HD 3000 Graphics           IDT  92HD87B1 audio driver  Dell Wireless 1702 802.11 b/g/n, Bluetooth 3.0+HS Driver           USB Controllers  Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C26 Intel(R) 6 Series/C200 Series Chipset Family USB Enhanced Host Controller - 1C2D Bluetooth Hard Copy Cable Replacement Server Renesas Electronics USB 3.0 Host Controller                                                                                                                       
    • Hi there, You can either use Lilu.kext and nVidiaGraphicsFixUp.kext or you can add the following patch to your config.plist under Kernel and Kext Patches: The kexts must be placed under the following path: /EFI/Clover/kexts/Other    Name: com.apple.driver.AppleGraphicsDevicePolicy Find: BA050000 00 Replace: BA000000 00   You can use clover configurator to mount the EFI partition on the drive that you have clover bootloader installed.
    • Hackintosh High SIerra 10.13.3 After installing Nvidia Web Driver System Boot Black Screen. Booting With " nv_disable=1 " Boot Flag System booting Fine But Graphics Was Laggy And 3D Graphics Acceleration Problem. What Can I Do Plz Help ............................. Sorry For My Bad English, English Is Not My Native Language.   My System RIG :   CPU : Intel Core i5 6400 RAM : 8GB HDD : 1TB WD For Windows And 500 GB WD For Hackintosh Graphics Card : Gigabyte GTX 1050Ti 4GB OC Mother Board : Gigabyte H110M-H DVD RW LG
    • grazie icanaro del suggerimento ma avevo già provato..nulla..continua a non andare..allego tutto l'occorrente..   Hack_Info.zip MarioLaptop.ioreg.zip
    • grazie icanaro del suggerimento ma avevo già provato..nulla..continua a non andare..