Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
danimac

enabling QE/CI ATI Mobility radeon 5145hd 512

4 posts in this topic

Recommended Posts

Hi to everyone

 

I have a problem…

 

I have installed aty_init in /EXTRA/Extensions and all kexts provided by netkas on S/L/E/ "Ati 5xxx series" from kexts.com

 

I have modified ati5000controller.kext with my id “0×95531002″ i have found this ID in another kext “ati4500controller.kext” but this is another story.

 

permission repaired with Kext utility 2.4.2

 

no graphicsenabler

no vbios

no atirom

 

restart and boot with no kernel panic … no errors but i get apple logo to load forever. i try to press the power button and the computer shutdown “stop” regularly only the screen dont change the image.

 

why ?!… I have to change the framebuffer ? how to change the framebuffer ?.

 

Sorry for my englsh ,i’m italian ..

 

Thanks in advance.

 

 

Config :

 

 

Chamaleon 2.0 rc5 r516

Ati mobility radeon hd 5145 514mb

Intel core i5 450m

4 gb ram 1333

 

Asus X52 JB Laptop

 

OSX 10.6.4 Vanilla 10.4.0 iAtkos s3 v2

Share this post


Link to post
Share on other sites
Hi to everyone

 

I have a problem…

 

I have installed aty_init in /EXTRA/Extensions and all kexts provided by netkas on S/L/E/ "Ati 5xxx series" from kexts.com

 

I have modified ati5000controller.kext with my id “0×95531002″ i have found this ID in another kext “ati4500controller.kext” but this is another story.

 

permission repaired with Kext utility 2.4.2

 

no graphicsenabler

no vbios

no atirom

 

restart and boot with no kernel panic … no errors but i get apple logo to load forever. i try to press the power button and the computer shutdown “stop” regularly only the screen dont change the image.

 

why ?!… I have to change the framebuffer ? how to change the framebuffer ?.

 

Sorry for my englsh ,i’m italian ..

 

Thanks in advance.

 

 

Config :

 

 

Chamaleon 2.0 rc5 r516

Ati mobility radeon hd 5145 514mb

Intel core i5 450m

4 gb ram 1333

 

Asus X52 JB Laptop

 

OSX 10.6.4 Vanilla 10.4.0 iAtkos s3 v2

 

 

Non puoi avere QE/CI su una mobility serie 4xx0 o 5xx0

Share this post


Link to post
Share on other sites
Non puoi avere QE/CI su una mobility serie 4xx0 o 5xx0

 

Ok :) finalmente uno che risponde ... mamma mia capisco che non sia un call center ma dio santo... per avere una risposta bisogna fare domanda in carta bollata...

 

Saresti in grado di dirmi il perchè ? è una limitazione di architettura "kernel verso questo chip" oppure una questione di framework di apple ?... cioè la causa principale "visto che proprio non capisco perchè una 1950 ed una 5770 si ed una 5150 no.. quale è ?.

 

Io stacosa la devo risolvere... Nel frattempo per usare il mio logic pro sul portatile ho dovuto patchare il plist di installazione affinchè non blocchi l'installazione perchè non trova la gpu. funziona benissimo però mi scoccia stare a 1024x768.

 

Ne approfitto pagando eh :D...

 

Volevo chiederti , ho estratto DSDT con dsdted visto che gli altri tool vanno in crash. Non l'ho editato ma solo compilato in aml e caricato da extra tramite prefpane di chamaleon ... siccome non saprei da dove iniziare per il patching di questa struttura sai mica indicarmi una risorsa utile online ?.

 

Se ti occorre ho modificato voodoops2controller e ora supporta maggiore e minore in posizione corretta e qualsiasi touch pad... Vorrei anche risolvere il problema cpu management anche se ti dico anche sotto stress a me pare si comporti normalmente sia come fan che come temperature.

 

Grazie mille...

Share this post


Link to post
Share on other sites

Hellow. I have an ati radeon hd5145, need to install an iatkos l2 10.7.2, need the kests, can you help me to install this ?

 

Thx

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×