Jump to content

Snow Leopard 1.6.4 up and running, but 2 main problems


bg4545
 Share

1 post in this topic

Recommended Posts

So after a few months of trial and error using different distros I've finally got Snow Leopard to install.

My system is an HP Pavilion p6130y Desktop

Specs:

[cpu-z.png]

AMD Phenom™ 9750 Quad-Core Processor 2.4GHz

Memory (RAM): 8GB (SnowLeo boots with "maxmem=4096" flag)

Motherboard: PEGATRON CORPORATION Model: VIOLET

Chipset: NVIDIA nForce 720a rev. A2

Graphics: NVIDIA GeForce 9100 (256MB) [integrated]

Audio: Realtek ALC888S [integrated]

Internet: nForce LAN and Atheros Wifi Adapter(Working)

618GB Windows Vista partition, 80GB Snow Leopard partition

 

I installed using the SnowOSX3.6-A distro (1.6.2) with almost default options.

SnowLeo boots with the flags "amd_kernel -v maxmem=4096"

I used Software Update to upgrade to 1.6.4 and installed audio kexts for the Realtek ALC888 and it works. iTunes was crashing on me but I used Marvin's AMD patcher and now it works. Internet (Wifi) worked without modification (in Snow Leopard, but not Leopard).

 

Now for what doesn't work:

The nVidia GeForce 9100 is not recognized and it only comes out as 32MB with 1024x768 display (my monitor is HP, supports 1920x1080@60Hz) so it kind of sucks that I can't get it to work. I've tried the enablers (NVInject, NVKush, etc.) but they just make the system reboot instead of load the login screen. I want to find out if there's a way to make it work but it's hard to look through all these guides (some are way outdated) and trying things and having to undo them afterwards..

I've got Vista already installed with MacDrive 7 so I can access my OS X drive from Windows and that's helped a lot.

 

The next thing is just an annoyance really; My keyboard (HP USB keyboard) sometimes doesn't work. Sometimes I'll boot the system, get to the login but when I try to type my password then nothing happens. Other times, it will boot, login and then after a while the keyboard just stops working. Mouse still works and everything else still works, just the keyboard stops. I can reboot and it will usually work for a while before giving out on me.

 

This last one is not a big issue but also kind of annoying. The volume controls don't work. I can press "Fn+F6" to mute and unmute, but I cannot do volume up or down. "Fn+F5" makes the volume thing appear and it clicks, but it doesn't move/change. The volume on the top bar (next to wifi) also does not work. You can move the slider but it doesn't stay where you put it. I can however change the volume by going to Preferences, then Sounds and move the slider there.

 

Oh also, one last thing; The front USB ports and Card readers do not work. They are not even on it seems. I don't know if there's a fix for that but I haven't looked too hard yet.

 

I don't know if it's worth noting but the only other distros I've successfully booted (just the installers) are iAtkos v7 and SnowLeo (1.6.2) by director A.K.

iAtkos v7 (Leopard) installed fine, but I could not get sound, wifi, or graphics, and I had the same keyboard issue.

 

 

EDIT: I should probably mention, right now I'm using the DVI port for dispay, but I do have VGA as well. I remember at one time in Leopard I got to a point where I could change display resolution but DVI was cut off (black) from near the top all the way down (just a small portion of the screen was showing) but VGA worked fine. I use DVI for Windows and it would be a shame to have to unplug and plug in another cable... But I do already have to change my BIOS settings between OSes so I guess it's a sacrifice of effort for outcome

 

EDIT2: I also forgot to mention that OSx86Tools does not fully work for me; Certain things (like boot.plist editor) give me an AppleScript Error so I can't really use OSx86Tools for anything.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...