Jump to content
Kabyl

ATI Radeon HD6000, HD5000 and HD4000 series support in Chameleon

861 posts in this topic

Recommended Posts

Advertisement

Hi guys,

 

I am really new to all this stuff and was wondering what do I do with the boot file that was the download. I know the original post said if you don't know how to use it then don't use it, but I really want my ATI 5830 to work with my hackintosh.

 

Thanks,

renn.

Share this post


Link to post
Share on other sites

@TH3L4UGH1NGM4N

 

Ok I'll give it a shot, thanks.

 

 

Edit: No luck... :( I put Kabyl's latest boot on root, rebooted and now every time I try to boot it just restarts (Not even an Apple Logo).

Share this post


Link to post
Share on other sites

no dice with his boot file... did you by chance happen to backup your original boot file? Going to have to revert back to that one and find another solution to your 5830

should be possible through adding your dev ID to the x3000 accelerator kext. Just let me know when you're back up in action or if you need some help fixing your current boot issue.

Share this post


Link to post
Share on other sites

Using the Uakari FB for the 58xx you're supposed to get QE along with the resolution changes but going based on other users experience and netkas's site, it would seem that the 5830 is the oddball out of the group because I'm yet to hear of anyone getting QE to work

 

you could try setting graphicsenabler=yes and see if it yields any better results but I can't attest to it working for you because it has only worked for my 6870.

Share this post


Link to post
Share on other sites

@TH3L4UGH1NGM4N

 

That sucks :D I already have Uakari as the frame buffer and GraphicsEnabled as Yes

 

 

Well the holidays are coming up and I think I'm just going to get a new card :P How is the 6970 with the hackintosh. I have heard it is having problems with msaa. How about with QE/CI?

Share this post


Link to post
Share on other sites

yeah I know it really blows to come so close and not able to have it fully working =

 

and the 6970 works with QE/CI but also lacks QE/CI for a lot of users as well as it isn't fully functional in os x and has other issues relating to sleep, cold boot bug (where the card wouldn't boot from a "cold boot"), and some other issues. In my opinion, unless you want to wait it out until it's fully supported, I'd suggest bumping down to a 6870 if you don't mind so much or just try to wait it out for better support but I wouldn't get it as my main card because of the fact that it isn't fully functional as of yet.

 

It's your call though in the end renn.

Share this post


Link to post
Share on other sites

@TH3L4UGH1NGM4N

 

So many decisions... Well if I were to get a new card I would want the latest and greatest... so I'll wait and see if Netkas pushes out any updates for it from now to the New Year. Thanks for all the help :)

Share this post


Link to post
Share on other sites

yeah it's best to just wait it out atm because  seems to be developing drivers for the not so distant "radeon 7000" aka Tahiti cards so maybe something will come for the 69xx before then as well.

 

And no problem man always glad to be of assistance :)

Share this post


Link to post
Share on other sites

I can live with my 3 distros of Linux (Ubuntu, Mint, and Arch), 1 mostly working hackintosh, and Windows 7 gaming partition for now :) Thanks again for the help.

Share this post


Link to post
Share on other sites

Can anyone help me?

 

I have a latptop with 2 gpus (onboard and offboard of course hehe)

 

The thing is.. one is ati mobility 4250 - device id: 0x9712 (onboard)

 

and the other is ati mobility 6550 - device id: 0x68c1 [this one isnt named 6550 on OSX i dont know why! its 5600 or something like that.. I guess is the same chipset or whatever]

 

Can anyone help me to enable them? Well, just one of them hehe at the moment, its using the onboard one but no acceleration and 1024x768 resolution only.. is it possible to use one of my gpus with QE and all the good things?

 

I'm Running snow leopard 10.6.8 fully updated

 

 

Thanks!!

Share this post


Link to post
Share on other sites

Hi everyone,

 

I have a litle problem with my ATI HD 5970 (2Go) on Lion 10.7.2.

After adding my device ID in the ATI5000controler.kext , adding my GPU Bios on /Extra & edit boot.plist, everything works fine but my GPU is really too hot (50°C idle on windows, 70°C idle on OSX) , and my GPU fan is too slow, it didn't respects GPU BIOS fans values. Can anyone helps me ? :)

 

 

Thanks a looooot ! =D

Share this post


Link to post
Share on other sites
Hi Kabyl I'm back with your booter full time as I'm gettin some video errors with the others! I've got a few odderties if you don't mind having a look?
MSR_IA32_PERF_STATUS (0x198): 0x0616082006000820 max: 8 current: 8 CPU: Vendor/Model/ExtModel: 0x756e6547/0x17/0x1 CPU: Family/ExtFamily: 0x6/0x0 CPU: MaxCoef/CurrCoef: 0x8/0x8 CPU: MaxDiv/CurrDiv: 0x0/0x0 CPU: TSCFreq: 3215MHz CPU: FSBFreq: 401MHz CPU: CPUFreq: 3215MHz CPU: NoCores/NoThreads: 4/4 CPU: Features: 0x0000025f Attempting to read GPT Read GPT Reading GPT partition 1, type C12A7328-F81F-11D2-BA4B-00A0C93EC93B Reading GPT partition 2, type 52414944-0000-11AA-AA11-00306543ECAC Reading GPT partition 3, type 426F6F74-0000-11AA-AA11-00306543ECAC Read HFS+ file: [hd(0,3)/System/Library/CoreServices/.disk_label.contentDetails] 16 bytes. Read HFS+ file: [hd(0,3)/Extra/com.apple.Boot.plist] 1057 bytes. Attempting to read GPT Read GPT Reading GPT partition 1, type C12A7328-F81F-11D2-BA4B-00A0C93EC93B Reading GPT partition 2, type 52414944-0000-11AA-AA11-00306543ECAC Reading GPT partition 3, type 426F6F74-0000-11AA-AA11-00306543ECAC Read HFS+ file: [hd(1,3)/System/Library/CoreServices/.disk_label.contentDetails] 16 bytes. Attempting to read GPT Read GPT Reading GPT partition 1, type C12A7328-F81F-11D2-BA4B-00A0C93EC93B Reading GPT partition 2, type 48465300-0000-11AA-AA11-00306543ECAC Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/theme.plist] 2714 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/background.png] 966 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/logo.png] 333 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_generic.png] 5347 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_hfsplus.png] 12670 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_hfsraid.png] 18469 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_ext3.png] 12538 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_fat16.png] 5102 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_fat32.png] 5254 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_ntfs.png] 10969 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_cdrom.png] 5228 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_selection.png] 1262 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_scroll_prev.png] 1012 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/device_scroll_next.png] 1013 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_boot.png] 1747 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_verbose.png] 4116 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_ignore_caches.png] 4051 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_single_user.png] 4114 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_memory_info.png] 1634 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_video_info.png] 1593 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_help.png] 1711 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_verbose_disabled.png] 1370 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_ignore_caches_disabled.png] 1445 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_single_user_disabled.png] 1485 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/menu_selection.png] 323 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/progress_bar.png] 344 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/progress_bar_background.png] 369 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/text_scroll_prev.png] 733 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/text_scroll_next.png] 743 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/font_console.png] 3499 bytes. Read HFS+ file: [hd(0,3)/Extra/Themes/Daves/font_small.png] 6244 bytes. Read HFS+ file: [hd(0,3)/Extra/com.apple.Boot.plist] 1057 bytes. Read HFS+ file: [hd(0,3)/com.apple.boot.S/Library/Preferences/SystemConfiguration/com.apple.Boot.plist] 358 bytes. Read HFS+ file: [hd(0,3)/System/Library/CoreServices/SystemVersion.plist] 479 bytes. Loading Darwin 10.6 Loading kernel mach_kernel Read HFS+ file: [hd(0,3)/mach_kernel] 4096 bytes. Read HFS+ file: [hd(0,3)/mach_kernel] 5579907 bytes. LoadDrivers: Loading from [/Extra/Extensions.mkext] Read HFS+ file: [hd(0,3)/Extra/Extensions.mkext] 4096 bytes. Read HFS+ file: [hd(0,3)/Extra/Extensions.mkext] 49944 bytes. LoadDrivers: Loading from [/com.apple.boot.S/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] Read HFS+ file: [hd(0,3)/com.apple.boot.S/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] 4096 bytes. Read HFS+ file: [hd(0,3)/com.apple.boot.S/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] 4393815 bytes. LoadDrivers: Loading from [/system/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] Read HFS+ file: [hd(0,3)/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] 4096 bytes. Read HFS+ file: [hd(0,3)/System/Library/Caches/com.apple.kext.caches/Startup/Extensions.mkext] 4393815 bytes. Read HFS+ file: [hd(0,3)/Extra/DSDT.aml] 28665 bytes. Using PCI-Root-UID value: 0 ATI card POSTed, reading VBIOS from legacy space ATI Juniper ATI Radeon HD 5770 1024MB (Vervet) [1002:68b8] (subsys [1682:2991]):: PciRoot(0x0)/Pci(0x1,0x0)/Pci(0x0,0x0) Read HFS+ file: [hd(0,3)/Extra/smbios.plist] 684 bytes. Intel P45/G45 DRAM Controller [8086:2e20] at 00:00.0 Frequency detected: 643 MHz (1286) Dual Channel CAS:9 tRC:9 tRP:9 RAS:24 (9-9-9-24) SMBus CmdReg: 0x3 Scanning SMBus [8086:3a30], mmio: 0xfe6fec04, ioport: 0x400, hostc: 0x1 SPD[0] (size): 146 @0x50 Slot: 0 Type 24 2048MB (DDR3 SDRAM) 1286MHz Vendor=Kingston PartNo=99U5471-002.A00LF SerialNo=8C2E17AC SPD[0] (size): 146 @0x51 Slot: 1 Type 0 0MB (EPROM) 1286MHz Vendor=NoName PartNo= SerialNo=8C2E17AC SPD[0] (size): 146 @0x52 Slot: 2 Type 24 2048MB (DDR3 SDRAM) 1286MHz Vendor=Kingston PartNo=99U5471-002.A00LF SerialNo=8D2EFCAB SPD[0] (size): 146 @0x53 Slot: 3 Type 24 2048MB (DDR3 SDRAM) 1286MHz Vendor=Kingston PartNo=99U5471-002.A00LF SerialNo=8D2E19AC SPD[0] (size): 176 @0x54 Slot: 4 Type 0 0MB (EPROM) 1286MHz Vendor=NoName PartNo= SerialNo=8D2E19AC SPD[0] (size): 176 @0x55 Slot: 5 Type 0 0MB (EPROM) 1286MHz Vendor=NoName PartNo= SerialNo=8D2E19AC SPD[0] (size): 255 @0x56 SPD[0] (size): 255 @0x57 CPU is Intel® Core™2 Quad CPU Q9450 @ 2.66GHz, family 0x6, model 0x17 Type: 0, Length: 24, Handle: 0x0 BIOSInformation: vendor: Apple Inc. version: IM91.88Z.008D.B08.0904271717 releaseDate: 11/06/2009 Type: 1, Length: 27, Handle: 0x1 SystemInformation: manufacturer: Apple Inc. productName: iMac9,1 version: 1.3 serialNumber: W87234JHYA4 uuid: 00020003-0004-0005-0006-000700080009 wakeupReason: 0x6 skuNumber: To Be Filled By O.E.M. family: iMac Type: 2, Length: 15, Handle: 0x2 BaseBoard: manufacturer: Apple Inc. product: Mac-F2218FC8 version: 1.0 serialNumber: To be filled by O.E.M. assetTagNumber: To Be Filled By O.E.M. locationInChassis: To Be Filled By O.E.M. boardType: 0xA Type: 3, Length: 21, Handle: 0x3 SystemEnclosure: manufacturer: MICRO-STAR INTERNATIONAL CO.,LTD type: 3 version: 1.0 serialNumber: To Be Filled By O.E.M. assetTagNumber: To Be Filled By O.E.M. Type: 4, Length: 40, Handle: 0x4 ProcessorInformation: socketDesignation: CPU 1 processorType: 3 processorFamily: 0xC2 manufacturer: Intel processorID: 0x10677 processorVersion: Intel® Core™2 Quad CPU Q9450 @ 2.66GHz externalClock: 401MHz maximumClock: 3215MHz currentClock: 2666MHz serialNumber: To Be Filled By O.E.M. assetTag: To Be Filled By O.E.M. partNumber: To Be Filled By O.E.M. Type: 7, Length: 19, Handle: 0x5 Type: 7, Length: 19, Handle: 0x6 Type: 7, Length: 19, Handle: 0x7 Type: 5, Length: 24, Handle: 0x8 Type: 6, Length: 12, Handle: 0x9 Type: 6, Length: 12, Handle: 0xa Type: 6, Length: 12, Handle: 0xb Type: 6, Length: 12, Handle: 0xc Type: 8, Length: 9, Handle: 0xd Type: 8, Length: 9, Handle: 0xe Type: 8, Length: 9, Handle: 0xf Type: 8, Length: 9, Handle: 0x10 Type: 8, Length: 9, Handle: 0x11 Type: 8, Length: 9, Handle: 0x12 Type: 8, Length: 9, Handle: 0x13 Type: 8, Length: 9, Handle: 0x14 Type: 8, Length: 9, Handle: 0x15 Type: 8, Length: 9, Handle: 0x16 Type: 8, Length: 9, Handle: 0x17 Type: 8, Length: 9, Handle: 0x18 Type: 8, Length: 9, Handle: 0x19 Type: 8, Length: 9, Handle: 0x1a Type: 8, Length: 9, Handle: 0x1b Type: 8, Length: 9, Handle: 0x1c Type: 8, Length: 9, Handle: 0x1d Type: 8, Length: 9, Handle: 0x1e Type: 8, Length: 9, Handle: 0x1f Type: 8, Length: 9, Handle: 0x20 Type: 8, Length: 9, Handle: 0x21 Type: 8, Length: 9, Handle: 0x22 Type: 8, Length: 9, Handle: 0x23 Type: 8, Length: 9, Handle: 0x24 Type: 9, Length: 13, Handle: 0x25 Type: 9, Length: 13, Handle: 0x26 Type: 9, Length: 13, Handle: 0x27 Type: 9, Length: 13, Handle: 0x28 Type: 10, Length: 6, Handle: 0x29 Type: 13, Length: 22, Handle: 0x2a Type: 16, Length: 15, Handle: 0x2b Type: 18, Length: 23, Handle: 0x2c Type: 19, Length: 15, Handle: 0x2d Type: 17, Length: 27, Handle: 0x2e MemoryDevice: deviceLocator: DIMM1 bankLocator: BANK0 memoryType: DDR3 memorySpeed: 1286MHz manufacturer: Kingston serialNumber: 8C2E17AC assetTag: AssetTagNum0 partNumber: 99U5471-002.A00LF Type: 18, Length: 23, Handle: 0x2f Type: 20, Length: 19, Handle: 0x30 Type: 17, Length: 27, Handle: 0x31 MemoryDevice: deviceLocator: DIMM2 bankLocator: BANK1 memoryType: SDRAM memorySpeed: 1286MHz manufacturer: NoName serialNumber: 8C2E17AC assetTag: AssetTagNum1 partNumber: PartNum1 Type: 18, Length: 23, Handle: 0x32 Type: 20, Length: 19, Handle: 0x33 Type: 17, Length: 27, Handle: 0x34 MemoryDevice: deviceLocator: DIMM3 bankLocator: BANK2 memoryType: DDR3 memorySpeed: 1286MHz manufacturer: Kingston serialNumber: 8D2EFCAB assetTag: AssetTagNum2 partNumber: 99U5471-002.A00LF Type: 18, Length: 23, Handle: 0x35 Type: 20, Length: 19, Handle: 0x36 Type: 17, Length: 27, Handle: 0x37 MemoryDevice: deviceLocator: DIMM4 bankLocator: BANK3 memoryType: DDR3 memorySpeed: 1286MHz manufacturer: Kingston serialNumber: 8D2E19AC assetTag: AssetTagNum3 partNumber: 99U5471-002.A00LF Type: 18, Length: 23, Handle: 0x38 Type: 20, Length: 19, Handle: 0x39 Type: 22, Length: 26, Handle: 0x3a Type: 32, Length: 20, Handle: 0x3b Type: 34, Length: 11, Handle: 0x3c Type: 28, Length: 22, Handle: 0x3d Type: 36, Length: 16, Handle: 0x3e Type: 35, Length: 11, Handle: 0x3f Type: 27, Length: 14, Handle: 0x40 Type: 36, Length: 16, Handle: 0x41 Type: 35, Length: 11, Handle: 0x42 Type: 27, Length: 14, Handle: 0x43 Type: 36, Length: 16, Handle: 0x44 Type: 35, Length: 11, Handle: 0x45 Type: 39, Length: 22, Handle: 0x46 Type: 131, Length: 6, Handle: 0x46 AppleProcessorType: ProcessorType: 0x501 Type: 132, Length: 6, Handle: 0x47 AppleProcessorBusSpeed: ProcessorBusSpeed (QPI): 0.0GT/s Type: 127, Length: 4, Handle: 0x48 Customizing SystemID with : 00020003-0004-0005-0006-000700080009 Read HFS+ file: [hd(0,3)/Extra/DSDT.aml] 28665 bytes. ACPI table not found: SSDT.aml FADT: Restart Fix applied! FADT: Using custom DSDT! Starting Darwin x86_64 

With memory detection it hangs looking at memory slots that aren't there!! Some times only 1 extra slot sometimes 2, sometimes slot 4 or 5 or both sometimes slot 7?

SPD[0] (size): 176 @0x54 Slot: 4 Type 0 0MB (EPROM) 1286MHz Vendor=NoName PartNo= SerialNo=8D2E19AC SPD[0] (size): 176 @0x55 Slot: 5 Type 0 0MB (EPROM) 1286MHz Vendor=NoName PartNo= SerialNo=8D2E19AC 

Only slot 0, 1, 2 ,3 are filled (4 slots in total on this MB.) Also the last SPD read say's size 176 - the other 3 are 255? I have always had a memory error shown in System Profiler with MSI boards, during diagnostics check. Maybe this is the problem?

Power On Self-Test: Last Run: 09/02/2011 00:12 Result: Failed Failure Type: Memory Memory Slots: DIMM1/BANK0, DIMM2/BANK1, DIMM3/BANK2, DIMM4/BANK3 

Secondly:- System UUID shown above is not registered in System Profiler. Although i think that in system profiler is correct (checking in windows now) and is not taken from EN0 Mac address! UUID shown in bdmesg is correct but not shown in System Profiler. Any help appreciated! D

 

Has anyone found a fix for this?!?! My Lion partition hangs up when I am booting in when it is also looking at memory slots! The error is "Device in slot: :Slot 1--" And when I look in system preferences in my Snow Leopard partition, it says that there is only Slot 0 and Slot 2!

 

Why is this?

 

Does anybody have a fix for this issue?

 

***********************

 

Something really off topic, can somebody show be a link that tells you how to get all of your RAM? I am using 4GB and want to use my full 6GB.

 

Thanks.

 

 

-Jugz

Share this post


Link to post
Share on other sites

Hello everyone,

 

@Kabyl

I have a problem with a laptop 2 cards graphics,impossible for me have screen résolutin native 1600*900*32.

 

Spécification laptop:

 

i7 2630QM (Intel HD3000)

card graphics AMD 6770M.

 

HP DV7 6090ef

 

The problem is impossible disable one card in bios,how work 2 cards same time ? (switch).

 

For install the white windows install to right.

 

 

img0082jcv.jpg

 

Impossible click on following for do install.

 

How do work switch between card (work the 2 cards same time ?

 

 

Thanks advance.

Share this post


Link to post
Share on other sites

I've got the HD 5450 1GB -- does anyone have any problems recording in Camtasia or Screenflow? My audio gets really choppy, and I'm using a USB mic.

Share this post


Link to post
Share on other sites

Hello, i have Asus N52JU with Ati 6370m, is same 5470m but rebranded.

Now can activate it from chimera 1.8, use ati5000enabler and override edid of my lvds. But the problem is i don´t know how fix framebufer. Can you help me?

When boot have black screen but i've change monitor Ati card work, but only half screen.

I attached all information i think you need for help me:

ioreg with framebufer loaded, bios dump, vanilla next (7.1.8 from Lion 10.7.3), enabler I used ...

Please help me because is the last piece of hardware i need for 100% hackintosh, (now work USB, card reader, webcam, wifi, ...)

Thanks for you time.

http://db.tt/9dpWtEvH

 

Share this post


Link to post
Share on other sites

Hello, i have Asus N52JU with Ati 6370m, is same 5470m but rebranded.

Now can activate it from chimera 1.8, use ati5000enabler and override edid of my lvds. But the problem is i don´t know how fix framebufer. Can you help me?

When boot have black screen but i've change monitor Ati card work, but only half screen.

I attached all information i think you need for help me:

ioreg with framebufer loaded, bios dump, vanilla next (7.1.8 from Lion 10.7.3), enabler I used ...

Please help me because is the last piece of hardware i need for 100% hackintosh, (now work USB, card reader, webcam, wifi, ...)

Thanks for you time.

http://db.tt/9dpWtEvH

Did you try to set various framebuffers in chameleon?

Share this post


Link to post
Share on other sites

Can anyone help me?

 

I have a latptop with 2 gpus (onboard and offboard of course hehe)

 

The thing is.. one is ati mobility 4250 - device id: 0x9712 (onboard)

 

and the other is ati mobility 6550 - device id: 0x68c1 [this one isnt named 6550 on OSX i dont know why! its 5600 or something like that.. I guess is the same chipset or whatever]

 

Can anyone help me to enable them? Well, just one of them hehe at the moment, its using the onboard one but no acceleration and 1024x768 resolution only.. is it possible to use one of my gpus with QE and all the good things?

 

I'm Running snow leopard 10.6.8 fully updated

 

 

Thanks!!

 

same problem here. Please help. Thansk a ton!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×