Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
DarkCarnival

Fair warning - stay away from OS X if you do serious stuff

5 posts in this topic

Recommended Posts

Ok. Let me get the formalities out of the way.

 

This happened to me using a legitimate macbook pro 17" (around 5,1 - basically the first gen 17" alu MBP which supports 8gb ram) running a fully updated copy of OS X snow leopard.

 

I rarely reboot my system and I guess it's been at least 14 days since I last did so, I don't because in addition to running OS X I have two virtual machines (XP and Linux) on which I do most of my actual work due to various things ranging from preferences to the tools either not functioning or being available on OS X to begin with.

 

(On that note, I'm studying at a university to become a programmer -- being a developer on OS X sucks a bit)

 

Anyway, tonight I attempted a reboot to reach my actual bootcamp windows installation only to be greeted by the Apple logo (GRRRRR forgot to hold down the option key, AGAIN!) and then a curious symbol, the international no symbol, as in the symbol you usually see in no smoking zones.

 

So I had a hop over to Apple's support pages and did the happy keyboard dance to try and kick some sense into the system. I had more fun trying a verbose bootup only to find it looping a "still waiting for root device" error.

 

I've played around a little with an eSata external disc these past days and since OS X boots based on GUUID's I'm thinking that *might* be what confused my dear little retarded OS X installation, but truly I am at a loss as to what it is.

 

I do know that had I the space to spare, I could attempt an "Archive and Install" in which case it would move the existing install somewhere else on the disc and install a fresh copy of OS X --- But I don't.

 

Unlike Windows and especially Linux, it seems that if your OS X is having a little hic-up, you're dead in the water as there's no recovery readily available, unless you permanently set aside a good chunk of harddrive space to hold an auxiliary copy of OS X should it crash on itself.

 

Thus I'm now forced to begin carving out my files from within the Windows install, that very OS which receives so much hate and laughter from most Apple fans will now be what's going to pull my ass out of the fire as OS X is convinced that my system is absent harddrives.

 

I'm only happy that I can actually get my files out as I actually code a bit on the side for a job not to mention the notes I accumulate as a result of the courses I'm following as well as past ones.

 

Suffice it to say, reboots killing my system isn't something I'm accustomed to, in fact, I haven't every tried this before save one time with a Windows 98 system. Let's dwell on that a moment, a Windows-frigging-98 install has done the same thing - nothing else -- never another windows install and certainly never a Linux install.

 

 

It's all well and fine should you discount this entire story as one big rant from an Apple hater - but I urge you to at least take measures to protect your things as the system you use clearly isn't as stable as it's being praised to be.

 

Now I'm off to the intarwebz, seems I need to make time to rescue my files off this computer and figure out what sort of OS I should now run on this macbook....

Share this post


Link to post
Share on other sites

@3.14r

 

I believe you just saved his bacon!

 

Ha, I have at-least two working copies of OSX already baked in the oven just incase. Hackintosher veterans seem to be aware of what updates can do. Nice info, bookmarked it. Thank you

Share this post


Link to post
Share on other sites

That's a good tip, but really, it's completely ridiculous that you have to resort to such extreme measures for something this simple. I could fix this with an install disc and 4 minutes in Linux and I'm quite certain the same holds true for windows.

This is, not surprisingly, in stark contrast to what the Apple marketing department would have you believe, that this truly is the most advanced OS in the world and consequently more stable than others.

 

I don't have the time these days to muck about with things as lengthy as mirroring disks and doing checksums to avoid truly killing off all my files etc before writing it back etc. simply to fix what ought to be fixable by a boot-CD as it is in every other OS.

 

I expect to set up a system and have it functioning at least 6 months - especially so when you pay a premium for the Macbooks

(Don't get me wrong, I don't expect sultan-like treatment here, merely what I can get elsewhere and on cheaper laptops).

 

That and the fact that the MBP runs like a nuclear reactor whenever I run anything else than OS X just pisses me off.

 

This is due to Apple's complete neglience of the BIOS-mode, had they only allowed you to select which card to use in BIOS mode things wouldv'e been fine, but I guess this way they can further perpetrate the myth of OS X being inherently superior to other OS's.

Failing that, at least they could've implemented the newest UEFI mode thus allowing Windows to be installed in EFI mode.

 

Anyway, I have a cheaper laptop laying about which I'll be making do with for my day-to-day work, it's slower and the screen certainly isn't on par with the MBP - but at least it won't up and die on me for no reason.

 

I'm currently going to sell the macbook if I can, I've certainly had my fill and the only Apples I'm having from now on are of the sort that goes into an apple pie.

 

(Mind you, in fairness, while it *ran* in OS X it ran pretty well)

 

PS!

I'm certainly not harshing on you at all, in fact, I thank you for the tip given and certainly hope that it will benefit others (well, I hope they'll never encounter this problem, but if they do...) -- anyway, it's just hard not to feel immensely disappointed in how poorly this is handled by Apple. "Please reinstall your system" as a solution to a problem is something I'd only expect to hear in Redmond... :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×