Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
OuVerRos

Sony Vaio VPCCW21FW

16 posts in this topic

Recommended Posts

Instalação Snow Leopard em Notebook Sony Vaio VPCCW21FW

 

Vc vai precisar:

 

- Distro iATKOS S3 Snow Leopard 10.6.3 DVD (Size: 3.4 GB)

- Atualização Mac OS X v10.6.4 Update (Size: 607.21 MB)

- CD RW ou DVD RW para gravar o Mac OS X v10.6.4 Update

 

PS: Se vc conseguir usar pendrive no lugar da midia RW fique a vontade. Eu optei por marcar o minimo de coisas na Customize pois depois de atualizar varias coisas vão funcionar nativamente na v10.6.4 (USB é uma delas).

 

Após varias tentativas de instalar usando CD Boot + Retial SL 10S432 v10.6.0 e com todas as possives opções de boot ficava sempre em looping logo após o incio de leitura do DVD. Não vou entrar em detalhes nesse erro, pq pode ser desde o simples fato de o leitor não ter iso com a cara da midia até o fato de a própria controladora não dar acesso ou tipo de boot em questão. Como eu ainda não havia baixado a Retail Mac.OSX.Snow.Leopard.v10.6.3-HOTiSO optei pela Distro que eu já tinha em DVD do iAtkos S3 v2.

 

Mesmo com a Distro não tem jeito ... o processo só vai pra frente com busratio=20 -x (pois é eu tb me perguntei isso: pq 20 e não 16 HuAhUaHuAHuAhUaHuA mas o fato é que com 20 foi).

 

Então na tela da barra regressiva do DVD tecla-se qualquer telca e digitamos busratio=20 -x e tecla-se ENTER.

Comigo demorou um pouco até aparecer a primeira tela de instalção ... +/- 3 min.

 

Pelo menu entrei no Disk Utility eu formatei pra GUID com 2 partições, uma de 100GB e outra 400GB.

 

diskutility.jpg

 

guidb.jpg

 

Após ter feito esse processo encerre o Disk Utility. Selecione o HD para a instalação e prossiga.

 

Na Customize faça as marcações como segue:

 

iatkoss3snowleopard1063.jpg

 

Após a instalação deixe subir o sistema pra ver se carrega normal. Sei lá, vai que sobe hehehe (comigo não subiu) ficou carregando e não saiu da tela da maça. Fiz o reset em -v e nada de decifrar o erro.

 

Unica forma de subir o sistema pra concluir a instalação foi recorrer ao busratio=20 -x hehehe

Sem o DVD no drive ligue o note e na contagem regressiva tecla algo e digite busratio=20 -x

 

Agora com o sistema carregado vamos copiar o update que foi gravado o Mac OS X v10.6.4 Update pro Desktop e executar a atualização. Se tudo correu bem, depois de atualizar não precisa mais digitar nada no boot.

 

Vamos agora pra instalar o Video. E esse ta sendo chato ...

 

 

Vou deixar aqui +/- o que estou fazendo e depois arrumo.

 

 

lizardu.jpg

Comentario: Pois é Old .. tb não sei pq depois de várias tentativas resolvi tentar com o Lizard de novo e foi). Resoluções liberadas e aceleração reconhecida.

 

Se tudo até aqui deu certo vc esta com o sistema atualizado com Kernel Vanilla e com um erro de tela preta HuAhUaHuaHuAhUaHuaHuAhUaHua não se preocupe, o sistema esta subindo normalmente porém a saída do video esta sendo enviada pra porta VGA. Desligue o notebook e conecte um cabo VGA e suba o sistema.

 

Segue o com.apple.boot.plist dentro da pasta Extra:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Boot Graphics</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>1920x1200x32</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=i386</string>
<key>PciRoot</key>
<string>0</string>
<key>Timeout</key>
<string>1</string>
</dict>
</plist>

 

Estou analisando as kexts instaladas e verificando se é possivel aplicar a inverção do sinal de saida:

http://www.insanelymac.com/forum/index.php?showtopic=230887

 

 

Infos do Sistema:

 

devices.png

kexts.png

 

Pasta Extra:

 

extrag.png

 

Fix About This Mac: http://www.mediafire.com/?qr3md75l6nvoqa1

Rede wi-fi: http://www.mediafire.com/?5lybou6q9fmyy03

 

 

Deixe o arquivo dsdt.aml no raiz e faça um reboot com -f -v

Assim que subir o sistema delete da pasta Extra as kexts: ElliottForceLegacyRTC e EvOreboot (duas kexts a menos hehehe)

 

 

Desculpem ... tive que devolver o Notebook e não consegui fazer todos os testes afim de ter sucesso total na instalação.

Share this post


Link to post
Share on other sites

Certo. Vou enviar por email pra ela e tentar explicar como fazer.

 

Todos os dsdt.aml funcionam no raiz? ... pasta ela colocar no raiz e dar em reboot ou existe algo mais a fazer?

Share this post


Link to post
Share on other sites

Funciona na raiz ou na pasta Extra.

 

Basta colocar o arquivo e ativar os drivers, da mesma maneira que sem o dsdt funcionava no monitor externo mas o do laptop ficava preto, e ver se faz alguma diferença.

Share this post


Link to post
Share on other sites

Então. Minha duvida é justamente essa: o local do arquivo. Pode ser no raiz ou na pasta Extra, pode ser qualquer um desses dois locais?

Pq a install que eu fiz, apesar de estar com Vanilla agora no 10.6.4, eu usei o DVD do iAtkos S3 e nele tem uma pasta Extra no raiz que esta oculta. Pra eu explicar pra dona do note como jogar o arquivo dentro dessa pasta Extra oculta fica ruim hehehe e se pode ser no raiz mesmo tendo a pasta Extra não tem problema, fica mais facil eu explicar pra ela onde jogar o dsdt no raiz :(

Share this post


Link to post
Share on other sites

Pode ser na raiz, porém se tiver um dsdt.aml na pasta Extra, não saberemos qual dos dois foi carregado.

 

Para confirmar use os parâmetros "DSDT=/dsdt.aml Wait=yes" no boot, que ele mostra as mensagens e espera que uma tecla seja pressionada antes de iniciar.

Share this post


Link to post
Share on other sites

Ela disse que não funcionou. Vou continuar procurando aos poucos e assim que puder eu encontrar com ela na facu vejo o note dela pessoalmente.

Share this post


Link to post
Share on other sites

Boa tarde OuVerRos..

 

O meu note é da mesma série VPC da Sony. O seu tutorial me facilitou a vida e muito, por isso antes das dúvidas gostaria de agradecer.

 

Agora, vamos ao que interessa.. O modelo do meu Sony Vaio é VPC-EB11FX.

É um core i3 330M com uma Intel HD Graphics,.. O resto é praticamente igual.

Antes eu estava com um problema. Quando eu instalava ocorria tudo OK, porem não reconhecia o mouse.

Consegui solucionar este problema. Porém agora surgiu outro.

Eu instalo a distro iAtakos S3 V2 tudo ok, faço o primeiro login e tal, tudo bunitinho. Porém quando eu reinicio ou desligo e ligo novamente o note, o SO não carrega. Ele trava na tela cinza da maça..

Tens alguma ideia do que possa ser? Porque eu sempre consigo mexer durante o primeiro login..

E agora?

 

Por via das dúvidas também sou de Floripa..

Se você conseguir me ajudar, ficarei muito grato.

Valew

Share this post


Link to post
Share on other sites

Blz Nando ... bem vindo ao forum.

 

Use a opção -v no boot e poste uma foto da tela onde fica parado pra gente analisar se existe algum erro.

Share this post


Link to post
Share on other sites
Blz Nando ... bem vindo ao forum.

 

Use a opção -v no boot e poste uma foto da tela onde fica parado pra gente analisar se existe algum erro.

 

Olá pessoal, quero começar agradecendo... Ótimo post, muito bom mesmo.

 

Mas estou com um problemão, quando termina a instalação, logo quando sai a logo da Bios, ja aparece

um erro de Boot. Ja reinstalei varias vezes e não consigo nem chegar na tela branca da Maçã.

 

Meu VAio é o mesmo modelo que vc utilizou para o teste.

 

O que posso fazer?

Share this post


Link to post
Share on other sites
Olá pessoal, quero começar agradecendo... Ótimo post, muito bom mesmo.

 

Mas estou com um problemão, quando termina a instalação, logo quando sai a logo da Bios, ja aparece

um erro de Boot. Ja reinstalei varias vezes e não consigo nem chegar na tela branca da Maçã.

 

Meu VAio é o mesmo modelo que vc utilizou para o teste.

 

O que posso fazer?

Qual versão vc está usando?

Vc já tem o Windows instalado?

Share this post


Link to post
Share on other sites
Qual versão vc está usando?

Vc já tem o Windows instalado?

 

Sim, tenho o Windows, e uma partição agora com o MAC,

Só consigo entrar no sistema pelo DVD de instalação.

aperto F8, ai coloca a marção em cima da partição que tem o MAC, escrevo= busratio=20 -x

e ele da boot.

 

Sem o DVD da erro boot0 = ...

Alguma coisa assim...

 

Outro detalhe, quando entro no sistema, os pen drive não funciona para instalar a atualização,

nem mesmo um outro DVD qualquer.

 

 

Obrigado pela ajuda :gun:

Share this post


Link to post
Share on other sites
Sim, tenho o Windows, e uma partição agora com o MAC,

Só consigo entrar no sistema pelo DVD de instalação.

aperto F8, ai coloca a marção em cima da partição que tem o MAC, escrevo= busratio=20 -x

e ele da boot.

 

Sem o DVD da erro boot0 = ...

Alguma coisa assim...

 

Outro detalhe, quando entro no sistema, os pen drive não funciona para instalar a atualização,

nem mesmo um outro DVD qualquer.

 

 

Obrigado pela ajuda ;)

 

entra no sistema e instala esse Chameleon

http://www.insanelymac.com/forum/index.php...t&p=1634096

 

me mande os arquivos gerados no desktop por esse programa

http://www.insanelymac.com/forum/index.php...st&id=81816

Share this post


Link to post
Share on other sites

I ran a hard disk diagnostic test with the vaio care software and it came back ok. I have a sony vaio restore and windows automatic restore points. So i could try that tonight when i get back home.

Share this post


Link to post
Share on other sites

Buenas aver si alguien me puede echar una mano

tengo un sony vaio y no hay manera de instalarle xp por culpa de dichoso sata

aver si alguien que tenga este portatil me puede explicar que tengo que hacer ya lo e probado casi todo y no hay manera

e probado crea un cd xp personalizado pero no tengo los driver sata para este modelo

alguien tiene un xp especifico para este portatil?

un saludo

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×