Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
El.Pilote

MSI Big Bang xPower

7 posts in this topic

Recommended Posts

Bonsoir à tous,

 

J'ai décidé de créer un tuto sur la Big Bang xPower comme personne ne semble l'avoir fait aussi bien dans le forum anglais que français. Avec ce que je vais vous fournir, vous devriez avoir un verbose boot totalement dénué d'erreurs sous OS X 10.6.7, en 32 comme en 64 bits.

 

Je vais volontairement éviter les étapes basiques d'installation, suffisamment de topics sur ce sujet existent déjà pour du X58, assumant que vous ayez déjà quelques connaissances dans le domaine du hackintosh. J'expliquerai donc ce qui fonctionne ou non et posterai les kexts et le DSDT que j'utilise.

 

Je passerai aussi la partie vidéo, comme chacun possède un carte graphique différente.

 

Ce qui fonctionne avec le DSDT :

- CPU power managment natif (remerciant Chameleon RC5 au passage)

- Eteindre et redémarrer

- ICH10 natif (pour éviter le kext AHCIBlockStorage)

- Chargement du AppleLPC

- AppleSMBusPCI (plus d'erreurs au démarrage)

- Veille, sans coupure de l'USB au réveil

- jMicron e-SATA

- Firewire (seulement après une mise en veille)

dsdt.aml.zip

 

Les kexts requis :

- FakeSMC (avec monitoring des températures)

- Ethernet (RealtekR1000SL.kext)

- Audio (VoodooHDA.kext)

- e-SATA (JMicron36xeSATA.kext, pour faire joli dans les informations système)

(Tous les kexts se placent dans S/L/E)

MSI_Big_Bang_xPower_Kexts.zip

 

Ce qui ne fonctionne pas :

SATA 6Gbps :D

L'USB3 fonctionne avec des périphériques USB2, à tester.

 

Premièrement vous devrez mettre à jour votre bios avec le dernier en date.

 

Egalement, et je ne sais pourquoi, j'ai du brancher mon disque dur Mac sur le 4e port SATA, la veille ne fonctionnant pas sur le 1er ni le 2nd, essayez vous-même, c'est peut-être juste relatif à ma configuration.

 

Configuration du bios :

Mettre tous les chips en AHCI

 

Dans Power Managment Setup :

ACPI Function - Enabled

ACPI Standby Set - S3

EUP 2013 - Disabled

Restore On AC Power Loss - On

Wake Up Event - USB - Enabled

 

Vous êtes libre de configurer le reste comme bon vous semble, l'overclocking fonctionne, mon i920 à 4Ghz ne bronche pas.

 

Téléchargez le dernier Chameleon RC5, il va falloir utiliser GenerateCStates et USBBusFix.

 

Voilà le com.apple.boot.plist que j'utilise:

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
   <key>Graphics Mode</key>
   <string>1920x1200x32</string>
   <key>Kernel</key>
   <string>mach_kernel</string>
   <key>Kernel Flags</key>
   <string>-v arch=x86_64</string>
   <key>Theme</key>
   <string>Hackintosh</string>
   <key>GenerateCStates</key>
   <string>yes</string>
   <key>UseAtiROM</key>
   <string>yes</string>
   <key>GraphicsEnabler</key>
   <string>Yes</string>
   <key>USBBusFix</key>
   <string>Yes</string>
</dict>
</plist>

 

J'espère que ce tuto aura aidé les autres membres possédant cette carte mère à installer OS X sur leur configuration, cela m'a pris pas mal de temps à trouver les modifications à faire, le résultat en valant la peine.

 

Si par hasard quelqu'un sait comment utiliser le Firewire sans avoir à mettre le "Mac" en veille auparavant, je suis preneur.

 

A bientôt!

Share this post


Link to post
Share on other sites
Un petit bump pour savoir comment se porte cette config?

 

Et une question en prime.. tu as des coef impairs pour le multi de ta RAM si je ne m'abuse?

 

Bonjour, désolé du retard je n'ai pas activé la notification par email :/

 

La config' se porte parfaitement bien, passage en 10.6.5 ok, j'ai découvert que les ports USB3 fonctionnaient nativement simplement après les avoir activé dans le bios, la seule chose ne fonctionnant pas pour le moment est le SATA6GB. Donc on peut considérer que tout fonctionne :)

 

Voodoohda est un peu mou en capture micro et j'aimerai trouver un système de remplacement pour faire fonctionner le son parfaitement mais la carte son est très rare donc peu de chances de voir apparaître une solution "parfaite".

 

Oui mes coefs sont impairs en 4ghz ;)

 

Si tu as des questions n'hésite pas!

Share this post


Link to post
Share on other sites

Vieux motard que jamais :D

 

C'est une bonne carte, y'a pas à dire, Stella à jeter son dévolu dessus également. Pour les coeff, je parlais de ceux de la RAM, non pas ceux du CPU ;)

 

 

Pour le son tu as la carte Audigy 2ZS qui fonctionne avec des drivers dispo sur le forum ; sinon des solutions comme le M2Tech Hiface, mais ça nécessite un peu d'investissement (surtout pour les mélomanes).

 

Tchô.

Share this post


Link to post
Share on other sites
plop je squatte :)

 

Si tu touche un peu en O/C tu pourrais me dire ton bclk max avec cette board ?

 

Thx

 

Désolé de répondre si tard je n'ai plus eu beaucoup de temps à consacrer au monde du hackintosh, il faudrait d'ailleurs que j’essaie d'installer Lion voir ce que cela donne :(

 

Pour le bclk je ne peux te dire, mon i920 est un C0 et chauffe pas mal donc 4ghz max avec hyperthreading et un bclk de 211.

 

En tout cas sa tiens la route, aucun problème avec les MAJ du soft Apple.

 

Cependant j'aimerai remplacer Voodoohda, si quelqu'un a des infos la dessus je suis preneur!

 

++

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×