Jump to content

ati ata chipset driver- waiting on root


6 posts in this topic

Recommended Posts

hello, i have a athlon 64 3500+. it's ati xpress200, but i'm not using the on-board video card.


the thing is, my windows install is on the sata drive, where the macosx86 drive is it's own ata drive.



anyhow, vmware install wass fast everything is running, i'm trying to follow this guide:




i've tried the southbridge driver but it does not work. so i deleted that kext and tried this one:






i'm still getting waiting on root error.


my mobo is:


sb400 ati southbridge


xpress 200 rs 480 rev 10


any help would be appreciated. linux/unix is pretty new to me, i used to have a imac and fiddled with osx before but not this much so it's been fun so far.



thanks again for any help








how can i see if those kext files load up correctly, can i check from booting vmware?

Link to comment
Share on other sites

Waiting root device means the system cannot determine the boot drive. Try disconnecting the SATA drive and verify that the IDE chain is set to have the hard drive as primary master and the DVD is primary slave. Disconnect all external drives if you have them and any flash drives. If this doesn't solve it, reverse the DVD (to master) and the hard drive to slave.


This is one of the hardest errors to solve.


Try ioreg in Terminal to see what is loaded. Also, run System Profiler, click on Extensions and then click on kext of interest and see what it says.

Link to comment
Share on other sites

well i have alot to rule out.....


currently going to try this, since i have 3 hdd's and i have this built-in memory card redaer thing too....


i'll try unplugging that first :D


my setup is like this:


sata- winxp


160 gig hdd with dvdrom


then the macosx86 80 gig on it's own channel

Link to comment
Share on other sites

does it matter that the drive is ata?


i tried disconnecting everything from the ide channels except the drive no go.


i'll keep trying different configs. the drive was set to slave, so i put it to master but still no go.

Link to comment
Share on other sites

i'm not sure what the problem is here.


booted with rd=disk0s0 -v


thought it was going to work. give different message:


appleatiipaata blah blah


looks like one of the diff kext's i put in.


but still get the waiting message....



Q: When I try to install OSx86, I get the message "Still waiting for root device."


A: OSx86 is not seeing your optical drive. If the drive is IDE, make SURE it is on the IDE port that goes to your southbridge (usually the blue one, but it varies), NOT on any supplementary IDE controllers. If it is SATA, set your bios settings to emulate or compatibility or something like that, NOT native or RAID or AHCI. Note: After changing the sata mode, if you also run windows off of the same/another HD on this controller, you may notice degraded performance and/or faliure to boot windows IF you change the sata settings.



ok but i'm trying to boot off hdd not optical..... could it be a sata problem even though i'm not using osx on the sata drive?




If you mean boot instead of install, just replace the phrase "optical drive" with hard drive, the rest still applies. It is a detection issue with your IDE/SATA controller. Also you have to check that The Hard Disk is on the same ATA cable as the optical drive (in my case a DL DVD recorder).

Edit: Try deleting the ApplePS2controller.kext - I get rid of that and it boots up for me no problem then!


EDIT: If you have an Ati Xpress200m Chipset, you must use scousi's Ati ATA kext.



ok i will swap my 160 with the 80, put osx86 on the channel with the dvd.


going to read-re the scousi's ati ata kext, even though i'm not getting anywhere's with it :D

Link to comment
Share on other sites


  • Create New...