Jump to content
InsanelyMac Forum
Rammjet

[How to] Setting Your Partition "Active" Using Fdisk in MacOSX

Recommended Posts

I checked your link.. it appears to relate to a fresh install. My take on it all is to follow the instructions up to the point of the install from the OSX86 install disk and then proceed to do the clone to the new disk. Is that correct?

I think my mistake was to repartition with the OSX Disk utility (?) rather than erase the partion and format it as a Mac partition.

Thanks

Steve

Share this post


Link to post
Share on other sites
Advertisement
My take on it all is to follow the instructions up to the point of the install from the OSX86 install disk and then proceed to do the clone to the new disk. Is that correct?

Yes

 

I think my mistake was to repartition with the OSX Disk utility (?) rather than erase the partion and format it as a Mac partition.

The hard drive has to have an MBR partition scheme like a PC uses. Disk Utiliy on the install DVD is much older and cannot do that. However, the newer Disk Utility you get after an install can do an MBR partition scheme if you select the Option button to set it.

 

It is simpler to tell everyone to format the whole drive as FAT32 and then reformat the primary partition as HFS+.

Share this post


Link to post
Share on other sites

Hi, well i got it all up and running but now im just wondering about the updates, ive read a little (that i could find) but can anyone provide kind of a summery of how the update process works, i assume you have to wait for a mac/unix god to patch and release it, but are they whole, or in parts? do all parts generally work, or does it boil down to the system, what parts work and what ones dont?

thanks in advance guys (probably rammjet, im knew but he seems pretty helpful so far)

Share this post


Link to post
Share on other sites

I've followed the instructions and marked the HFS+ partition active, but it doesn't works. I have a external USB HDD width OS X 10.4.6 installed, this drive also have another partition in FAT32 format. I have Windows XP installed in my internal SATA HDD. If i boot from the install DVD and wait until countdown ends, i can boot into OS X, but if i try to boot from external USB HDD i only get a letter L at the bottom of screen and system hangs... ;)

 

Many thanks to all in advance,

 

.:FiDo:.

Share this post


Link to post
Share on other sites

Now how about going into Start-> Control Panel -> Admin Tools -> Computer Management and in there on the left side select disk management (or what it is called) and a built in XP disk manager should appear. Now right-click the desired partition and "Make active". (this option shouldn't be greyed out even for OSX (AF) partition; wasn't for me).

Your machine will boot from OSX partition and you should be able to select which OS you want to boot upon OSX bootloader startup unless you have QuietBoot enabled with no Timeout key in com.apple.boot.plist - if so, you can hold F8 to bring up the OS selector.

Share this post


Link to post
Share on other sites

Thanks Rammjet, this solved my problem, but when it boots it says :

"The CPU has been disabled by the guest operating system. You will need to power off or reset the virtual machine at this point.".

 

Anyone can help me.

 

My Specs:

Mobo: Intel D946GZis

CPU: Pentium D 3.40GHz

RAM: 1GB DDR2

HD: 160GB SATA, 80GB IDE (Installed here)

Video: PowerColor Radeon X800 GT

Sound: SoundBlaster Audigy

Share this post


Link to post
Share on other sites

Hey Rammjet ,

I get an error "fdisk is in the form dev/rdisk0"

 

when i type fdisk -e/dev/rdisk0

or fdisk -e /dev/rdisk0

 

Any suggestions?

I've had this working before (to set my other OS active, i used the same commands from the same OSX dvd yet it isn't working this time.

 

Thanks in advance,

Tom

Share this post


Link to post
Share on other sites
I get an error "fdisk is in the form dev/rdisk0"

 

when i type fdisk -e/dev/rdisk0 <-- incorrect

or fdisk -e /dev/rdisk0 <-- correct

 

Any suggestions?

See comments in quote above.

 

Be sure you type a zero instead of the letter "O"

 

Also, be sure you are pointing to the correct hard drive. If OSX is on a partition on the 2nd hard drive then the command uses: rdisk1

Share this post


Link to post
Share on other sites

now when i restart, nothing happens. no b0 error or anything. I still need the install dvd to do it

Share this post


Link to post
Share on other sites

Hi,

 

Do I still need to make the partition active only if Mac OS X is the only OS on my machine?

 

 

Please help.

 

 

 

 

There are a lot of people who experience a b0 error on their first boot up after installation. Or the bootloader immediately takes them back to the Windows installation (on dual boot).

 

These people probably forgot to set the MacOSX partition "Active"

 

A common mantra provided here to newbies for setting up for installation is:

  • Make the partition Primary
  • Make the partition ID=AF (signifies an HFS partition)
  • Make the partition Active

There is a built-in Unix utility in MacOSX that can be used to set your partition "Active". It is called Fdisk

Setting Your Partition "Active" Using Fdisk

 

Words in bold below are things you must type (followed by Enter).

 

1. Boot your Mac OS X install dvd

2. Once the installer is running, go to the Utilities menu and open Terminal

 

3. Determine which disk your MacOSX partition is on

Type
diskutil list

 

Verify which disk number holds your partition (disk
0
, disk
1
, etc.)

 

4. Start using Fdisk

Assuming the MacOSX disk is the first disk ("disk0"), then

type
fdisk -e /dev/rdisk0
<== use "rdisk" with your disk number here !!

 

Ignore the error "fdisk: could not open MBR file ..."

 

5. Determine which partition for MacOSX needs to be set "Active"

Type
p

 

Verify which partition is for MacOSX (1, 2, 3, etc.)

 

6. Set the partition "Active"

Assuming it is partition 1, then

type
f 1
<== use your partition number here !!

 

7. Save and exit

Type
write

 

Type
y
(yes you are sure)

 

Type
exit
(to quit)

 

8. Remove the install DVD and reboot

Share this post


Link to post
Share on other sites

Hey, guys, i did the command

 

fdisk -e /dev/rdisk0

 

Then

 

Flag 1

 

now there is a * next to my first partition,

 

so i save,

 

then exit

 

then it reboots,

 

and i see the ATI Mobility 9000 vesa... so and so,

 

then a bunch of text goes flying past my screen for like 10 secs saying loading so and so,

 

then i see a blank screen,

 

then it restarts itself.

 

Thanks for help/

Share this post


Link to post
Share on other sites

Setting the partition active got your computer to boot the OSX partition. The errors have to do with your OSX installation. Start a new thread for your booting/restarting problem. It is no longer an issue of setting your partition active.

Share this post


Link to post
Share on other sites
There are a lot of people who experience a b0 error on their first boot up after installation. Or the bootloader immediately takes them back to the Windows installation (on dual boot).

 

These people probably forgot to set the MacOSX partition "Active"

 

A common mantra provided here to newbies for setting up for installation is:

  • Make the partition Primary
  • Make the partition ID=AF (signifies an HFS partition)
  • Make the partition Active

There is a built-in Unix utility in MacOSX that can be used to set your partition "Active". It is called Fdisk

Setting Your Partition "Active" Using Fdisk

 

Words in bold below are things you must type (followed by Enter).

 

1. Boot your Mac OS X install dvd

2. Once the installer is running, go to the Utilities menu and open Terminal

 

3. Determine which disk your MacOSX partition is on

Type
diskutil list

 

Verify which disk number holds your partition (disk
0
, disk
1
, etc.)

 

4. Start using Fdisk

Assuming the MacOSX disk is the first disk ("disk0"), then

type
fdisk -e /dev/rdisk0
<== use "rdisk" with your disk number here !!

 

Ignore the error "fdisk: could not open MBR file ..."

 

5. Determine which partition for MacOSX needs to be set "Active"

Type
p

 

Verify which partition is for MacOSX (1, 2, 3, etc.)

 

6. Set the partition "Active"

Assuming it is partition 1, then

type
f 1
<== use your partition number here !!

 

7. Save and exit

Type
write

 

Type
y
(yes you are sure)

 

Type
exit
(to quit)

 

8. Remove the install DVD and reboot

 

thanks for the great advice and help Rammjet. I have a quick question. i did as you said and now i just sit a a blinking cursor. i made the 0 my active partition. could i have made the wrong one active? how can i tell which one should be active? kind of new at this

Share this post


Link to post
Share on other sites

Hey thanks for the 'how to'

i did like you posted, and i think i got everything right, but when i remove the Install DVD and reboot, i get the Gray apple screen wit the apple, then i get a 'cancel' icon on top of the Apple icon. with the rotating wheel inderneath just spinning. and it stays there forever. not sure what im doing wrong

Share this post


Link to post
Share on other sites

Rammjet,

 

Is there any comand I can set in com.apple.boot.plist, <key>Kernel Flags</key> section to specify with partition to boot to?

 

I have 3 boot (Win XP 32 bits, Win XP 64 bits and MAC OS X in this partition order). The default partition is set to Win XP 32 bits witch I use most of the time but when I boot to Mac OS i´d like to go to it´s partition straith without having to select Mac OS X partition again from the Darving menu.

Share this post


Link to post
Share on other sites

okay, i didint boot onto my disk, i just did this in terminal in regular osx. now i cant boot to win 'nix or osx without the dvd. is there anything i can do?

Share this post


Link to post
Share on other sites

Hi, thanks a lot Rammjet for your guide.

 

I think I did everything said but no way. I can not boot after having a copy of my main partition with carbon copy cloner to my other drive. I just got a blank screen with a flashing underscore.

 

post-49579-1168461121_thumb.jpg

 

I think also that the primary partition done with gparted was right. I'm getting nut. I can not determine where the problem come from.

 

post-49579-1168460839_thumb.jpg

 

 

Any help? Thanks

Share this post


Link to post
Share on other sites

i' ve just installed jas 10.4.8 with semthex 8.8.1 i think and installs ok. When it finishes and restarts it shows a blinking cursor and nothing happens. If i try to boot from dvd is starts installation again. Tested with sata and ide drives. same problem. Its not the "b0" error. It shows nothing but a blinking cursor. i had a stable 10.4.7 installation prior to this. Any help?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×