Jump to content
Habib1

ATi x700 Mobility, but no way to get it working :(

9 posts in this topic

Recommended Posts

Hi,

 

I´m a new Hackintosh user since 4 Days and I´m like my new OS :D I´ve read many HowTos and Guides so I leanerd much about to handle with OS X. I don´t want to Post as Newbee No. 1457 for the same problem, but what I did, I don´t get install my graphic card correctly.

 

My Hardware:

Samsung X50 Notebook

ATi Mobility x700 (ID 5652) PCIE

WSXGA 1680x1050

2GB RAM, 100GB 7K100 Hitachi

 

Mac OS X 10.4.6

 

 

What I`m try:

 

Like some HowTos, I installed Callisto (003-008) and then I´ve patched my ATIRadeon9700 manualy. Always I cleared the caches and repaired the permissions.

 

Callisto effects after install:

003Bugfix: I have a corrct screen, but only in 1024x768, no QE,CI

005-008: I´ve all Resolutions available, but after the first switch to 1680x1050 I get every time corruptions at screen (flicky stripes all over the screen, but the image is nice viewable), no QE,CI

 

I think, my ATIRadeon9700.kext are wrong, or old or something, cause every time I try to activate this (manualy patched or script made by koverg patch 0.2) I get after the reboot only a multicolored screen and I can´t see any Objects.

 

The Tip to delete any .kext wich doesn´t need I tried also without luck.

 

What works is every time set the Resolution manuely, but only 1400x1050x32 without any drivers. But in this mode I can´t see usable Videos or other mutlimedia stuff, cause the PC is very slow and unstable.

 

Could somebody help me? I want I usable OS X but at this point I don´t know the next step to try?

 

Graphic Hw:

Raw EDID base

 00: 00 FF FF FF FF FF FF 00  36 7F 00 00 00 00 00 00 
 10: 00 00 01 03 80 28 1E 00  F2 00 00 00 00 00 00 00 
 20: 00 00 00 21 08 00 31 40  45 40 61 40 71 40 81 40 
 30: 00 00 00 00 00 00 95 2E  90 A0 60 1A 2E 40 30 20 
 70: 00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 38 

Display adapter
 Adapter description......... ATI MOBILITY RADEON X700
 Adapter device ID........... 0x56521002
 Display settings............ 1680x1050, 32bpp

 

 

Regards

Habib

Share this post


Link to post
Share on other sites
Advertisement

{censored}, today I get one time QE/CI working, but only with the koverg-patch. I tried to extract the ATIRadeon9700.kext Files out of the 10.4.6 Update Bundle. After them I patched they and after the next reboot, I´ve seen the first time both supported. In this case I though that these was the solution and treid the Callisto Driver (with Framebuffer CallistoFB) but now I get the same error as before. I thought I could remove only Callisto and reverse the edit for the framebuffer, but since that, I´ve never seen QE/CI back...

Now I get excact the same errors as the post before... :) argh... what I´m doing wrong?

 

Regards

Habib

post-48024-1154027645_thumb.jpg

Share this post


Link to post
Share on other sites

yep x700 mobility sucks. i can get qe an ci with koverg.. but what i really want is 1280x800 resolution. tried callisto.. always black screen.

Share this post


Link to post
Share on other sites

i think this is the problem for everyone of us here who own that x700 mobility (5653)

QE/CI are supported with koverg 0.2 (with artifacts, MouseLocator helps) but no res change yet :thumbsup_anim:

would love to see my Asus A6Va Laptop run on 1280x800...

Share this post


Link to post
Share on other sites
i think this is the problem for everyone of us here who own that x700 mobility (5653)

QE/CI are supported with koverg 0.2 (with artifacts, MouseLocator helps) but no res change yet :huh:

would love to see my Asus A6Va Laptop run on 1280x800...

 

 

X700 ( 5653 )

 

Here is my Patched Callisto Driver to Change resolution 1280x800 and Qe + Ci Enabled!

 

Its out of the Box for the X700 with ID 5653 and Dotclock 71250 ! No need to change anything!

 

 

 

Peace

Patch_X700.rar

Share this post


Link to post
Share on other sites
X700 ( 5653 )

 

Here is my Patched Callisto Driver to Change resolution 1280x800 and Qe + Ci Enabled!

 

Hello!

 

Thank your for your driver package! Unfortunately it only ALMOST got my graphics card (Mobility X700 (5653) in an Acer Aspire 1692) working ;) Could you please tell me step by step how to install it? I tried to install the three .kexts with the OSX86Tools kext-installer and I didn't know what to do with the .plugin and .bundle files so I just tried copying them into the Extensions folder...

 

Anyways, the graphics card is recognized in System Profiler but no CI/QE. Also, I could change the resolution in the Systemsettings/Displays settings, but when I do, the screen stays black and I have to reboot. If I try to boot with "Graphics Mode"="1280x800x32@60" it will even fail to boot.

 

So, hope to hear from you soon - graphics is the only thing I still ned to have a decently running Leopard system (iPC 10.5.6. should that matter...) :wacko:

 

Greets

Share this post


Link to post
Share on other sites
X700 ( 5653 )

 

Here is my Patched Callisto Driver to Change resolution 1280x800 and Qe + Ci Enabled!

 

Its out of the Box for the X700 with ID 5653 and Dotclock 71250 ! No need to change anything!

 

Peace

 

 

Can you tell me whats the procedure to edit the Hex value to modify Dot clock? I want to modify it to 96300 and I do not know which file to modify. I tried looking up Calisto, ATIRadeon9700 and CallistoHAL and none of them had anything like how the thread says at location 0x490e. It points to an entire line and I do not know which byte to change.

Also Should I convert 96300 string to hex? Then the hex equivalent according to this site http://www.easycalculation.com/ascii-hex.php is 39 36 33 30 30. Where should I enter this? Someone please help.

Its for ATI Radeon Mobility x700 on ASUS A7v

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×