Jump to content

iPhone Simulator MainThread freezes

10 posts in this topic

Recommended Posts

Hello everybody,

I have a severe problem with my iPhone Simulator on MacOSX86 Snow Leopard. I started to develop an iPhone game some time ago on 10.5.8. But then I decided to upgrade to 10.6.4, because I needed several of the new features of iOS 4. The upgrade process worked very well, I know it was too easy :-D Now on iPhone SDK 4 the whole UI is buggy. This shows up in random freezes of the MainThread (the UI Thread) the App seems to be not responding anymore, the only thing is to quit with the home button or sometimes double tapping twice convinces the application to go on... Not only my apps are affected by this problem, but the whole iOS 4 (okay, the few apps that come with the iPhone Simulator). When I switch to iPhone OS 3.1 or 3.2 it works well again. I cannot imagine what's wrong, I tried everything that come to my mind. Several reinstalls and stuff. The installation process is also fine, the only thing that runs my computer into a kernel panic are the CHUD extensions, therefore I had to remove them. Everything else is fine, I have networking, sound, accelerated graphics... This really drives me crazy, I was so motivated to proceed with my game, but in this condition the simulator isn't usable for debugging and testing. Also I haven't got a full developer account up to now and cannot test on the device. It would cost additional 3 months to get me a mastercard to pay for the membership.

Okay, if anybody knows something or had the same problem as me, please help! :-)

Link to comment
Share on other sites

i may be able to help you out for testing on device... i can add you to my dev account and give you builds n stuff... as for that issue;


installing the xcode 4 had a small ui issue in the simulator, the apps didnt get their icons rounded off or load properly.


Check the info.plist for the skd version. there could be something there thats bugging up (eg built with sdk 3.x with 4 features)


I would try a full reinstall of xcode. as in to the point that /Developer was removed etc...



Willing to help... I don't think its the computer, more likely the install or some little setting...



EDIT: Whats your system profiler show... XCode has not worked when i quickly removed it

Link to comment
Share on other sites

This does the System Profiler say:

Developer Information:

 Version:	3.2 (10M2262)
 Location:	/Developer
 Xcode:	3.2.3 (1688)
 Interface Builder:	3.2.3 (788)
 Instruments:	2.7 (2529)
 Dashcode:	3.0.1 (330)
 Mac OS X:
 10.5:	(9L31a)
 10.6:	(10M2262)
 iPhone OS:
 3.2:	(7B405)
 4.0:	(8A306)
 iPhone Simulator:
 3.2:	(7W367a)
 4.0:	(8A306)


The complete reinstall didn't help. Maybe I don#t know where all the settings are located, I executed uninstall-devtools mode=all and removed the Developer folder, but my settings are preserved anyway. The same error after the reinstall, I can make 5 or 6 clicks/touches and then the whole UI halts. My guess would be, Apple did a nasty optimization of the UIKit on the x86 codepath, that my hacked NVdarwin driver does not support properly. And about the settings I do not know much, the most is hidden in some configuration files by apple anyway. It is definetly not a problem of my application, because on the iPad Simulator it works, although its compiled for 4.0 :-D but crashes as soon as I call some of the 4.0 functions.

You can really add me to your developer account? :( Do you have the enterprice version of the developer membership or how is that possible? This would be really nice, because I think the only thing I can do otherwise is waiting for SDK 4.1 and hoping the issue will disappear or wait 3 months until I can afford my own membership. Also it would be nice to see if the program is transfered to the device properly and runs fine, before I pay the 99$ :D

Everything else is a waste of time I think, because I don't even know where to look after the error. Nothing on the console is indicating that anything goes wrong and with instruments I could discover, that after the freeze calls to UIKit take place actually, but are stopped at some point I think, I don't know very much about the internals, therefore I cannot tell where and why ...


thanks up to now!

Link to comment
Share on other sites

hi... sorry about the late reply... ive been really busy.


I should be able to give you permissions and publishing rights... OR you could jailbreak and publish and test without that stuff...


If you want me to try and help (no guarantees it will work perfectly first shot) then we will start by getting your idevice/(s) UUID.


In the process ill need to send a bunch of certificates and stuff... I usually use dropbox when working with other friends... If you don;t already have it, then sign up under me. and we both get bonus space...





oh, and if for some reason the eventual addition of you to my team fails, a last resort would be for you to dropbox me the source and i compile it for you... just a thought


if you need, my secondary email is scottapotamas@gmail.com

It is a better option than emailing through insanely or pm's

Link to comment
Share on other sites

Okay, the idea itself is quite good, I considered it a while ago by myself, but at this time my device was unable to be jailbroken, because of the omnious "MC" modell-identifier, which stands for a new bootloader that prevents me from jailbreaking... eventually I've got a jailbreak now, but just through this bug in the Safari Web Browser and I think apple is going to fix this as soon as possible thus rendering me unable to jailbreak again. I will definitly need the 4.1 Software Update, because of the introduction of the announced Game Center which will be very important for my game.

But nevertheless it is worth a try. But I have a question, can I after I installed the necissary certificates debug on the iPhone just the same as I can do it with XCode and a regular device? Because manually copying the builds onto device would be very tedious.

Sending you my sourcecode to build won't solve my problem, because it isnt my compiler who fails, but the simulator architecture! ^^

Link to comment
Share on other sites

ive helped work on the pdf exploit. it has been patched for os4.1 beta 3.


As for the other stuff... I think you need a variety of certificates and other keys... ill dig some up stuff for you.


at last check the


wwdc certificate

developer/team leader cert (me)

.pb9 or something

.mobileprovision file once uuid has been added to my provisioning portal.


gamecentre stuff is a bit trickier with the same level of complexity as in app purchases...

Link to comment
Share on other sites

Out of some reason your last post wasn't emailed to me, meanwhile I managed to set up my device for testing on my own (after some youtube&google search :-D), it works really like build&go! :(:)

Just executed a fancy script called lemontea.sh, but I really don't know or care about what it does ^^, created a custom "iPhone Developer" Certificate and installed the Appsync 4.0 from the hackulous repository, which is a little bit paradox, because this is used to install cracked apps usually and this is quite the opposite I want :-D. Now the app got builded and installed on the device with one click, but debugging currently doesn't work for some reason:

Error launching remote program: failed to get the task for process 795.
The program being debugged is not being run.

However I'm glad this worked so easy and well.


You really worked on the Safari exploit? Nice work! ^^ I really hope there will be a chance to jailbreak on 4.1, but we will see what apple is planning... Maybe I can take you up on your offer then if necessary? (But probably not, because then I will have my own developer account I hope. ^)

But what do you mean with GameCenter is a bit trickier? I really just do know the basics. Are there limitations for not registered developers?


Thanks for helping up to now!

Link to comment
Share on other sites

its good that you can test your app for now... the lack of debugging would be a real pain. You could add some code to say, log the debug messages or errors to a .txt saved locally. it would be a {censored} but would be a way around it.


As for game centre and the developer account. Because apps that use in app $$$ or gamecentre or accessories, they require a bit more work on the app id bit.


Instead of just adding a app name and device and downloading, gamecentre requires something from xcode, then it has some certificate thing. I haven't looked at it cause I dont find it relevant to my needs. Anyway, apple makes this happen because its dealing with peoples apple id's. They make people do this for security of the accounts i believe...


I would recommend getting the licence. It really is worth it and $99. The price really is amazing compared to the <$500 for any development studio on windows.

Link to comment
Share on other sites

OK, just for the record, debugging is not bugging me anymore, haha... for everyone who wanna try this out by himself, here is the complete tutorial: http://www.alexwhittemore.com/?p=354

Now the app takes a hell of time to load, but i think this is because of my very slow USB-Link, because it is somehow broken, but on a regular and fully functional pc it should run fine!


As Bob Ross always saying, we should sign it and call that little rascal finished! ;) ;)


@ Scottapotamas: You can't imagine how familar I am to this method :-D On 10.5.8 the debbuging in Xcode was not working at all and I developed a whole non-UI network-protocol using NSLog :-D This was horrible, I still get nightmares sometimes at night... :P

Link to comment
Share on other sites


  • Create New...