Jump to content
kozlek

Chameleon RC5 mode with mem detection enabled and automatic P-States & C-States generation for native power managment

1,215 posts in this topic

Recommended Posts

I thought it was the latest one from assembla svn, but the link from the first post seems to have changed.

Share this post


Link to post
Share on other sites
Advertisement
This is really cool stuff. I just tried it out but got Memory Allocation error on boot. I built the source with xcode and replaced the boot file in my / directory. Are there other files I need to copy as well?

 

I had the same problem from the assembla.com site but using the source (now changed) in post #1 mine compiled fine and works (version 204).

Share this post


Link to post
Share on other sites

Thank you. I'll check it out.

 

Also thanks to ZEF for your response.

 

You guys are doing some great stuff!

Share this post


Link to post
Share on other sites
try to use "Wait"="Yes" option in boot.plist to check chameleon log. I need some debug information from it. Maybe SSDT patcher didn't found CPUs in DSDT. Where is knowing bug in CPU name detection algo. I'll fix it later.

Hi,

I've made some test with revision 352 but it gives me memory allocation error with DropSSDT,EnablePStates and EnableCStates all set to "Yes"

 

CPU DSDT code:

 

	Scope (_PR) {
	Processor (CPU0, 0x00, 0x00000810, 0x06) {}
	Processor (CPU1, 0x01, 0x00000810, 0x06) {}
	Processor (CPU2, 0x02, 0x00000810, 0x06) {}
	Processor (CPU3, 0x03, 0x00000810, 0x06) {} 
}

 

c.a.B.p code:

[size=1]<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Boot Banner</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>1920x1080x32</string>
<key>GraphicsEnabler</key>
<string>No</string>
<key>DropSSDT</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>Instant Menu</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=i386</string>
<key>Quiet Boot</key>
<string>No</string>
<key>SystemType</key>
<string>1</string>
<key>Theme</key>
<string>Default</string>
<key>Timeout</key>
<string>0</string>
<key>Wait</key>
<string>No</string>
<key>device-properties</key>
<string></string>
</dict>
</plist>[/size]

 

 

memory allocation error:

post-464373-1279844595_thumb.jpg

 

If I use C-State in DSDT and so I put EnableCStates=No in c.a.B.p i can boot up, but no speedstep (like with the value injected in DSDT).

 

Please note that i'm using Zotac GF9300 WIFI ITX, with a q9300 overclocked @2.62

 

The only way I can have speedstep with this configuration is with P-StateChanger (i've not tested with VoodooPowerMini yet)

 

With DSDTSE I can see the 4 ssdt table attached here:

SSDT.zip

 

My q9300 was seen as Xeon before the upgrade, now it's unknown

 

Like snackole i've just compiled it with "make clean; make" and changed the boot in root, boot1h and boot0 are from ANVAL bootloader.

 

Now I'll test with the 204 on the official Chameleon repo.

 

mem detection not tested ( my ddr2 was not recognized on the last version Rekursor released some time ago)

Share this post


Link to post
Share on other sites

Hi all,with the 204 from chameleon repo I have no more memory issue at boot with DropSSDT,EnableCStates and EnablePStates = Yes.

but still I have CST error in kernel.log:

 

Jul 23 03:41:46 localhost kernel[0]: AppleIntelCPUPowerManagement: initialization complete

Jul 23 03:41:46 localhost kernel[0]: AppleIntelCPUPowerManagementClient: ready

Jul 23 03:41:55 macbook-pro-di-tomare kernel[0]: ACPI_SMC_PlatformPlugin::pushCPU_CSTData - _CST evaluation failed

Jul 23 03:42:05: --- last message repeated 1 time ---

Jul 23 03:41:55 macbook-pro-di-tomare kernel[0]: ACPI_SMC_PlatformPlugin::registerLPCDriver - WARNING - LPC device initialization failed: C-state power management not initialized

 

Just to be sure that OC is not causing any problem I'm now at default clock.

 

Now i'll boot with wait=Yes to check if there is something helpful ...

 

EDIT: As reported in another topic, it works but with an old dsdt i was using, not with my last one. CPU recognized as Quad core Xeon as expected...

Share this post


Link to post
Share on other sites
Where is some problems with CPU detection after I've integrated valv's CPU type injection code. Need more testers and reports to fix it. So Quad Core is not detected or information for injection was incorrect. Will check it later.

 

 

 

Compiled the new one and it is now Fixed! ;)

 

Thanks :wacko:

Share this post


Link to post
Share on other sites

Ok folks,

 

I optimized the mem detection, and it is now blazing fast :)

 

Warning:

this version has memory detection enabled by default,

so it's only intended for people for whom mem detection did NOT crash

before with latest mozodojo / zef enhancements in build 204

 

For people for whom it crashed before (if any), it should not work better,

only mem detection time has been dramatically reduced ...

 

here:

boot.zip

 

EDIT: even faster:

boot_2.zip

 

I'll commit the changes after some sleep and after some feedback :D

Share this post


Link to post
Share on other sites
Ok folks,

 

I optimized the mem detection, and it is now blazing fast :)

 

Warning:

this version has memory detection enabled by default,

so it's only intended for people for whom mem detection did NOT crash

before with latest mozodojo / zef enhancements in build 204

 

For people for whom it crashed before (if any), it should not work better,

only mem detection time has been dramatically reduced ...

 

....

I'll commit the changes after some sleep and after some feedback :D

Thanks for your work.

 

Devices: 945GCM-S2L, DDR2 667 MHz 2 x 1 GB

I could see mem detection at booting correctly but mem report in System Profiler was wrong.

Bank0/1/A0:

 

Size: 1 GB

Type: DDR2 SDRAM

Speed: 667 MHz

Status: OK

Manufacturer: Kingston

Part Number: 9905316-005.A04LF

Serial Number: FFFFFF???

 

Bank2/3/A1:

 

Size: 1 GB

Type: DDR2 SDRAM

Speed: 800 MHz

Status: OK

Manufacturer: N/A

Part Number: N/A

Serial Number: N/A

 

updated @ 21.01

***************************************

Devices:EP45-UD3R, G.Skill DDR2 1066 MHz 2 x 2 GB

 

rekusor's boot

Bank0/1/A0:

 

Size: 2 GB

Type: DDR2 SDRAM

Speed: 800 MHz

Status: OK

Manufacturer: G Skill Intl

Part Number: F2-8500CL5-2GBPK

Serial Number: 100000000

 

Bank4/5/A2:

 

Size: 2 GB

Type: DDR2 SDRAM

Speed: 800 MHz

Status: OK

Manufacturer: G Skill Intl

Part Number: F2-8500CL5-2GBPK

Serial Number: 100000001

 

 

AsereBLN's boot

Bank0/1/A0:

 

Size: 2 GB

Type: DDR2 SDRAM

Speed: 1066 MHz

Status: OK

Manufacturer: G.SKILL

Part Number: F2-8500CL5-2GBPK

Serial Number: 0x00000000

 

Bank4/5/A2:

 

Size: 2 GB

Type: DDR2 SDRAM

Speed: 1066 MHz

Status: OK

Manufacturer: G.SKILL

Part Number: F2-8500CL5-2GBPK

Serial Number: 0x00000000

 

from CPU-Z

post-93383-1279893577_thumb.jpg

Share this post


Link to post
Share on other sites

Does it load other ACPI tables, too? Cause I currently boot valv's loader with a custom APIC table...

@the_chameleon_team: Thx for your work!

Share this post


Link to post
Share on other sites

Just tried to use this on my system. The system reboots when it attempts to generate C-States P-States for my CPU.

My CPU is an intel Core i7 920. My motherboard is the EVGA X58 SLI.

 

Correction: Seems like it's doing it when it's generating P-States, not C-States..

Share this post


Link to post
Share on other sites

I decided to try out the memory detection, and unfortunately it doesn't work: Chameleon locks hard after loading a couple of files, with no error messages or anything like that.

 

I'm running on a P45 motherboard, with 2 x 2GB DDR2-800 modules from Super Talent. Are there any dumps or debug information I can collect to help? Perhaps I'll try to compile RC5 with the debug flag set for the mem. detection.

Share this post


Link to post
Share on other sites
EDIT: even faster:

boot_2.zip

 

Hi rek!

 

Thanks, the detection works pretty fast now! :) Only one downside: I got 800MHz displayed again for my 1066MHz Kingston modules. r204 detects the correct 1066MHz frequency (removed the empty BANK1/3 results):

 

BANK0/DIMM0:

 

Size: 2 GB

Type: DDR2 SDRAM

Speed: 1066 MHz

Status: OK

Manufacturer: Kingston

Part Number: 2G-UDIMM

Serial Number: FFFFFFB5

 

BANK2/DIMM2:

 

Size: 2 GB

Type: DDR2 SDRAM

Speed: 1066 MHz

Status: OK

Manufacturer: Kingston

Part Number: 2G-UDIMM

Serial Number: FFFFFFA4

Share this post


Link to post
Share on other sites
@zef: Could be the right time for an official RCx release ?

 

Hi Trauma!

 

Sure, RC5 is coming soon :D We need more testers/feedbacks.

 

Bye,

zef

Share this post


Link to post
Share on other sites

Hey this is great!

E8400 here, 4 p-states, can't reach lower one at 2GHz, lowest possible with ChamRC5 is 2,3GHz and while going down from higher to lower stay, very rarely, for a moment at 2GHz.

Voltage a little high. I can reach lowest p-state with voodooPM.

Share this post


Link to post
Share on other sites

to ZEF & other head chameleon devs:

Question about Pstate Generator (voodoopwoer/superhai based).

As i used superhais .kext i had to use an key (in his .plist) to avoid Pstate 0 (higest Multi= highest MHz). So i Limit Pstates to 1 (=Multi 9* as in bios setting)

Reason: My Ep35 - Intel C2D runs OC by FSB 266>333 BUT! lowered Multiplyer 10>9 . (9*333 = 3 GHz, default 10*266=2.66 Ghz)

I dont now how latest chameleon works in this case. superhais kext tried to switch to Pstate 0 as 10* which KPs the too much OCed CPU (10*333 vs 10*266 default).

I run vanilla Pstates (dsdt.aml) which works good, Pstates Multi 6 to 9 used there. Not the default 10 as fastest multi.

Would i run also here in KP using newest chameleon V204+ ? Or does the generator checks real FSB and "see" by AI or by reading BIOS setting (Multi *9) that 10* isnt possible to generate ?

Share this post


Link to post
Share on other sites

@zef and others of Chameleon team

 

Please change framebuffer of HD5700 Series to

 

 

{ 0x100268B8, "Vervet"}, I have this HD5770 and got DUAL DVI.

{ 0x100268BE, "Vervet"}, I am guessing or it may be "Uakari."

 

 

Thank you for your work.

Share this post


Link to post
Share on other sites
EDIT: As reported in another topic, it works but with an old dsdt i was using, not with my last one. CPU recognized as Quad core Xeon as expected...

 

Solved the problem with the DSDT not working.

It was

Scope (_PR) section that need to be at the beginning of the dsdt not at line 300 like oit was in my dsdt.

 

I've not tried the modded mem detection from rek (nice to see you back again on this) because in 204 it's still not working for me.

 

My ram are 2x2GB TeamElite DDR2 800Mhz on the zotac gf9300 wifi itx

Share this post


Link to post
Share on other sites

Work Pefect.

CPU: T6400 with 3p-state and 4 c-state.

I have 5 SSDT and put it to Extra, use original CPU on DSDT. I have P-state and C-state.

I love u, Mozodojo.

Share this post


Link to post
Share on other sites
Just tried to use this on my system. The system reboots when it attempts to generate C-States P-States for my CPU.

My CPU is an intel Core i7 920. My motherboard is the EVGA X58 SLI.

 

Correction: Seems like it's doing it when it's generating P-States, not C-States..

 

Same here. Only difference is I have a i7 930 and the motherboard is a X58A-UD3R rev. 1.0.

Share this post


Link to post
Share on other sites

Latest version on SVN at time of post leads to "Memory allocation error", enabling memory detection on Abit IP35 Pro with 4x2 GB DDR2 Team Group.

ASERE 1.1.9, instead, detects it correctly as:

 

Bank0/1/A0:

 Dimensioni:    2 GB
 Tipo:    DDR2 SDRAM
 Velocità:    850 MHz
 Stato:    OK
 Produttore:    TeamElite
 Codice prodotto:    Xtreem-Dark-1066C6
 Numero di serie:    0x00000000

Bank2/3/A1:

 Dimensioni:    2 GB
 Tipo:    DDR2 SDRAM
 Velocità:    850 MHz
 Stato:    OK
 Produttore:    TeamElite
 Codice prodotto:    Xtreem-Dark-1066C6
 Numero di serie:    0x00000000

Bank4/5/A2:

 Dimensioni:    2 GB
 Tipo:    DDR2 SDRAM
 Velocità:    850 MHz
 Stato:    OK
 Produttore:    TeamElite
 Codice prodotto:    Xtreem-Dark-1066C6
 Numero di serie:    0x00000000

Bank6/7/A3:

 Dimensioni:    2 GB
 Tipo:    DDR2 SDRAM
 Velocità:    850 MHz
 Stato:    OK
 Produttore:    TeamElite
 Codice prodotto:    Xtreem-Dark-1066C6
 Numero di serie:    0x00000000

 

Keep up the good work.

 

Biciolino

Share this post


Link to post
Share on other sites

Great Chameleon RC5 project you have going on.

 

However, my Core i7 720QM Asus M60J laptop reboots too on rev198 from first post when trying to generate PStates or CStates. I have to boot with GeneratePStates=No and GenerateCStates=No

 

Once booted, memory detection is wrong. System profiler reports 800MHz DDR2 when it's 1333MHz DDR3.

 

Processor is also reported wrong. I have Core i7 720QM, but Core i5 is being reported. Curiously, Geekbench correctly reports Core i7.

Share this post


Link to post
Share on other sites

Memory detection with latest from SVN:

Memory Slots:

 ECC:	Disabled

Bank0/1/A0:

 Size:	Empty
 Type:	Empty
 Speed:	Empty
 Status:	Empty
 Manufacturer:	Empty
 Part Number:	Empty
 Serial Number:	Empty

Bank2/3/A1:

 Size:	2 GB
 Type:	DDR2 SDRAM
 Speed:	800 MHz
 Status:	OK
 Manufacturer:	N/A
 Part Number:	N/A
 Serial Number:	N/A

Bank4/5/A2:

 Size:	Empty
 Type:	Empty
 Speed:	Empty
 Status:	Empty
 Manufacturer:	Empty
 Part Number:	Empty
 Serial Number:	Empty

Bank6/7/A3:

 Size:	2 GB
 Type:	DDR2 SDRAM
 Speed:	800 MHz
 Status:	OK
 Manufacturer:	N/A
 Part Number:	N/A
 Serial Number:	N/A

 

Memory detection with Asere's booter:

Memory Slots:

 ECC:	Disabled

Bank0/1/A0:

 Size:	Empty
 Type:	Empty
 Speed:	Empty
 Status:	Empty
 Manufacturer:	Empty
 Part Number:	Empty
 Serial Number:	Empty

Bank2/3/A1:

 Size:	2 GB
 Type:	DDR2 SDRAM
 Speed:	1200 MHz
 Status:	OK
 Manufacturer:	G.SKILL
 Part Number:	F2-9600CL5-2GBTD
 Serial Number:	0x00000000

Bank4/5/A2:

 Size:	Empty
 Type:	Empty
 Speed:	Empty
 Status:	Empty
 Manufacturer:	Empty
 Part Number:	Empty
 Serial Number:	Empty

Bank6/7/A3:

 Size:	2 GB
 Type:	DDR2 SDRAM
 Speed:	1200 MHz
 Status:	OK
 Manufacturer:	G.SKILL
 Part Number:	F2-9600CL5-2GBTD
 Serial Number:	0x00000000

 

P- and C-states generation works fine.

Share this post


Link to post
Share on other sites
Memory detection with latest from SVN:

Memory Slots:

 ECC:	Disabled

Bank0/1/A0:

 Size:	Empty
 Type:	Empty
 Speed:	Empty
 Status:	Empty
 Manufacturer:	Empty
 Part Number:	Empty
 Serial Number:	Empty

Bank2/3/A1:

 Size:	2 GB
 Type:	DDR2 SDRAM
 Speed:	800 MHz
 Status:	OK
 Manufacturer:	N/A
 Part Number:	N/A
 Serial Number:	N/A

Bank4/5/A2:

 Size:	Empty
 Type:	Empty
 Speed:	Empty
 Status:	Empty
 Manufacturer:	Empty
 Part Number:	Empty
 Serial Number:	Empty

Bank6/7/A3:

 Size:	2 GB
 Type:	DDR2 SDRAM
 Speed:	800 MHz
 Status:	OK
 Manufacturer:	N/A
 Part Number:	N/A
 Serial Number:	N/A

 

Memory detection with Asere's booter:

Memory Slots:

 ECC:	Disabled

Bank0/1/A0:

 Size:	Empty
 Type:	Empty
 Speed:	Empty
 Status:	Empty
 Manufacturer:	Empty
 Part Number:	Empty
 Serial Number:	Empty

Bank2/3/A1:

 Size:	2 GB
 Type:	DDR2 SDRAM
 Speed:	1200 MHz
 Status:	OK
 Manufacturer:	G.SKILL
 Part Number:	F2-9600CL5-2GBTD
 Serial Number:	0x00000000

Bank4/5/A2:

 Size:	Empty
 Type:	Empty
 Speed:	Empty
 Status:	Empty
 Manufacturer:	Empty
 Part Number:	Empty
 Serial Number:	Empty

Bank6/7/A3:

 Size:	2 GB
 Type:	DDR2 SDRAM
 Speed:	1200 MHz
 Status:	OK
 Manufacturer:	G.SKILL
 Part Number:	F2-9600CL5-2GBTD
 Serial Number:	0x00000000

 

P- and C-states generation works fine.

 

Also for this i said to mozo that for me that code was not completely the same. I have the same result.

bye and thanks;)

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×