Jump to content

USB Hardware Problem With Snow Leopard

1 post in this topic

Recommended Posts

Hi everyone!


I ran an ideneb build of 10.5.8 on this system and it worked perfectly apart from the front USB ports not working and the optical drive not wanting to burn discs.


Now I've installed Snow Leopard using the iATKOS_S3 release of SL. Initially my firewire was not working so I removed the AppleHPET.kext and it woke up. OS is stable and no kernel panics so far! I've ran various applications such as Logic Pro and seems to be working nicely!


However... I have a Virus Ti which is a Hardware synthesizer and it communicates via USB. When I run the software/driver installation it trys to detect the Virus during the installation but fails to do so. Other USB devices such as Mouse, Keyboard and external HDDs work fine and the Virus Ti is detected in system profiler under the USB bus but the installer fails to detect it somehow.


I never had this issue with 10.5.8 Ideneb which is strange.


I have a feeling it may be to due one of the USB fixes I may of selected during the customization part of the Snow Leopard setup.


If anyone here knows of a possible fix it would be very much appreciated! Or if anyone knows whats the correct options / fixes to select during the installation of iATKOS_S3 that would be awsome!




I've reinstalled (without formatting) this time without selecting any USB fixes and used the EFI 10.6 bootloader. I had to remove the APPLEHPEC.kext for the firewire to work again obviously due to reinstalling the OS but the Virus is now detected and USB Working!!! :)

Link to comment
Share on other sites


  • Create New...