Jump to content
oldnapalm

DSDT editor and patcher

1,001 posts in this topic

Recommended Posts

You should ask MaLd0n, Auto-Patcher was maintained by him and it was his decision to take it off-line (as well as deleting the original topic). Since it's his work I won't publish it here without his permission.

 

The patches from latest version are available here.

Share this post


Link to post
Share on other sites
Advertisement

Hey MaLd0n, oSxFr33k was kind enough to help out with a few things, he also said that you might be able to help out create a DSDT file for my Asus G74SX-BBK7.

It'll be really cool if you could. Please!!

 

Just follow the link that oldnapalm posted above. DOwnload that entire zip file your Asus will be there. Then use the DSDT editor from here, the first post on this thread to patch your own virgin DSDT.

 

WHat is also tricky is you have to make sure you already have a virgin DSDT either by booting into a live linux CD or booting into Leopard/Snow/Lion without DSDT already loaded. That is the tricky part the rest is easy.

 

I have not seen a really good step step guide on how to do this. Maybe here and there but never an all inclusive with all the optional ways tutorial that I have ever seen yet.

 

You could get a virgin DSDT from someone who has the EXACT I mean EXACT laptop as yours Model for Model and Hardware for Hardware. Even the kind of memory and amount of memory can make some small differences.

 

Your last resort would be to grab it from where I told you before tonymac DSDT database and take your chances. I personally prefer the one MaLd0n prepared for me.

 

I am not near my laptop but I will PM you sometime this weekend and attach it but I would suggest you not use it. I have 16GB samsung memory in mine and mine is the XT1. The one from Best Buy or Tiger Direct (CompUSA) have a different graphic card and monitor.

 

@oldnapalm,

 

Is there a link to download all the patches in one Zip or RAR file?

 

Thanks

Share this post


Link to post
Share on other sites

hi oldnapalm

 

i want to do some work for my nvidia card optimus one

 

so to switch on or off the card i must copy some methods form ssdt of optimus table

rom , ps0 , ps3 , on , off

 

this my working dsdt DSDT.aml.zip

 

and this the ssdt table that i want to copy from it some methods that needed on switching card SSDT-4.aml.zip

 

and here i copied the five methods to the end of dsdt on alone scope to ignore some problems

DSDT.dsl.zip

but there are to errors while compiling about this two lines

 

    OperationRegion (BPCI, SystemMemory, EBAS (0x1000), Field (BPCI, ByteAcc, NoLock, Preserve)


    OperationRegion (BPC1, SystemMemory, EBAS (0x2000), Field (BPC1, ByteAcc, NoLock, Preserve)

 

can you please compile it for me :)

Share this post


Link to post
Share on other sites

I want to download all the patches as one big file rather than downloaded each individually. I would like to have them as reference or use if I ever get that hardware be able to have it conveniently tucked away for future referral rather than downloaded each when needed. WHo knows how long they will be available is the other reason.

Share this post


Link to post
Share on other sites

Hi

 

I'm a complete noob when it comes to DSDTs.

 

I've got an Acer 6930g which I can get to 10.6.7 and run nice and stable. But obviously that's not enough - I want Lion!

 

Now a very helpful chap called Marchrius (over at http://hackbookpro.altervista.org/en/) has managed to get Lion running with the wifi working and everything. The main turn off for me using mine with SL is I've always had to use a wifi dongle which is just a pain. I've got a Broadcom BCM94321 card apple branded so I know it's Airport capable. I've also installed a bluetooth module into my laptop.

 

Whenever I try to install Lion and get errors relating to either bluetooth or airport, so I'm sure this can be worked around with a DSDT.

 

My questions, simply, are these;

 

1. If I use this thread's DSDT editor/patcher in Mac OSX to make a DSDT, it has no affect on the errors I receive, would making a DSDT in Linux change this since both wifi and bluetooth work using Ubuntu?

2. How the hell do I use the Linux version (or even the windows one, doesn't matter)? I just get a folder with files in it and don't know what I need to do to turn it into a running program.

 

Any help would be appreciated and free e-beers gladly bought :D

Share this post


Link to post
Share on other sites

Hi All, I’m in desperate need of a kext or DSDT for my Toshiba Satellite hackintosh. I am dual booting Mac OS X Snow Leopard 10.6.7 and Windows 7. On the hackintosh, I have it all working except a few things. To be specific my laptop is the Satellite L755-S5214. I can get internet through the Ethernet, but not through my WIFI adapter. Also, I can’t get sound, or the graphics card to work. I used ###### and installed the kexts, but still a no go on those particular things. Is there somewhere online where I could go when I’m on the hackintosh, plugged in to the Ethernet cable and have it recognize my hardware and find the right drivers/kext for them to work? Or do I have to do it through a customer DSDT? Can anyone help me here!?!? Also, one other issue, I can boot only with the ###### disk. If I take it out, I get stuck at the white apple screen. Thanks in advance for any help!!

 

All of what I know about my system:

Toshiba Satellite L755-S5214

Intel i3-2310M

4 GB DDR3 Ram

Intel Graphics card 3000

Realtek RTL8188CE Lan Wireless Card

Share this post


Link to post
Share on other sites

Please guys, no "please do it for me" posts in this topic.

 

Post here only if you wanna do it yourself and need help, or if you have questions/suggestions about DSDT Editor.

Share this post


Link to post
Share on other sites

Please guys, no "please do it for me" posts in this topic.

 

Post here only if you wanna do it yourself and need help, or if you have questions/suggestions about DSDT Editor.

 

I sincerely hope my post wasn't misunderstood...I just want to know how to get the program working in Windows/Linux? I can't find an executable file that runs, just a load of different files. I'm sure it's something obvious but I'm afraid I don't have a clue! :|

Share this post


Link to post
Share on other sites

It doesn't matter which version you use, the result will be the same. What matters is the patching you do, not the OS where you are running the editor.

 

The multi-platform version has a .jar file, if you have Java installed, this file type should be associated with JRE.

Share this post


Link to post
Share on other sites

Hi there,

 

I installed OS 10.6 on an Advent 4213 netbook using NBI 0.84 RC1. I had problems upgrading to 10.6.8 mainly to do with the GMA950 IGP (see link). I was advised to patch the DSDT file.

 

I tried to manually add the GMA950 laptop patch with DSDTSE first, and I had 60+ errors. I'm trying now with DSDT editor under Windows. I used the auto-patch feature. When I compile the file the compiler shows 9 warnings and 1 error. Clicking on the 'Fix errors' button doesn't fix the error. Below is a list of the warnings and the error. What should I do to fix it?

 

Error message: Object does not exist (DGTP)

Warning 1: Not all control paths return a value (_DOD)

Warning 2: Reserved method must return a value (Package required for _DOD)

Warning 3 to 9: Possible operator timeout is ignored

Share this post


Link to post
Share on other sites

Apply the DTGP patch too.

Done

 

Thanks. I've applied all of the following patches:

 

GMA950_laptop

DTGP

RTC Fix

HPET Fix

New HPET

HDEF

PIC & TIMR devices (manual patch)

 

How do I know if this is enough or if I have to apply more patches?

Share this post


Link to post
Share on other sites

There is a serious bug with this app.

 

If you inadvertently misplace a { or } and close the dsl document before fixing it you are royally screwed!

It will discard all code after the } which closes the definition block. Why the hell would you discard any code if it's in dsl form.

 

Just lost 5 days work I am fn fuming right now!

 

Is the source code for this app available?

Share this post


Link to post
Share on other sites

Hi, can anyone edit my dsdt for me?

I'm sort of a half-noob at it...I tried before and didn't get too far...

My motherboard is the Asus Rampage III Formula

 

I have tried using the auto patcher and it worked but not too well.

The hpet edits didn't help and I still needed the nullcpupowermanagment kext

Also the audio fix didn't work when I installed the ALC8xx kext (at the time I didn't try a rollback to 10.6.2 though)

Sleep still needed a sleep enabler, I don't know if thats how it always is...but I think its from the fact that the hpet

edits didn't work and I wasn't using the applecpupowermanagment kext and instead I was using nullcpupowermanagment

kext which, as I heard, kills native sleep...

 

Anyway, Is anyone here skilled enough to do a correct edit that would fix most of my issues so I can use less kexts?

I know I'm asking for a lot...but it would mean a lot for us rampage iii formula users...

 

I need the cmos reset fix, the reboot/shutdown fix, hda fix, sleep, hpet, and any other fixes that this mobo might need...

The sound chipset is ALC889, The lan controller is an Intel controller so I always use a kext for that...

 

So if anyone is able to do this nice thing and patch the dsdt for my board I would really appreciate it.

If anyone is willing to try, I can post a non-edited dsdt from my board.

Thanks.

Share this post


Link to post
Share on other sites

Ok sorry guys, never mind what I asked...I don't need any help anymore lol...

 

I just sat down again and figured it all out...

I now have a perfect dsdt system with correctly patched hpet and hdef...and native sleep!

Thanks to everyone who put work into developing the patches and the patcher itself! ;)

Share this post


Link to post
Share on other sites

Hi,

Before shutdown fix patch, my board shut down 1 out 10 times approximately.

and after patch shut down works very well.

I patched my board with gigabyte shutdown fix,although my board is evga x58.

because no other patches worked.

But now my power and hard disk LED light of my case never turns off.

Is there any fix for this?

Thanks

Share this post


Link to post
Share on other sites

Hello all anyone could help me build my DSDT???

ask for the information you need

 

Mynotebook is

 

Hp Pavillon DV6 6169sl CPU i7-2670QM @ 2.20GHz - Bios F1B

Schede Video Intel HD 3000 e ATI Radeon HD 6770M

Audio IDT High Definition

Ethernet Realtek PCIe

Wi-Fi Broadcom 4313

Share this post


Link to post
Share on other sites

Hi

I'm having a few problems with my advent 4213. I'm runing Win7 and Mac OS X 10.6.8 on it. The issue I'm having is when using the battery all of the following are off: webcam, WiFi, 3G, and bluetooth. To make the battery last longer, I think, the BIOS is set to turn them off when the AC adapter is unpluged. In Win 7 all I have to do is to use the right combination of Fn+Function key to switched them back. In Mac OS Fn+Function key does not work. I current work arround is to boot into Win7, switch them on, restart and then boot into make OS.

 

I'm wondering can I get Mac OS to switch them OS by editing my DSDT table?

 

Also, SleepEnabler for 10.6.8 doesn't seem to work on this netbook. When I put the netbook to sleep, the screen switches off for 1 or 2 seconds and then the netbook wakes. It doesn't freeze.

What part of the DSDT table I need to modify?

 

I doubt that there are any patches for this netbook, so I've to patch it myself. I hope I can get the necessary guidance to do it.

 

Thanks

 

Edit:

I reverted to an older version of the BIOS and everything is okay now.

Share this post


Link to post
Share on other sites

Message to El Coniglio,

 

Could you please release the source code so I other ppl can improve on it,

There is a FREAKING annoying bug that erases code because of a misplaced {, } OR {/*.

 

No matter how careful I am it still happens even if you get an error free AML compile prior to saving.

Or if you can fix it it would be perfect.

When there is an extra { or } on save it will discard all code after the { or }.

When adding comments and you type it like this {/*it also discards code on save but in a weird way. 

If you put the /* on a different line then it's ok.

 

To recap, an extra { or } and comments like this {/*  discards codes on save or when you do an update tree.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By Haive_Music
      Hey guys,
       
      I'm really hoping someone has the experience and ability to help me iron out the last remaining issue on my build.  
       
      The motherboard is: Gigabyte Z370 Aorus Gaming 7 and I'm running a Alpine Ridge thunderbolt card (Revision 2).   I've gotten everything working for the most part with the exception of Thunderbolt hotplug.  This is the last piece of the puzzle.  I've tried so many different DSDT/SSDT's, cable plugged in, and unplugged, without any luck at all. 
      I've managed to get my Focusrite Clarett 8Pre Thunderbolt working and it's showing up under the PCI section.  It works great, until I shut the device off and turn it back on.  I'd really like to try to get this hotplug issue sorted out, but I've had absolutely no luck so far.
       
      I've managed to get the Alpine Ridge NHI and USB controllers showing up in the PCI section too, but for some reason, the USB lists a bunch of ',,,,,,,,' after the name. 
       
       
      I'll be the first to admit - I don't really know a whole lot about what I'm doing with this stuff, but I've attached relevant files in hopes someone more experienced and knowledable can help me get this working.  
       
      Thanks guys!
      config.plist
      DSDT.aml
      John’s iMac.iojones

      SSDT-TB3.aml
    • By neo_fox33
      DSDT patched for GA-Z97x-Gaming 3 V2 NVIDIA
       
      ACPI Specification 6.2a
    • By kylon
      ACPI and Clover config for Acer Aspire v5-571PG intel i5-U IvyBridge
       
       
      Not Working:
      - sd card reader
       
       
      Tested on High Sierra 10.13.6 and Clover EFI 4678
       
       
      Notes:
      Somehow boot Clover EFI.
      You may need to disable UEFI and boot Clover as Legacy with EmuVariable.
      After that, you should install and boot macOS to install clover as legacy in your EFI partition.
      Now disable Secure Boot and enable UEFI Mode. (remove EmuVariable)
      You may need more steps if you are dual-booting with Windows.
       
       
      **To reset your BIOS, power on the pc and hold the power button for about 30-40 seconds or you can short G2101 (RAM SLOT 1)**
       
       
      Feel free to ask for help.
       
      You will need:
      Clover install options: Install in EFI Partition, Install boot0af, Enable OsxAptioFixDrv-64 and script RC Latest Clover config (acerAspirev5-571PG - CCE Bank) from here ATH9KFixup (here) WhateverGreen (here) Rehabman AppleIntelBacklightInjector (here) in L\E + rebuild cache Rehabman Voodoo PS2 Controller (here) Rehabman ACPI Battery Driver (here) vit9696 AppleALC (here) + Lilu (here) Mieze Realtek RTL8111 (here)
    • By kylon
      A big thanks to wegface for teaching me a lot of things.
       
       
      Tested on High Sierra 10.13.6 and Clover EFI 4679
       
      Not Working:
      - realtek sd card reader (pm me if you have a fix)
       
      Notes:
      **CPU patches are disabled, if you are using a locked BIOS you must enable them**
       
      Clover EFI:
      - Install it in UEFI Mode and change your hdd partition table to GPT.
      - You will be able to install ANY OS in EFI mode, even if this pc does not support EFI at all! (No guide available for this)
       
      You will need:
      My unlocked BIOS (OPTIONAL) (here) Latest Clover config from CCE Bank (here) (asus k53sj-kylon) Rehabman AppleIntelBacklightInjector (here) in L\E + rebuild cache Rehabman Voodoo PS2 Controller (here) Rehabman ACPI Battery Driver (here) vit9696 AppleALC (here) + Lilu (here) Mieze Realtek RTL8111 (here) FakeSMC 3.5.1 from Clover EFI source
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://olarila.com/forum/viewtopic.php?f=81&t=6771     First... If you need DSDT edits for SkyLake, KabyLake or CoffeeLake... -Post your full Clover folder with original tables in Origin folder(Extract with F4 in Clover boot screen) -Post Ioreg, extract with Ioreg Explorer http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222606 -Run it, post files generated in your desktop http://www.insanelymac.com/forum/index.php?app=core&module=attach&section=attach&attach_id=222609  Installation   --Create a bootable copy of macOS Sierra Check out the link http://www.insanelymac.com/forum/files/file/559-flash-drive-maker/   --Create a bootable copy of macOS HighSierra Check out the link http://diskmakerx.com/   --Install Clover in USB stick https://sourceforge.net/projects/cloverefiboot/files/Installer/   --Replace with my Clover folder  CLOVER.zip   --Install Sierra/High Sierra and boot into system!   Post Installation   --Install Clover in HDD/SSD and replace with my folder CLOVER.zip   --Reboot and activate video!   -Nvidia WebDriver Sierra http://www.insanelymac.com/forum/topic/312525-nvidia-web-driver-updates-for-macos-sierra-update-07212017/ -Nvidia WebDriver High Sierra http://www.insanelymac.com/forum/topic/324195-nvidia-web-driver-updates-for-macos-high-sierra-update-10162017/ -Cuda http://www.insanelymac.com/forum/topic/302795-cuda-90214-is-out-update-10162017/   --DSDT My DSDT with Skylake patches DSDT.MaLd0n GA H110M-S2.zip Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI --FakeSMC https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek --Audio https://github.com/vit9696/AppleALC --USB https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads --LAN http://www.insanelymac.com/forum/topic/287161-new-driver-for-realtek-rtl8111/   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!   ENJOY!  
×