Jump to content
Sign in to follow this  
Followers 0
sk8er000

[Aiuto] Disattivare bluetooth dopo aggiornamento a 10.6.4

56 posts in this topic

Recommended Posts

Non so che pensare, a questo punto potrei provare a copiare l'intero file info.plist della 10.6.3 nel kext della 10.6.4 e sperare che funzioni...

comunque è un comportamento assai strano.Io ti proporrei, se hai un bel back up e zero dati importanti, di fare un bel formattone e ripartire da zero. Così, giusto per essere sicuri di aver tutto pulito!

Share this post


Link to post
Share on other sites
Advertisement
Non so che pensare, a questo punto potrei provare a copiare l'intero file info.plist della 10.6.3 nel kext della 10.6.4 e sperare che funzioni...

comunque è un comportamento assai strano.Io ti proporrei, se hai un bel back up e zero dati importanti, di fare un bel formattone e ripartire da zero. Così, giusto per essere sicuri di aver tutto pulito!

Ho pensato la stessa cosa e ho provato da un hd USB a rifare tutto ma il bt non funziona uguale (naturalmente il sistema da USB era lentissimo) ma almeno so che anche se lo faccio su quello interno non risolvo nulla...purtroppo ho visto che succede a molti che non funzioni il Bluetooth..quello che non mi spiego è quello strano boot l'unica cosa che avevo fatto ho cambiato batteria dato che ho quella originale a 4 celle più un'altra a 6..

Share this post


Link to post
Share on other sites

ho trovato cosa fa funzionare il bluetooth e non fa funzionare bene il mouse e fa fare casino all'audio per un po'!!

 

o meglio ho capito quando lo fa sistematicamente in entrambi gli hd sia quello nuovo che quello vecchio...

 

dopo lo sleep!!!

 

in pratica quando mando in sleep il pc dopo aver installato il kext della 10.6.3 in s/L/E con kexthelper quando dopo aver messo il pc in sleep e lo riaccendo ecco cosa succede:

il bluetooth si può disattivare

il track pad ogni tanto impazzisce e quando ad esempio uso la tastiera scomapre il puntatore

e l'audio fa questo suono ripetuto (non sempre)

 

questo sia nella vecchia installazione che in una pulita...

 

per il mose ho sostituito l'applePS2 con il Voodoops2 non so se c'entra però comunque resta il fatto che fino a che il pc non va in sleep il bt non si disativa e dopo si.... :construction: :construction:

 

spero quesa informazione possa aiutare

Share this post


Link to post
Share on other sites

ti dirò...il rumore (un beep random ogni tanto) LO FA ANCHE A ME.

Però, nella 10.6.3. quando mando in sleep non impazzisce nulla.A questo punto non so più che pensare.Tu hai provato a copiare il file info.plist del kext 10.6.3 nel kext della 10.6.4??

Share this post


Link to post
Share on other sites
ti dirò...il rumore (un beep random ogni tanto) LO FA ANCHE A ME.

Però, nella 10.6.3. quando mando in sleep non impazzisce nulla.A questo punto non so più che pensare.Tu hai provato a copiare il file info.plist del kext 10.6.3 nel kext della 10.6.4??

 

provato ma anche dopo lo sleep in quel modo non funziona...

 

il problema audio dipende dal kext del bluetooth e quello al mouse dal voodooPS2 che con l'ApplePS2 non lo da però reputo più importante gestire la luminosita che vedere il puntatore mentre scrivo!

 

provato ma anche dopo lo sleep in quel modo non funziona...

 

il problema audio dipende dal kext del bluetooth e quello al mouse dal voodooPS2 che con l'ApplePS2 non lo da però reputo più importante gestire la luminosita che vedere il puntatore mentre scrivo!

 

 

forse ho trovato una possibile soluzione ma non ne sono sicuro, non vorrei che fosse la stessa cosa che faceva cura..

 

solo che non sono capace a convertire gli id...

 

riporto il testo interessato, se non si può lo rimuovo subito!

 

This hack requires enough knowledge of Terminal.app, guys. Credits to tetany for the original hack. This guide, now, is for 10.6.x users running the excellent NBI from meklort. Note: In the BIOS settings (F2), Bluetooth should be ENABLED and USB Legacy Support DISABLED...

 

Open Terminal and type:

Code:

 

cd /System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/BroadcomUSBBluetoothHCIController.kext/Contents/

 

sudo cp -p Info.plist Info-backup.plist

 

sudo nano Info.plist

 

Inside the file, locate the entry:

 

<key>Broadcom2046FamilyUSBBluetoothHCIController_37A</key>

 

and further down, locate the vendor and product IDs:

 

<key>idProduct</key>

<integer>33301</integer>

<key>idVendor</key>

<integer>1452</integer>

 

You must replace the values in red with the ones from your device, found in System Profiler > USB > Bluetooth device info. Remember, you must convert (via Calculator in Programmer mode) your hex values to decimal. This is important.

 

So for my Broadcom BT device, Product ID is 688 (0x02b0) and Vendor ID is 16700 (0x413c). The values needed are of decimal type, don't forget. I replace the red ones with mine:

 

<key>idProduct</key>

<integer>688</integer>

<key>idVendor</key>

<integer>16700</integer>

 

then save Info.plist using Ctrl+O (then Enter) then Ctrl+X (then Enter) to exit once saved. You can check if you've properly entered the new IDs by comparing the files:

Code:

 

diff Info.plist Info-backup.plist

 

After that, type:

Code:

 

sudo touch /System/Library/Extensions

 

and close Terminal. You will wait a couple of minutes, until the system becomes idle (I can check via iStat Menus and my CPU load). Snow Leopard will rebuild the kext cache, and will include the new Info.plist we just modified.

 

Once the system is OK. do a reboot and check that you can enable/disable the Bluetooth device. During verbose boot you will notice that there's an extra report about AppleEFINVRAM was added to the Bluetooth device. That's it, it should be able to switch on/off.

 

Otherwise, if you haven't modified /Extra/ at all, run meklort's (from NBI installation) Update Extra.app and when done, reboot.

 

That's it, folks.

Share this post


Link to post
Share on other sites

Si, è praticamente quello che facevo io però fatto da terminale.

Al momento ho dei turni allucinanti a lavoro ed ho pochissimo tempo, ti mostro una via, secondo me, più semplice per fare la stessa cosa.

crei una copia (semplicemente trascinandolo sul desk) di IoBlutoothfamili.kext. A questo punto click destro sul kext, selezioni mostra contenuto pacchetto, ti si aprirà una cartella denominata contents, all'interno della cartella contents ce ne sono altre tre (più altri files) ma quella che ci interessa è plugins.

All'interno della cartella plugins troverai altri kext, devi aprire BroadcomUSBBlutoothchicontroller.kext con il medesimo procedimento di prima (cioè mostra contenuto pacchetto) e ti si aprirà un'altra cartella contents!!!

All'interno di questa seconda cartella contents c'è un file denominato info.plist ed è esattamente il file che vogliamo modificare per far funzionare (o almeno provarci) il bluetooth.

aprendolo dovrai trovare la voce indicata nella guida che hai messo in quote ed inserire gli ID corretti.

Controlla in system profiler che non siano già buoni (se gli hex sono gli stessi del tipo della guida siamo a cavallo,controlla che quelli tra parentesi corrispondano:

Product ID is 688 (0x02b0) and Vendor ID is 16700 (0x413c).

Non dovessero corrispondere puoi usare osx86tools per convertire i tuoi hex in decimali.

Una volta modificato il file info.plist elimini il vecchio kext e lo rimpiazzi con la versione nuova, ricostruisci la cache con il programma che non ricordo come si chiama ma che ha l'icona di una scarpa da tennis e riavvii dopo aver riparato i permessi. Incrociando le dita questa è la strada.

Spero di essere stato chiaro,adesso vado a letto oppure crollo sulla tastiera!Buon hacking, fammi sapere se ne cavi qualcosa!

Share this post


Link to post
Share on other sites
Si, è praticamente quello che facevo io però fatto da terminale.

Al momento ho dei turni allucinanti a lavoro ed ho pochissimo tempo, ti mostro una via, secondo me, più semplice per fare la stessa cosa.

crei una copia (semplicemente trascinandolo sul desk) di IoBlutoothfamili.kext. A questo punto click destro sul kext, selezioni mostra contenuto pacchetto, ti si aprirà una cartella denominata contents, all'interno della cartella contents ce ne sono altre tre (più altri files) ma quella che ci interessa è plugins.

All'interno della cartella plugins troverai altri kext, devi aprire BroadcomUSBBlutoothchicontroller.kext con il medesimo procedimento di prima (cioè mostra contenuto pacchetto) e ti si aprirà un'altra cartella contents!!!

All'interno di questa seconda cartella contents c'è un file denominato info.plist ed è esattamente il file che vogliamo modificare per far funzionare (o almeno provarci) il bluetooth.

aprendolo dovrai trovare la voce indicata nella guida che hai messo in quote ed inserire gli ID corretti.

Controlla in system profiler che non siano già buoni (se gli hex sono gli stessi del tipo della guida siamo a cavallo,controlla che quelli tra parentesi corrispondano:

Non dovessero corrispondere puoi usare osx86tools per convertire i tuoi hex in decimali.

Una volta modificato il file info.plist elimini il vecchio kext e lo rimpiazzi con la versione nuova, ricostruisci la cache con il programma che non ricordo come si chiama ma che ha l'icona di una scarpa da tennis e riavvii dopo aver riparato i permessi. Incrociando le dita questa è la strada.

Spero di essere stato chiaro,adesso vado a letto oppure crollo sulla tastiera!Buon hacking, fammi sapere se ne cavi qualcosa!

ok perfetto grazie ero arrivato anche io fino all'info plist ma non sapevo come convertire gli ID cerco di provare in giornata e farti risapere, intanto grazie!!

Share this post


Link to post
Share on other sites

ci sono aggiornamenti, ma non buone notizie...

 

allora ecco i risultsti della procedura:

 

kext che era nella 10.6.3:

 

modificando gli id si attiva l'opzione on/off ma il bluetooth passa solo da off a on ma non viceversa...

 

kext per la 10.6.4:

 

non funziona nemmeno con gli id modificati..

 

 

a questo punto non ho idea di come risolvere questa cosa, però almeno un passo avanti lo abbiamo fatto!

 

P.S.

 

Adesso nemmeno dopo lo standby si ridisattiva più il bluetooth

Share this post


Link to post
Share on other sites

ciao ragazzi è un piacere leggervi

sono un felice possessore di hackintosh desktop

e leggendo i vs post vedo che avete installato sul netbook n310 che ho appena ritirato dalla wind

 

qualche consiglio per l'installazione? meglio la retail? ci sono da fare modifiche

Share this post


Link to post
Share on other sites
ciao ragazzi è un piacere leggervi

sono un felice possessore di hackintosh desktop

e leggendo i vs post vedo che avete installato sul netbook n310 che ho appena ritirato dalla wind

 

qualche consiglio per l'installazione? meglio la retail? ci sono da fare modifiche

 

Trovi tutto ciò che ti occorre qua.

Share this post


Link to post
Share on other sites
ci sono aggiornamenti, ma non buone notizie...

 

allora ecco i risultsti della procedura:

 

kext che era nella 10.6.3:

 

modificando gli id si attiva l'opzione on/off ma il bluetooth passa solo da off a on ma non viceversa...

 

kext per la 10.6.4:

 

non funziona nemmeno con gli id modificati..

 

 

a questo punto non ho idea di come risolvere questa cosa, però almeno un passo avanti lo abbiamo fatto!

 

P.S.

 

Adesso nemmeno dopo lo standby si ridisattiva più il bluetooth

 

cavolo, ci avevo sperato.

però con il kext che era per la 10.6.3 lo si può tenere perennemente spento e attivarlo solo in caso di effettiva necessità il che è già un notevole passo avanti.

Lunedì sono di festa e proverò ad aggiornare a 10.6.4 così inizio a lavorarci nei ritagli di tempo (fino a settembre sono schiavo ;) maledetta stagione estiva ;) )

Share this post


Link to post
Share on other sites

purtoppo usando poco il ho nontato un ulteriore problema solo ora ma ve lo comunico:

 

adesso dopo aver modificato gli id del kext iobluetoothfamily per il 10.6.3 anche se lo cancello da generalextensions riparo i permessi e ne reinstallo uno senza gli id cambiati, l'icona del bluetooth continua a darmi l'opzione disattiva ma non si disattiva affato, inoltre ho notato che ora il bluetotth NON FUNZIONA, mi spiego meglio, quando il bluetotth è attivo viene rivelato dagli altri devices ma non riceve ne invia files e inoltre quando si prova a fare una scanzione dei dispositivi bluetooth attivi non è in grado di farla...

 

a questo punto non so più dove sbattere la testa..sono costretto a tenerlo disinstallato.. :(:D

Share this post


Link to post
Share on other sites
purtoppo usando poco il ho nontato un ulteriore problema solo ora ma ve lo comunico:

 

adesso dopo aver modificato gli id del kext iobluetoothfamily per il 10.6.3 anche se lo cancello da generalextensions riparo i permessi e ne reinstallo uno senza gli id cambiati, l'icona del bluetooth continua a darmi l'opzione disattiva ma non si disattiva affato, inoltre ho notato che ora il bluetotth NON FUNZIONA, mi spiego meglio, quando il bluetotth è attivo viene rivelato dagli altri devices ma non riceve ne invia files e inoltre quando si prova a fare una scanzione dei dispositivi bluetooth attivi non è in grado di farla...

 

a questo punto non so più dove sbattere la testa..sono costretto a tenerlo disinstallato.. :thanks_speechbubble::wacko:

 

abbastanza sconcertante.

tra l'altro io ancora non ho avuto tempo di aggiornare a 10.6.4

però è strano che utilizzando il vecchio kext non funzioni più. Veramente strano.

Share this post


Link to post
Share on other sites
abbastanza sconcertante.

 

Scusate l'intrusione. Complice una fastidiosa influenza fuori stagione che mi ha svegliato in piena notte, ho provato a seguire la procedura indicata da cura: ho copiato IObluetoothfamily.kext per 10.6.4, ho modificato il file Info.plist secondo istruzioni e ho installato con Kexthelper, poi ho riparato i permessi e rigenerato la cache delle estensioni con KextUtility perché non avevo proprio voglia di fare tutto da terminale. visto che gli occhi lacrimano abbondantemente.

Risultato: il bluetooth finalmente si disattiva, e naturalmente si riattiva, anche dopo aver mandato il netbook in sleep.

A proposito: ho lavorato su un Asus eeepc 1005ha con SL 10.6.4.

 

Leggendo i vostri post mi è venuto un dubbio, probabilmente infondato, ma ve lo dico lo stesso. Non è che per caso i codici esadecimali del prodotto e del fornitore sono sbagliati?

Intendiamoci, non sto facendo illazioni sulle vostre capacità, ma a volte è una banale distrazione a compromettere il risultato.

Nel dettaglio: avete per caso ricavato i codici dalla colonna che si apre in "preferenze di sistema" cliccando sulla voce Bluetooth? Se fosse così ecco scoperto l'inghippo.

;)

La procedura corretta è: attivare il bt da bios, aprire syspref e portare il puntatore sulla voce USB, dalla colonna destra in alto selezionare il BT e in basso compariranno i dati, tra cui id prodotto e id fornitore (e non "produttore", come invece si legge selezionando a sx la voce Bluetooth) basta convertirli in decimali e seguire la procedura.

Mi rendo conto che la cosa è banale e probabilmente lo avete già fatto, ma siccome anch'io inizialmente ho fatto lo stesso errore ho creduto opportuno raccontare la mia esperienza, sperando possa tornare utile a qualcuno.

Share this post


Link to post
Share on other sites

quoto quanto detto da k31, ho aggiornato a 10.6.4 ed editato finalmente con la conversione in decimali corretta (questo discorso di id vendor e id fornitore è veramente una mezza trappola, state molto attenti!sono due cose diverse) eseguita tramite un sito on line (lo linkerò se qualcuno lo necessita) il file info.plist e...magia, il bluetooth funziona alla perfezione.

se sk8er000 è ancora dei nostri lo comunico, cdon 10.6.4 va a meraviglia ;)

Share this post


Link to post
Share on other sites
quoto quanto detto da k31, ho aggiornato a 10.6.4 ed editato finalmente con la conversione in decimali corretta (questo discorso di id vendor e id fornitore è veramente una mezza trappola, state molto attenti!sono due cose diverse) eseguita tramite un sito on line (lo linkerò se qualcuno lo necessita) il file info.plist e...magia, il bluetooth funziona alla perfezione.

se sk8er000 è ancora dei nostri lo comunico, cdon 10.6.4 va a meraviglia :D

 

Certo che sono ancora dei vostri! anche se purtroppo avevo abbandonato le prove! appena posti l'info.plist lo confronto magai ho sbagliato io, ora che so che a voi funziona al massimo reinstallo tutto fino a che non parte!!

Share this post


Link to post
Share on other sites
Certo che sono ancora dei vostri! anche se purtroppo avevo abbandonato le prove! appena posti l'info.plist lo confronto magai ho sbagliato io, ora che so che a voi funziona al massimo reinstallo tutto fino a che non parte!!

questo è il kext con il mio id fornitore!

eventualmente, per reinstallare tutto aspetta domani!posterò una guida completa con aggiornamento a 10.6.4 e tutto il necessairer!

Share this post


Link to post
Share on other sites
questo è il kext con il mio id fornitore!

eventualmente, per reinstallare tutto aspetta domani!posterò una guida completa con aggiornamento a 10.6.4 e tutto il necessairer!

 

 

purtroppo non riesco a scaricare il kext, mi apre una pagina vuota il link :wacko:

Share this post


Link to post
Share on other sites
purtroppo non riesco a scaricare il kext, mi apre una pagina vuota il link :hysterical:

 

a me lo apre ma dice decompressione fallita °_°

provo a ricaricarlo stasera °_°

Share this post


Link to post
Share on other sites

scusa potresti ripostare il file?

 

in questo mese ho provato un po' di volte sia a scaricare sia a risolvere ma niente, allora prima di formattare volevo fare un ultimo tentativo!

 

 

grazie!!

Share this post


Link to post
Share on other sites
scusa potresti ripostare il file?

 

in questo mese ho provato un po' di volte sia a scaricare sia a risolvere ma niente, allora prima di formattare volevo fare un ultimo tentativo!

 

 

grazie!!

 

ciao sk8er!!! senti, la cosa in realtà è piuttosto semplice, in realtà sbagliavamo id da usare.

allora, io potrei anche postare il mio kext ma non è detto che funzioni sul tuo perché potrebbe cambiare l'id del device.

Molto più semplice è inserirlo di proprio pugno dopo averlo convertito con un hex to decimal converter (se ne trovano tantissimi on line).

Ad esempio, è risultato che il mio id produttore fosse 0x2151 (hex) che ho convertito in decimale ed è uscito: 8529

tramite la procedura che ti spiegai a inizio post ho inserito questo codice nel kext et voilà, il gioco è fatto, più semplice a farsi che a dirsi :)

fammi sapere se hai difficoltà ti aiuto volentieri, lo sai!

 

edit:

 

per quanto riguarda l'id da convertire non è quella alla voce bluetooth ma quella alla voce usb. sotto periferiche usb troverai anche il bluetooth (ovviamente in system profiler) l'id da covertire è l'id prodotto che vedi alla voce usb (diverso da quello che vedresti da bluetooth ma non so perchè).

Share this post


Link to post
Share on other sites
ciao sk8er!!! senti, la cosa in realtà è piuttosto semplice, in realtà sbagliavamo id da usare.

allora, io potrei anche postare il mio kext ma non è detto che funzioni sul tuo perché potrebbe cambiare l'id del device.

Molto più semplice è inserirlo di proprio pugno dopo averlo convertito con un hex to decimal converter (se ne trovano tantissimi on line).

Ad esempio, è risultato che il mio id produttore fosse 0x2151 (hex) che ho convertito in decimale ed è uscito: 8529

tramite la procedura che ti spiegai a inizio post ho inserito questo codice nel kext et voilà, il gioco è fatto, più semplice a farsi che a dirsi :)

fammi sapere se hai difficoltà ti aiuto volentieri, lo sai!

 

edit:

 

per quanto riguarda l'id da convertire non è quella alla voce bluetooth ma quella alla voce usb. sotto periferiche usb troverai anche il bluetooth (ovviamente in system profiler) l'id da covertire è l'id prodotto che vedi alla voce usb (diverso da quello che vedresti da bluetooth ma non so perchè).

 

due domande velocissime:

 

bisogna convertire entrambi gli id (prodotto e produttore)?

 

il kext lo hai messo su s/l/e o su general extensions?

 

grazie ancora

 

P.S

è un paradosso riuscire a farlo funzionare alla vigilia del 10.6.5 alcuni rumors danno per oggi il rilascio..

Share this post


Link to post
Share on other sites
due domande velocissime:

 

bisogna convertire entrambi gli id (prodotto e produttore)?

 

il kext lo hai messo su s/l/e o su general extensions?

 

grazie ancora

 

P.S

è un paradosso riuscire a farlo funzionare alla vigilia del 10.6.5 alcuni rumors danno per oggi il rilascio..

 

credo che possa funzionare anche su 10.6.5 :) Ho convertito solo il product id ed io personalmente lo uso in general extension.

Senti, volevo farti una domanda un pochettino ot. Tu hai aggiornato tramite netbookinstaller etc no? Hai avuto problemi con l'icona della batteria e lo sleep?

Share this post


Link to post
Share on other sites
credo che possa funzionare anche su 10.6.5 :) Ho convertito solo il product id ed io personalmente lo uso in general extension.

Senti, volevo farti una domanda un pochettino ot. Tu hai aggiornato tramite netbookinstaller etc no? Hai avuto problemi con l'icona della batteria e lo sleep?

 

sì lo ho aggiornato prima di mettere la 10.6.4, l'icona della batteria non mi da problemi, l'unico difetto dello speep e che quando riaccendo il pc parte un rumore dalle casse, ma come premo un tasto qualunque della tastiera torna tutto a posto..

 

ho letto comunque che ne uscirà un altro tra un po' di tempo!

 

ho corretto gli id e il bluetooth continua a non funzionare...comunque ho visto che sono gli stessi tuoi id che hai postato nel post internazionale...ora provo ad aggiornare alla 10.6.5 così se va in kernel panic reinstallo tutto...

ho già aggiornato il mediacenter in firma e come risultato non mi vede più il dongle usb bluetooth, in questo caso però nemmeno su informazioni di sistema..anche lì non ho idea di come fare..sono proprio sfortunato con questo dannato bluetooth!!

Share this post


Link to post
Share on other sites

dopo un aggiornamento alla 10.6.5 sono riuscito a mettere a posto la maggior parte delle cose, ora il bluetooth funziona di nuovo (orima nemmeno quello), però di disattivarlo nemmeno l'ombra ho provatonei seguenti modi tutti su general extension:

 

-kext che funzionava su 10.6.3

-modificando l'id prodotto mettendo convertito quello sotto la voce usb

-modificando l'id prodotto mettendo convertito quello sotto la voce bluetooth

-modificando entrambi gli id mettendo quelli convertiti sotto la voce usb

-modificando entrambi gli id mettendo quelli convertiti sotto la voce bluetooth

 

naturalmente dopo ogni modifica ho eseguito update extra

 

ma il risultato è sempre stato lo stesso non compare nemmeno la voce disabilita..

 

in compenso conla 10.6.5 mi sebra più veloce il sistema soprattutto nell'avvio..

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×