Jump to content
Mammoth

[Guide] HP DV8, DV7, DV6, & DV5, 10.6.4 Easy, Comprehensive Installation

v2.00 Installation, Update, and Mammoth Installation media  

141 members have voted

  1. 1. Is v2.00 something you are interested in and would use?

    • Yes
      139
    • No
      2
  2. 2. Which are you most interested in?

    • v2.00 Installation Guides
      95
    • v2.00 Post-installation Update Guide
      46

1,266 posts in this topic

Recommended Posts

Hi All,

 

I am getting the following kernel panic when booting up the install USB of SL.

 

post-201072-1297288087_thumb.jpg

 

I hope somebody can help me boot the install USB of SL.

 

Thanks.

 

NSCXP2005

Share this post


Link to post
Share on other sites
Advertisement
Hi All,

 

I am getting the following kernel panic when booting up the install USB of SL.

 

post-201072-1297288087_thumb.jpg

 

I hope somebody can help me boot the install USB of SL.

 

Thanks.

 

NSCXP2005

 

Try it 3 times in succession. See if it boots by the 3rd time or not. I know that might sound weird, but we need to try that first.

Share this post


Link to post
Share on other sites

Hi Mammoth,

 

Wonderful. Greatly appreciate your hard work and that of others.

 

I'm back. I have been closely monitoring this thread and wanted to do the v1.20 or v2.0 over the weekend.

 

Couple of questions:

 

1. Mine is a dv8t-1200 (as you know already). I wanted to install from scratch. Is there a v1.2 or v2.0 available now and if so, which one to pick? I already have Mac OS X 10.6.4 Snow Leopard DVD. Do I need to have the latest full version of Mac OS X to begin with?

2. I already have a USB Wifi Card from Airlink 101. But, it seems to be running slow on Windows 7. I would also like to patch the BIOS to remove the Intel Wifi card restriction. What is the best approach for that and which thread has the exact info I need? Because, if I screw up the BIOS hack, my dv8t would turn into a brick :D

3. I also wanted to have Windows 7 (dual partition) on the same hard drive. Do I need to install Mac OS X first and then Windows 7?

4. Is everything working (Intel speedstep, thermal control, fan, noise, fn keys, Media smart buttons, SD card slot, HDMI, firewire, eSATA, webcam, built in mic etc)?

5. Remember, the popping sound we had? Is it fixed now?

 

Btw, I have been watching this - the keys on the keyboard are slowly fading. I checked up on other HP forums and they have suggested me to call HP to get a replacement keyboard (HDX 18) that also has backlit built in. Do you also have this problem?

 

Sorry for the long list of questions as I'm kind of out of touch for a while now :P but I'm always glad that we both worked together on lot of the issues we discovered early on.

 

Thanks.

 

MacMan50

Share this post


Link to post
Share on other sites
Hi Mammoth,

 

Wonderful. Greatly appreciate your hard work and that of others.

 

I'm back. I have been closely monitoring this thread and wanted to do the v1.20 or v2.0 over the weekend.

 

Couple of questions:

 

1. Mine is a dv8t-1200 (as you know already). I wanted to install from scratch. Is there a v1.2 or v2.0 available now and if so, which one to pick? I already have Mac OS X 10.6.4 Snow Leopard DVD. Do I need to have the latest full version of Mac OS X to begin with?

2. I already have a USB Wifi Card from Airlink 101. But, it seems to be running slow on Windows 7. I would also like to patch the BIOS to remove the Intel Wifi card restriction. What is the best approach for that and which thread has the exact info I need? Because, if I screw up the BIOS hack, my dv8t would turn into a brick :)

3. I also wanted to have Windows 7 (dual partition) on the same hard drive. Do I need to install Mac OS X first and then Windows 7?

4. Is everything working (Intel speedstep, thermal control, fan, noise, fn keys, Media smart buttons, SD card slot, HDMI, firewire, eSATA, webcam, built in mic etc)?

5. Remember, the popping sound we had? Is it fixed now?

 

Btw, I have been watching this - the keys on the keyboard are slowly fading. I checked up on other HP forums and they have suggested me to call HP to get a replacement keyboard (HDX 18) that also has backlit built in. Do you also have this problem?

 

Sorry for the long list of questions as I'm kind of out of touch for a while now :) but I'm always glad that we both worked together on lot of the issues we discovered early on.

 

Thanks.

 

MacMan50

 

THE RETURN OF MAC MAN 50!!!!!!

 

Great to see you back!

 

1) I think the only retail version available it 10.6.3. The 10.6.4 you have is probably a "restore" disc for an actual Mac, and none of those will work on any Hac. So you have to have retail 10.6.3. I am working on v2.00 (did more work on it today and will do more tomorrow). So it's not ready yet, but getting close. You CAN (and should) get the Getting Ready Guide I just released and start with that. It's on the 1st post page.

 

2) We have just had recent posts all about Wi-Fi and patching. Read the two most recent pages and you will find all the info. ; )

 

3) The two best ways are either, 1) to have Win 7 already installed, then use Win7 Disk Manager to resize Win7 to allow for OS X to be installed. 2) Make an image of Win7, blow it all away, install OS X, then restore Win7.

 

4) Most everything is working now accept some Fn and media keys, and only card readers that are USB based (ours are PCI, so no. Someone has to make drivers).

 

5) Yeah, that stuppied popping sound is a real bother to me. No, it's not fixed unless we set our machines to be 3,1, which is NOT our machine. That is something we still need to solve, but many people with Hacs have that issue.

 

6) I hadn't noticed about the keys fading, but I just looked and it does look like some of them are showing signs of wear already. Freaking HP! I don't know if the back-lit keyboards will work on our machines, but would get one if they did.

 

Yes, you were a tremendous help from the beginning, so it's great to see you back! 8 )

 

v2.00 is almost ready, and it's a HUGE leap forward to what most are using now. I am very eager to get it finished and released! :P

Share this post


Link to post
Share on other sites
THE RETURN OF MAC MAN 50!!!!!!

 

Great to see you back!

 

1) I think the only retail version available it 10.6.3. The 10.6.4 you have is probably a "restore" disc for an actual Mac, and none of those will work on any Hac. So you have to have retail 10.6.3. I am working on v2.00 (did more work on it today and will do more tomorrow). So it's not ready yet, but getting close. You CAN (and should) get the Getting Ready Guide I just released and start with that. It's on the 1st post page.

 

2) We have just had recent posts all about Wi-Fi and patching. Read the two most recent pages and you will find all the info. ; )

 

3) The two best ways are either, 1) to have Win 7 already installed, then use Win7 Disk Manager to resize Win7 to allow for OS X to be installed. 2) Make an image of Win7, blow it all away, install OS X, then restore Win7.

 

4) Most everything is working now accept some Fn and media keys, and only card readers that are USB based (ours are PCI, so no. Someone has to make drivers).

 

5) Yeah, that stuppied popping sound is a real bother to me. No, it's not fixed unless we set our machines to be 3,1, which is NOT our machine. That is something we still need to solve, but many people with Hacs have that issue.

 

6) I hadn't noticed about the keys fading, but I just looked and it does look like some of them are showing signs of wear already. Freaking HP! I don't know if the back-lit keyboards will work on our machines, but would get one if they did.

 

Yes, you were a tremendous help from the beginning, so it's great to see you back! 8 )

 

v2.00 is almost ready, and it's a HUGE leap forward to what most are using now. I am very eager to get it finished and released! :P

 

Hi Mammoth would love to join forces with your team and improve what can be done here? I have a big background in IT, technical hardware and software aspect, Linux, MacoSX, Windows. MS-DOS > Terminal :D I'm good with creating custom AppleHDA's.

Share this post


Link to post
Share on other sites
Hi Mammoth would love to join forces with your team and improve what can be done here? I have a big background in IT, technical hardware and software aspect, Linux, MacoSX, Windows. MS-DOS > Terminal :D I'm good with creating custom AppleHDA's.

 

 

 

That sounds great!

 

Speaking of AppleHDA, we have been trying to figure out how to solve the "popping sound" we have in audio, but to my knowledge, no one has yet. It seems to be possibly related to power saving (the audio card being turned on and off). There are a few system types that for some reason are not susceptible to this, one being 3,1. Our systems are closest to 6,2 though, but has popping. I read somewhere once that it was thought there was another audio related file/kext that needed to be modified, and that would maybe solve it.

 

If someone could figure that out, they would be a hero to many of the scene.

 

: )

Share this post


Link to post
Share on other sites

Mommoth,

 

I can not tell you how much your work and everyone on this forum has help me understand the process and problems that I have run in trying to install OSX on my HP DV8T.

 

You are the greatest and I eagerly await your 2.0 guide.

 

Thank you very much.

Share this post


Link to post
Share on other sites

Hi Mammoth,

 

I have tried the boot USB 3 times in succession but, it still comes up with the same error.

 

Do you know any other way to get it to boot.

 

All the best,

 

NSCXP2005

Share this post


Link to post
Share on other sites
Hi Mammoth,

 

I have tried the boot USB 3 times in succession but, it still comes up with the same error.

 

Do you know any other way to get it to boot.

 

All the best,

 

NSCXP2005

 

Ok, first if you could list your specs in your sig that would help me to help you faster.

 

Try booting with the DSDT disabled (by renaming it) and see if you can boot then. Is your BIOS "InSyde"?

 

Mommoth,

 

I can not tell you how much your work and everyone on this forum has help me understand the process and problems that I have run in trying to install OSX on my HP DV8T.

 

You are the greatest and I eagerly await your 2.0 guide.

 

Thank you very much.

 

Thank you BaneFire!

 

Your comments are much appreciated as that's the only pay I get for doing all of this (well, that and all the other fine people who help me an contribute. :)

 

I'm working on v2.00 right now. :D

Share this post


Link to post
Share on other sites

Hey just wanted to give everyone a quick update on the progress of v2.00.

 

I was able to do a lot of work on it today and I'm pleased to tell you that I have the core installation steps down to LESS than 2 pages! It's amazing. That's from a bare hard drive to a booting hard drive with Chameleon and OS X installed in less than 2 pages!

 

Oh, yeah; I just timed the install duration of the OS X installer installing files from the USB device: 16 minutes!

 

So things are going VERY well, and I expect to be able to announce a projected release date soon.

 

:wub:

Share this post


Link to post
Share on other sites
Hey just wanted to give everyone a quick update on the progress of v2.00.

 

I was able to do a lot of work on it today and I'm pleased to tell you that I have the core installation steps down to LESS than 2 pages! It's amazing. That's from a bare hard drive to a booting hard drive with Chameleon and OS X installed in less than 2 pages!

 

Oh, yeah; I just timed the install duration of the OS X installer installing files from the USB device: 16 minutes!

 

So things are going VERY well, and I expect to be able to announce a projected release date soon.

 

:)

That is awsome progress Mammoth. I am sitting on the edge of my seat waiting for your release.

Share this post


Link to post
Share on other sites

Hi Mammoth,

 

I have added my HP Pavillion Dv6000 to my Signature.

 

The times I booted it up 3 times was with the DSDT renamed and it still does not boot into the SL Installer.

 

Any advise how to get it working?

Share this post


Link to post
Share on other sites
Hi Mammoth,

 

I have added my HP Pavillion Dv6000 to my Signature.

 

The times I booted it up 3 times was with the DSDT renamed and it still does not boot into the SL Installer.

 

Any advise how to get it working?

 

Ok, I want to figure this out (and must so it will work for others). I will get back to you as I have some things I must do today and won't even be home. Hang in there.

Share this post


Link to post
Share on other sites
Ok, I want to figure this out (and must so it will work for others). I will get back to you as I have some things I must do today and won't even be home. Hang in there.

 

I have some problems in my dv8 :

 

1) when i put it into sleep, it happens (expecially after hibernation) that usb ports are not working any more after awaking from sleep/hibernation and sometimes dvd too doesn't work. I have to reboot.

 

2) now battery is way better using glsy latest acpibattery kext, but it doesn't go automatically to sleep when battery is low (KWS script doesn't work too here, it continously sleep and awake itself until the battery is off, with the high risk to damage the hd, since it happened many times battery goes off while writing hibernate file into hd)

 

3) power management doesn't work as should, machine doesn't go to sleep automatically after having set the sleep-time in pm options under sysprefs

 

Mal

 

----

DV8-1100t, i7 720qm, 8 gb ram ddr3-1333, 2x500GB 7200 seagate hds,geforce 230M 1GB,latest bios

Share this post


Link to post
Share on other sites
I have some problems in my dv8 :

----

DV8-1100t, i7 720qm, 8 gb ram ddr3-1333, 2x500GB 7200 seagate hds,geforce 230M 1GB,latest bios

Are you using a DSDT with my latest auto-patcher applied?

Share this post


Link to post
Share on other sites

How's the project coming along? Unfortunately, I deleted an iocph kext and now my rig won't boot so I think I have to start all over. It KPs with an ACPI driver instantly on boot so I thought I would give Mammoth's tut a try.

Share this post


Link to post
Share on other sites

Hello everyone,

 

Time for a quick update on the status of v2.00 Guides & Files:

 

- The installation process is solid. As always, you can't get to everything you set out to get, but there comes a point where you have to say, "that's enough for this round". Things that I can't finish we will have to finish together after the release, otherwise I will be working on it forever!

 

- The Guides, the guides, the guides! That's what I'm mainly working on now. About 85% of the original guides have been completely re-written, with about 15% of the originals still being relevant and included. I have a lot of additional information to impart to you all, including all the new features, plus rearranging and reorganizing all of the guides.

 

- Compatibility. I mentioned the installation process as being "solid", and it is, for my machine. Once I get the new guides done enough (as they are the hardest, most time consuming part of the project), I will switch gears back to having some BETA testers try some things out on their machines. If the guides are nearly done, then once the BETA testing PASSES, then I will be able to release shortly after that.

 

- There are a few other things I would still like to spend a little more time on to see if I can get them working, but if not, like I said, we will just have to work on those together.

 

So I am going to put a ROUGH ESTIMATE of SOMEWHERE around March 1st as a POSSIBLE release window. If things go fairly smoothly, and I am able to take time and continue to work on this, then that estimate becomes possible, but NOT guaranteed. I don't want to get people's hopes up, and then let you down. I'm just trying to give you an idea of how much work I have left to do, and how long it should take to finish it.

 

That's it. Try to keep your questions to a minimum, as answering questions and working on side issues takes time away from the big project.

 

This release is for all of you, so hang tight 'til it's worthy of release!

Share this post


Link to post
Share on other sites

First, Thanks to all of you for the great help.

 

I will be trying the v2.00 Guide on my laptop. I have just installed an extra disk, and I have already made a backup of windows 7.

 

I have also a G4 Mac with Tiger and about this, just one thing: when tryin to prepare the "Mammoth DVxt Boot USB - v1.15a" on the G4, I had errors because the fdisk440 has some reference which dosn´t work on Tiger os. When the 2.0 guide is ready I will have to go to a friend´s with a Mac Book wih SL to make it.

Share this post


Link to post
Share on other sites

Is there a way to copy the IOPCIFamily.kext off of the Snow Leopard installation disk to the /System/Library/Extensions folder of my hard drive using the Terminal provided by the install cd? I assume the kext is on the cd. I would like to have a working system again until the release of Mammoth's guide.

Share this post


Link to post
Share on other sites

I going to by a new laptop DV8, what I can see so is there more models if I go with Mobility Radeon HD 5650

Is this possible to work with OSX ? or it's safer with Geforce ?

 

 

//Peter

 

Share this post


Link to post
Share on other sites
First, Thanks to all of you for the great help.

 

I will be trying the v2.00 Guide on my laptop. I have just installed an extra disk, and I have already made a backup of windows 7.

 

I have also a G4 Mac with Tiger and about this, just one thing: when tryin to prepare the "Mammoth DVxt Boot USB - v1.15a" on the G4, I had errors because the fdisk440 has some reference which dosn´t work on Tiger os. When the 2.0 guide is ready I will have to go to a friend´s with a Mac Book wih SL to make it.

 

Hi Elixz,

 

You may be happy to learn that with v2.00, if you have a Windows 7 installation installed, you will be able to use that for the initial steps.

 

Is there a way to copy the IOPCIFamily.kext off of the Snow Leopard installation disk to the /System/Library/Extensions folder of my hard drive using the Terminal provided by the install cd? I assume the kext is on the cd. I would like to have a working system again until the release of Mammoth's guide.

 

Yes, this is possible, you may even be able to boot into single user mode and do it that way on boot up: -s

 

The IOPCIFamily.kext may be in a .PKG file though, so you would to figure out how to extract it. Of course, you could post what version you are on and someone by be able to upload it for you.

 

I going to by a new laptop DV8, what I can see so is there more models if I go with Mobility Radeon HD 5650

Is this possible to work with OSX ? or it's safer with Geforce ?

 

 

//Peter

 

 

Traditionally, it has always been best to go with an Nvidia GPU; however, now that Apple is starting to use some ATI GPUs, this is changing. You would need to find out if that is one Apple is going to (or already does) support. 10.6.7 is right around the corner, and it is going to provide support for more ATI GPUs.

Share this post


Link to post
Share on other sites

@Mammoth, Just a suggestion, the pdf file you created is nearly 14MB. I suggest you open that pdf file in Preview.app and then Save As and choose Reduce File Size in Quartz Filter, which will slim down the file size to 500KB.

 

Finally, I was wondering if you guys have sleep working. If I am not mistaken I remember you having a hard time and black screen when using some of the sleep modes. Can you share the current situation? If you have solved these problems, how?

 

I have never had S3 sleep working but at least I used to have Hibernate but now, I noticed that it is somehow broken.

Just before it wakes up, it goes to sleep again. Now, I can only use "Sleep Only" option after which I lose the audio. If I use an audio device which has an USB input then I have sound after sleep otherwise sound is not working.

 

Thanks,

Share this post


Link to post
Share on other sites
@Mammoth, Just a suggestion, the pdf file you created is nearly 14MB. I suggest you open that pdf file in Preview.app and then Save As and choose Reduce File Size in Quartz Filter, which will slim down the file size to 500KB.

 

Finally, I was wondering if you guys have sleep working. If I am not mistaken I remember you having a hard time and black screen when using some of the sleep modes. Can you share the current situation? If you have solved these problems, how?

 

I have never had S3 sleep working but at least I used to have Hibernate but now, I noticed that it is somehow broken.

Just before it wakes up, it goes to sleep again. Now, I can only use "Sleep Only" option after which I lose the audio. If I use an audio device which has an USB input then I have sound after sleep otherwise sound is not working.

 

Thanks,

 

Thanks for the tip JBraddock,

 

I tried using Preview as you suggested, but it reduces all of the image quality too much. What I will do is shrink the images down, so the next ones won't be so large. Thanks for speaking up about this.

 

Sleep and wake is working great with v2.00, and it's due to features in newer versions of Chameleon, DSDT edits by NIXin and Taptun.

 

How are you invoking hibernation? I do not have hibernation as an option anywhere that I can find. Perhaps I need to enable it somewhere?

Share this post


Link to post
Share on other sites

HP DV7 4183/Intel/i5 m460@2.53/series/3400 series chipset/Intel/mobile 5 series/Broadcom Corp/BCM4313 502.1 1b/g LP-PHY/ATI Manhattan Mobility Radeon HD 5470

 

can't get it to work. boots from Chameleon gets to cant find ebios then loops continuos.

Share this post


Link to post
Share on other sites

===========

 

Something else I've just noticed...

 

On my desktop Hac, I have the Eject icon on the top Menu Bar, but not on my DV8.

 

Does anyone know why this is or how we can add/enable it?

 

HP DV7 4183/Intel/i5 m460@2.53/series/3400 series chipset/Intel/mobile 5 series/Broadcom Corp/BCM4313 502.1 1b/g LP-PHY/ATI Manhattan Mobility Radeon HD 5470

 

can't get it to work. boots from Chameleon gets to cant find ebios then loops continuos.

 

What installation method / procedures are you following? What are you using for your boot / install media?

 

Your issue may be due to you having an i5 CPU and/or your Radeon.

 

Once you answer the first 2 questions, I may have a few things for you to try.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×