Jump to content
Mammoth

[Guide] HP DV8, DV7, DV6, & DV5, 10.6.4 Easy, Comprehensive Installation

v2.00 Installation, Update, and Mammoth Installation media  

141 members have voted

  1. 1. Is v2.00 something you are interested in and would use?

    • Yes
      139
    • No
      2
  2. 2. Which are you most interested in?

    • v2.00 Installation Guides
      95
    • v2.00 Post-installation Update Guide
      46

1,266 posts in this topic

Recommended Posts

Good news! Another late christmas present.

 

Thanks to a great technique that mbeifuss developed, I hacked the BIOSes for all of HP DV6-2xxx, DV7-3xxx and DV8 to allow for any WiFi card.

 

If anybody is interested in the modded DV8 BIOS, I'm posting it below.

This bios was tested by Mammoth and it works (you can use any WiFi card in the first miniPCIe slot), so it should be safe to flash, but in case something goes wrong, write here and we'll help you recover your old BIOS via USB flash drive.

I don't take any responsibility if you brick or damage your laptop, though.

 

Unpack and Flash in Windows by running InsydeFlash.exe.

http://improwizuj.pl/temp/dv8-WIFIunlocked-bios.rar

 

Debugging method shown here, if you want to get your hands dirty:

Capture_.PNG

Capture2_.PNG

 

Generic steps for hacking theoretically all InsydeFlash BIOSes are posted here:

http://www.insanelymac.com/forum/index.php?showtopic=227226

 

Cheers,

NIXin

 

PS

I'll post the hacked DV6 and DV7 at a later time.

Share this post


Link to post
Share on other sites
Advertisement
Hi all,

 

Mammoth, thanks for the option to beta test here are my results:

1) Fresh 60gb drive no partitions, bootet with the beta cd and received the error after a little while: still waiting for root device?

2) Restarted machine, booted the cd properly and then managed to boot a 10.6.3 disk and boot to installer, booted to disk utility and tried to partiton disk, was unable to make the Cham partition smaller as suggested but proceeded anyway.

3)Smooth installation with no key presses, just mouse movement on screen blanking.

4) Installation completed in 20 mins, restart with your boot cd and booted into a fresh install on the HD.

5)Followed instructions in guide, but skipped installing legacy kernel, just went straight to installing 10.6.4 then kokomal kernel.

6) No kernel panics on restart but Cham didn't install properly?

7) followed guide again and tried to reinstall cham but again failed.

8)Reformatted drive and reinstalled from scratch to make sure it wasn't some silly error, still stuck at same point again with installing chameleon

 

Could you please check the file is correct on the cd or if I'm making a basic error? Happy to format drive and try again.

 

Thanks.

 

Great Sammity, that's mostly all good news.

 

But like said in the BETA testing documentation (did you see it?), the installation is not complete and no one should try to complete it at this point. The files on the CD are from 1.15 and should not be used. The KoKomal kernel should not be used FOR SURE and I'm surprised you didn't get a KP when you tried.

 

A full installation CANNOT be completed with that CD; we are only running tests at this point.

 

THANK YOU for testing and reporting back your results!

Share this post


Link to post
Share on other sites

@NIXin,

 

Awesome skills, just used the autopatcher with Gsly's battery kext and it compiled without problem and I now have a correct battery time remaining shown in my DV8.

 

thanks!

 

@Mammoth

 

Yeah I did read the instructions :wacko: twice,

 

Since I was testing i just wanted to see how far I could proceed before i encountered a roadblock. Just for information purposes more than anything. Naturally I'm not expecting a full working system from a beta.

Share this post


Link to post
Share on other sites
@NIXin,

 

Awesome skills, just used the autopatcher with Gsly's battery kext and it compiled without problem and I now have a correct battery time remaining shown in my DV8.

 

thanks!

 

@Mammoth

 

Yeah I did read the instructions :D twice,

 

Since I was testing i just wanted to see how far I could proceed before i encountered a roadblock. Just for information purposes more than anything. Naturally I'm not expecting a full working system from a beta.

 

Ok cool, thanks. :wacko:

 

NIXin is amazing! He is really making "all things possible"!

Share this post


Link to post
Share on other sites

You could try starting up with the boot kernel flag: -f

 

Note that when you do this, once the OS X GUI does come up, your mouse and/or trackpad, may NOT be functional. This is OK at this point. Just press and release the power button and you should have the option to shutdown the machine. Just press Enter to do this. Then start the machine normally and see if the problems have been fixed.

 

Hi Mammoth , thanks for the response , I tried the -f kernel flag , but it did not work , here is what i got when tried to open couple of programs

 

Process: iPhoto [343]

Path: /Applications/iPhoto.app/Contents/MacOS/iPhoto

Identifier: com.apple.iPhoto

Version: 9.1.1 (9.1.1)

Build Info: iPhotoProject-5270000~1

Code Type: X86 (Native)

Parent Process: launchd [119]

 

Date/Time: 2010-12-29 18:07:27.880 -0800

OS Version: Mac OS X 10.6.5 (10H574)

Report Version: 6

 

Interval Since Last Report: 37906 sec

Crashes Since Last Report: 71

Per-App Interval Since Last Report: 630 sec

Per-App Crashes Since Last Report: 2

Anonymous UUID: 4949AE0E-F5E1-4CDC-883F-

 

Exception Type: EXC_BAD_ACCESS (SIGBUS)

Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000093296dc7

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

 

Thread 0 Crashed: Dispatch queue: com.apple.main-thread

0 GLEngine 0x1e276862 dyld_stub_gfxInitializeLibrary + 4

1 com.apple.opengl 0x9328f6c0 glcNoop + 521

2 com.apple.opengl 0x932902cd glcGetIOAccelService + 366

3 com.apple.opengl 0x93290447 glcGetIOAccelService + 744

4 com.apple.opengl 0x93295e1b CGLGetPixelFormatRetainCount + 2367

5 com.apple.opengl 0x9328c881 CGLChoosePixelFormat + 121

6 com.apple.iPhoto 0x0010a248 0x1000 + 1086024

7 com.apple.iPhoto 0x0090ecae 0x1000 + 9493678

8 com.apple.iPhoto 0x0001498c 0x1000 + 80268

9 com.apple.iPhoto 0x0001321a 0x1000 + 74266

10 com.apple.iPhoto 0x00012ea8 0x1000 + 73384

11 com.apple.iPhoto 0x00012e45 0x1000 + 73285

12 com.apple.iPhoto 0x00012358 0x1000 + 70488

13 com.apple.CoreFoundation 0x958439b4 -[NSSet makeObjectsPerformSelector:] + 196

14 com.apple.AppKit 0x9890921c -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 1566

15 com.apple.AppKit 0x989071f4 loadNib + 257

16 com.apple.AppKit 0x98906848 +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 831

17 com.apple.AppKit 0x989064fe +[NSBundle(NSNibLoading) loadNibFile:externalNameTable:withZone:] + 158

18 com.apple.AppKit 0x989961e7 -[NSWindowController loadWindow] + 223

19 com.apple.AppKit 0x9892cf76 -[NSWindowController window] + 89

20 com.apple.AppKit 0x98b91f88 -[NSWindowController showWindow:] + 36

21 com.apple.iPhoto 0x0000982f 0x1000 + 34863

22 com.apple.AppKit 0x98ad2e00 -[NSDocument showWindows] + 116

23 com.apple.iPhoto 0x000097e0 0x1000 + 34784

24 com.apple.AppKit 0x98cab712 -[NSDocumentController(NSDeprecated) openUntitledDocumentOfType:display:] + 148

25 com.apple.iPhoto 0x00008da3 0x1000 + 32163

26 com.apple.AppKit 0x98ad1125 -[NSDocumentController openUntitledDocumentAndDisplay:error:] + 153

27 com.apple.AppKit 0x98aeda8c -[NSDocumentController(NSInternal) _openUntitled] + 143

28 com.apple.AppKit 0x98ad0cab -[NSApplication _doOpenUntitled] + 446

29 com.apple.AppKit 0x98ad04bf -[NSApplication(NSAppleEventHandling) _handleAEOpen:] + 228

30 com.apple.AppKit 0x98ad010d -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 101

31 com.apple.Foundation 0x92e7b7a4 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 511

32 com.apple.Foundation 0x92e7b568 _NSAppleEventManagerGenericHandler + 228

33 com.apple.AE 0x94da3f58 aeDispatchAppleEvent(AEDesc const*, AEDesc*, unsigned long, unsigned char*) + 166

34 com.apple.AE 0x94da3e57 dispatchEventAndSendReply(AEDesc const*, AEDesc*) + 43

35 com.apple.AE 0x94da3d61 aeProcessAppleEvent + 197

36 com.apple.HIToolbox 0x93bcf323 AEProcessAppleEvent + 50

37 com.apple.AppKit 0x989499ca _DPSNextEvent + 1420

38 com.apple.AppKit 0x98948fce -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 156

39 com.apple.AppKit 0x9890b247 -[NSApplication run] + 821

40 com.apple.AppKit 0x989032d9 NSApplicationMain + 574

41 com.apple.iPhoto 0x00003739 0x1000 + 10041

42 com.apple.iPhoto 0x00003295 0x1000 + 8853

 

Thread 1: Dispatch queue: com.apple.libdispatch-manager

0 libSystem.B.dylib 0x90699982 kevent + 10

1 libSystem.B.dylib 0x9069a09c _dispatch_mgr_invoke + 215

2 libSystem.B.dylib 0x90699559 _dispatch_queue_invoke + 163

3 libSystem.B.dylib 0x906992fe _dispatch_worker_thread2 + 240

4 libSystem.B.dylib 0x90698d81 _pthread_wqthread + 390

5 libSystem.B.dylib 0x90698bc6 start_wqthread + 30

 

Thread 2:

0 libSystem.B.dylib 0x90698a12 __workq_kernreturn + 10

1 libSystem.B.dylib 0x90698fa8 _pthread_wqthread + 941

2 libSystem.B.dylib 0x90698bc6 start_wqthread + 30

 

Thread 3:

0 libSystem.B.dylib 0x9067315a semaphore_timedwait_signal_trap + 10

1 libSystem.B.dylib 0x906a0ce5 _pthread_cond_wait + 1066

2 libSystem.B.dylib 0x906cfac8 pthread_cond_timedwait_relative_np + 47

3 com.apple.Foundation 0x92e82e24 -[NSCondition waitUntilDate:] + 453

4 com.apple.Foundation 0x92e3bae5 -[NSConditionLock lockWhenCondition:beforeDate:] + 279

5 com.apple.Foundation 0x92e3b9c8 -[NSConditionLock lockWhenCondition:] + 69

6 com.apple.proxtcore 0x8f66814f -[XTMsgQueue waitForMessage] + 47

7 com.apple.proxtcore 0x8f666f30 -[XTThread run:] + 400

8 com.apple.Foundation 0x92e46bf0 -[NSThread main] + 45

9 com.apple.Foundation 0x92e46ba0 __NSThread__main__ + 1499

10 libSystem.B.dylib 0x906a085d _pthread_start + 345

11 libSystem.B.dylib 0x906a06e2 thread_start + 34

 

Thread 4:

0 libSystem.B.dylib 0x906730fa mach_msg_trap + 10

1 libSystem.B.dylib 0x90673867 mach_msg + 68

2 com.apple.CoreFoundation 0x9581437f __CFRunLoopRun + 2079

3 com.apple.CoreFoundation 0x95813464 CFRunLoopRunSpecific + 452

4 com.apple.CoreFoundation 0x95813291 CFRunLoopRunInMode + 97

5 com.apple.Foundation 0x92e8071c -[NSRunLoop(NSRunLoop) runMode:beforeDate:] + 279

6 com.apple.proxtcore 0x8f6693c5 -[XTRunLoopThread run:] + 453

7 com.apple.Foundation 0x92e46bf0 -[NSThread main] + 45

8 com.apple.Foundation 0x92e46ba0 __NSThread__main__ + 1499

9 libSystem.B.dylib 0x906a085d _pthread_start + 345

10 libSystem.B.dylib 0x906a06e2 thread_start + 34

 

Thread 5:

0 libSystem.B.dylib 0x906730fa mach_msg_trap + 10

1 libSystem.B.dylib 0x90673867 mach_msg + 68

2 com.apple.CoreFoundation 0x9581437f __CFRunLoopRun + 2079

3 com.apple.CoreFoundation 0x95813464 CFRunLoopRunSpecific + 452

4 com.apple.CoreFoundation 0x95813291 CFRunLoopRunInMode + 97

5 com.apple.Foundation 0x92e8071c -[NSRunLoop(NSRunLoop) runMode:beforeDate:] + 279

6 com.apple.proxtcore 0x8f6693c5 -[XTRunLoopThread run:] + 453

7 com.apple.Foundation 0x92e46bf0 -[NSThread main] + 45

8 com.apple.Foundation 0x92e46ba0 __NSThread__main__ + 1499

9 libSystem.B.dylib 0x906a085d _pthread_start + 345

10 libSystem.B.dylib 0x906a06e2 thread_start + 34

 

Thread 6:

0 libSystem.B.dylib 0x90698a12 __workq_kernreturn + 10

1 libSystem.B.dylib 0x90698fa8 _pthread_wqthread + 941

2 libSystem.B.dylib 0x90698bc6 start_wqthread + 30

 

Thread 7:

0 libSystem.B.dylib 0x90698a12 __workq_kernreturn + 10

1 libSystem.B.dylib 0x90698fa8 _pthread_wqthread + 941

2 libSystem.B.dylib 0x90698bc6 start_wqthread + 30

 

Thread 0 crashed with X86 Thread State (32-bit):

eax: 0xa04818e4 ebx: 0x1e1009be ecx: 0x1e1009b0 edx: 0xa04818e4

edi: 0x00000000 esi: 0x93296dc7 ebp: 0xbfffe2a8 esp: 0xbfffe26c

ss: 0x00000023 efl: 0x00010283 eip: 0x1e276862 cs: 0x0000001b

ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x0000000f

cr2: 0x93296dc7

 

then I got this on Word program:

 

Microsoft Error Reporting log version: 2.0

 

Error Signature:

Exception: EXC_BAD_ACCESS

Date/Time: 2010-12-29 18:13:09 -0800

Application Name: Microsoft Word

Application Bundle ID: com.microsoft.Word

Application Signature: MSWD

Application Version: 14.0.0.100825

Crashed Module Name: GLEngine

Crashed Module Version: 1.6.11

Crashed Module Offset: 0x00179000

Blame Module Name: GLEngine

Blame Module Version: 1.6.11

Blame Module Offset: 0x00179000

Application LCID: 1033

Extra app info: Reg=en Loc=0x0409

Crashed thread: 5

 

I am not sure what all this means , but it looks bad to me , is there any way to fix it? , or do i have to re install the OX , I tried re-installing the programs , but it gives me the same error reports .

 

thanks again for all your help........

Share this post


Link to post
Share on other sites
You could try starting up with the boot kernel flag: -f

 

Note that when you do this, once the OS X GUI does come up, your mouse and/or trackpad, may NOT be functional. This is OK at this point. Just press and release the power button and you should have the option to shutdown the machine. Just press Enter to do this. Then start the machine normally and see if the problems have been fixed.

 

 

Hi Mammoth , thanks for the response , I tried the -f kernel flag , but it did not work , here is what i got when tried to open couple of programs

 

Sorry Oskr66, I don't know what's going on with your system. I would try Googling around, maybe your hard disk has a problem, or something just got corrupted. Was your system fully updated to 10.6.5? All patches and updates from Apple? If not, maybe you encountered some known bug. Other than that, sorry. I haven't seen that (and hope I don't).

 

:thumbsup_anim:

Share this post


Link to post
Share on other sites

I wanted to create a brand new, clean DSDT for my DV8 so that I could apply NIXin and Gsly's DSDT patching and Battery kext. I removed my DSDT, booted back into OS X (now with no DSDT), then used DSDTSE to extract a new DSDT. I went about removing all the errors & warnings, and was able to get rid of all of them accept one (twice), so I'm wondering if anyone knows how to properly correct these:

 

/Users/Mammoth/Library/Application Support/EvOSoftware/DSDT/DSDTFiles/dsdt.dsl 1828: Name (PR01, Package (0x0) {})

Remark 5072 - Effective AML package length is zero ^

 

/Users/Mammoth/Library/Application Support/EvOSoftware/DSDT/DSDTFiles/dsdt.dsl 1829: Name (AR01, Package (0x0) {})

Remark 5072 - Effective AML package length is zero ^

 

I read on Yehia Amer's page that he was able to change "(0x0) {}" to "(0x00) {0x00}" and I tried that, but didn't work for me. I tried a few different combinations, like "(0x01) {}", which compiled with no errors no warnings, but KPs on every attempted boot. So for now, I left those warnings in, compiled with NIXin's updated script for Gsly's Battery kext, dropped the kext into /C/E/E/ and ran ChamExtUp, rebooted, and awesome! Battery working correctly with time count down and all. SO NICE, GREAT WORK Gsly, NIXin, and MaLd0n!!!! Thanks VERY much. :thumbsup_anim:

 

Oh, and I should mention that Gsly really paid attention to detail as now when we plug and unplug power, the screen brightens and dims as it should! Super nice.

 

@Gsly: One thing I just noticed, I unplugged the power, and everything worked perfect; however, when I plug the power back in, it went from 1:05 previously, to :27. I know you said there were still some things you were working on, but I'm just providing some testing info back. Again, thanks. ^_^

 

Now, if someone could help me properly get rid of those last warnings, I could sleep at night!

Share this post


Link to post
Share on other sites
Sorry Oskr66, I don't know what's going on with your system. I would try Googling around, maybe your hard disk has a problem, or something just got corrupted. Was your system fully updated to 10.6.5? All patches and updates from Apple? If not, maybe you encountered some known bug. Other than that, sorry. I haven't seen that (and hope I don't).

 

^_^

 

Thanks Mammoth for your response . I guess I will have to back up my system , it is all up to date , and then start all over .

Done it many times , so it should be no problem..... :thumbsup_anim:

 

thanks again ....

Share this post


Link to post
Share on other sites
update:

 

Strange, but it always work, if i boot with "-v -f" boot flags (by typing them every time i boot , not with adding them to com.apple.Boot.plist)

HDMI sound works !!!!!

but after i used AppleJack, it is working all the time with no problems ^_^;)

 

This is very interesting Yehia Amer, can you do a test for me? Try running Pfix and see if that breaks it. Then if you run AppleJack if that again fixes it.

 

Thanks.

 

Thanks Mammoth for your response . I guess I will have to back up my system , it is all up to date , and then start all over .

Done it many times , so it should be no problem..... :thumbsup_anim:

 

thanks again ....

 

Maybe you should try running AppleJack on it. Try that first if you can and let us know how it goes.

Share this post


Link to post
Share on other sites
hi Mammoth

This topic by iFabio is very helpful, take a look

Chameleon 2 RC5 Unofficial Package Installer, Unofficial Package Installer based on latest RC5 trunk.

 

update:

 

Strange, but it always work, if i boot with "-v -f" boot flags (by typing them every time i boot , not with adding them to com.apple.Boot.plist)

HDMI sound works !!!!!

but after i used AppleJack, it is working all the time with no problems :thumbsup_anim:^_^

post-307642-1293585342_thumb.png

 

Hey Yehia Amer,

 

Does your system KP if you insert or remove the HDMI cable? Mine does every time. My HDMI audio doesn't show up like yours for some reason. Something else to sort out.

Share this post


Link to post
Share on other sites

mammoth, can u point me to the loc in this forum where it explains how to patch dsdt? i extracted mine thru linux but now i can't in this post how to patch it

 

jason

Share this post


Link to post
Share on other sites

Hey guys,

to everybody that has KP with GenericBrightness - you need to take a photo of the Kernel Panic and post it in the GenericBrightness thread, otherwise the creator won't be able to fix it.

Share this post


Link to post
Share on other sites
I'm wondering if anyone knows how to properly correct these:

 

/Users/Mammoth/Library/Application Support/EvOSoftware/DSDT/DSDTFiles/dsdt.dsl 1828: Name (PR01, Package (0x0) {})

Remark 5072 - Effective AML package length is zero ^

 

/Users/Mammoth/Library/Application Support/EvOSoftware/DSDT/DSDTFiles/dsdt.dsl 1829: Name (AR01, Package (0x0) {})

Remark 5072 - Effective AML package length is zero ^

You might want to update your AML compiler as those do not cause me trouble, however I mostly edit DSDT in Notepad++ on Windoze and compile there. On the Mac side, you can download the compiler source and compile it there although I recall I had to fix something to get that to build... I'll upload a binary the next time I boot up OSX :(

 

@Gsly: One thing I just noticed, I unplugged the power, and everything worked perfect; however, when I plug the power back in, it went from 1:05 previously, to :27. I know you said there were still some things you were working on, but I'm just providing some testing info back. Again, thanks. :P

Do you mean that the counter was 1:05 *before* plugging back in and then it switched to 0:27 when you plugged in, or you plugged back in and the counter showed 1:05 and then 0:27? There is a difference :)

 

In the first scenario, 1:05 is the time until your battery is dead and then 0:27 is the time to recharge to full. In the second scenario, it takes a bit for the code to average the values before the calculation is close. These are the logic bugs I hinted at and its not code I wrote... I think the AppleSmartBatteryManager has some logic that works around this by polling the battery more often after plug/unplug events...

Share this post


Link to post
Share on other sites

@NIXin

can you add DV5 to patcher? i can tell you the DSDT patches i applied on mine to work!

Share this post


Link to post
Share on other sites
mammoth, can u point me to the loc in this forum where it explains how to patch dsdt? i extracted mine thru linux but now i can't in this post how to patch it

 

jason

 

Do a search on NIXin's posts and you'll find it.

 

I downloaded the latest source for the AML compiler from http://www.acpica.org/ and compiled it for OSX:

 

 

Wow, awesome. I'm headed out right now but will try it out when I get back.

 

Thanks very much Gsly! I will post if using it resolves that laging warning.

 

Take care, and EVERYONE have an INCREDIBLE (but safe), fun NEW YEAR!!!!

Share this post


Link to post
Share on other sites
@NIXin

can you add DV5 to patcher? i can tell you the DSDT patches i applied on mine to work!

I can, but you have to provide me with your clean (raw, unmodified) DSDT and the list of all patches you've applied.

Share this post


Link to post
Share on other sites

QUOTE (Mammoth @ Dec 1 2010, 10:04 AM)

- Getting ANY of the HP buttons working would be a bonus. So if you are able to do it, GREAT, as no one to date that I know of has been able to do anything with them.

 

QUOTE Gsly

As for the hot/HP keys, some are generated via the regular keyboard interrupt and others are controlled via the EC. I think I've found a datasheet for the EC used in the DV8 via your internal "guts" pictures (thanks!) so there might be hope for those as well. If needed, a custom kext can bridge between the EC/DSDT to make it all work..

 

QUOTE (Mammoth @ Dec 1 2010, 10:04 AM)

- On the Keyboard and TrackPad .kexts, elsewhere in this thread (more recently), someone posted a working, non-Voodoo, working, 64-bit version. I did not have the time to even look at it before, let alone try it, but I think I saw several downloads of it and believe it is working; I think it even added more TrackPad functionality.

 

QUOTE Gsly

That is likely the one Slice created. I'm going to use his a basis as he's already got code in there to make Asus hotkeys work and I'm just going to rip that out and replace with HP keys. I've got his code now and I just need to create a new SVN project, compile a debug version and see what keys I can get working...

 

 

=====================

 

@Gsly

 

Hi Gsly,

 

I just wanted to touch bases with you and check on the progress of the above items. Mainly right now I'm looking at TrackPad functionality.

 

The post I referenced above was from Jy371 on October 8, 2010 here:

 

http://www.insanelymac.com/forum/index.php...653&st=413#

 

Following are the issues I have with the 2 kext available from that post. I am hoping we can come up with a "best of both worlds" solution:

 

- 2FingerScroll

The main feature I personally like with this one is that I can place the pointer in a window and then tap, hold, and drag, to scroll. I also like all the other features that are available in the Preference Pane.

 

BUT there are two really bad issues (at least for me) that makes it unusable.

 

1) I like my tracking speed set to maximum (like when using MousePrefpane), but with 2FingerScroll, its maximum is about half that of MousePrefpane, so to me it seems really slow. Can we change this somehow?

 

The other issue is that it seems temperamental, like the TrackPad has lost some of its sensitivity; sometimes it misses my input or doesn't respond and I have to keep trying. I see this most when I am holding down the left mouse button and trying to drag a scroll bar. I have to try several time.

 

- MousePrefpane

This one is the most responsive, has the best feel, and always works. For me, the only thing missing that I want is the ability to place the mouse pointer in a window, then be able to tap, hold, and drag in order to scroll that window.

 

 

Thanks!

 

UPDATE

 

I just found the following and am checking it out now:

 

http://www.insanelymac.com/forum/index.php...amp;hl=trackPad

Share this post


Link to post
Share on other sites

Hi Mammoth .,

On your next release , are you going to implement the fix ( flash) for the BIOS to be able to use our "blacklisted" wireless cards? I seen someone fixed it here on this tread . How hard would it be to make this a reality ?

You asked on your update to mention anything we might be missing ........ thanks for all your hard work .

:rolleyes:

Share this post


Link to post
Share on other sites
Hi Mammoth .,

On your next release , are you going to implement the fix ( flash) for the BIOS to be able to use our "blacklisted" wireless cards? I seen someone fixed it here on this tread . How hard would it be to make this a reality ?

You asked on your update to mention anything we might be missing ........ thanks for all your hard work .

;)

 

Hello Oskr66,

 

Yes, this going to be available for most current DVx systems, so long as HP doesn't radically change the BIOS soon.

 

Hi Mammoth .,

On your next release , are you going to implement the fix ( flash) for the BIOS to be able to use our "blacklisted" wireless cards? I seen someone fixed it here on this tread . How hard would it be to make this a reality ?

You asked on your update to mention anything we might be missing ........ thanks for all your hard work .

:)

 

Can you please add your system specs to your signature? Please see the instructions on the #1 post of this thread on how to do it.

 

Thanks.

Share this post


Link to post
Share on other sites

@mammoth

i got my hands on 10.6.3 and here are the results: it works! I used the boot cd you sent me and i can get to the installer and also complete disk utility with partition selecttions and what not! any other results required?

Share this post


Link to post
Share on other sites

hello everyone! ok, i have some troubles with installation of osX on my HP Pavilion dv7-2250em. i tried a lot of distros, few different customizations but with no result. farthest that i got was a completed instalation but i never made os x to boot. can anyone give me some opinions on what distribution should i try to use or anything, please?

Share this post


Link to post
Share on other sites
@mammoth

i got my hands on 10.6.3 and here are the results: it works! I used the boot cd you sent me and i can get to the installer and also complete disk utility with partition selecttions and what not! any other results required?

 

Awesome! That is the best testing report yet, and I didn't think it would work on your machine since it is so differnent. I am really focusing on making the next Mammoth release more open to more systems, so this shows I'm going in the right direction, which is good! :P

 

What about video? You should be able to install OS X, then when finished, boot from the BETA Mammoth CD and then startup OS X. Then I would like to know about the video. Is it perfect (QE/CI), correct resolution, correct card detected and shown in System Profiler?

 

 

 

hello everyone! ok, i have some troubles with installation of osX on my HP Pavilion dv7-2250em. i tried a lot of distros, few different customizations but with no result. farthest that i got was a completed instalation but i never made os x to boot. can anyone give me some opinions on what distribution should i try to use or anything, please?

 

Hello Chrisys32,

 

Which BIOS does it have? Is it Insyde, or Pheonix, or something else?

 

KiD KuN has just tried my BETA Installation CD which worked for him, and he has a Core2 Duo machine like you. So it's looking like my updated Mammoth release may work for your machine. If you would like to BETA test the CD, that may give you an indication if it will work on your machine.

 

Let me know if you would be willing to BETA test it and report back the results. If you don't have a blank hard drive to test with, and/or you cannot erase yours, you would only be able to do limited testing, such as booting the CD and then testing to see if you can run the OS X installer.

 

Hey guys,

to everybody that has KP with GenericBrightness - you need to take a photo of the Kernel Panic and post it in the GenericBrightness thread, otherwise the creator won't be able to fix it.

 

Yes, and I've added a link to the thread to do this on post #1.

Share this post


Link to post
Share on other sites

@mammoth,

Guess what! you will be happy with these news! SUCCESS! your boot CD is working on my machine. I used to install and also start the Installed OS. Everything works out of box apart from battery,sound and card reader. The color profile has to be added. Video is perfect as its from my DSDT. and also it has QE/CI and also PERFECT identification in system profiler. I have attached photos of the OS Install Disc Booting up, When its booted and into the agree ment, Disk utility, installing screen and also successful install screen. Also image showin about this mac and Nvidia card in system profiler! Check them and let me know. Sorry i could not upload a video as i have less time and my camera is away. Thanks alot and looking forward to the final release!!

post-40940-1293983216_thumb.jpg

post-40940-1293983567_thumb.jpg

post-40940-1293983580_thumb.jpg

post-40940-1293983601_thumb.jpg

post-40940-1293983639_thumb.jpg

post-40940-1293983656_thumb.jpg

post-40940-1293983678_thumb.jpg

post-40940-1293983694_thumb.jpg

post-40940-1293983713_thumb.jpg

post-40940-1293983726_thumb.jpg

Share this post


Link to post
Share on other sites

Hey guys,

 

Glad to hear 1.20 is on the way! Great job! And thank you for all your efforts Mammoth and whoever contributed to this project. I wish I could do anything for you but my knowledge is limited :)

 

I have a small issue. I'm using the system which is told in 1.15 and works great. But sometimes when I plug out the power cable it says "you need to restart your computer". Sometimes it does not happen when I plug out but when I plug it in back. Is there any solution for that?

 

Also I patched my DSDT before to make sleep work. Now I saw that we have a brand new DSDT but it needs the original untouched DSDT. Is there any chance to find it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×