Jump to content

Broadcom 5784 onboard NIC not working.

1 post in this topic

Recommended Posts

First some info about me and hackintosh. Been out of the scene for a while now. Used to run Leopard in its early days on a Dell Inspiron 1705e for a while, using the Kalyway install, i believe. I decided to buy a Macbook. Loved it. Recently my Macbook was stolen, and here I am, crawling back again. This time I am doing an OSx86 installation on my gaming rig.


Dell XPS 730x

Intel Core i7 Quad Core CPU

X58 Intel Chipset Gigabyte Mainboard

MS-7543 V1.0 Mainboard

6 GB DDR3 RAM (downgraded to 4 during install)

NVidia GeForce 9800GT 512MB

Dual Gigabit Ethernet (2nd one disabled from BIOS)



I have been trying for 2 days now to get my Broadcom 5784 Ethernet adapter to work and have had no such luck. I have searched the net and a few OSx86 sites and have had no luck finding any information.


I have even gone to the point of disabling both of my Ethernet adapters from the BIOS, and installing an Intel PCI NIC, which I still am having no luck with. Chose that one, since [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] only has 2 options as far as NICs go, RealTEK and Intel. I would prefer to use my on-board NIC if at all possible.


Running OSx86 Snowleopard 10.6.3.


Everything worked 100% with a vanilla install using [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] Supported and [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], and my Legal SL install disk/update disk.....except for the onboard NIC.


I have tried what I believe should be able to get the card to work with a .pkg that runs a script to get this NIC to work, but I couldn't seem to get it to function.



Also, a 2nd general question:


When I install a kext for a device, I need to reboot to get this device to be recognized, correct? example: Install the kext for the broadcom 5784 card, go to network devices, and it wont be listed automatically, correct? Assuming I need a reboot before this will be seen. Following that, once I do a reboot, will it be recognized immediately, or do I need to hit the + button underneath and add the hardware?


Please reply to either this, a PM, or email me @ gparaschis@gmail.com

Thanks a lot for any information you can provide.


George P.

Link to comment
Share on other sites


  • Create New...