Jump to content
touche

Já tem Kext para ECS Black GTS 250 2048MB (NVIDIA) ?

61 posts in this topic

Recommended Posts

Não entendi o que você quer fazer.

 

Você tem uma partição EFI? Que kexts tem nela?

 

Tentou iniciar a partição instalada usando o boot CD com "GraphicsEnabler=No -x -v"?

Share this post


Link to post
Share on other sites
Advertisement
Não entendi o que você quer fazer.

 

Você tem uma partição EFI? Que kexts tem nela?

 

Tentou iniciar a partição instalada usando o boot CD com "GraphicsEnabler=No -x -v"?

 

Tentei sim.

 

E na particao do 10.6.3 tem uma EFI. Soh que tanto pelo cd de boot quanto pelo efi da particao,

o erro eh o mesmo, ou seja, desliga o monitor depois de um tempo.

Eu fiz este procedimento que vc mandou tanto pelo boot cd quando pela efi da particao.

Share this post


Link to post
Share on other sites

Quais kexts você tem na EFI do HD?

 

Tente fazer o boot no modo single user (digite "-s" no Chameleon) e rode esses comandos

mount -uw /
mv /System/Library/Extensions/NVDA* /
exit

Share this post


Link to post
Share on other sites
Quais kexts você tem na EFI do HD?

 

Tente fazer o boot no modo single user (digite "-s" no Chameleon) e rode esses comandos

mount -uw /
mv /System/Library/Extensions/NVDA* /
exit

 

Amigo Old, eu consegui fazer funcionar!

Resolvi na madrugada formatar o hd mantendo a partição de instalação do 10.6.3.

Ai eu entrei com o cdboot do tonymacox e dei boot pela partição do 10.6.3, e foi de primeira!

 

screenshot20100523at104.th.png

 

Somente duas coisas ainda não funfam direito.

1 - Não reconhece o meu gravador de cd/dvd

2 - E o som só entra quando eu dou um boot pelo boot cd do tony

 

Alguma sugestão?

 

Depois que tudo estiver funcionando, eu vou colocar um tutorial de como eu fiz para a minha config.

 

MB - Gigabyte P55A-UD3P

Socket - LGA1156

Processador - i7-860 box

Placa de Video - EVGA GeForce GTX 260 896 DDR3 PCI-E 2

 

Muito obrigado por sua paciência e ajuda.

 

Abs,

 

Touche

Share this post


Link to post
Share on other sites
Veja o device ID da controladora IDE

http://www.insanelymac.com/forum/index.php?showtopic=218684

 

e adicione na kext

http://www.insanelymac.com/forum/index.php?showtopic=218797

 

ou instale a kext correspondente se a controladora IDE não for Intel.

 

Old, pelo Hardware Info, aparece isso, mas honestamente eu não sei o que fazer com esta informação.

 

1033:0194 NEC Corporation ERROR: Unknown Device

 

abs,

Share this post


Link to post
Share on other sites

Não é isso, posta a tela do Hardware Info.

 

Pelo site da Gigabyte é uma iTE IT8213

http://www.gigabyte.com.tw/Products/Mother...me=GA-P55A-UD3P

 

Chipset:

 

1. 6 x SATA 3Gb/s connectors (SATA2_0, SATA2_1, SATA2_2, SATA2_3, SATA2_4, SATA2_5) supporting up to 6 SATA 3Gb/s devices

2. Support for SATA RAID 0, RAID 1, RAID 5, and RAID 10

 

Marvell 9128 chip:

 

1. 2 x SATA 6Gb/s connectors (GSATA3_6, GSATA3_7) supporting up to 2 SATA 6Gb/s devices

2. Support for SATA RAID 0 and RAID 1

 

JMB362 SATA2 chip:

 

1. 2 x eSATA 3Gb/s connectors on the back panel supporting up to 2 SATA 3Gb/s devices

2. Support for SATA RAID 0, RAID 1, and JBOD

 

iTE IT8213 chip:

 

1. 1 x IDE connector supporting ATA-133/100/66/33 and up to 2 IDE devices

 

iTE IT8720 chip:

 

1. 1 x floppy disk drive connector supporting up to 1 floppy disk drive

 

Você precisa da AppleVIAATA.kext e adicionar o device no Info.plist, se não tiver

<key>ITE IT8213 PATA Controller</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.AppleVIAATA</string>
<key>Hardware Name</key>
<string>IT8213 PATA</string>
<key>IOClass</key>
<string>AppleVIAATARoot</string>
<key>IOPCIPrimaryMatch</key>
<string>0x82131283</string>
<key>IOProbeScore</key>
<string>1500</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>Serial ATA</key>
<false/>
</dict>

Share this post


Link to post
Share on other sites
Não é isso, posta a tela do Hardware Info.

 

Pelo site da Gigabyte é uma iTE IT8213

http://www.gigabyte.com.tw/Products/Mother...me=GA-P55A-UD3P

 

 

 

Você precisa da AppleVIAATA.kext e adicionar o device no Info.plist, se não tiver

<key>ITE IT8213 PATA Controller</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.AppleVIAATA</string>
<key>Hardware Name</key>
<string>IT8213 PATA</string>
<key>IOClass</key>
<string>AppleVIAATARoot</string>
<key>IOPCIPrimaryMatch</key>
<string>0x82131283</string>
<key>IOProbeScore</key>
<string>1500</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>Serial ATA</key>
<false/>
</dict>

 

Segue a tela, como vc pediu:

 

screenshot20100523at545.th.png

Share this post


Link to post
Share on other sites

1283:8213 IT8213 IDE Controller

 

Adicione no Info.plist da AppleVIAATA.kext

<key>ITE IT8213 PATA Controller</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.AppleVIAATA</string>
<key>Hardware Name</key>
<string>IT8213 PATA</string>
<key>IOClass</key>
<string>AppleVIAATARoot</string>
<key>IOPCIPrimaryMatch</key>
<string>0x82131283</string>
<key>IOProbeScore</key>
<string>1500</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>Serial ATA</key>
<false/>
</dict>

 

Esse tópico explica como editar o Info.plist

http://www.insanelymac.com/forum/index.php?showtopic=218797

Share this post


Link to post
Share on other sites

qq parada extraia a kext de dentro do cd [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]

 

sempre faco isso

 

se estah funcionando com o cd e pq tah carregando as kexts atraves dele

 

e no [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] jah tem tudo pra sua configuracao

 

:D

Share this post


Link to post
Share on other sites

Maldon, mas a sua controladora é a mesma?

 

Ele escreveu

Somente duas coisas ainda não funfam direito.

1 - Não reconhece o meu gravador de cd/dvd

2 - E o som só entra quando eu dou um boot pelo boot cd do tony

entendo que apenas o som funciona com o boot CD.

Share this post


Link to post
Share on other sites
1283:8213 IT8213 IDE Controller

 

Adicione no Info.plist da AppleVIAATA.kext

<key>ITE IT8213 PATA Controller</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.AppleVIAATA</string>
<key>Hardware Name</key>
<string>IT8213 PATA</string>
<key>IOClass</key>
<string>AppleVIAATARoot</string>
<key>IOPCIPrimaryMatch</key>
<string>0x82131283</string>
<key>IOProbeScore</key>
<string>1500</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>Serial ATA</key>
<false/>
</dict>

 

Esse tópico explica como editar o Info.plist

http://www.insanelymac.com/forum/index.php?showtopic=218797

 

Old, fiz o que vc falou, mas não funcionou.

Como eu não entendo muito disso, eu não sei se coloquei no lugar errado, segue:

 

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

<key>CFBundleDevelopmentRegion</key>

<string>English</string>

<key>CFBundleExecutable</key>

<string>AppleIntelPIIXATA</string>

<key>CFBundleGetInfoString</key>

<string>2.5.1, Copyright Apple Inc. 2000-2009</string>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleIntelPIIXATA</string>

<key>CFBundleInfoDictionaryVersion</key>

<string>6.0</string>

<key>CFBundleName</key>

<string>Apple Intel ICHx/PIIX ATA Driver</string>

<key>CFBundlePackageType</key>

<string>KEXT</string>

<key>CFBundleShortVersionString</key>

<string>2.5.1</string>

<key>CFBundleSignature</key>

<string>????</string>

<key>CFBundleVersion</key>

<string>2.5.1</string>

<key>IOKitPersonalities</key>

<dict>

<key>ESB2 ATA/100</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleIntelPIIXATA</string>

<key>Controller Name</key>

<string>ESB2 ATA/100</string>

<key>IOClass</key>

<string>AppleIntelPIIXATARoot</string>

<key>IOPCIPrimaryMatch</key>

<string>0x269e8086</string>

<key>IOProbeScore</key>

<integer>2000</integer>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>Supported Transfer Modes</key>

<string>0x3f061d</string>

</dict>

<key>ESB2 Serial ATA</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleIntelPIIXATA</string>

<key>Controller Name</key>

<string>ESB2 SATA</string>

<key>IOClass</key>

<string>AppleIntelPIIXATARoot</string>

<key>IOPCIPrimaryMatch</key>

<string>0x26808086</string>

<key>IOProbeScore</key>

<integer>2000</integer>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>Serial ATA</key>

<true/>

<key>Supported Transfer Modes</key>

<string>0x3f061d</string>

</dict>

<key>ICH7 ATA/100</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleIntelPIIXATA</string>

<key>Controller Name</key>

<string>ICH7 ATA/100</string>

<key>IOClass</key>

<string>AppleIntelPIIXATARoot</string>

<key>IOPCIPrimaryMatch</key>

<string>0x27df8086</string>

<key>IOProbeScore</key>

<integer>2000</integer>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>Supported Transfer Modes</key>

<string>0x3f061d</string>

</dict>

<key>ICH7 Serial ATA</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleIntelPIIXATA</string>

<key>Controller Name</key>

<string>ICH7 SATA</string>

<key>IOClass</key>

<string>AppleIntelPIIXATARoot</string>

<key>IOPCIPrimaryMatch</key>

<string>0x27c08086</string>

<key>IOProbeScore</key>

<integer>2000</integer>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>Serial ATA</key>

<true/>

<key>Supported Transfer Modes</key>

<string>0x3f061d</string>

</dict>

<key>ITE IT8213 PATA Controller</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleVIAATA</string>

<key>Hardware Name</key>

<string>IT8213 PATA</string>

<key>IOClass</key>

<string>AppleVIAATARoot</string>

<key>IOPCIPrimaryMatch</key>

<string>0x82131283</string>

<key>IOProbeScore</key>

<string>1500</string>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>Serial ATA</key>

<false/>

</dict>

<key>ICH7-M Serial ATA</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleIntelPIIXATA</string>

<key>Controller Name</key>

<string>ICH7-M SATA</string>

<key>IOClass</key>

<string>AppleIntelPIIXATARoot</string>

<key>IOPCIPrimaryMatch</key>

<string>0x27c48086</string>

<key>IOProbeScore</key>

<integer>2000</integer>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>Serial ATA</key>

<true/>

<key>Supported Transfer Modes</key>

<string>0x3f061d</string>

</dict>

<key>ICH8 ATA/100</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleIntelPIIXATA</string>

<key>Controller Name</key>

<string>ICH8 ATA/100</string>

<key>IOClass</key>

<string>AppleIntelPIIXATARoot</string>

<key>IOPCIPrimaryMatch</key>

<string>0x28508086</string>

<key>IOProbeScore</key>

<integer>2000</integer>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>Supported Transfer Modes</key>

<string>0x3f061d</string>

</dict>

<key>ICH8 Serial ATA</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleIntelPIIXATA</string>

<key>Controller Name</key>

<string>ICH8 SATA</string>

<key>IOClass</key>

<string>AppleIntelPIIXATARoot</string>

<key>IOPCIPrimaryMatch</key>

<string>0x28288086</string>

<key>IOProbeScore</key>

<integer>2000</integer>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>PCS Port Map</key>

<data>

kgGTAZICkwKSBJMEkgiTCA==

</data>

<key>Serial ATA</key>

<true/>

<key>Supported Transfer Modes</key>

<string>0x3f061d</string>

</dict>

<key>Parallel ATA Channel Driver</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleIntelPIIXATA</string>

<key>IOClass</key>

<string>AppleIntelPIIXPATA</string>

<key>IOProbeScore</key>

<integer>800</integer>

<key>IOProviderClass</key>

<string>AppleIntelPIIXATAChannel</string>

<key>Serial ATA</key>

<false/>

</dict>

<key>Serial ATA Channel Driver</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleIntelPIIXATA</string>

<key>IOClass</key>

<string>AppleIntelICHxSATA</string>

<key>IOProbeScore</key>

<integer>1000</integer>

<key>IOProviderClass</key>

<string>AppleIntelPIIXATAChannel</string>

<key>Serial ATA</key>

<true/>

</dict>

</dict>

<key>OSBundleLibraries</key>

<dict>

<key>com.apple.iokit.IOATAFamily</key>

<string>1.5.0d1</string>

<key>com.apple.iokit.IOPCIFamily</key>

<string>1.1.0</string>

<key>com.apple.kpi.iokit</key>

<string>9.0.0</string>

<key>com.apple.kpi.libkern</key>

<string>9.0.0</string>

<key>com.apple.kpi.mach</key>

<string>9.0.0</string>

</dict>

<key>OSBundleRequired</key>

<string>Local-Root</string>

</dict>

</plist>

Share this post


Link to post
Share on other sites

Você tem que adicionar na AppleVIAATA.kext, não na AppleIntelPIIXATA.kext como no exemplo do tópico.

 

Mude o nome da kext no comando, bem como a localização.

 

Pode estar em /S/L/E ou em /E/E.

Share this post


Link to post
Share on other sites
Você tem que adicionar na AppleVIAATA.kext, não na AppleIntelPIIXATA.kext como no exemplo do tópico.

 

Mude o nome da kext no comando, bem como a localização.

 

Pode estar em /S/L/E ou em /E/E.

 

 

Old, esta kext não estava nem na /S/L/E ou na /E/E.

Eu fucei na internet, baixei, editei e coloquei na /S/L/E, reparei as permissões e o cache.

 

Depois de restartar a máquina, eu inseri um dvd e o motor do cd/dvd fez aquele barulho

característico que está lendo a mídia, mas não montou.

 

Quanto ao som, eu tentei todas as possibilidades e não rolou. ;-(

 

Com a kext da voodoo, depois que eu reparo as permissões, aparece isso.

 

screenshot20100523at740.th.png

 

E com a outra, não acontece nada.

Share this post


Link to post
Share on other sites
Se deu esse erro é porque você não reparou as permissões corretamente. Veja nesse tópico, faça passo a passo que não tem erro

http://www.insanelymac.com/forum/index.php?showtopic=209655

 

Faça o mesmo procedimento com essa AppleVIAATA, já editei o plist

http://www.mediafire.com/?uzn0ojjtyuc

 

Obrigado por ter editado, Old. Mas infelizmente não funcionou. Eu segui a risca o tutorial

e testei a kext antes, não deu erro, mas não funfou. :-(

 

A da voodoo deu kernel panic. :-(

Share this post


Link to post
Share on other sites

O que aconteceu quando você rodou o kextload com a AppleVIAATA?

 

Sobre a VoodooHDA, certifique-se de estar usando a versão para Snow e tente remover a AppleHDA.

Share this post


Link to post
Share on other sites
O que aconteceu quando você rodou o kextload com a AppleVIAATA?

 

Sobre a VoodooHDA, certifique-se de estar usando a versão para Snow e tente remover a AppleHDA.

 

 

Não aconteceu nada, não apareceu mensagem nenhuma.

Quanto a voodoohda, foi a que vc postou no outro link, para snow. E eu removi a applehda antes de

fazer a inserção da voodoohda.

Share this post


Link to post
Share on other sites
Você moveu a AppleVIAATA para /S/L/E e atualizou o cache?

 

Estranho a VoodooHDA dar kernel panic, tem como você postar uma foto da tela?

 

Você pode tentar outra versão, como essa sugerida pelo Macmarques

http://www.insanelymac.com/forum/index.php...t&p=1469048

 

Se der novamente na hora que eu mandar restartar, eu tiro uma foto e te mando.

 

Se der novamente na hora que eu mandar restartar, eu tiro uma foto e te mando.

 

Old, esse voodo do marques funcionou perfeitamente, de prima!

Foi só instalar e pronto.

 

Acho que a única coisa pendente no meu sistema agora é o lance do cd/dvd.

 

valeu mesmo pela força!

Share this post


Link to post
Share on other sites
Onde você instalou a AppleVIAATA? Após reiniciar, rode o comando kextstat no terminal e veja se ela está carregada.

 

Eu não sei bem se é isso:

 

Last login: Sun May 23 22:48:41 on console

Joaquim-Saraivas-iMac:~ touche$ kextstat | grep AppleVIAATA

37 0 0xffffff7f807af000 0x7000 0x7000 com.apple.driver.AppleVIAATA (1.0.2) <35 9 5 4 3>

Joaquim-Saraivas-iMac:~ touche$

 

está certo?

Share this post


Link to post
Share on other sites

Ela está carregada.

 

Tem certeza de que o drive de DVD está ligado na IDE?

 

As outras controladoras (JMicron e Marvell) têm porta IDE?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×