Jump to content
KeFfBoY

Stop OSX from mounting the Windows Drives?..

16 posts in this topic

Recommended Posts

Hi everyone!

 

I have an annoying problem I'd want to get rid of.

 

Every time I start OSX it mounts the Windows7 disc, both partitions, and then I get an error that one of them isn't readable (the partition with Windows7 bootfiles on I guess). This is kinda annoying. ( I have Windows7 on one harddrive and OSX on another )

 

Is it any way to stop OSX from mounting this disc at all? I'd want it to be ejected by default.

 

Thanks in advance.

Anton

Share this post


Link to post
Share on other sites
Advertisement

I haven't found the fix yet for this one but I imagine it will most likely involve editing a system file. I too keep getting the same error message. I've gotten use to it but it be nice to rid of it like you say.

 

 

 

Hi everyone!

 

I have an annoying problem I'd want to get rid of.

 

Every time I start OSX it mounts the Windows7 disc, both partitions, and then I get an error that one of them isn't readable (the partition with Windows7 bootfiles on I guess). This is kinda annoying. ( I have Windows7 on one harddrive and OSX on another )

 

Is it any way to stop OSX from mounting this disc at all? I'd want it to be ejected by default.

 

Thanks in advance.

Anton

Share this post


Link to post
Share on other sites

I'm no expert on this, but I would wonder why the errors are happening in the first place. Doesn't happen to me, and I've not seen any other posts on that subject. Most people here have Windows and OS X installed - obviously!

Share this post


Link to post
Share on other sites
I'm no expert on this, but I would wonder why the errors are happening in the first place. Doesn't happen to me, and I've not seen any other posts on that subject. Most people here have Windows and OS X installed - obviously!

Share this post


Link to post
Share on other sites

Try this tip here, It'll not block OsX from mounting the partitions though:

Go to System Preferences > Spotlight. Once there, select the Privacy Tab. Then click on the + sign to add those partitions that are making trouble to you. Not sure if it'd fix something, but now spotlight will not attempt to search on those partitions. Maybe related to the issue you guyz are having, and maybe not.

 

Greetz

Share this post


Link to post
Share on other sites

You can try this. Open up Disk Utility and grab the UUID for your windows drive or drives.

 

Now open up a terminal window and do

 

 

sudo touch /etc/fstab

sudo nano /etc/fstab

 

And enter a line like this for each of the partitions you don't want to mount on start up

 

UUID=<paste UUID here> none ntfs ro,noauto

 

Use ctrl + X and then hit "y" to save the file. Reboot and let me know if it works ;)

Share this post


Link to post
Share on other sites
You can try this. Open up Disk Utility and grab the UUID for your windows drive or drives.

 

Now open up a terminal window and do

 

 

sudo touch /etc/fstab

sudo nano /etc/fstab

 

And enter a line like this for each of the partitions you don't want to mount on start up

 

UUID=<paste UUID here> none ntfs ro,noauto

 

Use ctrl + X and then hit "y" to save the file. Reboot and let me know if it works :P

Let's hope that works for him, but why is he getting these errors? It's not normal.

Share this post


Link to post
Share on other sites
Every time I start OSX it mounts the Windows7 disc, both partitions, and then I get an error that one of them isn't readable (the partition with Windows7 bootfiles on I guess). This is kinda annoying. ( I have Windows7 on one harddrive and OSX on another )

 

Install Testdisk on your hackintosh and have it check your NTFS partitions. It should give you an idea of what's wrong.

http://www.cgsecurity.org/wiki/TestDisk

Share this post


Link to post
Share on other sites

Editing /etc/fstab generally works, unless you have Paragon NTFS installed. If you "never" want to be able to mount the windows partition in OS X ( if you do mount it, don't mount it rw too often, people tell tales of corruption and I have has this happen myself) then you can add a launchd daemons that will unmount the specified file system whenever a mount event occurs.

 

For the later, do the following:

 

Make a file /Users/Shared/unmount (or w/e else you please) with the following content:

 

#!/bin/bash

diskutil unmount <insert UUID of Windows partition or /dev path>

 

Next in terminal: chmod +x /Users/Shared/unmount

 

Then, put a file /Users/<your user>/Library/LaunchAgents/unmount.plist with the following content:

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/
PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Label</key>
	<string>unmount</string>
	<key>ProgramArguments</key>
	<array>
			<string>/Users/Shared/unmount</string>
	</array>
	<key>StartOnMount</key>
	<true/>
	<key>RunAtLoad</key>
	<true/>
</dict>
</plist>

 

Reboot and your windows 7 partition will always unmount as you are using one user (if you have multiple users, you can put the second file in /Library/LaunchDaemons/)

 

To fix your mounting errors, run chkdsk on you windows partitions, it might help unless there is that annoying partition misalignment that windows loves so much.

 

You can also do similar things with /etc/rc.local I believe. Also, for the love of god learn to use Google or any other search engine for that matter (searching the title of this topic will provide you with exactly what you need).

Share this post


Link to post
Share on other sites
Hi everyone!

 

I have an annoying problem I'd want to get rid of.

 

Every time I start OSX it mounts the Windows7 disc, both partitions, and then I get an error that one of them isn't readable (the partition with Windows7 bootfiles on I guess). This is kinda annoying. ( I have Windows7 on one harddrive and OSX on another )

 

Is it any way to stop OSX from mounting this disc at all? I'd want it to be ejected by default.

 

Thanks in advance.

Anton

-----------

You can try this. Open up Disk Utility and grab the UUID for your windows drive or drives.

 

Now open up a terminal window and do

 

 

sudo touch /etc/fstab

sudo nano /etc/fstab

 

And enter a line like this for each of the partitions you don't want to mount on start up

 

UUID=<paste UUID here> none ntfs ro,noauto

 

Use ctrl + X and then hit "y" to save the file. Reboot and let me know if it works :)

----------------

Try this tip here, It'll not block OsX from mounting the partitions though:

Go to System Preferences > Spotlight. Once there, select the Privacy Tab. Then click on the + sign to add those partitions that are making trouble to you. Not sure if it'd fix something, but now spotlight will not attempt to search on those partitions. Maybe related to the issue you guyz are having, and maybe not.

 

Greetz

--------------------

I'm no expert on this, but I would wonder why the errors are happening in the first place. Doesn't happen to me, and I've not seen any other posts on that subject. Most people here have Windows and OS X installed - obviously!

------------

Hi There all.

 

As for all the answers, they all seem fine when you are running Leopard.

But not Snow Leopard with Paragon NTFS

 

@KeFfBoY

What partition KeFfBoY and WE all are talking about hiding is the "System Reserved" partition that only Windows 7 creates, when you perform a new, clean, re-partitioned install. That is its "EFI" or rather boot partition.

 

@ rfuilrez

About the TIP using and editing FSTAB file, that works only when you do not have ANY NTFS Read-Write drivers installed. And there are only 3 of them -> NTFs3G+MacFuse, or Tuxera, or Paragon NTFS for Mac.

In either of the three options, you CAN NOT hide the System Reserved Partition.

 

@imacken ----> You are probably not using Windows 7 or didn't create a partition using Windows 7 boot Disk. You must have installed Windows 7 over an existing Windows Xp or Vista Install Partition. The either of the latter two Operating Systems DO NOT create their Boot partitions.

 

@valv, Hi There!

The Spotlight thing doesn't work. That works only by NOT indexing the added/blocked partition.

 

Till next Time. Njoi!

 

Regards,

Freaky Chokra :)

-------------------

EDIT

Will be checking out MEmorial's suggestion, and posting the results.

 

Editing /etc/fstab generally works, unless you have Paragon NTFS installed. If you "never" want to be able to mount the windows partition in OS X ( if you do mount it, don't mount it rw too often, people tell tales of corruption and I have has this happen myself) then you can add a launchd daemons that will unmount the specified file system whenever a mount event occurs.

 

For the later, do the following:

 

Make a file /Users/Shared/unmount (or w/e else you please) with the following content:

 

#!/bin/bash

diskutil unmount <insert UUID of Windows partition or /dev path>

 

Next in terminal: chmod +x /Users/Shared/unmount

 

Then, put a file /Users/<your user>/Library/LaunchAgents/unmount.plist with the following content:

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/
PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Label</key>
	<string>unmount</string>
	<key>ProgramArguments</key>
	<array>
			<string>/Users/Shared/unmount</string>
	</array>
	<key>StartOnMount</key>
	<true/>
	<key>RunAtLoad</key>
	<true/>
</dict>
</plist>

 

Reboot and your windows 7 partition will always unmount as you are using one user (if you have multiple users, you can put the second file in /Library/LaunchDaemons/)

 

To fix your mounting errors, run chkdsk on you windows partitions, it might help unless there is that annoying partition misalignment that windows loves so much.

 

You can also do similar things with /etc/rc.local I believe. Also, for the love of god learn to use Google or any other search engine for that matter (searching the title of this topic will provide you with exactly what you need).

Edited by Freaky Chokra

Share this post


Link to post
Share on other sites
@imacken ----> You are probably not using Windows 7 or didn't create a partition using Windows 7 boot Disk. You must have installed Windows 7 over an existing Windows Xp or Vista Install Partition. The either of the latter two Operating Systems DO NOT create their Boot partitions.

 

Regards,

Freaky Chokra :superman:

Thanks for that, but I'm not sure to what you are referring. I don't have any issues, I was simply saying that the OP shouldn't be having these issues in the first place. Just seems that stopping it mounting was just hiding the issue.

BTW, yes I do use Windows 7. If you are referring to the 'System Reserved' partition, then I got rid of that some time ago. However, with or without it, I don't have the issue mentioned by the OP and I haven't seen it coming up from anyone else here.

Share this post


Link to post
Share on other sites
Thanks for that, but I'm not sure to what you are referring. I don't have any issues, I was simply saying that the OP shouldn't be having these issues in the first place. Just seems that stopping it mounting was just hiding the issue.

BTW, yes I do use Windows 7. If you are referring to the 'System Reserved' partition, then I got rid of that some time ago. However, with or without it, I don't have the issue mentioned by the OP and I haven't seen it coming up from anyone else here.

 

If you have Win7 installed on a separate physical HD the Win installer creates a 200MB boot partition that OS X see's and labels 'System reserved'.

 

This doesn't happen when both OS X and Win7 are in separate partitions on the same physical disk.

 

I have tried (and failed) to install windows without it creating the boot partition, but have failed (miserably) so far. Any suggestions?

Share this post


Link to post
Share on other sites
...Win installer creates a 200MB boot partition that OS X see's and labels 'System reserved'.
Use the Gparted Live CD (or other similar tool) to create partition layout for Windows. Do it before installing Windows. Or check this.

Share this post


Link to post
Share on other sites
Use the Gparted Live CD (or other similar tool) to create partition layout for Windows. Do it before installing Windows. Or check this.

 

Awesome thanks!! Although Now I have to re-install windows again!! :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×