Jump to content
InsanelyMac Forum
kizwan

Sony Vaio VPCF115FM Discussion: DSDT Injection

Recommended Posts

I ran pfix just after I saw that and still nothing....maybe i;m looking in the wrong place for the errors b/c I notice some sound assertation errors in verbose boot....any idea where I can find those errors in console?

..............

You can look in kernel.log or system.log files. If HDEF is properly injected by DSDT, you should see audio devices in System Profiler. Even if audio devices appear in System Profiler, it doesn't means audio will works but we can use it as an indicator that HDEF does injected properly by DSDT (which is very important). If it does, we can focus on the legacy kext & the modified AppleHDA.kext file. Both kext file need to have proper ownership & permissions.

Share this post


Link to post
Share on other sites
Advertisement
You can look in kernel.log or system.log files. If HDEF is properly injected by DSDT, you should see audio devices in System Profiler. Even if audio devices appear in System Profiler, it doesn't means audio will works but we can use it as an indicator that HDEF does injected properly by DSDT (which is very important). If it does, we can focus on the legacy kext & the modified AppleHDA.kext file. Both kext file need to have proper ownership & permissions.

 

Okay I'll try and get that to you after my orgo chem lecture I'll post what I have as soon as I can.

Share this post


Link to post
Share on other sites
Hey Mac Man 50,

 

Just checked on mine, it's still in China. : ( It's due to arrive on the 15th it says now. Once I get mine, I will get working on it right away. First the backups AND creation of the restore discs (great job by the way), then I will take out the factory drive an put in a spare hard drive to start experimenting with OS X and creating the new documentation.

 

I'll let you know once I get it in and once I start the new thread.

 

Mammoth

 

Thats good to know. It should arrive to you sooner than later. Hopefully, Friday :)

Share this post


Link to post
Share on other sites

Hi Mammoth,

 

I wanted to try on the dv8t while you wait to get yours.

And, I should say things are not looking good.

 

I tried the following:

 

1. Legacy empire efi v108, regular empire

efi v108

 

didn't work at all. Wrote some text on the white background

and stopped with a kernel panic.

 

2. Tonyosx86p55.iso

 

same stuff. Wrote lot of text and stopped.

 

3. [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] supported 2.0

had little hope but have to pass these before selecting

mac os x install DVD. cpus=1 busratio=12 fsb=133 maxmem=1024 -v -x

 

It went to the install screen and then it is is very slow. Mouse response is fine but keyboard response was very slow. Screen also was cut in pieces. Don't why.

 

 

I tried all combinations and also tried these:

busratio=20 Graphics Mode=1920x1080x32.

 

 

So, at this point my only hope is you getting dv8t and trying it out. I think you're more knowledgeable than me and hope to fix this. As a fallback scenario, I can get dv7t (Ready to ship) as most of the folks are using dv7t. But, only concern getting dv7t is the ready to ship model is dv7t-3180us and people have experimented with dv7t-3085dx. Don't know what is the difference between these two.

 

Hoping for the best from you.

 

Thanks.

Share this post


Link to post
Share on other sites

Macman,

 

as off topic as you last post was, to be able to install it with empire efi requires you booting up with -s boot flag and manually mounting the drive if I recall correctly. Try using the boot cd mammoth made as it will have the correct kernel in it and I believe it should be the same chipset as the vaios. Anyways I am about to finally check this audio for the vaio.

 

 

EDIT: kizwan here is my version of the DSDT file.

 

http://www.mediafire.com/?oqtio3mhnlo

Share this post


Link to post
Share on other sites

Hi Phantom,

 

Thanks for your assistance.

 

So, you're saying use boot flag -s in the Legacy Empire EFI v108 boot CD when it displays the UI? and also where is the mammoth boot cd? Please let me know.

 

Thanks.

Share this post


Link to post
Share on other sites

I tried MammothVPCF115FMv1.20 boot CD on dv8t and it is not even booting. I'm seeing endless blinking cursor and after 10 times, Windows 7 boots.

Share this post


Link to post
Share on other sites
I tried MammothVPCF115FMv1.20 boot CD on dv8t and it is not even booting. I'm seeing endless blinking cursor and after 10 times, Windows 7 boots.

 

 

Hi Mac Man,

 

let's move this discusion over to my VAIO thread.

 

The Mammoth Boot CD has DSDT for the VAIO. I'll make one later without it and have you try it.

 

Please only respond to this on the VAIO thread (where you got the Mammoth Boot CD from).

Share this post


Link to post
Share on other sites

 

 

I tested the above, it doesn't work due to our EDID no being picked up correctly, I've tried with windows and in ubuntu and no luck...

 

Kizwan anything new on the audio end?

Share this post


Link to post
Share on other sites
I tested the above, it doesn't work due to our EDID no being picked up correctly, I've tried with windows and in ubuntu and no luck...

 

Kizwan anything new on the audio end?

Sorry Phantom. I'm busy lately. I haven't take a look into your DSDT yet. I'll try look into it a.s.a.p. :mellow:

Share this post


Link to post
Share on other sites

Guys.... seriously,

 

DUMP YOUR VIOS ON EBAY!

 

Mine sold in like 3 days with Buy it Now. I got my HP DV8t in TODAY and it's totally awesome. 18" 1920x1080 display, it can have 2 hard drives installed (There are 2 bays for them)!

 

I'm still working on it, but here is what I have so far: booting OS X 10.6.3 from the hard drive, LAN fully working using an R1000 kext, it doesn't freak out when you click on "About This Mac", Disc Burning / DVD drive fully working, Firewire working, SATA, USB, Power, all working. Get this, the ExpressCard slot works!!!

 

Oh, I almost forgot: FULL VIDEO SUPPORT! Yep, 1920x1080, QE/CI to the max!

 

Needing work:

 

- Sound

- Bluetooth

- Wi-Fi

- MC slot

- Boot with more than 1 CPU (currently must use cpus=1, or KP)

 

Dump your PHONY, while you still can!

 

Mammoth

 

(Full guides, Boot CD, and new thread... coming soon!)

 

 

 

{censored}! Earthquake right now in Hollywood CA!

Share this post


Link to post
Share on other sites

Mammoth,

 

That is a excellent news. I'm feverishly waiting for your Boot CD to begin with. I definitely need your help. I have sent you private messages.

 

To get me running quickly, if you can just list the steps while I wait for your guide, that would be great.

 

For the WiFi, it may not work as it is a Intel one. But, I read elsewhere that you can get Dell dw1500 and insert it in the second PCI-e slot and it is recognized as Airport by SL.

 

Btw, it seems the earthquake was centered around San Diego and luckily, there seems be no damage. :P

 

Thanks.

Share this post


Link to post
Share on other sites

Dispite all the negative things about it, most people hackintosh not b/c of the sake of having a fake mac, its a learning experience, you learn not only more about alternative OSes, but about the actual hardware within a computer/laptop. Look at the linux world for vaios, it used to give them alot of issues but after a while they were able to get things running correctly.

 

All it really takes is some creativity to get these bad boy's running which is what this whole thread was about, finding ways to get this laptop if not all vaios to function properly. whether that will take a new driver for snc or simple dsdt mods we will see later on. Anyways I'm going to attempt to install SL on my tablet and look into kizwans dsdt audio fix and see if we can get audio working somehow later all

Share this post


Link to post
Share on other sites

@Mammoth

 

You know this topic is about a Sony Vaio. You now have a HP and mention it, but don't you think it is too much to now "hijack"this topic and put a guide for your HP in this topic? Make a seperate topic for it post the stuff there, now you are just confusing people and making a mess of this topic.

 

[edit]

I should have sended a pm to Mammoth, but didn't know how. I will soon delete this post, as it is off topic and makes a mess.

Share this post


Link to post
Share on other sites

Hello guys

 

I'm n00b and I have a problem with my BIOS. I want to make a hackintosh with my Vaio laptop but I don't know what version I've to install. Moreover I read many topics and the first thing to do seems to put the ACPI mode in the BIOS but Sony lock this in the BIOS since several years apparently. I found a tuto

http://forum.notebookreview.com/sony/18922...aio-laptop.html

who seems to be good but I'm wondering if it's necessary because in Everest log the ACPI is activated. Or can we make without ACPI mode with a handmade DSDT?

All my configuration is at the bottom and I precise that in a first time I want to install Snow Leopard on my External HDD to try if that's good and after make a dual boot with seven and if possible triple boot with opensuse.

PS: If you have any link to learn more about hackintosh, I'll take it!

 

Enjoy :thumbsup_anim:

Share this post


Link to post
Share on other sites

Dear Vaio VPCF115FM Owners ;)

 

i need help here. i bought my laptop from best buy but i lost my recovery partition and DVDs , so would someone please create iso files for his/her recovery dvds and send them to me or upload them to 4shared or rapidshare :????

 

 

 

thanks in advance,

 

my name is selim and my hotmail is hokaselim@hotmail.com

Share this post


Link to post
Share on other sites
Kizwan Here is the kernel log for v3 with my dsdt:

kernel.txt

 

tell me if I can do anything.

Hi Phantom, sorry for late reply. I see a lot of error message regarding AppleHDA in the log file. Can you post the System Profiler dump (with V3 kext loaded)? I can't explain why it is not working. Did you replaced your AppleHDA.kext with the modified one in the /S/L/E?

 

EDIT: Can you re-send kernel.log & system.log to me? Boot with V3 kext file & copy immediately both kernel.log & system.log to desktop.

 

I see you only put this in DSDT:-

				Method (_DSM, 4, NotSerialized)
			{
				Store (Package (0x04)
					{
						"layout-id", 
						Buffer (0x04)
						{
							0x0C, 0x00, 0x00, 0x00
						}, 

						"PinConfigurations", 
						Buffer (Zero) {}
					}, Local0)
				DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
				Return (Local0)
			}

I don't think it will work. Did you try copy my _DSM code to your DSDT?

Share this post


Link to post
Share on other sites
;) I would love to hear someone who got this to work! i tried literally everything and now im convinced that only DSDT can solve it!

Share this post


Link to post
Share on other sites
;) I would love to hear someone who got this to work! i tried literally everything and now im convinced that only DSDT can solve it!

 

 

It's a {censored}. it works just with external soundcard, external ethernet, external monitor..

Share this post


Link to post
Share on other sites
It's a {censored}. it works just with external soundcard, external ethernet, external monitor..

 

 

Yep its the same results with me! I had tried to install snow on my older vaio and at first it would never work with the display, just got a fuzzy or no screen. but eventually i found out i had to set the resolution manually.. but with this laptop it is again diferent.. sony sure sux! i still hope that maybe its a simple trick were overlooking to fix the display, or to fool it into working like i did on my vgn-fz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×