Jump to content
kizwan

Sony Vaio VPCF115FM Discussion: DSDT Injection

787 posts in this topic

Recommended Posts

Well i've just installed SL again on my laptop, and here is dsdt generated from it:

 

dsdt.zip

I forgot one thing, sorry. :P Please provide me your graphic card ROM file. You can obtain it using GPU-Z application in windows. This is to construct correct NVCAP. Do you have display on internal LCD with both GraphicsEnabler=No & GraphicsEnabler=Yes? If yes, I think I can get it to works.

 

I'll start working on it. I hope you have better luck than other VAIO owner. :D

Share this post


Link to post
Share on other sites
Advertisement

Hi Guys,

 

I do have a Vaio VPCF115FM, but never tried to install SL on it.

If i can help you in some way, please let me know!!

 

Best regards

Share this post


Link to post
Share on other sites
Sony Vaio VPCF115FM Specification:-

Intel® Core™ i7 - 720QM

Installed: 6GB (4GB+2GB)

Maximum: 8GB

Type/Speed: DDR3/1333MHz

NVIDIA® GeForce® GT 330M GPU w/ 1024 MB

Marvell® Yukon 88E8040 PCI-E Gigabit Ethernet Controller

Realtek ALC275 audio

 

Mac OS X Version:-

Snow Leopard 10.6.3 with MacBook Pro 3.1 update.

 

Objective: Generate modified DSDT to get at least the NVIDIA GeForce GT 330M & Realtek ALC275 audio working.

 

EDIT: For now, fix for Realtek ALC275 is not yet implemented in any test DSDTs.

Test DSDTs

NVIDIA GeForce GT 330M injection:-

http://www.mediafire.com/?mctzqehvmzx

http://www.mediafire.com/?xmzugwtm0tg

Test User: Mammoth

kizwan

this is the raw edid obtained from softmccs under Windows 7. I hope this help You.

Regards

MS_0025.txt

Share this post


Link to post
Share on other sites
Thank you for the results. :PYour F11Z1E also have NVIDIA GeForce GT 330M graphic card? If yes, did you install the MacBookPro 3.1 update? Please provide me your DSDT & ioreg dump (using IORegistryExplorer app). Also "Raw data" using MonInfo application in windows.

 

EDIT: I already read your post over here. Have you tried the latest Empire EFI v1.085 R2 with 10.6.3 + MacBookPro 3.1 update + (Tonymac's NVEnabler or ATY_init.kext)? It have framebuffer disabler & I think maybe you can get display on internal LCD but QE & CI might not work.

 

 

I think it is better for me to wait for you to install leopard first. ;)

 

So the files got from MonInfo attached.

I will boot in mac OS and upload the other ones too...

 

I have tried Empire EFI v1.085 R2, but it gets installation failed ... I have also followed the instructions given by extraspeed step by step 9ATY_Init modified) I have long discussions with extraspeed on Google Wave maybe you want to add you to the wave.

 

I can display on internal LCD but not 1920x1080 and not QE & CI

dspinfo.zip

Kostas___s_Mac_Pro.zip

dsdt.aml.zip

Share this post


Link to post
Share on other sites
Hi Guys,

 

I do have a Vaio VPCF115FM, but never tried to install SL on it.

If i can help you in some way, please let me know!!

 

Best regards

Thank you. If you can spend some of your time, you can test the modified DSDT posted at post #1. Or better, you can provided me "Raw data" taken in windows using MonInfo application. B)

 

this is the raw edid obtained from softmccs under Windows 7. I hope this help You.

Regards

Thank you for the EDID value. :rolleyes:

 

So the files got from MonInfo attached.

I will boot in mac OS and upload the other ones too...

 

I have tried Empire EFI v1.085 R2, but it gets installation failed ... I have also followed the instructions given by extraspeed step by step 9ATY_Init modified) I have long discussions with extraspeed on Google Wave maybe you want to add you to the wave.

 

I can display on internal LCD but not 1920x1080 and not QE & CI

Your dump file is identical with Mammoth's VPCF115FM. However I will post the modified DSDT for VPCF11Z1E very soon (in a couple of minutes).

Share this post


Link to post
Share on other sites
Thank you. If you can spend some of your time, you can test the modified DSDT posted at post #1. Or better, you can provided me "Raw data" taken in windows using MonInfo application. B)

 

 

Thank you for the EDID value. :rolleyes:

 

 

Your dump file is identical with Mammoth's VPCF115FM. However I will post the modified DSDT for VPCF11Z1E very soon (in a couple of minutes).

 

 

OK I am here to try.

Share this post


Link to post
Share on other sites

@gi�49 & PlumberGr,

Please try this modified DSDT with EDID injection for Sony VAIO VPCF11Z1E:-

http://www.mediafire.com/?yjiy1zgntom

 

@Mammoth & other Sony Vaio VPCF115FM owner, modified DSDT with EDID injection:-

http://www.mediafire.com/?mwtezd0nady

(EDID data is taken from VPCF11Z1E)

 

Please post here the result. If possible ioreg dump using IORegistryExplorer application. Good luck. B)

Share this post


Link to post
Share on other sites
@gi�49 & PlumberGr,

Please try this modified DSDT with EDID injection for Sony VAIO VPCF11Z1E:-

http://www.mediafire.com/?yjiy1zgntom

 

@Mammoth & other Sony Vaio VPCF115FM owner, modified DSDT with EDID injection:-

http://www.mediafire.com/?mwtezd0nady

(EDID data is taken from VPCF11Z1E)

 

Please post here the result. If possible ioreg dump using IORegistryExplorer application. Good luck. :rolleyes:

Share this post


Link to post
Share on other sites
@gi�49 & PlumberGr,

Please try this modified DSDT with EDID injection for Sony VAIO VPCF11Z1E:-

http://www.mediafire.com/?yjiy1zgntom

 

@Mammoth & other Sony Vaio VPCF115FM owner, modified DSDT with EDID injection:-

http://www.mediafire.com/?mwtezd0nady

(EDID data is taken from VPCF11Z1E)

 

Please post here the result. If possible ioreg dump using IORegistryExplorer application. Good luck. :rolleyes:

 

 

again half Accelerated.

Kostas___s_Mac_Pro.zip

Archive.zip

Share this post


Link to post
Share on other sites
again half Accelerated.

I assume no display at internal LCD when booting with GraphicsEnabler=No, right?

 

Can you try change the NVCAP & try one by one? Edit the dsdt & change the NVCAP.

1) Change the "7e" (OUTPUT GROUP 2) to "01". Compile & test.

2) (Make sure OUTPUT GROUP 2 is "7e" in this test) Change the "01" (OUTPUT GROUP 1) to "02", "03", "07" & "7f". Compile & test each of it.

 

FYI:-

0x04, 0x00, 0x00, 0x00, 0x00, 0x00, 0x01, 0x00, 0x7e, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x0a, 0x00, 0x00, 0x00, 0x00

The red, blue & green are OUTPUT GROUP 3, OUTPUT GROUP 1 & OUTPUT GROUP 2 respectively.

Share this post


Link to post
Share on other sites
HI Kizwan,

 

I have Sony VPC-F11S1E notebook.

Can you modify my DSDT?

 

thanks

Yes I can but I think it best to wait for results from Mammoth, gi�49 & PlumberGr. If the result is promising, I will modify your DSDT.

Share this post


Link to post
Share on other sites
@gi�49 & PlumberGr,

Please try this modified DSDT with EDID injection for Sony VAIO VPCF11Z1E:-

http://www.mediafire.com/?yjiy1zgntom

 

@Mammoth & other Sony Vaio VPCF115FM owner, modified DSDT with EDID injection:-

http://www.mediafire.com/?mwtezd0nady

(EDID data is taken from VPCF11Z1E)

 

Please post here the result. If possible ioreg dump using IORegistryExplorer application. Good luck. ;)

works only external display, connected via HDMI. resolution 1920x1080x32. NO INTERNAL DISPLAY.

posted IOREGISTRY, edid (softmmcs) sony, display and both.

Regards

edid_sony_e_display.rar

Share this post


Link to post
Share on other sites

I post also the softmccs log . Internal display and sony(connected via HDMI)

Regards

 

log from softmccs under W7

 

Sony Vaio VPCF115FM Specification:-

Intel® Core™ i7 - 720QM

Installed: 6GB (4GB+2GB)

Maximum: 8GB

Type/Speed: DDR3/1333MHz

NVIDIA® GeForce® GT 330M GPU w/ 1024 MB

Marvell® Yukon 88E8040 PCI-E Gigabit Ethernet Controller

Realtek ALC275 audio

 

Mac OS X Version:-

Snow Leopard 10.6.3 with MacBook Pro 3.1 update.

 

Objective: Generate modified DSDT to get at least the NVIDIA GeForce GT 330M & Realtek ALC275 audio working.

 

EDIT: For now, fix for Realtek ALC275 is not yet implemented in any test DSDTs.

Test DSDTs

NVIDIA GeForce GT 330M injection:-

http://www.mediafire.com/?mctzqehvmzx

http://www.mediafire.com/?xmzugwtm0tg

http://www.mediafire.com/?mwtezd0nady (EDID injection)

Test User: Mammoth

kizwan

log from softcmms

 

I post also the softmccs log . Internal display and sony(connected via HDMI)

Regards

 

log from softmccs under W7

 

 

log from softcmms

softMCCS.rar

Share this post


Link to post
Share on other sites
works only external display, connected via HDMI. resolution 1920x1080x32. NO INTERNAL DISPLAY.

posted IOREGISTRY, edid (softmmcs) sony, display and both.

Regards

Can you try the same thing I ask PlumberGr to do at post #37? Thank you.

Share this post


Link to post
Share on other sites

Guys, i am in the same boat but with VPCCW21FX.

 

Successful install with install from Empire EFI 1.85 R2 + retail dvd.

 

Updated to 10.6.3 with combo update and also macbook pro update 1.3.

 

Now booting using chameleon v2.0 - RC5pre7 r141, can use internal display by default but with no QE.

 

Using bootflags: /mach_kernel -x64 GraphicsEnabler=YES

 

GraphicsEnabler=YES gives me QE over VGA on my external monitor which is detected as Acer "H233H" (correct) and i get all resolutions.

 

What doesnt work:

 

QE w/Internal LED display

 

Atheros 9285 wireless

 

Marvell Yukon 88E8057

 

Nvidia/Intel realtek HD audio

 

 

 

Pretty sure this is a DSDT issue, any assistance would be greatly appreciated, what do you need from me if you were to assist me?

 

Thanks much!

 

Mat

Share this post


Link to post
Share on other sites
Yes I can but I think it best to wait for results from Mammoth, gi�49 & PlumberGr. If the result is promising, I will modify your DSDT.

 

OK! :(

 

thanks

Share this post


Link to post
Share on other sites
I forgot one thing, sorry. :P Please provide me your graphic card ROM file. You can obtain it using GPU-Z application in windows. This is to construct correct NVCAP. Do you have display on internal LCD with both GraphicsEnabler=No & GraphicsEnabler=Yes? If yes, I think I can get it to works.

 

I'll start working on it. I hope you have better luck than other VAIO owner. :)

 

Unfortunately I haven't been able to retrieve the vga bios, using both GPU-Z and latest nvflash, it simply tells eeprom not supported (unknown), is there any other way to retrieve it? I've google it but haven't found other option to do this...

 

And without GraphicsEnabler I got a working internal LCD with no QE/CI, and max res at 1280 x 1024, with GraphicsEnabler=yes it turned off the internal lcd..

Share this post


Link to post
Share on other sites
Unfortunately I haven't been able to retrieve the vga bios, using both GPU-Z and latest nvflash, it simply tells eeprom not supported (unknown), is there any other way to retrieve it? I've google it but haven't found other option to do this...

 

And without GraphicsEnabler I got a working internal LCD with no QE/CI, and max res at 1280 x 1024, with GraphicsEnabler=yes it turned off the internal lcd..

There is another way. Please follow instruction from this thread to dump your graphic card bios to file.

Share this post


Link to post
Share on other sites
thanks kizwan, I've finally managed to retrieve the vga bios, and here it is:

 

0649.006C.006F.vga.zip

These are two set of modified dsdt.aml file for Sony VAIO AW190JAH:-

http://www.mediafire.com/?deo3gzndyij

 

Test both dsdt.aml with GraphicsEnabler=No & GraphicsEnabler=Yes. If you have external monitor, connect it during testing. Please let me know the results & post here the ioreg dump for both dsdt.aml using IORegistryExplorer. Good luck.

Share this post


Link to post
Share on other sites

Both DSDT with GraphicsEnabler=Yes only works with external monitor and I think QE is working cause the top menu bar is transparent (and it also supports the full LCD native res which is 1440x900), with GraphicsEnabler=No internal LCD works but no QE and only at 1280 x1024 (stretched) max , here is the ioreg dump from both DSDT:

 

ioreg.zip

Share this post


Link to post
Share on other sites
Both DSDT with GraphicsEnabler=Yes only works with external monitor and I think QE is working cause the top menu bar is transparent (and it also supports the full LCD native res which is 1440x900), with GraphicsEnabler=No internal LCD works but no QE and only at 1280 x1024 (stretched) max , here is the ioreg dump from both DSDT:

 

ioreg.zip

According to ioreg dump, you're using framebuffer disabler kext & enabler/injector kext for graphic card (it inject different NVCAP). Please remove them & test again.

Share this post


Link to post
Share on other sites

Hi cloud03, these are another two sets of dsdt.aml (R3 & R4) for Sony VAIO AW190JAH. As usual please test both dsdt.aml with GraphicsEnabler=No & Yes. Make sure framebuffer disabler kext & graphic card injector/enabler kext (NVEnabler.kext, ATY_Init.kext, EVOEnabler.kext or similar) are removed or not installed.

http://www.mediafire.com/?mmwyiqj5zjt

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×