Jump to content
carlos228

DELL Vostro 3700 / 3xxx ( i5, Nvidia 330M ) OSX86 Snow 10.6.3

288 posts in this topic

Recommended Posts

Gezan,

 

I was reading dell's service manual, and I found this. (Dell listed there is a feature to disable Hybrid Graphic in BIOS) Dell Service Manual

 

Do me a favor please.

Boot up and press F2 to get into BIOS. Find out what is your Dell Bios version. Need that info. Also, give us the Video BIOS info

Then, go to Advanced - and look for the Hybrid Graphic option.

If you found this feature, "disable" the Hybrid Graphic option

 

Then take out the custombootcd and try to boot from the Harddrive.

If possible, BRING US SOME GOOD NEWS.

If not, bad news is okay.

 

To upgrade BIOS to A07, we need to restore the system back to Windows first.

 

Cheers!

 

I think this is bad news becuase i don't have the option in my bios to change something regarding my videocard.

Share this post


Link to post
Share on other sites
Advertisement
I think this is bad news becuase i don't have the option in my bios to change something regarding my videocard.

 

Gezan,

 

what is your bios version? Is it a07?

Share this post


Link to post
Share on other sites
Rekcu5 does your Main Bios page list both Video controllers or just one?

 

 

 

 

Something to think about:

 

Virgin DSDT for me only has one device "PEGP". On other DSDT there can sometimes be two. PEGP is the video Controller. Perhaps either deleting one, or swapping (or maybe even duplicating) the DSDT patching to be on the other card might help.

 

Disable in BIOS seems best option if you can.

 

Alternatively as Piyokos suggested either removing or blocking from loading the Apple kext that is concerned with Intel Video might work.

 

 

MiniHack,

 

Just updated my laptop to A07, couldn't located the Hybrid Graphic feature in the BIOS.

My BIOS only report one Video Controller

 

Video Controller - Nvidia Geforce GT310M

Video Bios Version - 70.18.49.00.1A.00

 

Thanks

Share this post


Link to post
Share on other sites
MiniHack,

 

Just updated my laptop to A07, couldn't located the Hybrid Graphic feature in the BIOS.

My BIOS only report one Video Controller

 

Video Controller - Nvidia Geforce GT310M

Video Bios Version - 70.18.49.00.1A.00

 

Thanks

 

I can confirm taht i have also only one videoadapter in the bios.

 

Video Controller - Nvidia Geforce GT330m

Video Bios Version - 70.16.5A.01.00

 

Hi,

The kexts in question are listed by Netkas here as being AppleIntelHDGraphicsFB.kext and AppleIntelHDGraphics.kext As you will see the two kexts in theory support using the Intel integrated graphics of i5. Maybe deleting them (and the extensions.mkext cache from system/library/caches/com.apple.kext.caches/startup) will stop the conflict. Backup the two kexts though and remember it is your own risk....

 

Last night i was searching for these ones to but my version of MacOSX (10.6.3) didn't have these.

 

piyokos pointed out an update that contained these two kexts.http://support.apple.com/kb/DL1026

 

But i couldn't install this update becuase it did not take my OSX partition. The rest of the prequisites seem to be allright.

 

 

-- Gezan

Share this post


Link to post
Share on other sites

Hi All,

 

After a couple of days hard work i'm able to boot into OSX from my HD.(Yeey)

 

But now comes the hard part my DSDT.aml is not able the detect my GForce 330m and inject te propper settings to get full Quality en QE/CI.

 

I'm adding my IOreg dump file if some knows how to add my devices to the DSDT file your welcome :thumbsup_anim: i have no clue how to.

 

 

Thanks

 

Gezan

dump.txt

Share this post


Link to post
Share on other sites
Gezan and Rekcu5,

 

Load the attached kext using Kext Utility. Then go to the plist in the Extra folder and change Yes to No for Graphics Enabler. Re-boot.

 

The attached kext recognises our Nvidia GPUs and enables graphics. It is a different way to enable them and if the problem was the bootloader being "confused" by seeing your Intel controller then maybe the kext method will see through the confusion and patch it all for you.

 

If the kext has loaded correctly you will see in system profiler under Graphics/Displays the "Rom revision" is Netkas.org.

 

I know this method of enabling graphics works [i have used it on other builds and have just tried it myself on this Vostro] and it is independent of anything to do with bootloader and DSDT so it might just do the trick for you.

 

Hope this works.

 

Hi MiniHack,

 

 

I tried your kext but and it works, the only thing is that it is seeing the intel card as main card and doesn't want to switch to nVidia so i can test resolution etc.

 

But it was a good try, last night i was chatting on irc with merklot. He made some changes to the chameleon bootloader so that i dumped the info about the Videocard table information.

 

Now there was something unexpected in recku5 and mine videocardtbale info, somthing that the chameleon bootlaoder couldn't parse and thats why it chrashed. Now was merklot not the guy we needed to have to program the graphics card into the bootlaoder but i'm putting some effort in beeing online in IRC to figure who i need to have.

 

irc.osx86.hu #vostro

 

 

-- Gezan

Share this post


Link to post
Share on other sites

yeah i've been busy lately so i haven't posted much but i always idle in #vostro if you have quick/stupid dsdt questions, nick is herschel. just msg or say my name in the channel to send an alert. its easier to get a line to a lot of osx86 gurus in irc too. awesome youve made that much progress since we last spoke!

Share this post


Link to post
Share on other sites

Hi!

 

As i am a newbie in this matter and apologize for my lack of knowledge in this matter.

I got myself a Dell Vostro 3700 and i would like to install a OSX on it.

I looked at the wiki- http://wiki.osx86project.org/wiki/index.ph...ith_NVIDIA_330M ,but there are somethings for me confusing:

I understand that i need to have a working macbook to make the install on a external hdd.

and then need to have a certain motherboard?

 

+ GraphicsEnabler=yes. Cinebench 11.5 what does it mean?

and where i get those needed kext files.

 

I thank you advance for your help ...

Share this post


Link to post
Share on other sites

GraphicsEnabler=yes

this is a boot property in the <StartVolumeRoot>/Extra/com.apple.Boot.plist file.

On the 3700 you can use the OSX native graphic system, no need for additional drivers, the 330 card is the same as on the MBP

 

Cinebench

is a benchmark System for 3D Software (especially Cinema 4D) which measures the CPU speed (render) and the Open-GL performance of the graphic card

 

http://www.maxon.net/en/downloads/cinebenc...nformation.html

 

:-)

Share this post


Link to post
Share on other sites
GraphicsEnabler=yes

this is a boot property in the <StartVolumeRoot>/Extra/com.apple.Boot.plist file.

On the 3700 you can use the OSX native graphic system, no need for additional drivers, the 330 card is the same as on the MBP

 

Cinebench

is a benchmark System for 3D Software (especially Cinema 4D) which measures the CPU speed (render) and the Open-GL performance of the graphic card

 

http://www.maxon.net/en/downloads/cinebenc...nformation.html

 

:-)

 

Thank you.

 

So still the working osx would be through another mac and usb hdd. But is that certain motherboard necessary?

Or can it be skipped??

Share this post


Link to post
Share on other sites

can anyone confirm that the new version of the 3700 (which may or may not come with hybrid vga driver) is working with full acceleration.

I have an asus k52jc with optimus hybrid technology and I am sending it back due to the fact that it is unhackable at present, this is caused by the hybrid driver allowing osx to see nvidia and intel as gpu's. I am interested in buying the vostro 3700 thanks to this forum but If i run into the same graphics problems that It may cause me to walk in front of a bus!

stuart

Share this post


Link to post
Share on other sites

Let's me sum up for anyone who plan to purchase a Vostro 3X00 with nvidia 3X0m as of September 9, 2010 and wish to have a fully working osx86:

 

*** It would NOT be an easy hack for the Video driver as of today, your osx86 Vostro would only have 1024x768 resolution and NO QE/CI ***

 

The rest of the hardware works, except wifi (this vostro thread has all the info). The only difference between the pre-july version and post-july version is the nvidia graphic card.

 

How could you tell you have received the non dedicated nvidia 310m or 330m (also to be known as hybrid graphics, nvidia optimus, post-july verson)?

 

You have to boot into Windows 7 (The Bios doesn't give you the full story). To switch between the nvidia graphic and intel graphic, there is an icon on the notification area "Power Options battery icon". Click it once, you should see "Balanced" or "Power saver"

  • If you set it to Power saver, the Windows 7 would start using your Intel® HD graphic. Check under Device Manager -> Display adapters, you would see one video card, Intel® HD Graphics
  • If you set it to Balanced, the Windows 7 would start using your nvidia graphic. Check under Device Manager -> Display adapters, you would see both video cards, Intel® HD Graphics and NVIDIA GeForce 3X0M

How we are hoping for to get the graphic issue "Fixed"?

 

  1. Dell Bios -- Hopefully the future version of Vostro 3XXX Bios would include the feature to disable the Intel HD Graphics. (Currently, no such feature on A07)
  2. Chameleon bootloader -- Hopefully some graphic expert from the voodoo team would correct this issue in the future release. Currently the post-july version of the Vostro would get the error "nvidia rom patching failed" before it boot into osx if you set the GraphicEnabler=Yes.

--Rekcu5

 

==========

 

If one want to have a fully working Vostro, keep working hard on it. Try to do as much as one can in the community! Read, Participate, Contribute, etc... If one just want to have a fully working OSX out of the box, go buy a Mac.

 

Have fun osx86-ing! ;)

Share this post


Link to post
Share on other sites

Thanks recqu / minihack,

 

I have returned a lenovo, replaced with asus k52jc and pulled all of the hair from my head as I only require this laptop for logic 9 and this requiresd graphic acceleration. The asus has hybrid nvidia driver, I finally thought I could make the move to vostro but now it appears I am wrong. I think it is bad of these manufacturers not to specify that these machines will only run windows 7.

mac did not employ optimus as the technology used to switch between graphics.

I have been trying for weeks but my knowledge has been exhausted.

good luck to anyone with the new hybrid version of graphics, I hate the word hybrid now.

stuart

Share this post


Link to post
Share on other sites
I don't have the 3500, I got the 3700 and I think the 3500 is a better choice, mainly because the 3700 is a little to big to cary around and it has two diffrent SD card chipset, I made a post about it somewhere in this thred, no big deal but my camera use it so I have to use usb cable.

 

As a hackingtosh it has been stable, no problems at all. I run 10.6.4.(1) the new macmini update and it just runs fine. Very few kext in \extra\extensions folder.

With MiniHack's dsdt shutdown and usb ports is working. Had some trouble with usb without it.

 

Oh you need to change the wifi card, as the 1520 is not working also in this thred.

 

So yes I'm happy with this as a hackingtosh and I don't regrets buying it as a hackingtosh.

 

//Mårten

 

Could anyone write down a proper guide for a dual win7 & SL installation as vanilla as possible as mårten have done?

 

I also would like to monitor CPU and GPU tempreture if possible!

 

 

chopped dxdiag info:

Time of this report: 9/10/2010, 15:35:57

Machine name: 1Q4B7L1

Operating System: Windows XP Professional (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.091208-2036)

Language: English (Regional Setting: Swedish)

System Manufacturer: Dell Inc.

System Model: Vostro 3700

BIOS: BIOS Date: 01/09/10 15:17:22 Ver: 08.00.10

Processor: Intel® Core™ i7 CPU Q 720 @ 1.60GHz (8 CPUs)

Memory: 3006MB RAM

Page File: 611MB used, 4281MB available

Windows Dir: C:\WINDOWS

DirectX Version: DirectX 9.0c (4.09.0000.0904)

DX Setup Parameters: Not found

DxDiag Version: 5.03.2600.5512 32bit Unicode

 

 

---------------

Display Devices

---------------

Card name: NVIDIA GeForce GT 330M

Display Memory: 1024.0 MB

Current Mode: 1600 x 900 (32 bit) (60Hz)

Monitor: Default Monitor

Monitor Max Res:

 

-------------

Sound Devices

-------------

Description: IDT Audio

Default Sound Playback: Yes

Default Voice Playback: Yes

 

-------------------

DirectInput Devices

-------------------

Device Name: Mouse

Device Name: Keyboard

Device Name: Fingerprint reader

Device Name: Webcam

 

DirectPlay Test Result: Not run

Registry: OK

 

-------------------

DirectPlay Adapters

-------------------

DirectPlay8 TCP/IP Service Provider: Wireless Network Connection - IPv4 -

 

------------------------

Disk & DVD/CD-ROM Drives

------------------------

Drive: C:

Free Space: 449.1 GB

Total Space: 476.9 GB

File System: NTFS

 

Drive: D:

Model: HL-DT-ST DVD+-RW GT32N

Driver: c:\windows\system32\drivers\cdrom.sys, 5.01.2600.5512 (Swedish), 4/14/2008 00:10:48, 62976 bytes

Share this post


Link to post
Share on other sites

I have installed A08 on my Vostro 3400, still no feature to enable or disable the hybrid graphic. I guess the unfortunate people still unfortunate. Looking forward for major changes on A09.

 

Rekcu5

 

New Bios A08. Anyone tried it yet?

 

Who knows, maybe for those unfortunate people with hybrid graphics their own update may be different.

Share this post


Link to post
Share on other sites

Ohh ....

 

Hello to all

 

I have an asus UL50VG with switchable graphic cards gma 4500 mhd and geforce g210M but i cant get to active g210M (dedicated graphic card) for get qe/ci. I have the same problem.

 

I need an actually hackintosh laptop 15" compatible with snow leopard for use xcode and I supose that the graphic card must be compatible with qe/ci.

 

Do you know any hackintosh laptop 100% compatible ?

 

Thanks a lot.

Share this post


Link to post
Share on other sites

Hi Minihack,

 

I found this http://www.tonymacx86.com/viewtopic.php?f=...415&start=0 thread on TonyMac stating the general problem we are facingh with our "Optimus" hybrid card solution.

 

I also found out that the main card running on the system is the GMA one from intel. If this cards detect the start of directx it wil fire up the nVidia one passing thru all the graphics data.

 

Now on of the big problems of this technology is that Mac Osx doesn't support our GMA graphics card maken the nVidia nearly impossible the fireup.

 

Besides the new laptop Apple made consists of their own graphics switching device, which seems to work more enegy efficient then the "Optimus" technology from nVidia. http://www.geek.com/articles/chips/macbook...timus-20100414/

 

So i think that there will be never good support for this "Optimus" technology and our Graphic cards on Mac OSX.

 

Btw. I'm trying to install Fedora on my laptop to see the new nVidia-linux driver suports the "Optimus" technology.

 

 

-- Gezan

Share this post


Link to post
Share on other sites

New BIOS for 3700 A09

 

1.Update PXE ROM for Novell Zenwork connection

2.Correct L2 Cache info at BIOS SETUP when Celeron CPU installed

Share this post


Link to post
Share on other sites
Here you go.

 

All my mod.s in it. Note that 3700 has 2 pegp devices whereas 3500 has just 1 so hopefully the mod is in the right place for the gfx.

 

Works good. Boots up with no KP. Thank You

Share this post


Link to post
Share on other sites

Hi Minihack,

 

Today i did a reinstall of OSX and tried booting with your /extra folder. I used the DSDT file you made for the other Vostro 3700 A09.

 

When i removed the SSDT files the system is booting further but eventually hangs on the AppleHDA.kext

 

After removing the AppleHDA and AppleHWSenser.kext its started booting into OSX.

 

Once i got into osx i saw that my videocard is being recognized, and the video bios file was loaded. This unfortuantly gives me QE/CI or a better resolution.

 

 

I don't know what need to be done to get the AppleHDA working, or how to create the SSDT files. Maybe you could give me a hand.

 

 

-- Gezan

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×