Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

rEFIt install/boot problem

1 post in this topic

Recommended Posts

Here's the setup....


First Generation MacBook 1,1. 2GB ram, 160GB HDD, everything else is stock.


on the internal hard drive, I have three partitions.




Snow Leopard


I like choices.



Recently, I've been having an affair with Linux Mint 8.


On an external USB hard drive (NOT a flash drive) I have two partitions. 1 HPFS+ partition to install rEFIt on and the other partition is where all of the linux madness will go (this one will be made into three partitions actually once linux is done with it)


I've installed linux, I've watched it boot (only when I took my internal drive out so the system HAD to boot from the only drive available, which was external) I know it works.


I put the internal drive back in where it belongs, boot into OS X, and install rEFIt (.14) to the rEFIt partition I made for it on my linux drive.


Moved the 'efi' folder, ran the enable.sh like the readme says, which I've seen work before...but this time...it will not work. Not at all.



I have all the ingredients like the rEFIt site says:

*External drive

*HPFS+ Disk Volume

*efi folder

*enable script execution from that folder on the external drive


I've tried it...over and over...and nothing at all works, I've tried rebooting twice, I've tried uninstalling and reinstalling. When my computer boots, I see a folder with a question mark in it flash for about a half a second, then OS X immediately boots.


I remember previously when I saw Linux boot and it was the only drive in the system, it took a few seconds for my macbook to see it had boot data, but it did boot, more than once even.


If there's a way I could get the OS X volumes to just....delay by like..10 seconds, maybe that'd be enough time for the efi volume on my external drive to have the proper influence?


Any ideas? thanks.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.