Jump to content
InsanelyMac Forum
calabuig

Please help me with ALC262, I'm desperate!

Recommended Posts

Hello, I have this problem: I have a Sony Vaio laptop VGN-AR41M and a Realtek ALC262 audio device onboard. I have Iatkos 10.5.7 installed and using old Taruga's AppleHDA patcher and ALC262 dump codec text I have no problem to get sound. I'd like to use Snow Leopard and I tried to to use my working AppleHDA Leopard kext in SL, but I have no success. Could you help me, please? Is there anyone with Realtel ALC262 working under SL with patched AppleHDA?

Thanks in advance!

Share this post


Link to post
Share on other sites
Advertisement

I'm here again with my problem with ALC262... please, help me...

 

I have this error message in the boot sequence:

 

ALCinject: Starting.

Apr 28 21:48:01 Mac-di-Marco kernel[0]: ALCinject: Setting built-in=<data not shown>

Apr 28 21:48:01 Mac-di-Marco kernel[0]: ALCinject: Setting layout-id=<data not shown>

Apr 28 21:48:02 Mac-di-Marco kernel[0]: Sound assertion "0 == fAudioFunctionGroup" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDACodecGeneric.cpp" at line 202 goto ExitError

Apr 28 21:48:02: --- last message repeated 1 time ---

Apr 28 21:48:02 Mac-di-Marco kernel[0]: Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

Apr 28 21:48:02 Mac-di-Marco kernel[0]: Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

Apr 28 21:48:02 Mac-di-Marco kernel[0]: Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

Apr 28 21:48:02 Mac-di-Marco kernel[0]: Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit Do you know what would it be the problem? Thanks in advance!

Share this post


Link to post
Share on other sites

I tried another AppleHDA version and I get a different error:

 

22:42:59 localhost kernel[0]: kxld[com.apple.driver.AppleHDA]: The super class vtable __ZTV13IOAudioEngine for vtable __ZTV14AppleHDAEngine is out of date. Make sure your kext has been built against the correct headers.

Apr 29 22:42:59 localhost kernel[0]: Can't load kext com.apple.driver.AppleHDA - link failed.

Apr 29 22:42:59 localhost kernel[0]: Failed to load executable for kext com.apple.driver.AppleHDA.

Apr 29 22:42:59 localhost kernel[0]: Kext com.apple.driver.AppleHDA failed to load (0xdc008016).

Apr 29 22:42:59 localhost kernel[0]: Failed to load kext com.apple.driver.AppleHDA (error 0xdc008016)

 

Any little help?

Share this post


Link to post
Share on other sites

There is no solution for alc 262 in snow leopard(10.6.3) =( I've tried everything - nothing works/

Fujitsu Siemens U9200

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×