Jump to content
oldnapalm

Drivers para áudio HDA

39 posts in this topic

Recommended Posts

Advertisement

Amigos,

primeiro quero agradecer, por que através desse fórum consegui fazer meu hackintosh quase perfeito.

Venho lendo muito tudo, meu problema é com a rede (não é para esse tópico :P ) e o ALC662, já li, tentei mudar os kexts e nada, não sai som pelo speaker, apenas pelo headphone. Já li em outros posts esse mesmo problema, mas ninguém conseguiu uma solução.

 

Alguém tem alguma idéia?

 

Notebook CCE Corei 330M

Share this post


Link to post
Share on other sites

oldnapalm,

muito obrigado, você sempre ajudando.

Já tinha lido tutorial e fiz as mudanças necessárias, principalmente a do "apito" agudo que acontece no meu notebook, mas não funcionou. Já li muita coisa e tentei muita coisa antes de perguntar, testei vários kexts nada. :o

 

Você conhece muito poderia me esclarecer, se influencia esses tutoriais serem sempre voltados para placas em desktops que tem várias entradas (green, pink, black, etc) e a do notebook que é básica, mic, fone e os speakers apenas.

 

O drive que coloquei ALC662 que é disponibilizado nos downlodas é perfeito, instala e funciona tudo, menos os speakers, tentei achar algo nos códigos para trocar as headphone com speakes em uma tentativa desesperada de fazer funcionar :P , mas não consegui.

 

De todo modo obrigado.

Share this post


Link to post
Share on other sites

Você tem que ler a parte sobre os "NodesToPatch", PinDefaults e verbs, isso vale tanto para a VoodooHDA quanto para a AppleHDA, porém para ajustar a VoodooHDA é mais fácil.

Share this post


Link to post
Share on other sites

Bom dia!

 

Tenho um probleminha com o meu VoodooHDA. Está tudo muito bem mapeado, excepto internal mic in. Tudo resto funciona, HDMI, mic in, phones, speaker etc.

 

O meu problema pelos vistos é comum, mas não encontro solução.

 

Basicamente, tem ruido branco, bastante alto. Nas colunas internas não chateia muito, mas ligadas externamente é horrível. Além do mais, youtubes e alguns videos com VLC, ouvem-se estalidos um pouco chatos.

 

A minha instalação é iAtkos L1 + 10.7.2... alguma suggestão?

 

Mudei para 44,1k 24bits, testei outras resoluções sem diferença nenhuma.

 

obrigado!

Share this post


Link to post
Share on other sites

Viva oldnapalm,

 

obrigado pelo link, mas nenhuma das soluções apresentadas são para o meu problema.

 

Entretanto, pensei que pudesse ser o microfone a infectar ruido ao inves de chiar, então fui e editei o plist, mudando o igain para 0.

 

repair + cache + reboot,

 

Conclusão, perdi todo o audio! Nada aparecia mapeado. Andei a tarde toda à volta, tanto com voodoo como kexts do meu próprio ALC 885/889, nada. Um tem mapeado perfeitamente do layout de I/O, mas não sai som.

 

Alguns KP mais tarde, voltei a conseguir meter som no meu portatil com VoodooHDA, mas desta vez com o PrefPane incluido ! Mesmos sintomas mas...

 

Fui então PrefPane, ao microfone interno (que nao capta nada), e reduzi o som ara zero. Já não tenho ruido branco! Está limpinho, excepto os tais clicks e pops.

Share this post


Link to post
Share on other sites

Oldnapalm e colegas,

 

Meu som funciona relativamente bem.. Mas ainda existe um chiado que incomoda bastante.

Segui o procedimento para som com chiado descrito no tópico "Problemas comuns" e mesmo assim o chiado permanece (diminuiu mas permanece).

 

Existe alguma forma de remover esse chiado completamente? Ou sempre terei q conviver com ele?

 

 

Obrigado.

Share this post


Link to post
Share on other sites

oldnapalm,

 

Não estou conseguindo acessar o link que mandou:

You don't have permission to access /osx86/files/10.6/Audio/VoodooHDA/ on this server.

 

Alguma outra forma?

 

Obrigado.

Share this post


Link to post
Share on other sites

Desculpe a demora, mas só hoje consegui testar..

 

Instalei o pkg 0.2.56, conforme recomendado, mas além de dar KP, o som ainda continou chiado.

 

Alguma outra solução? Pois o chiado incomoda bastante, o som tem q estar bem alto pra nao ouvi-lo.. :worried_anim:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×