Jump to content
SeBsZ

Resolution won't change...

23 posts in this topic

Recommended Posts

Hello there,

 

I am sure someone has asked this before but I searched the forums for "resolution" and just couldn't find anything...

 

I have a laptop with an ATI mobility radeon 9600 w/ 128MB graphics card. I am trying to get osX to run at my widescreen resolution of 1280x768. Inside OSx I can only choose 1024x768 from the list.

 

I tried running OSx with the boot option: "Graphics Mode"="1280x800" but it will still run at 1024x768. I also tried

 

"Graphics Mode"="1280x800x32"

and

"Graphics Mode"="1280x800x32@85"

 

but none actually change the resolution.

 

Help is very much appreciated. THank you!

Share this post


Link to post
Share on other sites
Advertisement
But my widescreen can't support 1280x1024... :S

 

Hi SebsZ,

I'm having the same problem (in VMWare though - not native). I tried: -

 

?video

 

at the boot prompt, which lists out the video modes supported. However 1280x800 wasn't on the list. I don't understand why this is. If I tried some of the resolutions listed (1152x864), then VMWare would boot into those resolutions correctly (but wouldn't allow me to go into full screen mode)... grrr. Any ideas anyone?

Share this post


Link to post
Share on other sites

Thank you so much - I was wondering how to take advantage of my 1400x1050 Tablet Screen :) Now if i could just get the ethernet to work

Share this post


Link to post
Share on other sites
In Darwin type,

 

"Graphics Mode"="1280x1024x32"platform=x86pc

 

It should work ok then

 

Hi.

 

Any idea to make this permanent? I don't want to have to enter this each time I boot.

 

Thank you

Share this post


Link to post
Share on other sites
Hi.

 

Any idea to make this permanent? I don't want to have to enter this each time I boot.

 

Thank you

 

from xplodenet.com,

 

once suitable, add to boot config file:

edit /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

add:

<key>Graphics Mode</key>

<string>1280x1024x32</string>

 

I tried this and it works, but my problem is that the refresh rate is at 87Hz, higher than what my lcd could display. I cant do the custom refresh rate as my video card is vesa 2.0

 

Any suggestions?

Share this post


Link to post
Share on other sites

Does anybody have an idea how we can patch the stuff so ?video gives us at least 1280x800 also?

I'm already running for days now with 1280x786 on my 1280x800 screen and it really looks like ..well you know. :)

Share this post


Link to post
Share on other sites
Does anybody have an idea how we can patch the stuff so ?video gives us at least 1280x800 also?

I'm already running for days now with 1280x786 on my 1280x800 screen and it really looks like ..well you know.  :lol:

 

in Darwin, try typing ?video and follow the instructions on how to see which resolution your graphics board can display for VESA. From what i heard, the 1280x800 isnt one of them. :) check it out nonetheless.

Share this post


Link to post
Share on other sites
from xplodenet.com,

 

once suitable, add to boot config file:

edit /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

add:

<key>Graphics Mode</key>

<string>1280x1024x32</string>

 

I tried this and it works, but my problem is that the refresh rate is at 87Hz, higher than what my lcd could display. I cant do the custom refresh rate as my video card is vesa 2.0

 

Any suggestions?

 

Thank you. It worked for me, but I can't change the refresh rate.

 

Any idea when we could get real drivers for ATI cards?

Share this post


Link to post
Share on other sites
neither could my display work

 

mine is radeon 9200 with 1280*800 widescreen display

 

any one can help?

 

 

I have the same configuation that you.. please help us..........

Share this post


Link to post
Share on other sites
from xplodenet.com,

 

once suitable, add to boot config file:

edit /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

add:

<key>Graphics Mode</key>

<string>1280x1024x32</string>

 

I tried this and it works, but my problem is that the refresh rate is at 87Hz, higher than what my lcd could display. I cant do the custom refresh rate as my video card is vesa 2.0

 

Any suggestions?

 

It looks like I dont have rights to edit this file with the deamoo logon. How did you logon on to edit the file?

Share this post


Link to post
Share on other sites
from xplodenet.com,

 

once suitable, add to boot config file:

edit /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

add:

<key>Graphics Mode</key>

<string>1280x1024x32</string>

 

 

How can I edit the boot config file? Do I need to start in safe mode or something?

Share this post


Link to post
Share on other sites

Hi, same problem here. I have a mobility Radeon 9700 with native resolution of 1440x900, and i can only get it to work at 1024x768.

Share this post


Link to post
Share on other sites
I read on another bbs that you can manually set the refresh rate as follows:

 

instead of using:

 

<key>Graphics Mode</key>

<string>1280x1024x32</string>

 

use this to set refresh rate to 100 hz:

 

<key>Graphics Mode</key>

<string>1280x1024x32@100</string>

 

I haven't tried this yet, but others seem to have had success with it.

 

Yes true. It works for some but not all setups. Some (including myself) has experienced when you add the refresh rate the machine just boots repeatedly after displaying some error.

So now you're warned :)

Share this post


Link to post
Share on other sites
Yes true. It works for some but not all setups. Some (including myself) has experienced when you add the refresh rate the machine just boots repeatedly after displaying some error.

So now you're warned  :)

 

How did you fix this after it happened to you?

Share this post


Link to post
Share on other sites

I have an ATI Radeon 9000 64MB on a gateway 450XL laptop. I could only get it to 1280x1024 because everything above that was a garbled screen.

 

I deleted

 

ATIRadeon8500.kext in \System\Library\Extensions

 

and set 1400x1050x32 in my com.apple.Boot.plist

 

rebooted

 

bam - crisp 1400x1050 resolution.

Share this post


Link to post
Share on other sites

Deleting the ati kexts lets me run at 1400x1040 (that is 4:3, not widescreen, though).

 

And, most cards won't let you pick the refresh rate. I think that is a VESA 3.0 spec, which isn't so common (most of these cards are VESA 2.0). On top of it, no functional ATI drivers really exist yet on OS X X86.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×