Jump to content
cmf

fermi/gtx 480/gtx 470

1,735 posts in this topic

Recommended Posts

Advertisement

No you don't need the package. I'll repeat this for the last time:

 

Fermi cards have been working on Snow Leopard since the 256 series drivers were first released back in November 2010.

This means that the "Fermi package" has been obsolete since then.

 

If you're using a Fermi architecture card on Snow Leopard and you haven't yet installed the Nvidia Quadro 4000 drivers, you must boot without any injection method running (GraphicsEnabler=n, there can be no GFX0 device in DSDT, no enabler/injector.kext of any kind etc etc).

 

Note that GTX 5xx and any newer Quadro model based on that architecture are not supported on Snow Leopard - you must install Lion. Before you ask, no, there is no way around that.

 

If you meet the requirements (Fermi GTX 4xx or Quadro based on that generation Fermi card) go to the nvidia driver download page and download the drivers for the Quadro 4000 for 10.6.8.

 

If you're not on 10.6.8 you'll have to find the download page for the older Quadro 4000 drivers that match the version of Snow Leopard that you are running. This will require some googling but you'll find them eventually. They're still hosted on nvidia's site. There are drivers available for 10.6.6 thru 10.6.8. In the early days there was a driver for 10.6.5 but I have not been able to locate it. Make absolutely sure that you download and install the correct ones.

 

The Quadro 4000 driver installer will not run if you're not using a Mac Pro model identifier. If you're using some other model identifier, do this:

Copy the installer package off of the disk image. Right click -> show contents, find distribution.dist inside and open it with textedit. Find the model identifier stuff in there and edit where appropriate so that it matches the model identifier you're using. It'll be obvious what to do once you're looking at it. Once you're done save the file and you can run the installer.

 

Update to Chameleon 2.1. Just install it on top of whatever you're using now, and unless you understand what you're doing, preferably using the same install method that you did previously. I'm not going to go into the installation process in detail, there are plenty of threads here and elsewhere that covers it.

 

Make sure you read boothelp.txt for information about new settings and possibilities. If you've been using an older version of Chameleon, its important to note that /Extra/com.apple.Boot.plist is now org.chameleon.Boot.plist, and that all instances of "manufacter" in your /Extra/smbios.plist must be renamed to "manufacturer".

 

Set GraphicsEnabler=y in your /Extra/org.Chameleon.Boot.plist. You may need to add your video card's device ID to GF100Hal.kext - this is not necessary for most cards though. Not sure if you'll need to do this for a Quadro 6000.

Anyway there are plenty of guides and tutorials that deal with that so I'm not going to go into it here. Google for example 'guide for all nvidia boards' to get an idea.

If you're having problems with display recognition and other weirdness, visit the NVEnabler release thread over on the ProjectOSX forums and start reading up on "NVCAP" and "display-cfg".

 

Note that GraphicsEnabler also allows for video BIOS overriding, as well as custom display-cfg and NVCAP injection via /Extra/org.Chameleon.Boot.plist.

 

That's all there is to it.

The "Fermi package" that you're looking for is obsolete by now and installing it on a modern Hackintosh will do more harm than good so please for the love of god stop asking about it.

Share this post


Link to post
Share on other sites

Hello,

 

I am not able to get this right. I am pretty new to all of this but am trying to catch on. I have installed osx and it seems to work fine. I just cannot get my GTX 470 to work? I updated Snow to 10.6.8 and installed the Quadro 4000 drivers . I cannot find the GF100Hal.kext to change the id. I install the drivers so not sure what I am doing wrong?

 

Thanks

Share this post


Link to post
Share on other sites

Managed to get one of my EVGA GTX470's to work very, very easily.

 

1. Installed Fermi compatible Chameleon from the 1st post onto my thumb drive

2. Installed NVFERMI.Fix.kext from page 8 to /Extra/Extensions and wiped my kextcache

3. Did a standard install of the nividia drivers from the 1st post (just doubleclicked and installed the .mpkg, rather than using pacifist, and double checked my /s/l/e folder to make sure the files installed).

4. Made sure I had Graphics Enabler: Yes in my com.apple.Boot.plist

5. Rebooted and it worked first time!

 

I do have a second card, which I haven't tried yet. Unfortunately my GA-UD5 mobo short circuited somehow and fried itself so I have to wait two weeks to get a replacement. Meanwhile my two GTX470's are sitting on the shelf. Bummer!

 

Hi,

 

I tried this and when I go to install package it says the computer already has graphics solution . I have not installed the drivers yet? I Had not installed the nvidia pkg yet. I am not able to boot into system now. I will install osx again and try the above again. Not sure why it said I had Drivers installed when I did not?

Thanks,

Zephr

Share this post


Link to post
Share on other sites

With which percentage can we say about zotac gtx 470 compatibility?

It depend from os version?

Can work on Maverick?

I do 3d rendering and video

thnks

Share this post


Link to post
Share on other sites

Hello, No big deal in 10.9

 

If you use Chameleon Bootloader just add:

 

    <key>GraphicsEnabler</key>
    <string>Yes</string>

 

in /Extra/org.chameleon.Boot.plist

 

And GTX 470 should work just fine. No additional kexts needed anymore.
 

Share this post


Link to post
Share on other sites

Hello again,

 

For some people

 

PCIRootUID=1 GraphicsEnabler=yes

 

seems to work.

 

I set up a machine with 2x GTX 285 some days ago. I know it is a completely different GPU but this has worked out for me.

So maybe its worth a try.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×