Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
cappio

Samsung N130

69 posts in this topic

Recommended Posts

SAMSUNG N130 LEOPARD 10.5.4 (MSIWINDX86.ISO)

18352_samsung-n130-white-1.jpg

 

cpu= intel atom n270 160GHz MMX SSE(1, 2, 3, 3s) OK

chipset i945 OK

ram= 1024Mb 333mhz OK

video= Intel GMA 950 OK QE CI (2" monitor out in test - error, vertical bands in the video)

audio= alc267 realteck all OK - OUT monitor & Jack3.5out, IN MIC & jack3.5IN *****

lan ethernet= OK

webcam= OK

SD Card reader= OK

usb (x3)=ok with IOUSBFamily_327.4.0.pkg.zip

 

sleep mode= WORK (tested by Alender)

multitouch= NOT WORK

scrolling= WORK (not tested)

wlan= (atheros ar9285 NO)

COMPATIBLE WI FI CARD

Dell 1397 OK AIRPORT **

Dell 1510 OK tested by mtest

--------------------------------------------------------------------------------------------------

 

AUDIO SOLUTION *****

1) Download, install and run Kext_Helper_b7.app.zip

2) donload & drag in KextHelper & install

VoodooHDA.kext.zip

HDAEnabler.kext.zip

3) Repair permission whit Disk Utility

4) Reboot & play!

 

 

--------------------------------------------------------------------------------------------------

REPLACE WIFI NETWORK CARD**

 

reccomended Dell 1397 B/G/N card

 

Where to buy: dell site for 40$ or ebay for 11$

How to:

</a>

 

IF THE CARD NOT WORK, INSTALL THIS KETX WHIT KEXTHELPER AND RESTART

 

Dell_1397_wifi_driver.zip

 

 

--------------------------------------------------------------------------------------------------

Share this post


Link to post
Share on other sites

my samsung n130 arrived by mail yesterday.

Now I can test it properly ..

The first impression is that win7 startedEd. limits the potential of the machine.

On my previous netbook, a eeepc with XPlite, despite poor performance, working much faster.

Another negative characteristic is the absence of bluetooth, and the quality of the audio speaker, a small, single channel, and scratchy!

Great for everything else (especially for the price!)... comin soon

Share this post


Link to post
Share on other sites
Guest PeterJones1

hi!

 

plz write soon about netbook

 

thanks

Share this post


Link to post
Share on other sites
Snow leopard work on n130 :(

 

Hi,

yes I know, soon I'll try the version 10.6.2 by Hazard whit patch for intel atom.

you have used vanilla kernell or a patched version?

what you use for wifi? Tanks

Share this post


Link to post
Share on other sites
Hi,

yes I know, soon I'll try the version 10.6.2 by Hazard whit patch for intel atom.

you have used vanilla kernell or a patched version?

what you use for wifi? Tanks

 

 

first step : prepare a usb installation with snow leopard dvd retail+NetbookBootMaker.

second step : after installation update the kernel with netbookinstaller and use combo update to going to 10.6.3.

Now,with new release of netbookinstaller i update the system to 10.6.4

 

My wifi card is Broadcom. I don't remember now the version :P my thread was canceled

Share this post


Link to post
Share on other sites

Im spanish and Im one Samsung N130 with XP and MsiWindosx86 (Mac osx 10.5.4).

Your recomended format, and install this last version of Snow Leopard? or updating?

 

Where is the best aplications for Mac and this ATOM?

 

 

Thank`s and sorry with my english!

Share this post


Link to post
Share on other sites
sleep work ;)

 

Today is arrived the wifi card.. i have installed a kext (look on top of page) and now full work airport!

 

Alender, how i can for patch sleep mode? you have a kext? please write here a small guide Tank's!!

Share this post


Link to post
Share on other sites

The Dell 1397 is B/G only, not B/G/N.

 

You should opt for the Dell 1510 (10 bucks more expensive) to have a working B/G/N out of the box.

 

Thanks for sharing all the info, I"ve juste ordered my N130 with a 2 GB memory module and a Dell 1510 wifi half-size mini pci-e adapter...

 

In few days time I'll be following your traces.

 

Great stuff.

Share this post


Link to post
Share on other sites

Hi,

Just to add my personnal experience to this... I've just finished to install OSX SL 10.6.3 on my N130.

 

I did it using the iATKOS S3 v2 image... Had to restore it to an external hard drive and then run NetBook Installer (0.8.4 rc 1) on the USB partition otherwise the N130 would not boot on the external drive (just hang with a blinking cursor or even worse go into a reboot loop !).

 

The install process went very smoothly, it was a little bit long but that's the price to pay to enter the Geek's heaven.

 

On the next reboot I had a bad larsen coming from the speaker, it seems that the mic is not muted and I could not figure out how to mute it.

 

Network wifi is not showing, but the Ethernet is working fine, althought only working at 100 Mbps half duplex for now, that's an other thing I will have to fix.

 

Trackpad is also working fine, two fingers scrolling with no problem (enabled through the control panel).

 

I plugged my bluetooth dongle and configured my Apple Magic Mouse as if it was all perfectly natural. Amazing.

 

^_^;):)

 

To summarize: great experience, I'm now waiting for my Wifi card replacement to enjoy my little hackintosh !

 

EDIT: Okay, so at the next reboot I had to deal with an error saying "header read size 200 incorrect image size". Something to deal with the hibernate mode. I disabled it via the command "sudo pmset -a hibernatemode 0", we'll see if this works.

 

EDIT2: The VGA port does not work. For some reasons the system changes the resolution of the desktop but there is no signal on the port.

 

After fixing the hibernate mode thing I could not manage to have the system boot normally -i.e. directly from the netbook HD. The bootloader shows and then I can briefly see an apple logo on a grey background and immediately the system reboots.

 

The weird thing is that booting on the USB iATKOS install disk and then selecting my fresh OSX install in the bootloader menu worked just fine.

 

Then I tried to use Netbook Installer to see if this could fix the issue but no luck. After using Netbook Installer the system was crashing with a kernel panic related to the org.voodoo.driver.VoodooHDA extension.

 

Now I'm reinstalling the whole thing.

Share this post


Link to post
Share on other sites

Quick update regarding my own experience...

 

I had hard time to have the OSX booting normally from the netbook hard drive. First I could only boot my OSX partition through the bootloader on the USB external drive used to install the OS.

 

Replacing the kernel install on the HD partition did the trick, see http://www.insanelymac.com/forum/index.php?showtopic=224928

 

Now here is the situation:

 

System: OK and stable, booting normally

Screen: OK

Webcam: OK

Trackpad: OK, including two fingers scrolling

Card reader: OK

USB ports: OK

Ethernet: OK

Sound: OK

Wifi: OK, with a replacement card Dell 1510

VGA out port: KO, monitor detected, can send signal to it but shows only garbage, any idea ?

Sleep: KO, goes to sleep but wakes up immediately with a black screen...

 

 

Not too bad ! :P:P:wacko::(:P:P:P:D:D:P:P

 

Quick tip: enable the SSH service on your OSX as soon as you can to be able to cleanly reboot the computer remotely this helped me a lot during my tests when the keyboard & mouse does not work any more or when the display gets screwed

 

 

EDIT: For reference, here are the steps to follow to install iATKOS S3 v2 on a Samsung N130 (NP-N130)...

 

PART A - Preparing the Installation

1. Download the iATKOS-S3-v2 ISO image

2. Restore to your USB drive using Disk Utility on a working Mac

3. Make the USB drive bootable with Netbook BootMaker

 

optional: upgrade your BIOS to the latest version

 

PART B - Installing the System

4. Change your BIOS setting to boot on USB drive

5. Boot on your USB drive

6. Customize the OSX install as you want, my recommendation is to remove VoodooHDA support and add SleepEnabler

7. Wait for the installation to finish

8. Next reboot, let the computer boot on the USB drive, select your HDD OSX partition in the boot menu

9. Once the installation finishes, use a terminal command line to replace your kernel /mach_kernel with the one on the USB drive /Volumes/iATKOS.../mach_kernel

10. Shutdown the computer

 

PART C - Post-Installation

11. Remove the USB drive

12. Attach USB keyboard and mouse to the netbook

13. Boot normally - OSX should show but with a wrong display resolution, netbook keyboard and keypad not working

14. Run Netbook Installer (in the Applications folder)

15. Uncheck "Install bootloader" (the one already installed should be fine)

16. Check "Install General Extensions" and "Generate DSDT"

17. Uncheck all the rest and click on Install

18. Be patient. Once finished, reboot.

 

Done !

Share this post


Link to post
Share on other sites
Trackpad: OK, including two fingers scrolling

 

Hi, what you use for enable scrolling? in System Preference i don't have this options..

 

could be useful for this project-linux multitouch in a hackintosh?

thanks

Share this post


Link to post
Share on other sites

Hi Cappio,

Unfortunately my knowledge of the extensions is too limited to be able to precisely answer your question.

 

I can only tell you that this feature has been added after i ran Netbook Installer 0.8.4 and selected the option "Install General Extensions".

 

After reboot, in the System Prefs, I get a new item called "Trackpad" (see below). Two figers scrolling (and more) can be configured through this pref pane, in the advanced options.

preferencesx.png

Share this post


Link to post
Share on other sites

I've just finished to install my Dell 150 Wireless card b/g/n ....

 

Works like a charm !

Share this post


Link to post
Share on other sites

Ok finally I fixed my sound problem... Not sure exactly how but for the record here is what I did.

 

First I took some time to remember when the sound ceased to work. After installing iATKOS the sound worked fine but I was obliged to run Netbook Install to have the trackpad and screen correctly supported. But after running Netbook Installer sound was gone.

 

:thumbsup_anim: At that point I was pretty confident that Netbook Installer was guilty. It is in fact installing a bunch of extensions and I then decided to do a little bit of house cleaning in /S/L/E and removed:

 

AppleHDA.kext

AppleHDA.kext.10.6.3

AppleHDA1062.kext

AppleTyMCEDriver.kext

AudioAUUC.kext

AudioIPCDriver.kext

 

By the way I am wondering how all those AppleHDA could live together...

 

Then I installed HDAEnabler.kext (not sure if necessary ?) and finally VoodooHDA 2.6.1 Snow L. I ran Update Extra, rebooted fingers crossed... And voilaaaa, sound was back working perfectly !!

 

Now, it seems that the VoodooHDA is still giving some KP from time to time at boot, I'll monitor that, but for the time being I am a happy man !!

 

:thumbsup_anim::):):P:P:P

 

EDIT: It looks like the KP at boot was related to the hibernate thing that was not disabled (pmset -a hibernatemode 0). Also to circumven the audio settings to be reset at boot I followed the instructions here --> http://www.insanelymac.com/forum/index.php?showtopic=219591

Share this post


Link to post
Share on other sites

I did not spend time on the VGA thing, too busy with the sound until now.

 

In the few tests I've made at best I could only see garbage being sent to the external VGA... :)

 

The colors were changing while me moving the mouse so I presume it's a matter of signal sync or something.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • i think the "red light" you are referring to is that you have a optical SPDIF output (3.5 mm) combo jack. it most likely will be "red" when audio is active. 
    • Domanda , ma il tuo configplist lo ha settato cosi Gengik????
      Noto molte cose atipiche , tipo aperto con Clover configurator nella sezione ACPI il nome DSDT.aml NON è selezionato , quindi in teoria NON dovrebbe caricare il DSDT che hai in Clover ACPI Patch , se usi SSDT x la CPU NON dovrebbero servirti quelle personalizzazioni sempre in configplist sezione CPU ...
      Secondo me dovresti partire da un configplist pulito , xche sempre secondo me c'è rimasto delle schifezze di qualche tool x installare facile    EDIT
      Scaricando il configplist di jolly NOTO ha impostato +o- come intendevo fare io , sistemando quello  sopra elencato e bammmmm NON avvia , mi forniresti x favore Hack info che trovi nella mia firma ???
      Grazie
    •   Can you share the Clover folder that lets you boot?
    • yes it is. i can boot using a backup from a backup of my clover. i am just trying to fix the VGA /HDMI so i tried using the clover i got from Allan
    •     I mean't to fix that. The new attached EFI only contains new USB patch that will unlikely fix anything unless your hackintosh is installed on a USB drive. If it is installed on your hard drive, as I said, try playing with the patches I attached in the screenshot (i.e. disabling some of them).   Your SATA Mode is AHCI in the BIOS right?


×