Jump to content
Glauber

10.6.3 Update + 9800GX2 = Black Screen!

36 posts in this topic

Recommended Posts

Hi All

 

I've just noticed when I set my display settings to 'mirror' I get an output from one DVI port and a blue screen out of the other.

 

Just thought I'd share in case this is linked to your problem.

 

NB:- when not set to 'mirror' I have no problem, main desktop on one monitor and desktop 2 on the other!

 

D

 

 

You need of these two for your vga, or in dsdt or in evoenabler:

 

"@0,display-cfg",

Buffer (0x0B)

{

0x03, 0x01, 0x00, 0x00

},

 

"@1,display-cfg",

Buffer (0x04)

{

0xFF, 0xFF, 0x00, 0x01

},

Share this post


Link to post
Share on other sites
Advertisement
You need of these two for your vga, or in dsdt or in evoenabler:

 

thanks smith I'll give it a go.

Share this post


Link to post
Share on other sites
thanks smith I'll give it a go.

 

No joy I'm afraid - I have add this to DSDT, note I still have to use GraphicsEnabler=Yes or I get no video output.

            Device (PEGP)
           {
               Name (_ADR, 0x00010000)
               Method (_PRW, 0, NotSerialized)
               {
                   Return (GPRW (0x09, 0x04))
               }

               Device (GFX0)
               {
                   Name (_ADR, Zero)
                   Name (_SUN, One)
                   Method (_DSM, 4, NotSerialized)
                   {
                       Store (Package (0x1C)
                           {
                               "@0,compatible", 
                               Buffer (0x0B)
                               {
                                   "NVDA,NVMac"
                               }, 

                               "@0,device_type", 
                               Buffer (0x08)
                               {
                                   "display"
                               }, 

                               "@0,display_cfg", 
                               Buffer (0x08)
                               {
                                   0x03, 0x01, 0x00, 0x00
                               }, 

                               "@0,name", 
                               Buffer (0x0F)
                               {
                                   "NVDA,Display-A"
                               }, 

                               "@1,compatible", 
                               Buffer (0x0B)
                               {
                                   "NVDA,NVMac"
                               }, 

                               "@1,device_type", 
                               Buffer (0x08)
                               {
                                   "display"
                               }, 

                               "@1,display_cfg", 
                               Buffer (0x08)
                               {
                                   0xFF, 0xFF, 0x00, 0x01
                               }, 

                               "@1,name", 
                               Buffer (0x0F)
                               {
                                   "NVDA,Display-B"
                               }, 

			"NVCAP",
			Buffer (0x18)
			{
		    /* 0000 */    0x04, 0x00, 0x00, 0x00, 0x00, 0x00, 0x03, 0x00, //HC1
		    /* 0008 */    0x1C, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x07, 
		    /* 0010 */    0x00, 0x00, 0x00, 0x00
			},

                               "NVPM", 
                               Buffer (0x1C)
                               {
                                   /* 0000 */    0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 
                                   /* 0008 */    0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 
                                   /* 0010 */    0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 
                                   /* 0018 */    0x00, 0x00, 0x00, 0x00
                               },

				"VRAM,totalsize",
				Buffer (0x04)
				{
				0x00, 0x00, 0x00, 0x38
				},

                               "device_type", 
                               Buffer (0x0C)
                               {
                                   "NVDA,Parent"
                               }, 

                               "model", 
                               Buffer (0x17)
                               {
                                   "nVidia GeForce GTX 260"
                               }, 

                               "rom-revision", 
                               Buffer (0x25)
                               {
                                   "nVidia GeForce GTX 260 OpenGL Engine"
                               }
                           }, Local0)
                       DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                       Return (Local0)
                   }
               }
           }

 

 

Although I have noticed that I get far smoother GFX with the DSDT addition. Video playback is notably less jittery !

 

D.

 

EDIT ... NB - GraphicsEnabler=No and GFX string also works for me but still same issue .. no big deal for me just thought it might be relevant here!

Share this post


Link to post
Share on other sites

I use only dsdt. Anything else, never.

 

This is my code:

 

Method (_DSM, 4, NotSerialized)
				{
					Store (Package ()
						{							   
							"AAPL,aux-power-connected", 
							Buffer (0x04)
							{
								0x01, 0x00, 0x00, 0x00
							}, 

							"AAPL,backlight-control", 
							Buffer (0x04)
							{
								0x00, 0x00, 0x00, 0x00
							}, 

							"AAPL,slot-name", 
							Buffer (0x0A)
							{
								"PCI-E 16x"
							}, 

							"@0,compatible", 
							Buffer (0x0B)
							{
								"NVDA,NVMac"
							}, 

							"@0,device_type", 
							Buffer (0x08)
							{
								"display"
							}, 

							"@0,display-cfg", 
							Buffer (0x0B)
							{
								0x03, 0x01, 0x00, 0x00
							}, 

							"@0,fboffset", 
							Buffer (0x04)
							{
								0x00, 0x00, 0x06, 0x00
							}, 

							"@0,name", 
							Buffer (0x0F)
							{
								"NVDA,Display-A"
							}, 

							"@1,compatible", 
							Buffer (0x0B)
							{
								"NVDA,NVMac"
							}, 

							"@1,device_type", 
							Buffer (0x08)
							{
								"display"
							}, 

							"@1,display-cfg", 
							Buffer (0x04)
							{
								0xFF, 0xFF, 0x00, 0x01
							}, 

							"@1,name", 
							Buffer (0x0F)
							{
								"NVDA,Display-B"
							}, 

							"@2,#adress-cells", 
							Buffer (0x04)
							{
								0x00, 0x00, 0x00, 0x01
							}, 

							"@2,#size-cells", 
							Buffer (0x04)
							{
								0x00, 0x00, 0x00, 0x00
							}, 

							"@2,compatible", 
							Buffer (0x13)
							{
								"NVDA,sensor-parent"
							}, 

							"@2,device_type", 
							Buffer (0x0F)
							{
								"NVDA,gpu-diode"
							}, 

							"@2,hwctrl-params-version", 
							Buffer (0x04)
							{
								0x00, 0x00, 0x00, 0x02
							}, 

							"@2,hwsensor-params-version", 
							Buffer (0x04)
							{
								0x00, 0x00, 0x00, 0x02
							}, 

							"@2,name", 
							Buffer (0x0E)
							{
								"sensor-parent"
							}, 

							"@2,reg", 
							Buffer (0x04)
							{
								0x00, 0x00, 0x00, 0x02
							}, 

							"NVCAP", 
							Buffer (0x18)
							{
								/* 0000 */	0x04, 0x00, 0x00, 0x00, 0x00, 0x00, 0x03, 0x00, 
								/* 0008 */	0x0C, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x07, 
								/* 0010 */	0x00, 0x00, 0x00, 0x00
							}, 

							"NVPM", 
							Buffer (0x1C)
							{
								/* 0000 */	0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 
								/* 0008 */	0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 
								/* 0010 */	0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 
								/* 0018 */	0x00, 0x00, 0x00, 0x00
							}, 

							"VRAM,totalsize", 
							Buffer (0x04)
							{
								0x00, 0x00, 0x00, 0x20
							}, 

							"subsystem-id", 
							Buffer (0x04)
							{
								0x10, 0x00, 0x00, 0x00
							}, 

							"device_type", 
							Buffer (0x0D)
							{
								"NVDA,GeForce"
							}, 

							"model", 
							Buffer (0x1E)
							{
								"Nvidia etc. etc."
							}, 

							"rom-revision", 
							Buffer (0x33)
							{
								"Nvidia etc. etc. [DSDT]"
							}
						}, Local0)
					MCDP (Arg2, RefOf (Local0))
					Return (Local0)
				}

 

I have this:

 

 

"@0,display-cfg",

Buffer (0x0B)

{

0x03, 0x01, 0x00, 0x00

},

 

 

not this:

 

"@0,display_cfg", ---> underscore? Why?

Buffer (0x0B)

{

0x03, 0x01, 0x00, 0x00

},

 

 

Anyway look here and here

 

Your problem, mirror on desktop, for my 9800gt, 8600gts and 8800gt, i resolved in this way. And it is strange that with your vga this "way" don't resolve the mirror mode.

 

Try other combination!

 

macbook pro 8600GT : 03010000 - ffff0001

macbook pro unibody 9400 : 03010300 - ffff0801

macbook pro white 9400 : 03010300 - ffff0201

mac pro 7300GT : ffff3600 - 00ff3e01

mac pro 8800GT : 03010000 - ffff0001

imac 24" 7600GT : 03035000 - ffff3601

Apple TV 7300Go : 01ff0000

powermac 6800GT : 00ff3e01 - 00ff3600

 

Ciao;)

Share this post


Link to post
Share on other sites

You know I've bee using DSDT for my GPU for a long time but have never managed to get this GTX260 to work with only DSDT .. Only EFi string as per PCWIz guide here or GraphicsEnabler=Yes

 

I've seen that barnum clames a DSDT fix here

 

But it doesn't work for me ..

 

Having looked at PCWiz's properties.plist for the GTX260 the major differance i see is that he has the rom version set to : 3172a (actual) not "nVidia GeForce GTX 260 OpenGL Engine" as everybody else seems to have ..

 

Anywho 3172a - is the fix - currently booting DSDT injection for GPU and guess what .... mirror displays works !!!

 

Top HOle Smith@@ Many thanks!

:D

 

This works for GTX260:

                Device (GFX0)
               {
                   Name (_ADR, Zero)
                   Name (_SUN, One)
                   Method (_DSM, 4, NotSerialized)
                   {
                       Store (Package (0x1C)
                           {
                               "@0,compatible", 
                               Buffer (0x0B)
                               {
                                   "NVDA,NVMac"
                               }, 

                               "@0,device_type", 
                               Buffer (0x08)
                               {
                                   "display"
                               }, 

                               "@0,display-cfg", 
                               Buffer (0x04)
                               {
                                   0x03, 0x01, 0x00, 0x00
                               }, 

                               "@0,name", 
                               Buffer (0x0F)
                               {
                                   "NVDA,Display-A"
                               }, 

                               "@1,compatible", 
                               Buffer (0x0B)
                               {
                                   "NVDA,NVMac"
                               }, 

                               "@1,device_type", 
                               Buffer (0x08)
                               {
                                   "display"
                               }, 

                               "@1,display-cfg", 
                               Buffer (0x04)
                               {
                                   0xFF, 0xFF, 0x00, 0x01
                               }, 

                               "@1,name", 
                               Buffer (0x0F)
                               {
                                   "NVDA,Display-B"
                               }, 

                               "NVCAP", 
                               Buffer (0x18)
                               {
                                   /* 0000 */    0x04, 0x00, 0x00, 0x00, 0x00, 0x00, 0x03, 0x00, 
                                   /* 0008 */    0x1C, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 
                                   /* 0010 */    0x00, 0x00, 0x00, 0x00
                               }, 

                               "NVPM", 
                               Buffer (0x1C)
                               {
                                   /* 0000 */    0x01, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 
                                   /* 0008 */    0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 
                                   /* 0010 */    0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 
                                   /* 0018 */    0x00, 0x00, 0x00, 0x00
                               }, 

                               "VRAM,totalsize", 
                               Buffer (0x04)
                               {
                                   0x00, 0x00, 0x00, 0x38
                               }, 

                               "device_type", 
                               Buffer (0x0C)
                               {
                                   "NVDA,Parent"
                               }, 

                               "model", 
                               Buffer (0x17)
                               {
                                   "nVidia GeForce 260 GTX"
                               }, 

                               "rom-revision", 
                               Buffer (0x06)
                               {
                                   "3172a"
                               }
                           }, Local0)
                       DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                       Return (Local0)
                   }
               }
           }

Share this post


Link to post
Share on other sites

Ok, i don't understand many your english, but this:

 

Having looked at PCWiz's properties.plist for the GTX260 the major differance i see is that he has the rom version set to : 3172a (actual) not "nVidia GeForce GTX 260 OpenGL Engine" as everybody else seems to have ..

 

it makes not difference, nothing, it's only "esthetic".

 

The only noticeable difference is that I have posted, on my, if i write to rom-revision: blablablablablabla god is good, instead "nvidia geforce etc." all works the same, the mirror works the same.

 

This is the right:

 

"@0,display-cfg",

Buffer (0x0B)

{

0x03, 0x01, 0x00, 0x00

},

 

and this:

 

"@1,display-cfg",

Buffer (0x04)

{

0xFF, 0xFF, 0x00, 0x01

},

 

 

Differences that you have correctly as I have shown;)

 

You do not show me "air", I realize this :P

 

Ciao

Share this post


Link to post
Share on other sites

LOL looks like you're correct ... I was a little bit drunk when i did this :D

Share this post


Link to post
Share on other sites

+1

 

I too have just upgrade to 10.6.3 and I have the same problem.

 

When I connect to the TV via the DVI / HDMI connection the system boots to a black screen.

 

When I connect the video out to an old CRT monitor the system boots normally.

 

I am running a EN9800GTX+ DK/HTDI/512M Asus card in an AMD system.

 

This setup worked 100% under 10.6.2 with EFI strings.

Share this post


Link to post
Share on other sites

10.6.4 is now out, has anyone who had the graphics problem updated to this one? I would like to know if it will work with XFX GeForce 9800GTX 512 before I do it because cant be bothered reinstalling...again :rolleyes:

 

cheers!

Share this post


Link to post
Share on other sites

ditto on this. has 10.6.4 made anyone's life sweeter?

 

EVGA GeForce 9800 GTX+ here and I'm getting the black screen under 10.6.3.

Share this post


Link to post
Share on other sites

zotac 9800gt 512mb amp, 2 dvi ports

1st port: dvi-hdmi cable to LG 47LE5500 TV

2nd port: dvi-dvi cable to LG L2040P monitor

working with idoc's mac8800gt vbios injected nvenabler, using custom nvcap

thanks to bigfish, idoc and the nvenabler team

 

idoc's nvenabler

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×