Jump to content
playfullyrastadoul

Snow leopard on Vaio vcpw12m1e

11 posts in this topic

Recommended Posts

hey,

 

my friends has juste bought a sony vaio vcpw12m1e, and he wants me to install snow leopard in it. i saw the specs, and i'm sure graphics will work fine (the same as dell min 10v). but sound, ethernet and wireless chipset aren't specified, and i want to know if someone got the vaio quite fully working with SL (if there is no sound, no problem)

 

any clues??

 

thanks a lot!

Share this post


Link to post
Share on other sites
Advertisement

]MY SNOW LEOPARD 10.6.2 running on VPC W21 M1E

- not fully working yet - thanks for any help!!

 

 

using the iPortable Snow x86 10.6.2 (Intel SSE2/SSE3 od higher)

http://www.infinitemac.com/f36/iportable-s...tel-sse2-t5476/

 

read the PDF readme to install and default kernel i did the instalation, also Patched DSTS and fixed Extensions and Extra with KextHelper.

 

WORKING HW after this clear isntall:

KEYBOARD US/another

USB full control

BLUETOOTH DUN - possible to pair any devices, and with my MacBook Pro I share the Internet over bluetooth, so its possible to activate Bluetooth PAN connection for connect to internet.

MOTION EYE- working fine (i think withouth graphic acceleration) - tried Photo Booth, Skype, and fully works.

SOUND IN/OUT - with VoodooHDA described bellow works built in Speakers, Mic. also Ext. IN/OUT + fn Keys

 

 

added this extensions:

(find at kexts.com, google)

 

VoodooHDA.kext + control panel VoodooHDA.prefPane

- working sound IN/OUT, Add customization of this device to System Preferences.

 

VoodooBAttery.kext

- working battery metter

 

UPDATE: it is possible to load also AppleACPIBatteryManager.kext for better battery con position :)

 

AppleSMBIOSEFI-28air.zip

- this extension fixes the About This Mac issue

 

 

Also added

but i think it is not working (I think its because of another device part release)

 

ApplePS2Trackpad.kext - i installed it from original system, but it still doesnt show any Preferences Panel in the System preferences

this kexts is located in /Extra/Extensions with anorther ApplePS2 kexts.

 

or should it be installed in /System/Library/Extensions?

 

I have tried apps like iTunes, Mail, Safari - everything works fine.

 

 

HAVE TO DO NEXT:

any help very welcome!

 

activate LAN and wireless

Attansic L1C (ATL1C) - AR8132 Fast Ethernet [1969:1062] - cant find any way to add another interface in Network Pref Panel - only bluetooth DUN & PAN and PPo atc.

 

activate Trackpad Preferences Panel, to use mutli touch and device settings change

- i already did it one time working, but dont remembner the steps :wacko:

 

activate GMA 3150 graphic controller

- i spent over hours by searching the solution, but still nothing working - no resolution change, no kext loaded.

 

there are also slots for SD card and HG dub, but this is not so important at this moment. :wacko:

 

 

00:00.0 Host bridge [0600]: Intel Corporation N10 Family DMI Bridge [8086:a010]

00:02.0 VGA compatible controller [0300]: Intel Corporation N10 Family Integrated Graphics Controller [8086:a011]

00:02.1 Display controller [0380]: Intel Corporation N10 Family Integrated Graphics Controller [8086:a012]

00:1b.0 Audio device [0403]: Intel Corporation N10/ICH 7 Family High Definition Audio Controller [8086:27d8] (rev 02)

00:1c.0 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 1 [8086:27d0] (rev 02)

00:1c.1 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 2 [8086:27d2] (rev 02)

00:1c.2 PCI bridge [0604]: Intel Corporation N10/ICH 7 Family PCI Express Port 3 [8086:27d4] (rev 02)

00:1d.0 USB Controller [0c03]: Intel Corporation N10/ICH7 Family USB UHCI Controller #1 [8086:27c8] (rev 02)

00:1d.1 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 [8086:27c9] (rev 02)

00:1d.2 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 [8086:27ca] (rev 02)

00:1d.3 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 [8086:27cb] (rev 02)

00:1d.7 USB Controller [0c03]: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller [8086:27cc] (rev 02)

00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)

00:1f.0 ISA bridge [0601]: Intel Corporation NM10 Family LPC Controller [8086:27bc] (rev 02)

00:1f.2 IDE interface [0101]: Intel Corporation N10/ICH7 Family SATA IDE Controller [8086:27c0] (rev 02)

00:1f.3 SMBus [0c05]: Intel Corporation N10/ICH 7 Family SMBus Controller [8086:27da] (rev 02)

01:00.0 Ethernet controller [0200]: Atheros Communications AR8132 Fast Ethernet [1969:1062] (rev c0)

02:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)

03:00.0 SD Host controller [0805]: Ricoh Co Ltd Unknown device [1180:e822]

03:00.1 System peripheral [0880]: Ricoh Co Ltd Unknown device [1180:e230]

03:00.4 SD Host controller [0805]: Ricoh Co Ltd Unknown device [1180:e822]

 

ABOUT THIS MAC - SYSTEM PROFILER

 

HARDWARE

Model Name: MacBook Air

Model Identifier: MacBookAir1,1

Processor Speed: 1,67 GHz

Number Of Processors: 1

Total Number Of Cores: 1

L2 Cache: 512 KB

Memory: 1 GB

Bus Speed: 1,33 GHz

Boot ROM Version: MBA11.00BB.B03

SMC Version (system): 1.30f3

Serial Number (system): W1234567890

Hardware UUID: 00000000-0000-1000-8000-00146C8ECD91

 

 

GRAPHIC CARD:

Display:

 

Type: GPU

Bus: Built-In

VRAM (Total): 64 MB of Shared System Memory

Vendor: Intel (0x8086)

Device ID: 0xa011

Revision ID: 0x0000

Kernel Extension Info: No Kext Loaded

Displays:

Display:

Resolution: 1024 x 768

Pixel Depth: 32-Bit Color (ARGB8888)

Main Display: Yes

Mirror: Off

Online: Yes

 

AIRPORT

Software Versions:

Menu Extra: 6.0 (600.22)

configd plug-in: 6.1 (610.2)

System Profiler: 6.0 (600.9)

Network Preference: 6.0 (600.22)

AirPort Utility: 5.4.2 (542.23)

IO80211 Family: 3.1 (310.6)

 

 

 

So, there will be a possibility that it should work...Can anybody help me please?

Share this post


Link to post
Share on other sites

its GMA 3150, thats for sure :)

No i didnt add any ID, wifi doesnt work yet for me...any glue? :)

have you added in airport atheros kext ur device id?? and are u sure it's gma 3100 and not gma 945?

Share this post


Link to post
Share on other sites

ok, so do you have pls the VAIO recovery disk? I would lke to change the state back to PC ;)

But now i cant install windows 7, becouse of no HD driver loaded during the installation startup process, so i cant use internall HD as an BootHD, or i dont know why i cant instal on this station back the windows..oh s..t..

 

Can you help me somehow pls?

 

Mine is 945... But i think u can get it working. Th main problem is wifi, i read in nektas blog that adding the dv id in appleatheros kext works fine

Share this post


Link to post
Share on other sites

thank you for your help:)

it works!

That's because of thé boot flag. Boot on a USB installation of 7, open up disk part via the command prompt, SET active the main Windows partition, reboot on USB, repair, enjoy ;)

Share this post


Link to post
Share on other sites
ok, so do you have pls the VAIO recovery disk? I would lke to change the state back to PC :D

But now i cant install windows 7, becouse of no HD driver loaded during the installation startup process, so i cant use internall HD as an BootHD, or i dont know why i cant instal on this station back the windows..oh s..t..

 

Can you help me somehow pls?

 

if u installed mac as guid then to reinstall windows u need to use gparted live to repartition-reformat hdd into ...

Share this post


Link to post
Share on other sites
]MY SNOW LEOPARD 10.6.2 running on VPC W21 M1E

- not fully working yet - thanks for any help!!

 

 

HAVE TO DO NEXT:

any help very welcome!

 

activate Trackpad Preferences Panel, to use mutli touch and device settings change

- i already did it one time working, but dont remembner the steps :D

 

activate GMA 3150 graphic controller

- i spent over hours by searching the solution, but still nothing working - no resolution change, no kext loaded.

 

.....

 

So, there will be a possibility that it should work...Can anybody help me please?

 

hi, i have vaio tz11mn with iPortable

and for me was no problem to get gma950 full qe-ci with stock kexts and efi string device-properties and for full resolution i used SwithResX

i guess your graphic card will work also with stock kext´s

do a combo update to 10.6.2 to get those kexts and a working vanilla mach_kernel

remember to remove framebufferdisabler from extra and /S/L/E ..framebufferdisabler

this has put me in the right track

u may also lock here fore more native speedstep and to get rid of some kexts from extra

 

how did u get webcam working ? any kext?

i have VGC-VCC7 and its not working

 

for mouse with touch and tap and full keys keyboard i use voodooPS2

Sleep works for u? for me does not

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×