Jump to content
mosslack

Asus 1201N Installation and support

2,573 posts in this topic

Recommended Posts

This describes the pattern of non-sleep on my hack as well. 4GB, sleep broken. I would like sleep to work, of course, but i have now gotten into the habit of a six second shutdown. Which is not to say that a two second sleep and a three second wakeup is not preferable.

Share this post


Link to post
Share on other sites
Advertisement
Hi

Just Update to 10.6.4 and no problem. Everything works like 10.6.3, except a KP with VoodooHDA when loaded on init.

I have to load it after startup.

Any good news on USB removal problem ? :P

I also tried to compare with my mbp ioreg but no news.

 

no luck on USB! The Zotac Ionitx has no USB removal on sleep but the BIOS supports OS EHCI hand off and legecy USB support.

 

 

I'm not using VoodooHDA so I didn't get hopefully ASUS improve the BIOS and maybe add AHCI mode for the HDD.

Share this post


Link to post
Share on other sites
Shutdown not working yet, i've tried also with gogetta dsdt but nothing.

 

For most detail for install i've used usb drive with leopard 10.6.2, next i've execute "1201N installer package v3", next i've run kext utility and finally i've install 10.6.3 update combo. But shutdown doesn't work.

 

Now i've tried with dsdt of gogetta plus an archive of this thread with all this files:

 

AppleACPIBatteryManager.kext

AppleACPIPS2Nub.kext

ApplePS2Controller.kext

ApplePS2Keyboard.kext

ApplePS2Mouse.kext

ApplePS2Trackpad.kext

AsusHotkeys.kext

CPUIDOverride.kext

CPUIDSymbols.kext

fakesmc.kext

OSXRestart.kext

PlatformUUID.kext

 

I've missed some files?? i must to erease some files of these?? There is some to make in System/Library/Extension to makw shutdown work?? Please i'm desperate...

 

PS: I have 325 bios version...i don't know if its important...

 

I use evOreboot instead of OSXRestart, so shutdown works.

 

no luck on USB! The Zotac Ionitx has no USB removal on sleep but the BIOS supports OS EHCI hand off and legecy USB support.

 

 

I'm not using VoodooHDA so I didn't get hopefully ASUS improve the BIOS and maybe add AHCI mode for the HDD.

 

If you look in ioregistery you will see that appleMCP79AHCI is loaded so AHCI is working.

 

PS : VoodooHDA is for sound controller, not hard drive controller.

Share this post


Link to post
Share on other sites
thanks for the stuff..

I'm now on 10.6.4 using your boot, dsdt and smbios. I also removed the sleepenabler.kext

unfortunately, now sleep doesn't work at all anymore. either closing the lid or pressing the sleep button makes the computer freeze on black screen.....do I need a ApplePowerManagement.kext or something?

 

EDIT:

installed a new sleepenabler.kext....can be found here on InsanelyMac or by Bing

works perfect

 

also, it always boots in verbose mode now. can I somehow get my normal Apple logo bootscreen back?

 

Where abouts is this?

Share this post


Link to post
Share on other sites

Does anyone know what this person means by this:

 

Good afternoon,

I am the holder of this нетбука 1201N, I put Mac OS Snow Leopard 10.6 Retail, all like norm but I can not truly pick up the loader, you could not reduce the Loader?

Or if there is possibility USB-boot that possibility to be loaded into the Leopard was at holder USB, and without it current Ubuntu and WiN7

 

I thought I was pretty good at reading broken english by now, but this one has me baffled.

 

Also, has anyone yet tried to install SL by substituting the 10.6.4 combo update for 10.6.3? I was hoping I wouldn't have to redo mine as it is working very well with 10.6.4 at the moment. Thanks.

Share this post


Link to post
Share on other sites

Is any one here multi-booting with windows 7? I've found that the hotkeys utility in windows 7 no longer adjusts the audio, and I believe it's due to the DSDT file. Does anyone know if there's anything in the DSDT related to audio that may help me resolve this?

Share this post


Link to post
Share on other sites
Is any one here multi-booting with windows 7? I've found that the hotkeys utility in windows 7 no longer adjusts the audio, and I believe it's due to the DSDT file. Does anyone know if there's anything in the DSDT related to audio that may help me resolve this?

 

Actually the DSDT has nothing to do with Windows 7. It is only for use with Snow Leopard. As for whether or not those keys work in Win 7 or not, I can't really say as I don't use hotkeys at all. Perhaps someone else might know?

 

The top post has been updated to reflect the newly updated guide which now covers 10.6.4. The file links within the guide have also been updated as well. I have tested this new install and it seems to work very well. As usual, if anyone has any problems or comments, please let me know so I can fix any problems you may encounter.

Share this post


Link to post
Share on other sites
I've made an injector kext for bluetooth in order to have the possibilty to switch BT off.

 

Put it in /Extra/Extention

 

Great !! it's works . thanks a lot !! :)

Share this post


Link to post
Share on other sites
Actually the DSDT has nothing to do with Windows 7. It is only for use with Snow Leopard. As for whether or not those keys work in Win 7 or not, I can't really say as I don't use hotkeys at all. Perhaps someone else might know?

 

The top post has been updated to reflect the newly updated guide which now covers 10.6.4. The file links within the guide have also been updated as well. I have tested this new install and it seems to work very well. As usual, if anyone has any problems or comments, please let me know so I can fix any problems you may encounter.

 

Hmm, it's strange that the keys stop working after I install os x. As a test later today, I'm going to remove my dsdt and boot and see what happens, if the hotkeys work, then chameleon is loading the DSDT fro OS's other than Mac os x, and I'll have to look into a patch for chameleon to fix it. Will get back to you guys later

Share this post


Link to post
Share on other sites

i've seen that my 1201N netbook have 3GB of ram memory, this is the cause of my problems?? keyboard and mousepad in 50% of times that i start OS X doesn't work and I must to restart netbook or I must to plug usb mouse and make reboot.

For shutdown and sleep the netbook doesn't shutdown, the screen become black but power is always on...the cause is 3GB of ram?? exist different dsdt or others files to substitute?? another things i've netbook with italian keyboard with < and > next to shift, maybe apple ps2 trackpad, controller and keyboard is not fully compatibile and this is cause of my problems with keyboard and mouse??

Share this post


Link to post
Share on other sites

Could someone explain the process of doing an update to 10.6.4 from 10.6.3 with (if needed) links to the files i need?

 

Thanks!

Share this post


Link to post
Share on other sites
Could someone explain the process of doing an update to 10.6.4 from 10.6.3 with (if needed) links to the files i need?

 

Thanks!

 

Go to post #1 the guide has been updated

Share this post


Link to post
Share on other sites

Need assistance. Have 1201N (2gb, 250gb hitachi hdd, rtl8191se wlan and atheros lan). I've expected no problems after reading the guide on how to get SL running on this netbook, however it's 5 days already that making me crazy.

 

Here's what I'm doing.

 

1) Restoring retail SL dmg to guid hfs extended (jrn) flash drive (tried 10.6, 10.6.1, 10.6.2, 10.6.3)

2) Using netbookbootmaker to add things to usb drive and make it bootable (tried from 0.82 to latest 0.84 RC1)

3) Starting my 1201n, putting arch=i386 (however it doesnt matter what parameters i put in)

4) Getting KP on AppleCPUPowerManagement preceeded by message that CPU is unsupported and lots of messages of kexts failed to load (incl sleepenabler and nullcpumanagement).

 

Can someone say me what i'm doing wrong? Why these kexts are displaying error (i suspect this KP is because workaround/fix/hack kext for powermanagement wasn't loaded)?

 

Need your assistance badly.

 

P.S. The only OSX distro that was working on my 1201n- iPortable that started right from usb drive (10.6.2, legacy_kernel and anv_kernel) however it didn't display my hdd drive volumes (as i'm new i don't know what to do with it, so advise on this thing could be also good way for me to get things working, because i will be able to clone my usb with iPortable to netbook's hdd).

Share this post


Link to post
Share on other sites
hey guys i've 1201N version with 3GB of ram and v325 of bios, which dsdt.aml I must to use??

 

Here is the link to one that amf5 posted back in post 434. See if this works for you.

 

Need assistance. Have 1201N (2gb, 250gb hitachi hdd, rtl8191se wlan and atheros lan). I've expected no problems after reading the guide on how to get SL running on this netbook, however it's 5 days already that making me crazy.

 

Here's what I'm doing.

 

1) Restoring retail SL dmg to guid hfs extended (jrn) flash drive (tried 10.6, 10.6.1, 10.6.2, 10.6.3)

2) Using netbookbootmaker to add things to usb drive and make it bootable (tried from 0.82 to latest 0.84 RC1)

3) Starting my 1201n, putting arch=i386 (however it doesnt matter what parameters i put in)

4) Getting KP on AppleCPUPowerManagement preceeded by message that CPU is unsupported and lots of messages of kexts failed to load (incl sleepenabler and nullcpumanagement).

 

Can someone say me what i'm doing wrong? Why these kexts are displaying error (i suspect this KP is because workaround/fix/hack kext for powermanagement wasn't loaded)?

 

Need your assistance badly.

 

P.S. The only OSX distro that was working on my 1201n- iPortable that started right from usb drive (10.6.2, legacy_kernel and anv_kernel) however it didn't display my hdd drive volumes (as i'm new i don't know what to do with it, so advise on this thing could be also good way for me to get things working, because i will be able to clone my usb with iPortable to netbook's hdd).

 

The Netbookbootmaker used with my guide for the 1201N is a special one made by Meklort just for this system. If you follow my guide (link on the top post) and use those files it should work just fine. HTH

 

Go to post #1 the guide has been updated

 

The steps used to update from 10.6.3 to 10.6.4 are outlined in the guide as well. It's a very simple procedure.

Share this post


Link to post
Share on other sites

Can someone with a 3 Gb RAM DSDT.AML file please post it. Someone on the thread needs to test to see if this is the source of their problems. Thanks!

Share this post


Link to post
Share on other sites
I've made an injector kext for bluetooth in order to have the possibilty to switch BT off.

 

Put it in /Extra/Extention

 

Nice one! I can also confirm that it is functioning well.

 

Just out of curiosity, would it b possible to inject through the DSDT instead of a KEXT? not that it matters I guess?

Share this post


Link to post
Share on other sites

I think we should really look into why sleep breaks when we're using the 4GB dsdt file. for me the 4GB was one of the major reasons why I got the 1201n in the first place. right now I can't use the thing to it's full potential. which sucks :)

Share this post


Link to post
Share on other sites
I think we should really look into why sleep breaks when we're using the 4GB dsdt file. for me the 4GB was one of the major reasons why I got the 1201n in the first place. right now I can't use the thing to it's full potential. which sucks :)

 

 

PLEASE TRY THE SLEEPENABLER KEXT.

 

AFTER THIS RUN KEXT UTILITY.

SleepEnabler.kext.zip

Share this post


Link to post
Share on other sites
Nice one! I can also confirm that it is functioning well.

 

Just out of curiosity, would it b possible to inject through the DSDT instead of a KEXT? not that it matters I guess?

 

Indeed, DSDT what my first approach but it didn't work. I've search on the web if someone has already use _DSM on USB devices and I find nothing.

 

Here is my code, if someone has the solution...

 

                Device (PRT2)
               {
                   Name (_ADR, 0x02)
                   Name (_UPC, Package (0x04)
                   {
                       0xFF, 
                       Zero, 
                       Zero, 
                       Zero
                   })
                   Name (_PLD, Buffer (0x10)
                   {
                       /* 0000 */    0x81, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00, 
                       /* 0008 */    0x30, 0x10, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00
                   })
/* start of BT hack */                

              	Method (_DSM, 4, NotSerialized)
               	{
               		Store (Package (0x04)
                       {
                       	"idProduct",
                           Buffer ()
                           {
                           	0x15, 0x82, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00
                           },
                       	"idVendor",
                           Buffer ()
                           {
                           	0xAC, 0x05, 0x00, 0x00, 0x00, 0x00, 0x00, 0x00
                           }
                       }, Local0)
                       DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                       Return (Local0)
               	}                

/* end of BT hack */                
               }

Share this post


Link to post
Share on other sites

For those who have problems with 3 or 4Gb memory, can you test with the 2Gb DSDT and remove RAM to only have 2Gb.

There are several tutorials on this forum to change amount of RAM in DSDT so when we will have the "final" (or a stable) DSDT, we will be able to modify DSDT to fit memory.

If we made fiew dsdt versions for different amount of RAM, it will be difficult to follow modifications. -_-

It's just a idea, I don't want to force anyone. :P

Share this post


Link to post
Share on other sites

Help Please. After install, I power off and power back on, I get a message "restart"

 

 

So After Installation, I erased everything in my extra folder and then I ran the installer V4. After that I would run the kext utility but not touching the optional kext with it. I turn it off and turn it back on and I would get the message restart. Did I do something wrong?

Share this post


Link to post
Share on other sites
PLEASE TRY THE SLEEPENABLER KEXT.

 

AFTER THIS RUN KEXT UTILITY.

 

this did not help. I tried with 4GB installed and the 4GB DSDT and sleep was not working. is sleep for you working with 4GB? if so, please enlighten us how you pulled that off!

 

 

For those who have problems with 3 or 4Gb memory, can you test with the 2Gb DSDT and remove RAM to only have 2Gb.

There are several tutorials on this forum to change amount of RAM in DSDT so when we will have the "final" (or a stable) DSDT, we will be able to modify DSDT to fit memory.

If we made fiew dsdt versions for different amount of RAM, it will be difficult to follow modifications. :P

It's just a idea, I don't want to force anyone. :P

 

like I said in my previous post, after I upgrade to 4GB sleep is broken. if I go back to 2GB and use the 2GB DSDT sleep is still broken. something messes up sleep when inserting 4GB, or when you install the 4GB DSDT.

only a complete reinstall with 2GB installed restores the sleep for me...

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×