Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
mosslack

Asus 1201N Installation and support

2,573 posts in this topic

Recommended Posts

Top post updated to reflect recent progress. Anyone hear anymore about progress on the Atheros e-net?

Share this post


Link to post
Share on other sites

Another question, how do you fix the keyboard mapping ?

Is there any thread on this forum with useful links or it can just be solved via osx preference pane ?

I was using an old logitec driver few year ago, but he wasn't mapping perfectly.

I am on azerty but any solution even for qwerty will be interesting.

Share this post


Link to post
Share on other sites

I'm using kernel 10.2 and SL 10.6.2 for those that asked.

 

I apologize I couldn't be more help. I was experimenting and didn't really log my steps.

 

But I'm glad you guys picked up my slack .

 

NC

Share this post


Link to post
Share on other sites

Great news to hear the sound actually working! Is there any way that we can get the wifi to work without the Dell card? Also I was just thinking but is there Any way to make the keys of the keyboard light up like the MacBook pros do?!?

 

How do I change my startup partiction to my mac and not my pc? Right now it boots easybcd and when I hit mac I get the chameleon bootloader. Is there any was to just use chameleon?

 

Thank you everyone!

Share this post


Link to post
Share on other sites
GOOD NEWS!!!

 

try this one

 

I fix the cache problem

 

http://www.mediafire.com/?rmj5qzvmnzm

 

but I cannot test the HDMI port

 

I love you!!!

 

I haven't seen it mentioned lately, does anyone still have time that they boot and keyboard/mouse still dont' work? It still happens to me randomly but a reboot fixes it.

Share this post


Link to post
Share on other sites

Did you try to run Kext Utility? You can do it by just double clicking it. If there is a kext cache problem that should take care of it. I think mine did that one time out of all the times I've restarted it. BTW, amf5 is still working on a new install procedure, but it is still not workable as of yet. Anyone else having install problems? I know Scorch95 was having severe problems with the trackpad and the keyboard would only work part time. Still? We need to get these glitches addressed and find out what is different about his system which causes this. Anyone?

 

EDIT: My 1510 arrived in the mail today. Will be doing a full pictorial on the install for the guide, but probably not 'til the weekend.

 

Great news to hear the sound actually working! Is there any way that we can get the wifi to work without the Dell card? Also I was just thinking but is there Any way to make the keys of the keyboard light up like the MacBook pros do?!?

 

How do I change my startup partiction to my mac and not my pc? Right now it boots easybcd and when I hit mac I get the chameleon bootloader. Is there any was to just use chameleon?

 

Thank you everyone!

 

As for the native wlan card, I really thought this would be an easy fix as my Neutrino uses a Realtek card and it works much like the Ralink utility works. In fact they look suspiciously similar. So I thought sure the new card would also function using that utility, but it doesn't. More than likely b/c it is an 'n' card, where the other one is a 'g' card. It is possible that Realtek will release a newer utility, but I have not seen any yet.

 

My dual boot guide uses Chameleon if you want to try that you can find it here. HTH

Share this post


Link to post
Share on other sites

Newegg failed to ship in time due to the fact my billing address couldn't differ from my shipping address. So I ordered my 1201N off amazon and got free 2 day shipping for $10 less. As well my 1510 card arrived before my 1201N!

Share this post


Link to post
Share on other sites

I almost ordered mine from Amazon, but my history with their shipping has not been good. I got my Snow Leopard from them and it was promptly sent to Washington state. Trouble is I live in Indiana.

 

BTW, I have updated the install guide to mention that the NBBM should be installed on the flash drive on a system running Snow Leopard. Several people have reported problems preparing the flash drive on a system running 10.5.x.

Share this post


Link to post
Share on other sites
I love you!!!

 

I haven't seen it mentioned lately, does anyone still have time that they boot and keyboard/mouse still dont' work? It still happens to me randomly but a reboot fixes it.

 

I second the Thank You for the gift of sound! :(

 

I've never had the keyboard/mouse not work. Perhaps a new install would fix it.

Share this post


Link to post
Share on other sites
The replacement Dell 1510 mini pci-e wlan card can be found on Ebay and directly from Dell.

 

Latest BIOS is 0321 and is available here.

 

Danger, Bill Robinson!

 

You CANNOT regress your BIOS.

 

Once updated from 0317, the first Golden release, to 0318, you may not go back to 0317, only forward to 0321.

 

Additionally, and I believe this to be of paramount importance, the Dell 1510 card is seen by MacOS as an Airport card, and that being said, there is no reason not to use the Airport drivers and utilities.

 

Meaning, the Dell 1510 card is most probably an Atheros card, as Broadcom and Atheros are the two Airport card choices which are supported by Apple.

 

You may input your WPA password during MacOS installation, but for some unknown reason you may have to input your WPA password again, after the initial boot of MacOS.

 

All-in-all, the Dell 1510 card is highly recommended. It is seen by MacOS as an Airport card, and it appears to be a little more sensitive than the stock card.

Share this post


Link to post
Share on other sites
BTW, I have updated the install guide to mention that the NBBM should be installed on the flash drive on a system running Snow Leopard. Several people have reported problems preparing the flash drive on a system running 10.5.x.

 

That's the reason why merklort uploaded his Extra Folder from the begining, some of us had troubles making the dvd from Leopard 10.5.x.

 

I followed your guide mosslack from the part using amf5 Extra folder and updating to 10.6.2 and everything worked great. Now I feel i have a macbook pro or something, its awesome. Thanks the team that made this possible!!

 

Some guy before said something about patching appleHDA audio better than using Voodoo, anyone continued that way? Sometimes i get a KP from audio kexts booting when I have plugged in my speakers to the audio output. But it happens not to often.

 

Thanks to everyone

Share this post


Link to post
Share on other sites
<SNIP>

Meaning, the Dell 1510 card is most probably an Atheros card, as Broadcom and Atheros are the two Airport card choices which are supported by Apple.

<SNIP>

 

The Dell card is Broadcom, but I forget the number at the moment. This was discussed at great length on the HP Mini 311 thread.

 

This install procedure has created a lot of confusion and for that I am sorry, but until a new procedure is available we are stuck with this one as it does work, just gotta watch your P's and Q's.

 

Also I need to hear from others who have done the dual boot about which OS to install first, etc. Peter informs me that installing Chameleon after the Windows install is not enough to overwrite the Windows boot files and you are left with a system which will not boot without help. I believe it may be necessary to use the Windows DVD via diskpart and make sure that partition 1 is active before installing Chameleon so the files get written to the correct location. Anyone else have this problem?

Share this post


Link to post
Share on other sites

I gotta question. Can you install the Windows 7 restore DVD after installing the Dell 1510 and then install the Dell 1510 drivers? This was an issue in some post, I want to install the Dell card before I begin my journey into operating system installs.

Share this post


Link to post
Share on other sites

From my personal experience on another hardware (gigabyte DS2-R), I installed OSX first.

Then I installed win7 but it erased the chameleon boot loader.

I used a cd with this bootloader (empire-efi), to boot into osx again.

In osx I switched the boot flag to osx (using fdisk), then re installed chameleon.

 

After that all was working (bootloader ok) but I still had a problem with vmware, to boot my win7 partition, to solve it :

switch boot flag to win7 partition, setup and launch vmware using win7 bootcamp partition, exit win7 and vmware, then switch the bootflag to osx again. After that all was working well, without needing to switch the boot flag anymore.

I never have to do some fdisk /MBR for my windows partition... but as I said, it wasn't on this netbook. And I don't use some kind of restore DVD for installing win7 (they usually suxx) , I prefer to use retail install DVD !

Share this post


Link to post
Share on other sites

-is dell 1390 wireless card ok like 1510?

 

-any chance to have a guide that doesn't require to have an original mac?

Share this post


Link to post
Share on other sites

je n'arrive pas à installer snow leopard, j'ai mis snow leopard sur une clé usb de 32go, j'ai installer netbookmaker mai rien a faire quand je boot sur ma clé usb le mac se lance mai au moment d'aficher la pomme un méssage me dit de redémarrer mon Asus 1201N voila je ne conprend pas

merci pour votre aide

je ne sais plus koi faire

Share this post


Link to post
Share on other sites
I gotta question. Can you install the Windows 7 restore DVD after installing the Dell 1510 and then install the Dell 1510 drivers? This was an issue in some post, I want to install the Dell card before I begin my journey into operating system installs.

 

Yes this does work as PeterHaas did it. I thought maybe you had to uncheck the option to install the drivers for the original card when the restore program is at that point, but I don't believe even that is necessary.

 

As for the Windows/Snow Leopard dual boot, there have been some problems with installing Windows first, but this is the same problem as installing Windows last. When Windows installs it takes over (it is a Micro$oft program after all), and it will insert it's own files where it needs them to be. And as placeb mentioned, the boot flags (active partition) are all messed up because of it. Whatever method you use, diskpart or fdisk, you need to insure that partition 1 (the EFI partition) is set as active before reinstalling Chameleon. This will insure that it's files and not Windows will reside there and be the active boot loader. And then Windows will not boot until the boot sector of it's partition is fixed using diskpart. So I will be adding some more wording to the dual boot guide in an effort to lessen the confusion. I hope this clears this up :)

Share this post


Link to post
Share on other sites

I have been busy with work this week and have been unable to get a linux distro installed as of this moment. I'm at school right now in a sociology class but when I get out later I will try to get one up and running. Currently I have the keyboard running majority of the time but out of the last 5 uses I've had to recompile/reboot with kext utility twice. I am currently using a bluetooth mouse and have the trackpad disconnected at the motherboard until I can get unbuntu up and running.

 

As far as the dual boot guide I followed the guide located on page 1 of this thread and used mossack's guide to set my netbook up and have had zero problems so far. I also used the asus recovery dvd and everything installed just fine with my win 7 ultimate disk to finish the install. I did this after the dell 1510 wireless card was installed and had no problems or error messages on install (windows wise).

 

Has anybody had problems with the shutdown function? Reboot works great but shutdown itself just turns the screen black and forces you to hold the power button down for the 5 seconds before shutting off. Gonna try to reinstall evoraboot and try again.

Share this post


Link to post
Share on other sites

As long as lilo or grub, whichever you use, is installed to the root partition and not the MBR, Chameleon should boot it just fine. All OS bootloaders consist of two parts, one resides on the MBR or EFI in our case and basically just acts as a pointer to whichever system you choose to boot. The other portion resides on the same partition your OS resides on and is what actually boots your OS. The distros of Ubuntu I have used in the past are much like Windows in that they don't give you the option to install this way, instead just installing to the EFI. It is possible that this has changed, but be sure to know what you are doing before letting whichever distro you choose install the bootloader. HTH

 

As for which version to install, consider you are running Snow Leopard and/or Windows 7 on this system, is the screen adequate for those? If not you may want the netbook version.

Share this post


Link to post
Share on other sites
je n'arrive pas à installer snow leopard, j'ai mis snow leopard sur une clé usb de 32go, j'ai installer netbookmaker mai rien a faire quand je boot sur ma clé usb le mac se lance mai au moment d'aficher la pomme un méssage me dit de redémarrer mon Asus 1201N voila je ne conprend pas

merci pour votre aide

je ne sais plus koi faire

 

Anyone care to take a shot at this, here is how babelfish translates:

 

I n' do not manage to install snow leopard, j' put snow leopard on a key usb of 32go, j' have to install netbookmaker May nothing has to make when I boot on my key usb mac launch out May at the time d' to post apple a message says to me to start again my Asus 1201N here are I conprend not thank you for your assistance I cannot any more koi make

 

ALSO, I have changed the dual boot guide to hopefully make it clearer. Please take a look and let me know what you think. Thanks!

Share this post


Link to post
Share on other sites

So everything is working beautifully except it says that i don't have a bluetooth device installed?! I kind of need/want that to work...

 

Any help please!

 

I have tried reinstall twice

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.

×