Jump to content
Zirus69

need help: SL on an acer aspire 5672

9 posts in this topic

Recommended Posts

Dear all,

 

I allready started to hackintosh my Dell mini 10v for this there is a special forum special for this in the internet.

NetbookInstaller made an very nice job for me.

 

But after everything is working on my Dell mini 10v I also want my Acer notebook running Snow Leopard.

Sometime a bigger screen is better ;-)

 

First of all the Notebook Informations:

-------------------------------------------

Acer Aspire 5672WLMi

Intel Centrino Core Duo T2300 (1,66 GHz, 667MHz FSB, 2MB L2 cache)

Chips: Intel 945 PM

Memory: 2GB DDR2

Graphics: Mobility Radeon X 1400

Screen: 15,4" TFT, 1280 x 800 Pixel

HDD: 100GB SATA (5400rpm)

Network: Modem, LAN (1 GBit/s), WLAN (54 MBit/s), bluetooth

Card-reader: SD/MMC, xD, Memory Stick

Monitor-sockets: Monitor (analog + DVI), TV-Out (S-VHS)

Data-sockets: 4 x USB 2.0, 1 x Firewire, 1 x PC-Card, Infrared

 

What I did till now:

-----------------------

I tried the first way I found Install to install SL (EMPIRE EFI v.1.085)

Install was no Problem

 

Problem:

------------

I can only boot into OSX via EMIPER EFI Boot CD

Chameleon 2.0 RC3 stops working at Apple bootscreen

Wifi is not working

 

What I dont know (maybe the solution)

---------------------------------------------

What kind of settings I have to make in the BIOS to boot throw Chameleon 2.0 RC3

Maybe thats the Key? or should I use an other EFI methode?

 

I hope to get some help from some "Hack"sperts.

 

Thanks for Help in advanced.

 

Best Regards from Germany

Share this post


Link to post
Share on other sites
Advertisement

Boot in verbose mode (type -v in Chameleon) to see where is it hanging.

 

I have an Aspire 5920 that needs "UHCIreset=yes" for Chameleon to work.

 

Which wifi card do you have?

Share this post


Link to post
Share on other sites
Boot in verbose mode (type -v in Chameleon) to see where is it hanging.

 

I have an Aspire 5920 that needs "UHCIreset=yes" for Chameleon to work.

 

Which wifi card do you have?

 

 

Thanks for the quick answere!

 

During v- boot I got following message. see Attachments

 

 

Wifi: Intel PRO/Wireless 3945ABG

 

Notebook specific can find here:

http://wellsaler003.en.ec21.com/Acer_Aspir...43_3138246.html

post-550303-1264540900_thumb.jpg

post-550303-1264540955_thumb.jpg

Share this post


Link to post
Share on other sites

Are you using a custom dsdt.aml file?

 

One difference I see is that Empire EFI uses Chameleon 2.0 RC4 and you are using RC3. Did myHack installer fail?

 

There is no Intel 3945ABG driver for Snow Leopard, just a development one for Leopard. I replaced it by a Broadcom BCM4311.

Share this post


Link to post
Share on other sites
Are you using a custom dsdt.aml file?

 

One difference I see is that Empire EFI uses Chameleon 2.0 RC4 and you are using RC3. Did myHack installer fail?

 

There is no Intel 3945ABG driver for Snow Leopard, just a development one for Leopard. I replaced it by a Broadcom BCM4311.

 

 

myHack was installing regularly.

 

I dont think that I use an custom dsdt.aml

to be honest I read many times some tutorials dealing with it but I am still not totally sure what it do.

And I don´t change something I dont know how to handel.

 

You are right if you take a look at the change log of Empire EFI 1.085 they write RC4 but I download the "first download ISO" for Intel core series and directly but it on a CD. But now I also download an Installer for RC4 and tried it out and the result is the same.

 

What would you advice me if you take a look at the other components of my Aspire 5672WLMi.

Is it worth to bay a new Wifi Card (for the rest of the components can get drivers or for rest also difficult to get it working with SL)

Even if its already 3 years old I am still happy with the Notebook so don´t want to bay a new one at the moment.

only for my interesting: What notebook is the best choice to get a (maybe everything working) Hackbook pro.

 

I have one more Question: in many threads people taking about hazard ..... is this an alternative of Empire EFI?

is this good?

 

so many Questions at one time but this topic is very interesting for me.

 

Thanks for you time to help me!

Share this post


Link to post
Share on other sites

post-550303-1279961389_thumb.jpg

 

 

 

I tried it now with

 

1) EMPIRE EFI v. 1.085 und OS 10.6 Install DVD

2) Snow Leopard 10.6.2 by Hazard

3) iAtkos S3 v2

 

 

 

and I always get the same problem when I start the system ...... can anybody help me?

 

 

 

(I already replayed my wifi with an braodcom 4321 )

Share this post


Link to post
Share on other sites
post-550303-1279961389_thumb.jpg

 

 

 

I tried it now with

 

1) EMPIRE EFI v. 1.085 und OS 10.6 Install DVD

2) Snow Leopard 10.6.2 by Hazard

3) iAtkos S3 v2

 

 

 

and I always get the same problem when I start the system ...... can anybody help me?

 

 

 

(I already replayed my wifi with an braodcom 4321 )

 

I have the same problem when booting with 2 cpu's.....

try booting with 'cpus=1', it should bypass this problem (but there will only be 1 core recognized.....)

 

I'm yet waiting for a final solution to come.... I figure this should be possible by some BIOS or DSDT modifications...

Share this post


Link to post
Share on other sites
I have the same problem when booting with 2 cpu's.....

try booting with 'cpus=1', it should bypass this problem (but there will only be 1 core recognized.....)

 

I'm yet waiting for a final solution to come.... I figure this should be possible by some BIOS or DSDT modifications...

 

 

I had the same problem with some Tiger distros and also with Leopard. The solution was flash the bios with a custom firmware wich I have. Now you can do the same with DSDT.

asstastic is an user from here who is always looking for solutions for this notebook.

He gave me this bios hack but a few months ago he told me that I had to change my bios for the original one to use DSDT instead of bios hack because it´s the best solution.

With the DSDT that he gave me we can fix also the 3945ABG wifi (Leopard) with Voodoo wireless.

Here is the post where asstastic tell about that http://www.insanelymac.com/forum/index.php...50#entry1428745

 

Good luck.

 

michaelz

Share this post


Link to post
Share on other sites
I had the same problem with some Tiger distros and also with Leopard. The solution was flash the bios with a custom firmware wich I have. Now you can do the same with DSDT.

asstastic is an user from here who is always looking for solutions for this notebook.

He gave me this bios hack but a few months ago he told me that I had to change my bios for the original one to use DSDT instead of bios hack because it´s the best solution.

With the DSDT that he gave me we can fix also the 3945ABG wifi (Leopard) with Voodoo wireless.

Here is the post where asstastic tell about that http://www.insanelymac.com/forum/index.php...50#entry1428745

 

Good luck.

 

michaelz

 

Thanks for your post, Michael!

Yeah, Assastic seems to have done some great work (he already helped me out quite a bit!), however, using his DSDT gives me a crash at booting. It hangs at:

IOAPIC: Version 0x20 Vectors 64:87

(right before ACPI: System State [s0 S3 S4 S5] (S3) should show up...)

 

Since this DSDT solution doesn't work for me, maybe I should try his modified BIOS... Do you still have it somewhere / know where I can download it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×