Jump to content
InsanelyMac Forum

rEFIt ate my drive...!

Recommended Posts



So I'm trying to install Ubuntu on my Mac Pro 2.8x8 on 10.6.2.


I first made the error of just installing the latest rEFIt, without realizing I couldn't choose which volume to install it on. But the remove procedure in the documentation seemed simple enough, so I went on to manually install rEFIt on a second int. drive, which had been partitioned using Bootcamp 3.0 for 1 mac and 1 windows partition.


I dragged the efi folder onto the volume and the ran the .enable.sh from Terminal.


When I rebooted and held down Option, I should have known something was amiss. The Ubuntu Install disc showed up, but no rEFIt menu. Nonetheless, I proceeded to boot from the disc. I deleted the fat32 partition from bootcamp volume, and created 1 600MB swap partition, and 1 100GB ext3 using "/" with the remaining free space. I then installed Ubuntu. I removed the disc and re-booted, again holding down shift.


And voila!


My Macintosh HD was no longer available as a boot volume. And when I selected the Windows volume, I got a disk error.


So I rebooted again, chose my startup drive's clone (smart boy!). I removed the efi folder from the root of my startup drive, and tried to re-boot. It only will now boot to the clone.


So I'm stuck. No Ubuntu, no rEFIt, no joy.


What am I doing wrong?


EDITED: I've made a bit more progress. I removed the rEFItBlesser from the startup volume's StartupItems folder. I then re-blessed the Coreservices folder on the drive:


sudo bless --folder '/Volumes/Macintosh HD/System/Library/Coreservices' --bootefi


I then rebooted. Guess what? Now I get the rEFIt menu when holding down option. However, even when the apple volume was selected, of which there was still but one, I booted back into my clone.


So I'm feeling rather screwed... :P

Share this post

Link to post
Share on other sites

I'm confused, you say "second drive" but...unless I'm horribly mistaken, MBP machines only have one hard drive. Do you mean partitions or are you connecting another hard drive externally?


In your case, assuming you mean partitions, I'd try to recover as much data as you could from your drive, re-partition it, and start over, be very careful to follow all of the instructions you have available and note every error you run into. Getting multi-boot to work on a mac is hard enough without complicating it with partitions. (I like to keep one OS to a drive, but that's me)



I find that trying to get linux and os x to be friends on the same drive is not worth the trouble. I ALMOST had it working harmoniously on my sad old generation 1,1 macbook but it kept wanting to reboot into the OS I use the least, and it was just really annoying, when I tried to fix that, it broke EVERYTHING so....I dunno....rEFIt is....well....version .14


Keep in mind, there are software packages out there which are still unstable WELL after their version 1 milestone. I'm not saying rEFIt is one of those, but I will say that I'm not over-flowing with hope for something that's still in V.14


In my experience, LILO crushes everything in its path, GRUB isn't too different in terms of hostility, and the OS X boot loader either stops GRUB from working, or GRUB stops it from working.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.